Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Wieso wird unsere lokale Webseite so spät aktualisiert vom Browser dargestellt ?

Frage Internet CMS

Mitglied: mirkobru

mirkobru (Level 1) - Jetzt verbinden

29.10.2009 um 10:05 Uhr, 4876 Aufrufe, 4 Kommentare, 1 Danke

Unsere lokale Webseite (Joomla 1.5) wird verspätet aktualisiert.

Hallo zusammen,

wir haben hier in der Firma einen Internetserver (Debian 4.0), welcher u.a. als transparenter Proxyserver (Squid 2.6) und auch als Webserver (Apache2) fungiert.
Ich habe eine Webseite mit Joomal 1.5 erstellt, und bin seit einiger Zeit nur mit den Templates am arbeiten.

Sobald ich Änderungen am Template vorgenommen habe, wie z.B. Anpassungen an .PNG Dateien, oder an .CSS Dateien, kann ich nur selten unmittelbar einen Effekt auf der Seite erkennen.

Beispiel:

30 Minuten vor Feierabend habe ich gestern die Farbe vom Hauptmenü in der entrechenden .CSS Datei geändert. Auf der Webseite hat sich nichts geändert. Heute morgen hatte das Menü dann die doch noch gewünschte Farbe erhalten.


Ich habe folgendes probiert:

1) ich habe Firefox und IE benutzt, beide haben das gleiche Problem, obwohl der eine etwas aktueller sein kann als der andere.
2) der Cache der Browser wurde gelöscht
3) Die Browser geschlossen und neu geöffnet
4) Der Cache von Squid wurde gelöscht

natürlich habe ich auch alles hintereinander probiert.

Leider hat nichts geholfen.

Heute Nachmittag trifft sich unsere Arbeitsgruppe und ich kann nicht das vorweisen was ich geplant habe, nur weil die Aktualisierung auf sich warten lässt.


Weiß jemand Rat ?

Vielen Dank im Voraus

Gruß,

Mirko
Mitglied: KowaKowalski
29.10.2009 um 10:26 Uhr
Hi mirkobru,

auch Euer Joomla hat nen internen Cache.
Schau mal in Deinem Joomlamenü den Menüpunkt "Werkzeuge"
Dort kannst Du, nachdem bearbeiten Deiner Seite, den Cache vor Ablauf seiner "Frist" löschen.
Dannach mal auf der hauptseite zusätzlich den Browsercache löschen oder mit F5 neuladen.

Dann könnte es schneller gehen mit dem neuen Design.


mfg
Kowa
Bitte warten ..
Mitglied: sqanto
29.10.2009 um 12:41 Uhr
wenn ich das richtig sehe musst du nicht den clint neustarten sondern den

dienst

also sprich den apache neustarten das geht ja ganz schnell 1-2 sekunden
Bitte warten ..
Mitglied: mirkobru
29.10.2009 um 12:57 Uhr
Danke, dass ihr so schnell geantwortet habt !

Nachdem ich den Cache von joomla (obwohl er deaktiviert war) geleert hatte, wurde die Webseite ordnungsgemäss aktualisiert !

Vielen Dank für den super Tipp.

Apache brauchte ich nicht neuzustarten

mfG

Mirkobru
Bitte warten ..
Mitglied: KowaKowalski
29.10.2009 um 13:09 Uhr
wenn´s nun klappt markiere diesen Fred doch bitte als gelöst



mfg
kowa
Bitte warten ..
Ähnliche Inhalte
CMS
gelöst PhpMyAdmin Login-Seite wird nicht dargestellt (3)

Frage von Static zum Thema CMS ...

DNS
DNS konfiguration Domainname Webseite (11)

Frage von TristanKayser zum Thema DNS ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Internet
gelöst Jeden morgen Internet-Probleme (59)

Frage von pjrtvly zum Thema Internet ...

DSL, VDSL
VDSL Signal via PowerLine an Fritzbox - Möglich? (19)

Frage von Seichobob zum Thema DSL, VDSL ...

Windows Server
Benutzer sperrt sich immer wieder im Active Directory Contoller (18)

Frage von Kirdy1301 zum Thema Windows Server ...