Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win 2003 Server Std - DNS Weiterleitung - Router - Problem

Frage Microsoft Windows Server

Mitglied: 35997

35997 (Level 1)

27.09.2006, aktualisiert 28.09.2006, 10774 Aufrufe, 7 Kommentare

Hallo zusammen.

Ich habe ein Problem mit einem Windows 2003 Server - Teledat Router 631 und der DNS Weiterleitung.


Es wurde AD eingerichtet mit DHCP und DNS.
Die ganze lokale Geschichte läuft super ... DNS Server arbeitet lokal prima und die Clients arbeiten "fast" wie sie sollen.
Um die ganze Geschichte ins Internet zu bekommen habe ich einen Teledat 631 Router welcher es mir leider NICHT ermöglicht die IP Adresse zu ändern. Um es auf den Punkt zu bringen ... mein Server hat die IP 192.168.0.1 ... die Clients fangen bei 192.168.0.50 an und der Router hat 192.168.2.1 ... ich weiß ... normal kann das nicht gehen ... aber jetzt kommt es ... der Router hat die Funktion "AnyIP" welche es ermöglicht aus anderen IP-Kreisen auf den Router zu verbinden. Das geht auch soweit.

Ich habe auf dem DNS-Server eine Weiterleitung eingerichtet auf verschiedene DNS-Server im Internet (Telekom).
Jeder Client bekommt die IPs: 192.168.0.5x - Subnet: 255.255.255.0 - Gateway: 192.168.2.1 - DNS: 192.168.0.1.

So sollte es ja alles gehen.

Heute Morgen ruft mich der Kunde an und sagt mir, dass die Clients nicht ins Internet kommen was aber zwei Tage lang super ging.
Ich zum Kunden gefahren und geschaut was los ist. Tatsache ... die Clients zeigen im IE nur "Verbindung wird hergestellt "IP" ".
Am Server komme ich ohne Probleme ins Internet nur die Clients wollen nicht. Clients wurden auch rebootet aber alles ohne Erfolg.
Ereignisse gibt es keine auf dem Server. Da ich nicht wusste was das sein kann habe ich dies gemacht.

- DNS Cache geleert
- Die Routerverbindung auf "Dauer" gestellt
- andere DNS-IPs eingetragen ( T-Online http://www.atelier89.de/users/dirk/t-o/ )
- DNS Task neu gestartet

danach ging wieder alles und der Kunde konnte wieder ins Internet. (heute)

Meine Überlegung ist jetzt ... wo ist der Fehler, warum konnte der Server noch ins Internet und wann tritt der Fehler wieder auf?

Man muss dazu sagen, dass es jede Nacht Spannungsabfälle (max. 1-30 Sekunden ) in der Firma gibt durch Bauarbeiten und große Maschinen die gestartet werden.
Der Server hängt an einer USV aber der Rest nicht. Aber das erklärt immer noch nicht warum der Server ins Netz konnte.
Ich hatte auch dran gedacht das es am Router liegt wegen seiner IP bzw. der komischen "AnyIP" Geschichte.

Die Clients haben eine Reservierte DHCP IP.

Ich warte jede Sekunde das der Kunde anruft und sagt "Internet geht nicht" ... warte nur drauf das der Router seine Verbindung trennt und wieder aufbaut (Zwangstrennung) und nix mehr geht.

Ich hoffe Ihr habt ein paar Tipps für mich.
Ich danke euch jetzt schon für eure Hilfe

Gruß
Mitglied: 33425
27.09.2006 um 16:56 Uhr
Wie sollen Die Clients das Gateway erreichen? GW 192.168.2.1, die liegen in einem anderen Netz (192.168.0.X)! Das das ganze funktioniert ist eher ein Wunder!
Du hast imho 2 Möglichkeiten

1. (fürn Arsch) Bau im Server eine 2 Netzwerkkarte ein, gib der eine IP-Adresse aus dem 192.168.2.X Netz und aktiviere Routing & Ras. Als GW für die Clients nimmst du dann die IP des Servers aus dem 192.168.0.X Netz.

2. Nimm einen ordentlichen Router. Preiswerte Router gibt es unter anderem von Linksys und kosten um die 50€. Das ist billiger als die Netzwerkkarte und der Einbau der Karte in den Server.

mfg
Schnitzelchen
Bitte warten ..
Mitglied: 35997
27.09.2006 um 17:26 Uhr
Mir ist schon klar das die in einem anderen Netz liegen. Ich war auch total verwundert.

Schau dir mal das BA vom Router an http://www.t-com.de/dlp/eki/downloads/T/Teledat_Router_631_BA_09.2004.p ...
Such in der PDF nach "AnyIP" oder "Any IP". Ich kannte diese Funktion bis jetzt noch nicht und finde sie auch nicht wirklich toll. Habe heute dem Kunden schon "angedroht" das er nen neuen Router braucht. Mich interessiert im mom wirklich die Ursache des ganzen. Liegt es wohl an dem Any IP kram?

Danke für deine Antwort
Bitte warten ..
Mitglied: DaSam
27.09.2006 um 19:46 Uhr
Hi,

warum kamen denn die Clients nicht ins Internet?

- funktionierte die DNS-Auflösung nicht (auf den Clients)
- funktionierte die DNS-Auflösung für externe Zonen nicht (auch auf dem Server)
- hat sich eventuell der DNS-Server der DTAG geändert?
- hat die "magische Routerbox" einen eigenen DNS-Forwarder?

Letzte Frage mit Ja beantwortet? Dann würde ich den DNS forwarder des DNS-Servers auf die IP-Adresse des Routers zeigen lassen. Beim Verbindungsaufbau zum Provider sollte dieser die DNS-Adressen eigentlich mitgeteilt bekommen und brav dorthin selbst forwarden.

cu,
Alex
Bitte warten ..
Mitglied: 35997
27.09.2006 um 21:03 Uhr
Also ich hoffe ich verstehe dich jetzt richtig.

Die interne DNS-Auflösung ging (getestet). Die externe ging auf den Clients nicht. Auf dem Server aber ja (Zufall das in dem mom auch die externe ging?) Ich kann nicht sagen ob der Router überhaupt online war (Lampe am Router deutete aber stark drauf hin). Ich bin der Meinung das die DNS Server (3Stück) am Montag noch gingen. Naja habe ja jetzt welche von T-Online drinne. Wenn ich die IP vom Router in die Weiterleitung eintrage geht es unzuverlässig bis nach na Zeit gar nicht. Warum auch immer.

Es macht für mich keinen Sinn das der Server online gehen konnte und die Client nicht. Ich will halt einen Fehler meinerseits ausschließen bei der konfiguration des DNS-Servers.
Bitte warten ..
Mitglied: DaSam
27.09.2006 um 21:24 Uhr
Hi,

ganz ehrlich: Schmeiss das Router-Dingens weg, so wie es jetzt konfiguriert ist auf jeden Fall.

Dann schau zu, dass deine DNS-Forwarding Struktur zuverlässig geht. I.d.R. sollte dein DSL Router DNS forwarder spielen können (mach doch mal einen nslookup mit dem DSL-Router als Ziel) und dann eben die DNS Server auf den Router forwarden lassen.

cu,
Alex
Bitte warten ..
Mitglied: 35997
27.09.2006 um 22:16 Uhr
Ich danke euch für eure Antworten ... ich werde jetzt ein paar Tage warten ob der Kunde sich meldet mit Problemen ... wenn ja kommt der möchtegern Router in die Tonne und packe die IP des neuen nur alleine in die Weiterleitung des DNS.
Der Sinn des Threads war für mich einen Fehler in der Konfig des Servers meinerseits auszuschließen. Ich denke ich habe alles richtig gemacht und es liegt einfach an der Kiste.

Gruss
Bitte warten ..
Mitglied: 35997
28.09.2006 um 15:15 Uhr
Wollte nur noch mitteilen das der Kunde wieder Probs mit dem Internet hatte. Router war weder über Browser noch über Ping zu erreichen. Router war aber laut LEDs online. Telekom konnte bei einer Messung das Gerät auch ansprechen. Nach der Messung ging plötzlich das Internet am Server wieder. Die Clients gingen aber nicht. Nach einen Reboot (Clients/Server/Netzwerkhardware) ging wieder alles. Habe jetzt einen neuen Router geordert.(NETGEAR DG834B) Denkt Ihr ich kann einen Konfigurationsfehler am Server ausschließen oder habe ich noch wo nen Fehler eingebaut? Lokale Auflösung geht wunderbar (nslookup <ServerName.Domain>). Die DNS Weiterleitung an die Router IP geht seit heute auch "plötzlich" wunderbar im gegensatz zu den letzten Tagen.

Gruss & Danke

Edit: Also ich kann sagen das es mit dem Netgear jetzt vorerst alles super geht. Kunde ist zufrieden.
Danke
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Win 2003 Server von außen nicht erreichbar (9)

Frage von Fighter89 zum Thema Windows Server ...

Windows Netzwerk
gelöst DNS - Weiterleitung zu DNS-Server in anderer Domain (5)

Frage von Schauer zum Thema Windows Netzwerk ...

DNS
gelöst DNS Weiterleitung ohne www (4)

Frage von simonsays zum Thema DNS ...

Windows Server
gelöst DNS Weiterleitung Strato (6)

Frage von florianza zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...