Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Frage Microsoft Windows Server

Win 2008 Aufgabenplanung geht nicht

Mitglied: mixmastertobsi

mixmastertobsi (Level 1) - Jetzt verbinden

25.10.2011 um 13:25 Uhr, 10696 Aufrufe, 8 Kommentare

Hallo,

nach dem Wechsel von WIN 2003 Server zu WIN 2008 Server funktioniert der geplante Task nicht mehr korrekt.

Ich habe eine Batchdatei, welche immer nachts aufgerufen wird.

In WIN 2003 wurde die Batchdatei jeder Nacht automatisiert gestartet und problemlos abgearbeitet.
In WIN 2008 habe ich unter Aufgabenplanung einen neuen Job angelegt. Als Ergebnis der letzten Ausführung bekomme ich immer den Code (0x2).

An was kann das liegen.
Mitglied: mixmastertobsi
25.10.2011 um 14:06 Uhr
Habs probiert - geht leider nicht.

Was mir allerdings aufgefallen ist - wenn ich den Haken bei "Nur ausführen, wenn Benutzer angemeldet ist" mache, wird das Skript problemlos abgearbeitet.
Wenn ich allerdings den Haken bei "Unabhängig von der Benutzeranmeldung ausführen" setze, kommt es zu diesem (0x2) Fehler.

NACHTRAG
Ich sollte wohl noch erwähnen, dass über die Batch-Datei mehrere PHP Dateien abgearbeitet werden.


So sieht die XML aus

<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.3" xmlns="http:
schemas.microsoft.com/windows/2004/02/mit/task">
<RegistrationInfo>
<Date>2011-10-21T17:19:43.9931915</Date>
<Author>Administrator</Author>
</RegistrationInfo>
<Triggers>
<CalendarTrigger>
<StartBoundary>2011-10-21T03:30:00</StartBoundary>
<Enabled>true</Enabled>
<ScheduleByDay>
<DaysInterval>1</DaysInterval>
</ScheduleByDay>
</CalendarTrigger>
</Triggers>
<Principals>
<Principal id="Author">
<UserId>Administrator</UserId>
<LogonType>Password</LogonType>
<RunLevel>HighestAvailable</RunLevel>
</Principal>
</Principals>
<Settings>
<MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
<DisallowStartIfOnBatteries>true</DisallowStartIfOnBatteries>
<StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
<AllowHardTerminate>true</AllowHardTerminate>
<StartWhenAvailable>false</StartWhenAvailable>
<RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
<IdleSettings>
<StopOnIdleEnd>true</StopOnIdleEnd>
<RestartOnIdle>false</RestartOnIdle>
</IdleSettings>
<AllowStartOnDemand>true</AllowStartOnDemand>
<Enabled>true</Enabled>
<Hidden>false</Hidden>
<RunOnlyIfIdle>false</RunOnlyIfIdle>
<WakeToRun>false</WakeToRun>
<ExecutionTimeLimit>P3D</ExecutionTimeLimit>
<Priority>7</Priority>
</Settings>
<Actions Context="Author">
<Exec>
<Command>D:\Batch\crown_daily_shop.bat</Command>
</Exec>
</Actions>
</Task>
Bitte warten ..
Mitglied: DerWoWusste
25.10.2011 um 23:36 Uhr
Hi.

Taste Dich ran. Nimm eine einfache Batch, die einen Ordner unter c: anlegt und schau, was passiert.
Bitte warten ..
Mitglied: MemphisV8
23.01.2013 um 14:15 Uhr
Hallo Zusammen,

ich habe ein sehr ähnliches Problem mit einem geplanten Task unter Windows Server 2008 R2 Std.

Ich habe eine .bat File welche ich einmal pro Stunde laufen lasse, diese holt via "move" von einem gemappten Netzlaufwerk (Z Daten und schiebt diese auf ein lokales LW.
Ziel soll es sein den Task OHNE angemeldeten User laufen zu lassen, der Domainuser hat lokale Adminrechte !

Ich habe mehrere Szenarien probiert:

1. Szenario, der Task wird im Planer eingestellt (keine "höchsten Rechte"):

- Konfigurieren für: Win Vista/ 2008
- User muss angemeldet sein
- läuft einmal die Stunde
- Pfad: C:\Pfad\zum\Script /C C:\C:\Pfad\zum\Script\Script.bat

Fazit: Task läuft. Ist aber nicht das Ziel

2. Szenario, der Task wird im Planer eingestellt (keine "höchsten Rechte"):

- Konfigurieren für: Win 7/ 2008 R2
- User muss angemeldet sein
- läuft einmal die Stunde
- Pfad: C:\Pfad\zum\Script /C C:\C:\Pfad\zum\Script\Script.bat

Fazit: Task läuft. Ist aber nicht das Ziel

3. Szenario, der Task wird im Planer eingestellt (keine "höchsten Rechte"):

- Konfigurieren für: Win Vista / 2008
- User muss NICHT angemeldet sein
- läuft einmal die Stunde
- Pfad: C:\Pfad\zum\Script /C C:\C:\Pfad\zum\Script\Script.bat

Fazit: Task läuft nicht

4. Szenario, der Task wird im Planer eingestellt (keine "höchsten Rechte"):

- Konfigurieren für: Win 7 / 2008 R2
- User muss NICHT angemeldet sein
- läuft einmal die Stunde
- Pfad: C:\Pfad\zum\Script /C C:\C:\Pfad\zum\Script\Script.bat

Fazit: Task läuft nicht.

5. Szenario, der Task wird im Planer eingestellt (keine "höchsten Rechte"):

- Konfigurieren für: Win XP / 2003 R2
- User muss NICHT angemeldet sein
- läuft einmal die Stunde
- Pfad: C:\Pfad\zum\Script /C C:\C:\Pfad\zum\Script\Script.bat

Fazit: Task läuft !
Ich hättte aber gerne das die Konfig für 7/2008R2 steht und es ohne angemeldeten Benutzer läuft !

Hat jemand ne Idee ?
Inhalt der Batch:

set STAMP=%DATE:~0,2%-%DATE:~3,2%-%DATE:~-2%
move /Y Z:\Pfad\der\Quelle_%STAMP%\*.* F:\Pfad\zum\Ziel\
move /Y Z:\Pfad\der Quelle2\%STAMP%\*.* F:\Pfad\zum\Ziel\
Bitte warten ..
Mitglied: DerWoWusste
23.01.2013 um 14:20 Uhr
Moin.

Wenn der Nutzer nicht angemeldet ist, gibt es kein z: - wie soll das laufen? Nimm UNC-Pfade.
Bitte warten ..
Mitglied: MemphisV8
23.01.2013, aktualisiert um 15:53 Uhr
Problem ist ja, das es - wenn ich die 2003er Einstellungen vornehme - dann läuft es komischerweise - Szenario 5!

Außerdem läuft das script auch dann nicht, wenn ich angemeldet bin und die Einstellung auf "muss nicht angemeldet sein" steht. Setzte ich den Haken wieder auf muss angemeldet sein läufts wieder - und ich habe mich dabei nicht einmal abgemeldet.

Daher erschliest es sich mir nicht warum es mit den anderen Konfigurationseinstellungen nicht läuft.
Bitte warten ..
Mitglied: DerWoWusste
23.01.2013 um 16:05 Uhr
Ja, Sz5 hatte ich gesehen und kann es mir zunächst nicht erklären.
Hast Du UNC-Pfade dennoch getestet?
Was bedeutet "Task läuft nicht" - erhältst Du einen Fehlercode?
Was hast Du eigentlich von der Konfig 2008R2/7 in diesem Fall?
Bitte warten ..
Mitglied: MemphisV8
23.01.2013, aktualisiert um 16:33 Uhr
Hi,

also habs mit UNC-Pfaden versucht, gleiches Bild wie oben

"Was heißt Task läuft nicht" -> Wenn ich im Taskplaner schaue dann steht dort "Bereit" und das bleibt auch so wenn die Zeit erreicht ist wo gestartet werden soll. Setzte ich die Paramter auf "muss angemeldet sein" dann rennt der Task los sobald die Zeit erreicht ist.

Von der 2008R2/7 Config hab ich an sich nichts, mir ist das Wurscht, insteressiet mich halt warum es bei 2003R2-Konfig rennt und bei 2008R2-Konfig nicht.

Unterm Strich läuft es jetzt - das war mein Ziel.

Vielen Dank für den Tipp mit den UNC-Pfaden
Bitte warten ..
Ähnliche Inhalte
Windows Server
Bat - Aufgabenplanung geht nur mit "Nur ausführen, wenn Benutzer angemeldet ist"
Frage von saschadroemerWindows Server6 Kommentare

Hallo, wir haben hier eine kleine bat die einwandfrei funktioniert, auch in der Aufgabenplanung ausgeführt wenn "Nur ausführen, wenn ...

Windows Server
Kalndergesteurte Aufgabenplanung
Frage von DasIzzyWindows Server3 Kommentare

Guten Morgen Also ich habe folgendes Problem: Die Windows Aufgabenplanung kann Kalender gesteuert verwendet werden. Jedoch kann ich, wenn ...

Batch & Shell
Aufgabenplanung Powershell
Frage von artecnetBatch & Shell5 Kommentare

Hallo, ich starte mit der Aufgabenplanung ein Powershellscript. Das klappt auch alles super, nur wenn es in dem Script ...

Batch & Shell
Script von WIN 2008 unter WIN 2012 nicht lauffähig
gelöst Frage von KeiosIDBatch & Shell5 Kommentare

Hallo, Nach dem Umzug auf einen 2012er Server laufen meine BackUpskripte nicht mehr. Hat sich da was wesentliches in ...

Neue Wissensbeiträge
Linux

Meltdown und Spectre: Linux Update

Information von Frank vor 2 TagenLinux

Meltdown (Variante 3 des Prozessorfehlers) Der Kernel 4.14.13 mit den Page-Table-Isolation-Code (PTI) ist nun für Fedora freigegeben worden. Er ...

Tipps & Tricks

Solutio Charly Updater Fehlermeldung: Das Abgleichen der Dateien in -Pfad- mit dem Datenobject ist fehlgeschlagen

Tipp von StefanKittel vor 3 TagenTipps & Tricks

Hallo, hier einmal als Tipp für alle unter Euch die mit der Zahnarztabrechnungssoftware Charly von Solutio zu tun haben. ...

Sicherheit

Meltdown und Spectre: Wir brauchen eine "Abwrackprämie", die die CPU-Hersteller bezahlen

Information von Frank vor 3 TagenSicherheit12 Kommentare

Zum aktuellen Thema Meltdown und Spectre: Ich wünsche mir von den CPU-Herstellern wie Intel, AMD oder ARM eine Art ...

Sicherheit

Meltdown und Spectre: Realitätscheck

Information von Frank vor 3 TagenSicherheit12 Kommentare

Die unangenehme Realität Der Prozessorfehler mit seinen Varianten Meltdown und Spectre ist seit Juni 2017 bekannt. Trotzdem sind immer ...

Heiß diskutierte Inhalte
Firewall
Penetrationstester-Labor - Firewalls
Frage von Oli-nuxFirewall10 Kommentare

Mich würde interessieren warum man beim Einrichten eines Penetrationstester-Labor (VMs) die Firewall der Systeme deaktivieren soll? Hat das nur ...

SAN, NAS, DAS
Wer kennt sich mit QNAP und CISCO aus ?
gelöst Frage von MachelloSAN, NAS, DAS9 Kommentare

Hallo Zusammen hier im Forum, Ich habe ein QNas 451+ und dieses NAS hat zwei GBit Lan Adapter die ...

Netzwerkgrundlagen
IPv6 Inter-VLAN Routing
gelöst Frage von clSchakNetzwerkgrundlagen9 Kommentare

Hi ich befasse mich gerade mit der Implementierung von IPv6 was bisher (in einem VLAN) korrekt funktioniert inkl. DNS ...

Windows Netzwerk
Zugriff auf den Desktop Ordner eines anderen Rechners in der gleichen Domäne
gelöst Frage von JensNomaWindows Netzwerk6 Kommentare

Guten Abend, ich war neulich mit unserem Admin am Tisch gesessen. Er an seinem Notebook angemeldet mit dem Domänen-Admin, ...