Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win 7 Pro in 2003 Domäne blockiert gesamtes Netzwerk

Frage Microsoft Windows Netzwerk

Mitglied: Zappelpeter

Zappelpeter (Level 1) - Jetzt verbinden

22.02.2010, aktualisiert 18.10.2012, 6232 Aufrufe, 11 Kommentare

Hallo allerseits,

kurz zur Umgebung: Server 2003 Standard Domäne, mit bisher nur XP 32-bit Clients und einigen Netzwerkdruckern.

Vor kurzem wurde ein PC ersetzt und läuft nun mit Windows 7 Pro, 64-bit.

Anmeldung an Domäne usw. klappte alles problemlos. System lief einige Tage stabil danach kam es zu folgendem Phänomen:

Alle Win XP Clients spielten verrückt, bzw. deren Druckerspooler Dienst. Der Dienst lief auf allen XP Rechner mit nahezu 100% Systemauslastung. Trenne ich den Win 7 PC vom Netzwerk, beruhigen sich die XP Clients nach kurzer Zeit.

Der DC hat die XP sowie die Win 7 Treiber für die Netzwerkdrucker.

Da es die spoolsv.exe ist welche durchdreht gehe ich mal davon aus das es an den Netzwerkdruckern liegt. Komme aber nicht weiter, bzw. habe ich keine Idee wie ich das Problem lösen kann.

Der Windows 7 Rechner läuft übrigens tadellos und druckt auch wie er soll, selbst wenn alle XPs besagtes Phänomen aufweisen.

Hat jemand so etwas schon erlebt oder eine Idee wie man dieses Problem lösen könnte?

Vielen Dank im vorraus.
Mitglied: DerWoWusste
22.02.2010 um 13:28 Uhr
Moin.

Normal ist das kaum. Wirf doch mal beidseitig (xp und win7) Wireshark an und berichte.
Bitte warten ..
Mitglied: Zappelpeter
22.02.2010 um 19:10 Uhr
So also hier mal die Ergebnisse anhand Wireshark:

Win 7 produziert bei auf ihm ausgelösten Druckauftrag, jede Menge Checksum-Fehler im TCP Header Bad:true beim request, bei der Übertragung. Schafft es aber trotzdem den Druck abzusetzen. Andere Netzwerkaktivitäten zeigen den selben Fehler.

Ergebnisse von diversen Probiermanövern:

Die spoolsv.exe der XP-Clients fängt an zu routieren wenn Win 7 einen Druck absetzt, übrigens auch die des Win 2003 Servers. Der Fehler ist auf diese Weise reproduzierbar. Andere Netzwerkaktivitäten des Win 7 Rechners zeigen keine Beeinträchtigung der XPs.

Ergo die Win 7 Druckerwarteschlange hat nen Knacks, oder?
Oder liegt das eventuell an dem tollen eingebauten Druckerserver des Win 7 pro?

Am Ende is die Netzwerkkarte einfach im Eimer :/

Hab keine Idee mehr...
Bitte warten ..
Mitglied: DerWoWusste
23.02.2010 um 08:31 Uhr
Was passiert bei xp wiresharktechnisch? Empfängt der Pakete von win7, wenn dieser druckt, oder...? Scheint ja so zu sein.
Ich habe auch keine Erklärung, würde aber den Win7 mal testhalber außer Dienst stellen und eine weitere win7 Testinstallation nehmen.
Bitte warten ..
Mitglied: Zappelpeter
23.02.2010 um 10:04 Uhr
Das XP empfängt nicht vom Win7 sondern vom DC, Server 2003 wenn das Phänomen auftritt. Und zwar tauschen beide Druckrequests und responses aus, ohne das etwas gedruckt werden sollte oder wird.

Der Win7 produziert nun ACK Meldungen zusätzlich zu den Headerfehlern, nach Update diverser Treiber, u.a. Platine und Netzwerkkarte.

Werd den Win 7 nochmal neu aufsetzen, scheint so als hätte Win7 bei sich die Drucker vom Warteschlangendienst getrennt, zumindest lässt sich der Prozeß spoolsv nicht erzeugen, die Druckerwarteschlange meldet aber gestartet... Und drucken tut er ja.
Kann man sich zwar schwer vorstellen, dass es daran liegt, am Ende versucht sich das Win7 des spoolsv der XPs zu bemächtigen, einfach dämonisch...

Mal schauen ob es danach besser läuft.

Außerdem mag ich nimmer Überstunden schieben, weil man schwer das Netzwerk zur Betriebszeit mit Win 7 infizieren kann

Danke DerWoWusste einstweilen
Bitte warten ..
Mitglied: Zappelpeter
24.02.2010 um 21:28 Uhr
Die Neuinstallation brachte keine Verbesserung, selbe Symptome wie zuvor...

Keine Ahnung was ich nun noch machen soll. Jemand noch eine Idee?
Bitte warten ..
Mitglied: DerWoWusste
24.02.2010 um 23:15 Uhr
Stell Dir 3 neue VMs hin: xp, 2003 (braucht kein DC sein) und win7 und stell das im kleinen Kreis zunächst mit einem Drucker nach. Es kann nicht sein, dass es auf sauberen Maschinen auftritt.
Bitte warten ..
Mitglied: fabgg6
28.02.2010 um 00:39 Uhr
Auf dem DC müssen sowohl 32-Bit- als auch 64-Bit-Treiber installiert sein und zwar in genau derselben Version. Dann müssen sich die Nutzer die Drucker neu einrichten.

http://blogs.technet.com/dmelanchthon/archive/2009/12/03/drucker-auf-wi ...

Gruß, GG.
Bitte warten ..
Mitglied: Zappelpeter
01.03.2010 um 09:47 Uhr
Hallo GG,

danke erstmal.

Beide Treiber liegen vor und sind Versionsgleich. Das mit dem Neueinrichten, ist aber einen Versuch wert.
Obwohl ich nicht viel Hoffnung habe.

Hatte so etwas ähnliches schon vermutet, da sich die Rechner ja die Druckerwarteschlange des Servers teilen und sobald da das Win 7 einen Druckjob auslöst die XPs nur Bahnhof verstehn usw.

Habe daher die Netzwerkdrucker mal via IP-Anschluß lokal am Win 7 installiert. Hat aber auch nix gebracht die XPs spinnen weiterhin und der Win 7 braucht bei dieser variante Minuten um den Druckjob abzusetzen.

Könnte es an den Netzwerkdruckern selbst liegen? Treiber gibt es aber für Win7 und 64 bit. Großformatige Kyocera sind das, mit eignem Netzwerkanschluß.

Ein weiterer freigegebener Drucker ein Samsung, welcher via USB am Server hängt, verursacht das Problem übrigens nicht.
Bitte warten ..
Mitglied: fabgg6
01.03.2010 um 23:12 Uhr
Naja, es muss nicht daran liegen. Du weißt ja, die Wege des Herrn ...

Ich habe vom Microsoft-Katalog für HP einen Universaldruckertreiber für Windows 2000/XP/Vista/7 in 32-Bit- und 64-Bit-Version heruntergeladen, danach den 32-Bit-Treiber auf dem 2003-Server installiert (über IP-Anbindung) und anschließend über "Druckereinstellungen ändern", "Freigabe" und "zusätzlichen Treiber" den 64-Bit-Treiber installiert. Dann müsste sich der Client bei Einrichtung des Druckers den jeweils für ihn zutreffenden Treiber einbinden.

Es funktioniert aber erst seit einer Woche. Vielleicht stehen die Probleme noch vor der Tür und warten nur darauf, endlich reingelassen zu werden. ;)

Für einen Brother-Drucker gab es übrigens keinen derartigen Universaltreiber. Da habe ich den für 2000/XP/2003/Vista genommen, auch wieder 32 und 64 Bit. Test von verschiedenen Clients ist morgen angesagt.
Bitte warten ..
Mitglied: Zappelpeter
02.03.2010 um 17:56 Uhr
Also es lag an den Druckern, bzw. deren Treibern.

Zurzeit funktioniert es ohne Probleme.

Das Problem war ein vermeintlich aktueller Treiber von Triumph-Adler.

Da deren Geräte nichts anderes sind als Kyocera-Geräte mit anderem Firmenaufdruck, habe ich mir mal von Kyocera die entsprechenden Treiber besorgt und siehe da, das Phänomen verschwand, bzw. trat nicht mehr auf, bis jetzt. Bin da erstmal vorsichtig mit Optimismus zur Zeit

Mir schleierhaft warum TA da alte Treiber unters Volk bringt aber nun gut, wieder etwas gelernt.

Mit Universaltreibern ist das so eine Sache, vor allem bei solchen Kopierkombimonstern mit Ihren vielen Funktionen fürs Netzwerk, auf die man ungern verzichten möchte.

Vielen Dank einstweilen an alle und dir GG. drück ich die Daumen mit dem Brother ;)
Bitte warten ..
Mitglied: fabgg6
10.03.2010, aktualisiert 18.10.2012
Der Brother läuft. Dafür gibt es unerklärliche Phänomene mit zeitweilig verschwindenden Druckern: http://www.administrator.de/forum/drucker-verschwinden-mitunter-f%c3%bc ....
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

(1)

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Netzwerk
SMBv2 in Windows 7 - Windows XP - Windows Server 2003 Domäne deaktivieren (4)

Frage von Mario.Steinberg zum Thema Windows Netzwerk ...

Windows Server
Trust mit 2003 Domäne (2)

Frage von gringouno zum Thema Windows Server ...

Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Heiß diskutierte Inhalte
DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...

Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (10)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (9)

Frage von 1410640014 zum Thema Backup ...