Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win 7: Standardbenutzer, UAC deaktiviert, Als Admin starten

Frage Microsoft Windows 7

Mitglied: Freund.der.Nacht

Freund.der.Nacht (Level 1) - Jetzt verbinden

25.01.2014 um 21:05 Uhr, 5292 Aufrufe, 5 Kommentare

Hallo an alle!

Ausgangssituation: (in VM)
- Win 7 Pro x64
- als Standardbenutzer angemeldet
- Benutzerkontensteuerung ist deaktiviert
- ein Programm ist bereits installiert, dieses muss als Administrator gestartet werden

Problem:
Das Programm lässt sich nicht als Administrator starten! (also z.B. Rechtsklick -> "Als Administrator ausführen")
Es wird als Standardbenutzer ausgeführt (was im Taskmgr ersichtlich wird) und funktioniert deshalb nicht korrekt.

Jemand eine Idee hierzu? Bin ich irgendwo falsch abgebogen?

Ist es denn unmöglich als Standardbenutzer bei deaktivierter Benutzerkontensteuerung ein Programm als Administrator auszuführen?
Bin für jede Hilfe dankbar!

MfG
Freund der Nacht
Mitglied: Pjordorf
25.01.2014, aktualisiert um 21:47 Uhr
Zitat von Freund.der.Nacht:

Hallo,

Hallo an alle!
- Benutzerkontensteuerung ist deaktiviert
Was erhoffst du dir hiervon und was soll es bei dir tatsächlich bringen die UAC zu Deaktivieren. Die Folgen (eine davon) davon merkst du ja gerade.

- ein Programm ist bereits installiert, dieses muss als Administrator gestartet werden
Mal versucht einen Task anzulegen um diese Programm dann mit entsprechenden Rechten zu starten (Die Abfrage kommt ja nicht mehr)? Oder per CMD und Runas (was ja noch funktionieren sollte auch bei deaktivierte UAC)?

Bin ich irgendwo falsch abgebogen?
Ja, du hast die UAC deaktiviert.

Ist es denn unmöglich als Standardbenutzer bei deaktivierter Benutzerkontensteuerung ein Programm als Administrator auszuführen?
Welchen Sinn soll das haben, die UAC ist doch bei dir deaktiviert und damit können keine erhöhten Rechte angefordert werden.. Und ausprobieren tue ich es nicht.

Gruß,
Peter

http://de.wikipedia.org/wiki/Benutzerkontensteuerung
http://www.sevenforums.com/general-discussion/109262-use-run-administra ...
Bitte warten ..
Mitglied: Freund.der.Nacht
25.01.2014 um 21:28 Uhr
Hallo Pjordorf,

Zitat von Pjordorf:

Was erhoffst du dir hiervon und was soll es bei dir tatsächlich bringen die UAC zu Deaktivieren. Die Folgen (eine davon)
davon merkst du ja gerade.

Ich erhoffe mir davon gar nichts, es geht auch nicht um mein System. Ich teste gerade eine Software, welche unbedingt als Administrator gestartet werden muss.

Mal versucht einen Task anzulegen um diese Programm dann mit entsprechenden Rechten zu starten (Die Abfrage kommt ja nicht
mehr)? Oder per CMD und Runas "was ja noch funktionieren sollte auch bei deaktivierte UAC)?

Nein, Tasks habe ich noch nicht versucht. Der Runas-Befehl fiel negativ aus.

Ja, du hast die UAC deaktiviert.

Das ist auch nur ein Test, um herauszufinden, ob das Programm auch bei Leuten funktioniert, die diese Konfiguration verwenden.

Welchen Sinn soll das haben, die UAC ist doch bei dir deaktiviert und damit können keine erhöhten Rechte angefordert
werden..

Siehe oben.

Und ausprobieren tue ich es nicht.

Verlangt auch niemand.


MfG
Freund der Nacht
Bitte warten ..
Mitglied: Pjordorf
25.01.2014 um 21:47 Uhr
Hallo,

Zitat von Freund.der.Nacht:
Ich teste gerade eine Software, welche unbedingt als Administrator gestartet werden muss.
Dann ist die UAC zu deaktivieren doch Kontraproduktiv.

Der Runas-Befehl fiel negativ aus.
Tolle Fehlermeldung mit der alle etwas anfangen können. Aber egal, ist ja dein Fehler und dein Problem.

bei Leuten funktioniert, die diese Konfiguration verwenden.
Bei meinen Kunden hat keiner so eine verkorkste Umgebung

Warum nicht einfach eine Software nehmen welche auch mit der UAC klar kommt? Und für ältere Programme wo es weder den Hersteller oder Quellcode oder gar eine ab Vista taugliche Version gibt, bieten sich die zahlreichen Virtualisierung an um dort auch noch XP und kleiner laufen zu lassen.

Dieser Link hat nicht geholfen?

Die UAC abzuschalten (gerade für Anwender) ist keine Option. Nie, Nimmer.

Gruß,
Peter
Bitte warten ..
Mitglied: Freund.der.Nacht
25.01.2014 um 22:05 Uhr
Hallo,

Mir ist klar, dass das kontraproduktiv ist. Ich wollte im Prinzip nur wissen, ob das Programm auch unter dieser Konfiguration laufen würde. Bei aktivierter Benutzerkontensteuerung funktioniert es natürlich.

Fazit: Ich werde dass alles mal so stehen lassen. Danke für deine Hilfe.

MfG
Freund der Nacht
Bitte warten ..
Mitglied: AlbertMinrich
27.01.2014 um 19:15 Uhr
Hilft dir evtl. Rechtsklick bei gehaltener SHIFT-Taste > als anderer Benutzer ausführen
Bitte warten ..
Ähnliche Inhalte
Windows 10
gelöst Win 10 UAC deaktiviert sich nach update (9)

Frage von Scifire zum Thema Windows 10 ...

Windows 10
Win-Updates trotz deaktiviertem Dienst? (3)

Frage von Scour1 zum Thema Windows 10 ...

Windows 10
gelöst UAC Benutzersteuerung macht Probleme (5)

Frage von Madzylinder zum Thema Windows 10 ...

Windows 10
gelöst Powershell Script UAC Abfrage deaktivieren (2)

Frage von schicksal zum Thema Windows 10 ...

Neue Wissensbeiträge
Multimedia

Raspberry Pi als Digital-Signage-Computer

(1)

Information von BassFishFox zum Thema Multimedia ...

Windows Update

Novemberpatches und Nadeldrucker bereiten Kopfschmerzen

(15)

Tipp von MettGurke zum Thema Windows Update ...

Windows 10

Abhilfe für Abstürze von CDPUsersvc auf Win10 1607 und 2016 1607

(7)

Tipp von DerWoWusste zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
Freigabe aus anderem Netz nicht erreichbar (21)

Frage von McLion zum Thema Router & Routing ...

Windows Server
Kennwort vergessen bei Hyper vserver 2012r (20)

Frage von jensgebken zum Thema Windows Server ...

Batch & Shell
Batch Programm verhalten bei shoutdown -p (19)

Frage von Michael-ITler zum Thema Batch & Shell ...

Festplatten, SSD, Raid
gelöst Raidcontroller funktioniert nur, wenn unter Legacy-Boot gestartet wird (14)

Frage von DerWoWusste zum Thema Festplatten, SSD, Raid ...