Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win Server 2012 Hyper-V Core mit 2 VMs - Netzwerk langsam

Frage Virtualisierung Hyper-V

Mitglied: kossab

kossab (Level 1) - Jetzt verbinden

08.06.2013 um 13:02 Uhr, 5474 Aufrufe, 18 Kommentare

Hallo Zusammen,

ich hoffe, es gibt ein paar Leute hier, die Erfahrung mit dem Hyper-V 2012 core haben.

Ich habe einen HP Server mit 6x HDD. 2x auf RAID1 für den Hyper-V und die anderen 4x auf RAID10.

Auf den RAID10 sind 2x VMs:
1. Windows 2008 R2 mit einer SQL Datenbank (über 50GB groß) mit 8GB RAM (da Foundation)
2. Win 7 64 Bit (8GB RAM)

Das Problem, das ich habe, ist das wenn ich vom Win 7 das entsprechenden Programm des SQL Server aufrufe sehr langsam ist.
Ich kann das Problem nicht wirklich lokalisieren, ob nämlich die SQL zu groß ist oder das Netzwerk.

Ich tendiere eher auf das Netzwerk, weil wenn ich ein 3GB Datei vom Server auf die 2. VM kopiere, gibt er am Anfang "Gas" ca. 110 MB/s, aber danach bei ca. 30% sinkt dramatisch ab.. erst auf 70MB, 50MB und es kommt teilweise auf ca. 13-17MB.

Ich habe im (englischen) Netz einige Infos gelesen, dass eventuell die Broadcom (2x Stück) vom HP Server mit dem Hyper-V 2012 nicht klar kommen.
Teilweise dass es am NIC der Netzwerkkarte liegen könnte.

Könntet ihr mir ein paar Tipps geben?

Vielen Dank
Mitglied: certifiedit.net
08.06.2013 um 14:04 Uhr
Hallo,

Wahrscheinlich Kombi aus gespart, gespart und gespart. Wer setzt bitte einen Foundation Server ein, wenn er weiss, dass die DB 5 fach das RAM Limit überschreitet? Ist dann doch wohl klar, dass der Server dauernd auslagert und damit schon viel Leistung der Festplatten zementiert.

Wie sieht es denn aus, wenn du den SQL Server herunter fährst und nur über den Win7 Dateien übers Netz ziehst?

Was für Platten hast du im Server?

Gruß
Bitte warten ..
Mitglied: aqui
08.06.2013, aktualisiert um 14:16 Uhr
Ferner aus Netzwerksicht die Frage WIE die beiden Broadcoms angeschlossen sind ??
  • Als Link Aggregation (was entsprechende Switch HW voraussetzt !)
  • Ein Link tot und nur einer aktiv
  • Active Standby Szenario wo ein Link aktiv ist und der andere im Fehlerfall übernimmt.
Auch dazu keinerlei Aussage
Auch da kann man vermuten gespart, gespart, gespart und auch noch falsch konfiguriert und aus der Billighardware nicht mal das letzte rausgeholt...?!
Was soll man da denn auch anderes als Ergebnis erwarten...?
Bitte warten ..
Mitglied: kossab
08.06.2013 um 14:20 Uhr
jetzt aber sorry.. ein HP DL380 G6 mit 6x SAS HDD ist keine Billig Hardware!!!!

zu Foundation: Leider war es ein alter Server und die Chefs wollten nicht eine komplette Installation, sondern den alten Server virtualisieren!
Bitte warten ..
Mitglied: certifiedit.net
08.06.2013 um 14:25 Uhr
Zitat von kossab:
jetzt aber sorry.. ein HP DL380 G6 mit 6x SAS HDD ist keine Billig Hardware!!!!

zu Foundation: Leider war es ein alter Server und die Chefs wollten nicht eine komplette Installation, sondern den alten Server
virtualisieren!

Und da hast du nicht dein Veto eingelegt in der Hinsicht, dass das ein Hirngespinst ist bei einem langsamen Server diese Konfiguration über eine Virtualisierung noch mehr zu verlangsamen?
Bitte warten ..
Mitglied: Flatcher
08.06.2013 um 15:44 Uhr
Hallo,

Welchen Switch verwendest du? Ist vielleicht der Switch überlastet?
lg
Bitte warten ..
Mitglied: kossab
08.06.2013 um 18:05 Uhr
Zitat von Flatcher:
Hallo,

Welchen Switch verwendest du? Ist vielleicht der Switch überlastet?
lg

ich vermute es langsam auch.
ist ein 8port Gigabit HP Procurve
Bitte warten ..
Mitglied: Pjordorf
08.06.2013 um 18:20 Uhr
Hallo,

Zitat von kossab:
ich vermute es langsam auch.
Hier muss keiner irgend etwas Vermuten wovon er keine Ahnung ( an @keine-ahnung) hat. Hier hilft ein einfaches NetIO aus um sich sofort gewissheit zu vershaffen. Ein allmähliches abnehmen der Übertragungsrate beim Kopieren von Daten (hier 3 GB - am Stück oder viele kleine Fragmente auf den Platten - Quell- und Zielplatte) deutet doch eher am mangelnden Cachespeicher, Plattencache usw. hin.

Gruß,
Peter
Bitte warten ..
Mitglied: kossab
08.06.2013 um 18:49 Uhr
Zitat von Pjordorf:
Hallo,

> Zitat von kossab:
> ich vermute es langsam auch.
Hier muss keiner irgend etwas Vermuten wovon er keine Ahnung ( an @keine-ahnung) hat. Hier hilft ein einfaches
NetIO aus um sich sofort gewissheit zu vershaffen. Ein allmähliches abnehmen der
Übertragungsrate beim Kopieren von Daten (hier 3 GB - am Stück oder viele kleine Fragmente auf den Platten - Quell- und
Zielplatte) deutet doch eher am mangelnden Cachespeicher, Plattencache usw. hin.

Gruß,
Peter

mal wieder eine "typische" Antwort
Bitte warten ..
Mitglied: certifiedit.net
08.06.2013 um 18:58 Uhr
@kossab:

was möchtest du denn sonst hören?

"Ja, dein Switch reicht nicht aus!" ?

Das ist aber nicht so. Ein HP ProCurve ist gemeinhin so konstruiert, dass er konsequent Daten durchleitet.

Die angemerkten Problempunkte sind:
HD, Controller, Ram und die Limitierung deines OS.

Grüße
Bitte warten ..
Mitglied: Pjordorf
08.06.2013 um 19:59 Uhr
Hallo,

Zitat von kossab:
mal wieder eine "typische" Antwort
Reicht dir zum Anfang die darin enthaltene Information wie du deine Vermutung in Stein meißeln kannst oder eben in der Tonne treten kannst nicht aus? Was ist an NetIO für dich zu schwer?

Liefere Fakten bzw. Messwerte. Dein Problem kann dann ganz einfach und simpel festgenagelt werden damit du dieses dann beheben kannst und mit deinem Konstrukt happy wirst.

Dein problem kann sich auch folgenderweise lesen/interpretieren:
Du hast ein Blech
Darauf ein HyperVisor type I mittels Hyper-V Server 2012 (das ist die Kostenlose Core Version des nur Hyper-V)
6 Festplatten, 2 im RAID 1 und 4 im RAID10
In diesem HyperVisor laufen 2 VMs mit
- Server 2008R2 Foundation mit 8 GB RAM und einer SQL Datenbank mit 50 GB
- Windows 7 64 Bit und 8 GB RAM

Und jetzt sagst du
das wenn ich vom Win 7 das entsprechenden Programm des SQL Server aufrufe sehr langsam ist
und du mutmasst jetzt durch dein
weil wenn ich ein 3GB Datei vom Server auf die 2. VM kopiere, gibt er am Anfang "Gas"...
das dies alles am Netzwerk liegt.

Was erwartest du von uns?

Wir kennen nicht dein Netzwerk
Wir kennen nicht deine weitere Umgebung
Wir wissen ja noch nicht einmal was du tatsächlich meinst. Warum?

Du nennst weder dein Blech noch um was für ein RAID System es sich handelt. RAID 1 und RAID 10 sind nur die RAID Level. Die sagen über die darunterliegende Hardware überhaupt nichts aus. Und ja, die ist bei dir mit sicherheit nicht unrelevant. RAID Levels sagen über der Leistungsfäöhigkeit eines Plattensystems nichts weiter aus. Und es gibt mehr als ein Weg ein RAID Verbund technisch (Hardware / Software) umzusetzen. Das, und nur das entscheidet über die tatsächlich zu erwartende Leistung eines RAID verbunds.

Du nennst nur ein SQL Datenbank. Von dem dazugehörigen SQL Server sagst du nichts. Und nur die Aussage das die SQL datenbank 50 GB an dateigrösse hat, sagt über die leistungsmöglcihkeit der SQL datenbank auch nichts aus. Der verwendete Server und das wie eine Datenbank aufgebaut und verwendet wird entscheidet über deren zu erwartende Leistung.

Du lässt uns hier weiterhin alle raten ob du mir deinem
das wenn ich vom Win 7
den Win 7 in deiner VM meinst oder ein per Klingeldraht angebunder Rechner der bei dir Kohlenkeller steht. Weiterhin können wir nur Vermuten was du mit deinem
das entsprechenden Programm des SQL Server aufrufe sehr langsam ist
tatsächlich meinst. Wir kennen dein Program nicht welches du Aufrufst und können dir somit auch nicht sagen ob es langsam oder schnell geschieht und ob dies vom Entwickler so vorgesehen ist. Oder meinst du evtl. das der Abruf der Daten aus deiner SQL Datenbank (wo ist der Server und wie ist dieser Konfiguriert, welches protokjoll wird verwendet ...) langsam ist? Wie hast du dies tatsächlich festgestellt? Eieruhr? Wovon redest du also tatsächlich?

Und bei deinem
wenn ich ein 3GB Datei vom Server auf die 2. VM kopiere
können wir wieder nur rätseln und Vermuten welchen Server du überhaupt meinst, wo dieser steht (Am Südpol?), was dessen Hardware sein könnte, wie dessen Anbindung ist (Klingeldraht LAN = CAT3?), Was dessen OS sein könnte, mit welchen Protokollen du diese 3 GB Daten kopierst, ob diese eine einzige Datei ist oder mehrere kleine Dateien oder ganz viele kleine Dateien, ob diese 3 GB Daten auf den Palttensystem mit unbekanntem Dateisystem als eine Datei (unfragmentiert) oder wenig oder viel fragmentiert vorliegen. Kopierst du von deinem Server 200R2 Foundation (VM) auf dein Win 7 (VM) oder was tust du? Denn auch deine VMs sind mittels eines Switches verbunden, dieser ist halt nur Virtuell und macht normal für deine VMs das mit 10 GBit/s. Oder welchen Switch meinst du tatsächlich? Wie ist dieser konfiguriert (sofern dies überhaupt gemacht wurde bzw. gemacht werden kann)? Was läuft noch in deinem Nezuwerk gleichzeitig ab? Was hat der Server X sonst noch gerade zu tun während du 3 GB Daten kopierst?

aber nicht mal in der Lage per NetIO mal schnell sein netzwerk zu prüfen ob dies sein Flaschenhals überhaupt sein kann, sondern nur Vermutungen und "Hab im netz gelesen das es"... Mehr als Hörensagen können wir hier nicht daraus entnehmen.

Geh auf unsere Fragen / Anregungen ein und liefer Fakten. Dann ist dein Problem ganz schnell kein Problem mehr und du kannst vor deinen Chefs glänzen /und das sogar mit Fakten und Fachwissen).

Und jetzt überleg dir deine Antwort
mal wieder eine "typische" Antwort
noch mal.

Gruß,
Peter

PS. Unsere Netze und VMs laufen, und zwar so wie es die Hardware und Software Leistungsmäßig zulässt. Dein Netz nicht.
Bitte warten ..
Mitglied: kossab
08.06.2013 um 20:17 Uhr
Peter.. ich erwarte keine "Glück###rei".. sorry dass ich das schreiben muss.

Ist das Forum hier für Experten? dann bitte bei der Registrierung "Bitte melde dich an, wenn Du dich mit der EDV auskennst"..

Es gibt Leute, wie ich, die suchen einen Rat von Personen (Euch) die auskennen. Wenn ich alles wüsste, würde ich mich nicht hier anmelden und Fragen stellen.

Wenn ich die Frage stellen würde: welche HP Server ist für ESXI geeignet, dann würden mir ein paar Leute die Liste von HP senden, wo die Server aufgelistet ist. Deshalb kannst Du mir jetzt nicht sagen, dass hier die Leute nicht wissen was ein HP DL360 G5 mit 2x QuadCore 3GHz, 16GB Ram und 6x SAS Festplatten, ist.
Wenn ich HP DL360 G5 eingeben, kriege ich gleich die Spezifikationen.

Sofern Du/Ihr mehr Infos braucht, dann bitte kurz reinschreiben.. aber mit einer Antwort zu kommen, wer keine Ahnung hat, dann ... blablabla...

Stell Dir vor, Du gehst zum Arzt weil Du Schmerzen und er fragt dich, was für welche.. Du sagst ihm an der Brust, ich glaube, ich habe mich erkältet..und er sagt Dir, ach Sie haben keine Ahnung...

Ist es so schwierig zu schreiben.. Freundchen: dein System ist ungeeignet.. oder bitte liefere uns Infos: Switsch, blabla usw...

Gruß




PS: Zur Info über "wenn ich ein 3GB Datei vom Server auf die 2. VM kopiere"

Ich habe geschrieben, das im Hyper-V ein Server und Win7 installiert.. wenn ich also diese 3GB Datei über dieses internes System (also das vSwitch) kopiere.. dann passiert eben diese Verlust an Bandbreite..
Bitte warten ..
Mitglied: certifiedit.net
08.06.2013, aktualisiert um 20:33 Uhr
Der exakte Name war im Anfangsposting nicht enthalten.

OK, und zu deinem Switchproblem: Was denkst du ist das Problem, wenn im vSwitch bereits der Durchsatz abfällt?

a) dein physischer Switch?
b) dein HostSystem?

Das Problem ist hierbei nicht, dass wir nicht helfen wollen.

Aber so Anfragen wie "ich habe ein Problem" sind keine Problembeschreibung, wenn man nicht exakt angibt, wie es aussieht.
Das können bspw. meine Kunden gerne machen, die haben einen Vertrag mit mir, da habe ich eine Doku erstellt, da weiss ich, wo der Schuh drückt und hab in 99% der Fälle bereits eine Lösung parat. Anderenfalls treten dann auch solche Probleme wie DB Zugriff zu langsam gar nicht auf, da das evaluiert wird, bevor der Kunde aktiv daran arbeitet.
Es heißt hier aber nicht ohne Grund Administrator.de, weil man hier erwartet, das ->alle<- Infos, soweit bekannt, auf den Tisch legt

Das du bspw intern die Daten überträgst kam erst jetzt heraus.

Also nochmals: Dein Raid, dein Ram oder deine CPU (kam die schon vor?) blockiert hier.

Grüße,

Christian.
Bitte warten ..
Mitglied: Flatcher
08.06.2013 um 21:19 Uhr
Hallo,

Hab mir die letzten Posts nur flüchtig durchgelesen.
Welchen Raidcontroller verwendest du? Read/Write Cache aktiv?
lg
Bitte warten ..
Mitglied: kossab
08.06.2013 um 21:31 Uhr
Zitat von certifiedit.net:
Der exakte Name war im Anfangsposting nicht enthalten.

OK, und zu deinem Switchproblem: Was denkst du ist das Problem, wenn im vSwitch bereits der Durchsatz abfällt?

a) dein physischer Switch?
b) dein HostSystem?

Das Problem ist hierbei nicht, dass wir nicht helfen wollen.

Aber so Anfragen wie "ich habe ein Problem" sind keine Problembeschreibung, wenn man nicht exakt angibt, wie es
aussieht.
Das können bspw. meine Kunden gerne machen, die haben einen Vertrag mit mir, da habe ich eine Doku erstellt, da weiss ich, wo
der Schuh drückt und hab in 99% der Fälle bereits eine Lösung parat. Anderenfalls treten dann auch solche Probleme
wie DB Zugriff zu langsam gar nicht auf, da das evaluiert wird, bevor der Kunde aktiv daran arbeitet.
Es heißt hier aber nicht ohne Grund Administrator.de, weil man hier erwartet, das ->alle<- Infos, soweit bekannt, auf
den Tisch legt

Das du bspw intern die Daten überträgst kam erst jetzt heraus.

Also nochmals: Dein Raid, dein Ram oder deine CPU (kam die schon vor?) blockiert hier.

Grüße,

Christian.


Hallo Christian,

ich sage nicht, dass ich auch als "Schuld" bin, dass ich nicht alle Infos geliefert habe.... aber einfach bei der ersten, zweiten Antwort dazu schreiben, "wir brauchen mehr Infos".

und ich schätze auch dass Peter sich mit der Materie auskennt, aber meine Explosion kam auch dazu, dass in der Vergangenheit das gleiche bei anderen Fragen passiert ist.. irgendjemand kommt und meint den "Glückscheißer" zu spielen..

hier die Infos des Servers

2x CPU: 2GHz Quad-Core Intel Xeon 5405
16 GB ECC RAM
6x 72GB SAS 15k Dual-Port
P400 RAID Controller
2x 700Watt Netzteil
Bitte warten ..
Mitglied: certifiedit.net
08.06.2013, aktualisiert um 21:39 Uhr
Exakt, wie erwartet, der P400 ist laut meiner Kurzrecherche der am meisten Low-Budget Controller, der in ein DL380 gepackt werden kann.

Wer Schuld hat ist irrelevant, aber wenn man aus den "mit-Admin" alle Infos aus der Nase ziehen muss ist das einfach ziemlich unproduktiv (und das auch nicht nur für uns)
Bitte warten ..
Mitglied: Flatcher
08.06.2013 um 21:41 Uhr
Hallo,

Kontrolliere bitte im Bios die Raid Einstellungen.
Bei Kunden habe ich mehrere DL380 mit P410 auf Vmware Basis stehen und darauf laufen bis zu 8 VM's problemlos und relativ performant.
Bitte warten ..
Mitglied: kossab
08.06.2013 um 21:47 Uhr
Zitat von Flatcher:
Hallo,

Kontrolliere bitte im Bios die Raid Einstellungen.
Bei Kunden habe ich mehrere DL380 mit P410 auf Vmware Basis stehen und darauf laufen bis zu 8 VM's problemlos und relativ
performant.

ist zwar ein P400, aber ich schaue morgen auf jeden Fall nach
Bitte warten ..
Mitglied: Flatcher
08.06.2013 um 21:51 Uhr
Hatte ein ähnliches Problem (bei einem Snapshot ging auf keiner Maschine was...) bei mir wars der Read/Write Cache.

lg
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Hyper-V
gelöst Win Server 2012 und Hyper V gleich Netzwerk extrem langsam (20)

Frage von Edaseins zum Thema Hyper-V ...

Microsoft
Server 2012 Hyper-V kann nicht importieren (7)

Frage von thomasreischer zum Thema Microsoft ...

Hyper-V
gelöst MS Server 2012 - Hyper-V - 2 NICs (5)

Frage von MiSt zum Thema Hyper-V ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...

Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...