Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win XP hal.dll defekt und Installation nicht in der Wiederherstellungskonsole aufgeführt

Frage Microsoft Windows XP

Mitglied: kidata

kidata (Level 1) - Jetzt verbinden

17.03.2008, aktualisiert 16:44 Uhr, 9848 Aufrufe, 2 Kommentare

Hallo,

ich habe vorhin meinen laufenden Laptop von einem Zimmer ins andere getragen, dabei ist das Gerät einfach ausgegangen.
Nach dem Neustart kam die Meldung:

Windows konnte nicht gestartet werden, da folgende Datei fehlt oder beschädigt ist:
<Windows root>\system32\hal.dll.
Installieren Sie ein Exemplar der oben angegeben Datei erneut.

Ich habe also die Installations-CD eingelegt und die Wiederherstellungskonsole gestartet. Es wurde eine Windows-Installation gefunden, allerdings G:\WINDOWS (das scheint das DELL MediaDirect zu sein) und nicht C:\WINDOWS wo das "richtige" Windows installiert ist.
Habe dann mit
bootcfg /rebuild
einen neuen Eintrag in der boot.ini angelegt, der endet allerdings mit allen Starteinstellungen (F8) im BlueScreen.

Auf C: kann ich leider in keinen Ordner wechseln etc. (Zugriff verweigert) - ist ja klar ich hab die Installation auf G: mit leerem Admin-Passwort gewählt.

Installiere jetzt gerade mal auf D: ein zweites Windows (mit identischem User + Passwort) und versuche dann mal auf die C:-Installation zu zugreifen. Werde dazu berichten.

Kann es sein das evtl. ein Hardware-Schaden vorliegt?

Was kann ich denn noch tun?

[update]

Mit der zweiten Installation habe festgestellt, das unter C:\windows der gesamte Ordner system32 fehlt!!!
Kann ich den "gefahrlos" von D: herüberkopieren? Viel mehr kann ja fast nicht mehr kaputt gehen.


[update]

Ich werde wohl um eine Neuinstallation auf C: nicht drumherumkommen wie es aussieht - entscheidende Dateien aus /system32/config lassen sich nich kopieren. Lade gerade noch ein Knoppix runter, evtl kann ich damit die Dateien kopieren, 1x mal das alte C:\windows starten und die Dateien meines Users unter C:\Dokumente und Einstellungen sichern - leider komme ich da nämlich von der Zweitinstallation aus nicht dran , obwohl ich den gleichen Benutzer und Kennwort verwende (habe den Zugriff auf die Eigenen Dateien für andere Benutzer eingeschränkt). Gibt es überhaupt eine Möglichkeit da ran zu kommen? Evtl. mit Knoppix?
Mitglied: drop-ch
17.03.2008 um 10:03 Uhr
Hi kidata

Zu deiner letzten Frage:
leider komme ich da nämlich von der Zweitinstallation aus nicht dran , obwohl ich den gleichen Benutzer und Kennwort verwende
Der Benutzername ist nur eine vereinfachte Darstellung für den Benutzer. Im Hintergrund wird vom System für jeden Benutzername eine SID erstellt. Diese SID ist einmalig.
Du kannst von deinem neuen System auf die Daten des alten Systems zugreiffen, indem du den Besitzt übernimmst. Dazu im Datei-Explorer rechte Maustaste auf das entsprechende Verzeichnis > Eigenschaften > Reiter "Sicherheit" > Knopf Erweitert > Reiter "Besitzer"
Hier kannst du den Besitz übernehmen. Option "Besitzer der Objekte und untergeordneten Container ersetzen" anwählen nicht vergessen.

Warum beim rumtragen des Gerätes dieser Fehler aufgetreten ist, kann dir wohl keiner hier im Forum sagen. Von einem Haarriss auf dem Motherboard über kalte Lötstelle bis zu statischer Ladung kann alles in Frage kommen.

gretz drop
Bitte warten ..
Mitglied: kidata
17.03.2008 um 16:44 Uhr
Hi kidata

Zu deiner letzten Frage:
> leider komme ich da nämlich von
der Zweitinstallation aus nicht dran , obwohl
ich den gleichen Benutzer und Kennwort
verwende
Der Benutzername ist nur eine
vereinfachte Darstellung für den
Benutzer. Im Hintergrund wird vom System
für jeden Benutzername eine SID
erstellt. Diese SID ist einmalig.
Du kannst von deinem neuen System auf die
Daten des alten Systems zugreiffen, indem du
den Besitzt übernimmst. Dazu im
Datei-Explorer rechte Maustaste auf das
entsprechende Verzeichnis > Eigenschaften
> Reiter "Sicherheit" > Knopf
Erweitert > Reiter "Besitzer"
Hier kannst du den Besitz übernehmen.
Option "Besitzer der Objekte und
untergeordneten Container ersetzen"
anwählen nicht vergessen.

Ich habe den Ordner unter "Dokumente und Einstellungen" jetzt mit einer KNOPPIX CD kopiert & kam dann an die relevanten Dateien ran.


Warum beim rumtragen des Gerätes dieser
Fehler aufgetreten ist, kann dir wohl keiner
hier im Forum sagen. Von einem Haarriss auf
dem Motherboard über kalte
Lötstelle bis zu statischer Ladung kann
alles in Frage kommen.

Wirklich sehr suspekt! Ein "chkdsk /r" hat den kompletten Ordner /system32 wieder zu Tage gebracht, aber zurückkopieren hat auch nicht geholfen.
Habe jetzt auf ein neues Windows auf der ursprünglichen Partition installiert & konfiguriere es grad wieder mit den gesicherter Daten.
Also alles halb so wild, nur eben sehr nervig und eine Menge Zeit die dabei drauf geht.

Grüße.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows XP
gelöst Suche Win XP Home Premium ISO Datei (7)

Frage von Stefan007 zum Thema Windows XP ...

Hyper-V
gelöst Bestehende XP-Installation mit Hyper-V virtualisieren (30)

Frage von fox14ch zum Thema Hyper-V ...

Windows 7
gelöst Win 7 Installation auf einem USB3 AIO (10)

Frage von Marcys zum Thema Windows 7 ...

Windows Installation
gelöst Fehlermeldung bei Installation mit Windows XP (7)

Frage von bestelitt zum Thema Windows Installation ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...