Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win2000 - Logon Skript wird nicht ausgeführt

Frage Microsoft

Mitglied: Benzer

Benzer (Level 1) - Jetzt verbinden

19.03.2009, aktualisiert 11:31 Uhr, 7202 Aufrufe, 12 Kommentare

Moin, ich will eine Batch (*.bat) Datei als Startskipt ablaufen lassen und das per GPO verteilen.

Habe dazu die Batch (proxy.bat) geschrieben.
Inhalt der proxy.bat:

Zitat:
regedit /s proxy.reg

Die die Datei proxy.reg im "silent mode" ausführt.
Inhalt der proxy.reg

Zitat:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"DisablePasswordCaching"=dword:00000001


Die Batch & die Registry Datei liegen in einem freigegebenen Ordner (Berechtigung Jeder - nur lesen) auf dem Server.

Dann habe ich eine GPO erstellt die unter:
Benutzerkonfiguration --> Windows-Einstellungen --> Skripts --> Anmelden
die auf die Batch Datei verweist.

Wenn sich der Test User der die GPO bekommen hat jetzt anmeldet, wird das Skript aber nicht ausgeführt und der Registry Eintrag nicht gesetzt.

Hat einer ne Idee was die Ursache sein könnte?

Wenn ich die Batch einfach so ausführe, wird der Eintrag in die Registry geschrieben.
Mitglied: El-Larso
19.03.2009 um 12:02 Uhr
Die User haben doch sicherlich keine Berechtigung in die Registry zu schreiben, oder? ;)
Bitte warten ..
Mitglied: 60730
19.03.2009 um 12:08 Uhr
Zitat von El-Larso:
Die User haben doch sicherlich keine Berechtigung in die Registry zu
schreiben, oder? ;)
Moin,

wäre im Fall von HKEY_CURRENT_USER eher unüblich

Ich tippe auf einen anderen "Bock"

mal testweise den /s rausnehmen und dann sieht man auch "was" los ist
Alternativ mein gern geschriebener Satz, bei Bätchen erst nach 100% zufriedenheit das @echo off eintragen

Ich verwette einen Topf Kaffe, daß "folgende Fehlermeldung / Popup auftaucht:

---------------------------
Registrierungs-Editor
xyz.reg kann nicht importiert werden: Fehler beim Öffnen der Datei.
Mögliche Ursache ist ein Datenträger- oder Dateisystemfehler.
OK

ergo - den kompletten Pfad der .reg mit in die Batch eintragen.

Gruß
Bitte warten ..
Mitglied: El-Larso
19.03.2009 um 12:24 Uhr
Zitat von 60730:
> Zitat von El-Larso:
> ----
> Die User haben doch sicherlich keine Berechtigung in die
Registry zu
> schreiben, oder? ;)
Moin,

wäre im Fall von HKEY_CURRENT_USER eher
unüblich


Tjoa... man sollte sich mal den Regkey anschauen, was? :D
Wäre unüblich, wenn das nicht lüppt.

Absolute Pfadangabe sollte wohl hinhauen.
Bitte warten ..
Mitglied: Benzer
19.03.2009 um 12:55 Uhr
Alsoooo... alle falsch :D (Hab ich das was von Kaffee gelesen? )
Meine .reg & .bat funktionieren.
Es liegt wohl am win2003 Server - da geht es (noch) nicht.

Habs jetzt mal mit win2000 als Testopfer ausprobiert. (Clients sind 2000 & XP)

Test user angemeldet - laden der Benutzereinstellungen dauert schon mal angenehm lange *hoff* - es klappt.
Allerdings bekomme ich beim ausführen einen UNC Fehler - ausführen der Datei vom Netzlaufwerk geht nicht.

Die Lösung:
Wieder die Kombination aus .reg & .bat - dachte ich.
Habe probiert das auszuführen um den UNC check zu deaktivieren:

Zitat:
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Command Processor]
"DisableUNCCheck"=dword:00000001

Aber natürlich kann auch dieses Starskript nicht ausgeführt werden - liegt ja auch im Netz.

Dann habe ich noch das hier gefunden:

Zitat:
reg add "HKCU\Software\Microsoft\Command Processor" /v DisAbleUNCCheck /t REG_DWORD /d 1

Ausführen und fertig. UNC check deaktiviert.

Aber wie bringe ich meine Clients bei das auszuführen ohne ein Startskript was im Netz liegt?!
Bitte warten ..
Mitglied: Dackelblick
19.03.2009 um 15:46 Uhr
Bei BAT-Scripts via logon-script ist es eine gute Idee, wenn man ein Client lokales Scipt ausführen will vorher im logon script auf das korrekt Laufwerk (C zu wechseln.
Bitte warten ..
Mitglied: DerWoWusste
19.03.2009 um 23:42 Uhr
N'Abend!
Warum machst Du es nicht (beides) mit reg add? Stört doch nicht, wenn das Skript im Netz liegt.
PS: es ist kein Startskript, sondern ein Anmeldeskript. Ein Startskript könnte nicht für HKCU genutzt werden.
Bitte warten ..
Mitglied: Benzer
20.03.2009 um 10:22 Uhr
Bitte warten ..
Mitglied: Benzer
20.03.2009 um 10:22 Uhr
Zitat von Dackelblick:
Bei BAT-Scripts via logon-script ist es eine gute Idee, wenn man ein
Client lokales Scipt ausführen will vorher im logon script auf
das korrekt Laufwerk (C zu wechseln.

Aber das Skript ist ja nicht lokal - sondern im Netz - was ja auch das UNC Problem verursacht.

Zitat von DerWoWusste:
N'Abend!
Warum machst Du es nicht (beides) mit reg add? Stört doch nicht,
wenn das Skript im Netz liegt.
PS: es ist kein Startskript, sondern ein Anmeldeskript. Ein
Startskript könnte nicht für HKCU genutzt werden.

Wie geht das denn per reg add als Skript? Eine Batch mit Ausführen --> reg add würde ja nicht funktionieren - UNC Fehler.
Bitte warten ..
Mitglied: 60730
20.03.2009 um 10:28 Uhr
Servus,

Wie geht das denn per reg add als Skript?
Eine Batch mit Ausführen --> reg add würde ja nicht funktionieren - UNC Fehler.

Ich lass mal die Hosen "runter" ....

Bei uns haben die wenigsten den UNC Check "Hack" - trotzdem stricke ich hin und wieder eine .reg mit ins Loginscript und es funktioniert trotzdem.

als extrem krummen workaround und nur weil Dackelblick (Volker) damit angefangen hat.
- Was aber nicht der Weg ist - den ich benutze - ich nutze die .regs wenn überhaupt wirklich direkt aus dem Netlogon.

copy %logonserver%\netlogon\123.reg %temp%\123.reg && regedit /s %temp%\123.reg || del %temp%\123.reg

Ansonsten schau dir mal Kixtart an, damit kannst du sehr "schöne" - "schnelle" Loginscripte schreiben.

Gruß
Bitte warten ..
Mitglied: Benzer
20.03.2009 um 11:38 Uhr
copy %logonserver%\netlogon\123.reg %temp%\123.reg && regedit /s %temp%\123.reg || del %temp%\123.reg

Das sieht doch auch nett aus - aber da habe ich immer noch ein Problem.
Ich muss das ja als *.bat im netlogon liegen haben und beim Anmelden ausführen lassen. Wenn ich eine *.bat ausführe kommt aber der UNC Fehler...

Bzw. Bei 2003 & XP kommt kein Fehler, es geht einfach nicht. Bei 2000 UNC Fehler.
Bitte warten ..
Mitglied: DerWoWusste
20.03.2009 um 21:14 Uhr
Bei mir kommt kein UNC-Fehler, weder bei 2000, noch bei xp. DisableUNCCheck hab ich noch nie gesetzt.
Batch als Loginskript, reg add... und fertig.
Bitte warten ..
Mitglied: Benzer
24.03.2009 um 11:41 Uhr
Ach du hast in die Batch das reg add geschrieben?
Ich hab die Batch ja nur die *.reg Datei ausführen lassen - evtl. liegts daran.

edit:
Ich habe mal das ausprobiert:
Batch mit:

reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /DisablePasswordCaching /t REG_DWORD /d 1

leider tut sich beim Anmelden des testusers gar nichts und der reg Eintrag wird nicht gesetzt...

edit2:

habe mich bei einem Schalter vertippt,

reg add "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings" /v DisablePasswordCaching /t REG_DWORD /d 1

funktioniert.
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Skript per GPO ausführen - Berechtigungen? (13)

Frage von honeybee zum Thema Windows Server ...

Batch & Shell
Powershell CHAT Skript (5)

Frage von xpxy15 zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...