Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win2000Server - Start der Zertifizierungsstelle Der Schlüsselsatz ist nicht vorhanden.

Frage Sicherheit Verschlüsselung & Zertifikate

Mitglied: Eukky

Eukky (Level 1) - Jetzt verbinden

10.01.2006, aktualisiert 06.06.2007, 15157 Aufrufe, 4 Kommentare

Nach einem Update startet die Zertifizierungsstelle nicht mehr, mit Fehlermeldung wegen des Schlüsselsatzes, 0x80090016 (-2146893802)

Hallo Leute,

suche Hilfe zu folgendem Problem: Nach einem Update startet die Zertifizierungsstelle nicht mehr, mit Fehlermeldung:" Der Schlüsselsatz ist nicht vorhanden. 0x80090016 (-2146893802)"

Auf dem Server läuft IIS und Exchange (inkl. OWA mit SSL), der ist auch Domänencontroller. Alle anderen Dienste außer Zertifizierungsstelle scheinen zu funktionieren. Ereignisanzeige: "Die Zertifikatsdienste wurden nicht gestartet: Kette des Zertifizierungsstellen-Zertifikats für Name_der_Zertifizierungsstelle konnte nicht erstellt werden. Der Schlüsselsatz ist nicht vorhanden. 0x80090016 (-2146893802)."

Habe ordentlich gegoogelt, die gefundenen möglichen Ursachen gelten bei mir nicht: Dienst "Geschützter Speicher" läuft; die Freigaben CertConfig und CertEnroll sind da, für mit Vollzugriff für Administratoren sowie System; genauso Vollzugriff haben System und Administratoren auf den Ordner "C:\Dokumente und Einstellungen\All Users\Anwendungsdaten\Microsoft\Crypto\RSA\MachineKeys".

Der Serverzertifikat ist noch da, OWA über SSL funktioniert ja, aber "Zertifikat erneuern" über Zertifizierungsstelle scheitert mit gleicher Meldung, "Zertifikat anzeigen" über Zertifizierungsstelle->Name_der_Zertifizierungsstelle->Eigenschaften->Allgemein bringt eine weitere Fehlermeldung: "Zugriff verweigert 0x80070005 (WIN32: 5)".

Im Allgemennen nennt Microsoft folgende 3 möglichen Ursachen: NTE_BAD_KEYSET (0x80090016)
? Key container does not exist.
? You do not have access to the key container.
? The Protected Storage Service is not running.

Sieht so aus, als ob Windows die Schlüssel nicht findet, obwohl die wohl noch da sind, weil
die Ausgabe von "certutil -verifykeys" ist:
Der Schlüssel Name_der_Zertifizierungsstelle wurde als öffentlicher Schlüssel für das Zertifikat Name_der_Zertifizierungsstelle bestätigt.
-- Das Testen der Signature wurde erfolgreich abgeschlossen
CryptAcquireContext hat 0x80090016 (-2146893802) zurückgegeben. -- Name_der_Zertifizierungsstelle(1)
LoadKeys hat 0x80090016 (-2146893802) zurückgegeben.
CertUtil: -verifykeys-Befehl FEHLGESCHLAGEN: 0x80090016 (-2146893802)
CertUtil: Der Schlüsselsatz ist nicht vorhanden.

Jemand eine Idee?
Danke!
Mitglied: Eukky
16.01.2006 um 16:45 Uhr
Hallo Honk,

vielen Dank fürs Link, probiere gerade einige Ideen aus dem Artikel aus.

Eukky
Bitte warten ..
Mitglied: Eukky
17.01.2006 um 10:12 Uhr
Hallo,

hat leider nichts gebracht; Delegierung ist nicht eingerichtet, der Rechner ist der einzige Server, also Webfreigaben-Zugriff spielt wohl auch keine Role (oder?), Smartcards werden nicht verwendet.
Die %WINDIR%\system32\certsrv\certdat.inc ist in Ordnung, ich habe mit gleicher Datei auf Win2000Server mit Exchange unter VMWare verglichen.

Grüße,
Eukky
Bitte warten ..
Mitglied: Eukky
06.06.2007 um 14:11 Uhr
Zertifizierungsstelle deinstalliert und wieder installiert, alles Prima!
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows 10
Windows 10 Start-Probleme - Hilfe (9)

Frage von clragon zum Thema Windows 10 ...

Audio
gelöst Extern kein Ton, Intern Ton vorhanden - Windows Server 2008 R2 (15)

Frage von Funky86 zum Thema Audio ...

Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Microsoft Office
Keine Updates für Office 2016 (12)

Frage von Motte990 zum Thema Microsoft Office ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...