Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win2003 Server Spiegelfestplatte Booet nicht (500G SATA)

Frage Microsoft Windows Server

Mitglied: commanderberti

commanderberti (Level 1) - Jetzt verbinden

30.10.2006, aktualisiert 03.11.2006, 6433 Aufrufe, 19 Kommentare

hallo zusammen,

habe einen windows 2003 server mit Athlon 64x2 und nforce 4 sli chipsatz.
dann unter windows eine microsoft software spiegelung für die startplatte eingerichtet.
es sind insg 4x 500 GB SATA platten in dem server wobei die startpartition (c.) 500GB groß ist und eben gespiegelt.
es läuft alles wunderbar, bis auf das problem das ich von der spiegelplatte nicht booten kann. sollte allso die 1. platte mal ausfallen habe ich nix von der spiegelung. .. wenn ich im bootmenue starten vom mirror auswähle (also solange disk 1 funktioniert) klappt das auch, er bootet dann von der mirror disk...
habe ich die mirror disk alleine im rechner bleibt die kiste nach dem bios meldungen mit blinkendem cursor stehen... das bootmenu (boot.ini) kommt nicht mal... wenn ich von cd boote und die wiederherstellungskonsole starte wird das windows auch nicht erkannt (also kein fixmbr oder fixboot möglich).... mir schein es als wäre z.B. der mbr nicht richtig auf den spiegelsatz geschrieben...
weis jemand hilfe?
danke!
Mitglied: leknilk0815
30.10.2006 um 15:26 Uhr
Hi,
der Spiegel ist schon in Ordnung, aber Windows bootet eben von der Platte, die in der Boot.ini angegeben ist, und das ist eben eine phys. Platte und nicht der Spiegel.
Wenn die zweite Platte im Spiegel ausfällt, bootet Windows anstandslos, weil die Boot.ini stimmig ist. Fällt die erste Platte aus, muß entweder die Boot.ini angepasst werden oder die Platten hardwaremäßig vertauscht werden.

Gruß - Toni
Bitte warten ..
Mitglied: commanderberti
30.10.2006 um 15:34 Uhr
jaein das wäre meine ich der fall wenn ich das bottmenü sehe und er dann bei der auswal des betriebssystems nicht bootet. ich sehe aber das bootmenü wenn die spiegelplatte dran ist nie!
habe natürlich auch schon versucht die spiegelplatte an den sata der bootplatte zu hängen und dann zu booten.. (so wars ja bei ide platten auch immer) geht aber auch nicht.. ist das selbe...
mmm mache das mit dem spiegeln eigentlich schon seit jahren und es hat bis jetzt immer geklappt...
was ist das nur... mmmmmmmm
Bitte warten ..
Mitglied: leknilk0815
30.10.2006 um 15:48 Uhr
Hi,
ich weiß nicht, um welche OS es sich handelt.
Windows Spiegel funktionieren bei Standard- Konfig sauber.
Da Du mehrere OS benutzt, deshalb auch einen Bootmanager drauf hast, denke ich, daß dieser eben nicht gespiegelt wird und somit nur auf der ersten Platte vorhanden ist. Ein HW- Raid- Kontroller würde sich "richtig" verhalten, da dieser die Platte Bit für Bit spiegelt. Windows spiegelt Patitionen...
Bitte warten ..
Mitglied: commanderberti
30.10.2006 um 15:52 Uhr
ne ich habe nur win2003 server drauf. und der installierte nach der spiegelung automatisch ein bootmenu mit auswahl:
boot von server 2003
oder boot vom mirror...

ist windows 2003 standart server rc2
Bitte warten ..
Mitglied: leknilk0815
30.10.2006 um 15:58 Uhr
sorry,
Mirror bei W2K3 hab ich noch nicht probiert, scheint wohl anders zu sein als früher.

Gruß - Toni
Bitte warten ..
Mitglied: commanderberti
30.10.2006 um 16:01 Uhr
ja ist anderst... habe mich auch gewundert, als ich nach dem ersten mirror ein bootmenü hatte..
nur booten von der mirror disk wenn die primäre futsch ist sollte er schon können, sonst kann ich mir den aufwand schenken... ztztztzt microsoft was tust du...
Bitte warten ..
Mitglied: leknilk0815
30.10.2006 um 16:06 Uhr
ich würde einfach mal die 2. Platte an den anderen Port hängen und sehen, was passiert. Vielleicht kann man da Rückschlüsse ziehen...
Bitte warten ..
Mitglied: commanderberti
30.10.2006 um 16:13 Uhr
hab ich schon gemacht...
bootet nicht, und wie schon gesagt läst sich auch nicht per wiederherstellungskonsole (boot von cd)ansprechen...... mmm habe nun mal die nvidia ide treiber runter geschmissen und nochmals eine neue spiegelung mit den microsoft treibern gestartet... er spiegelt halt jedes mal so 2h ... (500 GB..)
Bitte warten ..
Mitglied: sysad
30.10.2006 um 16:51 Uhr
Das Problem war schon bei IDE-Platten, wenn die Spiegelplatte als Slave konfiguriert war. Da half dann nur eine 4-Port Karte und die Platten wurde beide als Master drangehängt. Bei SATA sollte das eigentlich nicht mehr sein.

Das mit dem MBR ist m.E. die wahrscheinlichste Ursache. Deswegen klone ich die Platten vorher mit Acronis.(der Spiegel wird danach trotzdem neu aufgebaut, aber ich habe die Partitionstabelle etc. identisch).

Am W2003S liegt es nicht, die RAID1 Funktion ist fehlerfrei (das hat MS auch zugekauft und nicht selber geschnitzt...).

Als Test würde ich mal die 'Hauptplatte' und den 'Spiegel' vertauschen und sehen, ob es davon bootet.
Bitte warten ..
Mitglied: commanderberti
30.10.2006 um 16:58 Uhr
den tausch-test habe ich schon gemacht.. geht nicht.. mit was für ner soft von archonis klonst du? kann die soft auf windows servern betrieben werden?
Bitte warten ..
Mitglied: nexutron
30.10.2006 um 17:34 Uhr
Moin

Ich denke, das ein anderes Problem vorliegt

Wenn du 2 Platten Spiegelst, ist nur eine "Aktiv" (schau mal mit F-Disk nach)
Du musst die 2. Platte unter F-Disk Aktiv setzen, dann sollte es gehen.


Gruß Nex
Bitte warten ..
Mitglied: commanderberti
30.10.2006 um 20:24 Uhr
fdisk:

werde es morgen mit ner win98 bootdisk und fdisk versuchen. ganz erhlich war ich der meinung das die aktivierung mit fdisk ab win2k erledigt war... es gibt ja auch kein fdisk mehr ab win2k... mmm wenns das war, dann zahl ich dir ein bier...
danke
Bitte warten ..
Mitglied: commanderberti
31.10.2006 um 08:51 Uhr
leider lag es nicht an der aktibierung, die mirror platte war schon aktiviert.. bootet aber trotzdem nicht...
langsam fällt mir nix mehr ein...
Bitte warten ..
Mitglied: leknilk0815
31.10.2006 um 10:33 Uhr
letzte Idee:
versuch mal, statt der "defekten" Disk eine leere Disk dazuzuhängen, evt. bootet das System dann.
Dies ist zumindest bei den mir bekannten SCSI- Raid- Kontrollern so, wenn eine Disk im Array fehlt, bootet die Kiste nur nach Aufforderung, ist eine Disk vorhanden (wenn auch failed oder leer), bootet die Maschine alleine.
Vielleicht ist bei W2K3 ein ähnlicher Mechanismus am Werk...

Gruß - Toni
Bitte warten ..
Mitglied: sysad
31.10.2006 um 13:36 Uhr
Keine Panik, ganz langsam:

Dabei gehe ich davon aus, dass jetzt noch kein Spiegel eingestellt ist.

1. Klon erstellen, z.B. mit Acronis (macht die Partitionen gleich und den MBR)
2. Testen, ob der Klon booten kann (muss er!)
3. In der Datenträgerverwaltung die Spiegelung aller Partitionen von der ersten Platte erstellen (dabei ist es sinnvoll, einen nach dem anderen zu machen, weil der Kopf sonst wie wild auf den Platten rumfährt, was Zeit kostet)
4. 'Originalplatte' abhängen und vom Spiegel booten.

Mit SATA habe ich dabei keine Erfahrung, es müsste aber einfacher sein als mit PATA, weil das Master-Slave Konzept fehlt.
Bitte warten ..
Mitglied: leknilk0815
31.10.2006 um 14:56 Uhr
Nur als Kommentar aufzufassen:

Mit der Arconis- Lösung wäre ich absolut unzufrieden, da die Spiegelung mit Bordmitteln funktionieren MUSS!!
Ein Zusatztool, das bei Datenwiederherstellung nötig ist, halte ich bei so wichtigen Grundfunktionen für unsinnig, entweder es geht mit den von MS gestellten Mitteln, oder man nimmt eine komplett andere Lösung (Ghost- Image, HW- Raid. etc.).
Mischformen bringen im Ernstfall nur Verwirrung und Datenverlust durch Fehler, vom Zeitfaktor ganz zu schweigen.

Gruß - Toni
Bitte warten ..
Mitglied: commanderberti
03.11.2006 um 13:38 Uhr
bin nun einen schritt weiter. die erste platte hatte einen defekt! daher würde immer nur müll gespiegelt.
platte ausgetauscht booten jetzt auch die spiegel immer... nur: stürtzt der rechner bim booten vom spiegel immer (windows startbildschirm war schon da) ab und bootet wordlos neu... man
ztztzt..
Bitte warten ..
Mitglied: sysad
03.11.2006 um 13:52 Uhr
Da hast Du recht. Ich nehme Acronis auch nicht zum Spiegeln, sondern zum Klonen.

Nach meiner Erfahrung kann man aber nicht immer vom Spiegel booten, wenn nicht vorher ein Klon drauf gemacht wurde, der die MBRs mit kopiert.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Festplatten, SSD, Raid
Ausfallraten von SATA-Festplatten im harten Server-Einsatz - c't magazin (6)

Link von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Server-Hardware
gelöst Adaptec ESB2 SATA RAID Server 2012 R2 (8)

Frage von hometown zum Thema Server-Hardware ...

Windows Server
Mailserver auf Windows Server 2012 (9)

Frage von StefanT81 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...