Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win2k3 SMB - Exchange 2k3 - CTI Anwedung-Java

Frage Linux Samba

Mitglied: t3r0x

t3r0x (Level 1) - Jetzt verbinden

30.06.2006, aktualisiert 17.04.2007, 5306 Aufrufe, 6 Kommentare

Guten Abend miteinander


Ich habe bei mir zu Hause einen Small Business Srv und den dazumitgelieferten MS Exchange 2003 am laufen. Da ich seit neustem mit meiner Teilnehmervermittlungsanlage (Aastra) vernetzt bin (over LAN) wollte ich die CTI Anwendung in Betrieb nehmen. Das ganze Programm ist auf Java aufgebaut und ist spezifisch für meine TVA ausgelegt. Jetzt zu meinem Problem:

Bei verschiedenen Sache sollte mir die Applikation eine Mail zuschicken. Habe eine Mail-Adresse eingerichtet (oip@domain.ch) und diese auch so eingestellt bei der Applikation. Das Problem ist nur, dass er gar nicht zum Mail verschicken kommt, jedoch per OWA kann ich ohne Probleme verschicken/empfangen.

Auszug aus Log-File, wie gesagt Java Applikation:

1: ExchangeEventHandler:IsMessageValid: Parent=user1/Posteingang
2: >>OnSynchSave recieved-Change Event: file://./backofficestorage
2:/domain.ch/MBX/user1/Posteingang/OIP%3A Voice-Mail von 21 Andy Funk.EML
3: *EventsNotifier run>>>
4:CExchangeEvents::NotifyClientListeners - Parent Id=http://localhost/exchange/user1/Posteingang/
4:http://localhost/exchange/user1/-FlatUrlSpace-/
4:59517dfa4b294042ba5d88ecc7b8c73b-2435/ Folder type=urn:content-classes:mailfolder
5: CdoRecord open failed for
6:http://localhost/exchange/user1/Posteingang/OIP:%20Voice-Mail%20von%202 ...
6:Ein Objekt oder Daten, die den Angaben für Namen, Bereich oder Auswahlkriterium
6:entsprechen, konnten innerhalb dieses Vorganges nicht gefunden werden.
7: CExchangeEvents::NotifyClientListeners Error getting Item type:Ein Objekt oder
7: Daten, die den Angaben für Namen, Bereich oder Auswahlkriterium entsprechen, konnten
7: innerhalb dieses Vorganges nicht gefunden werden.
8: **EventsNotifier run over<<<

user1: domain-benutzer

Ich habe mal was über das Drive M gelesen, dass man auf "file://./backofficestorage/" zugreifen kann, wäre dies eine vielleicht eine Lösung?
Wenn ich auf http://srv/exchange/user1/ connecten will, findet er auch den pfad nicht. Gibt es diese Möglichkeit überhaupt?

Falls ihr mehr Infos braucht um überhaupt ewas anzufangen, einfach nur melden.

Vielen Dank für eure Hilfe

Andy, der dau ;))
Mitglied: unzhurst
30.06.2006 um 22:41 Uhr
Hallo Andy,

das Laufwerk M gibts bei Exchange 2003 nicht mehr...
Versuch mal folgendes:
- ruf mal die URL http://srv/exchange auf
- geht dass? dann log dich mit den Daten deines user1 ein
- was für einen Pfad zeigt er dir oben in der Adressleiste danach an?

Falls der Aufruf von http://srv/exchange nicht geht, hast du ein Problem mit
deinem OWA. Dann sollte aber auch eine Fehlermeldung im Browser erscheinen?!

Gruß aus dem Badischen
Patrick
Bitte warten ..
Mitglied: t3r0x
01.07.2006 um 09:50 Uhr
Hallo Patrick!

Der OWA funktioniert einwandfrei für jeden User. Es wird mir aber nur folgendes angezeigt in der Adressleiste: https://srv/exchange/. Nichts von einem User in der Adressleiste.

Gruss Andy
Bitte warten ..
Mitglied: unzhurst
01.07.2006 um 10:11 Uhr
d.h. der OWA ist für https konfiguriert?
https://srv/exchange geht, http://srv/exchange geht nicht?
Meld dich mal mit einem Benutzer an und klick in seinen Posteingang,
dann sollte der Pfad so aussehen https://srv/exchange/userxyz/posteingang?

Kannst du ihn deiner Java-App einstellen dass er https und nicht http benutzt,
falls http nicht freigeschaltet ist?

Gruß
Bitte warten ..
Mitglied: t3r0x
01.07.2006 um 10:41 Uhr
Leider kann ich bei Application nicht einstellen ob er http oder https machen soll. Daher habe ich einfach mal den Exchange ohne ssl laufen lassen, und siehe das das gleiche Problem.

Ich kann auch nicht auf das verzeichniss http://srv/exchange/user1/Posteingang zugfreifen. Wenn ich mich im OWA einlogge und auf Posteingang klicke, bleibt die URL genau die selbe, also http://srv/exchange

andy
Bitte warten ..
Mitglied: unzhurst
01.07.2006 um 13:07 Uhr
merkwürdig...
greifst du durch einen ISA auf den Exchange zu oder direkt ohne Firewall usw.?
Hast du die Sache mit den URLs direkt auf dem Exchange getestet?

Gruß
Bitte warten ..
Mitglied: t3r0x
17.04.2007 um 22:33 Uhr
Hallo

Sorry erstmal, dass ich nichts mehr geschrieben habe. Habe es wohl einfach verpeilt. Es ist mir schon ein wenig peinlich, dass ich erst jetzt antworte. Jedoch denke ich, dass es sinnvoll ist die Lösung zu präsentieren, falls sonst jmd. am gleichen Problem (selbstverständlich mit der gleichen PBX) scheitert, wie ich dazumal.

Das Problem war, dass sich die Anwendung nicht am Exchange authentifiziert hat. Somit musste ich beim Virtuellen SMTP Server unter den Relay-Einstellungen, die IP des Servers (auf dem die Java Applikation läuft) angeben, dass der relayen darf.

Wegen dem OWA Zugriff...
der Zugriff funktioniert natürlich über http://srv/exchange/user@domain.ch/posteingang.

Hatte dazumal halt noch gar keine Ahnung von dem Ganzen, hat sich jedoch bis heute ein ganz wenig geändert ;)

Gruss Andy *rot-werd*
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Exchange Server
gelöst SBS2011 - im Exchange mobile Geräte löschen (4)

Frage von MiSt zum Thema Exchange Server ...

Exchange Server
Inhalt von Postfächern in Exchange löschen (9)

Frage von m.reeger zum Thema Exchange Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Exchange Server
Exchange 2013 lässt sich nicht Updaten (7)

Frage von onkel87 zum Thema Exchange Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

SAN, NAS, DAS
gelöst HP-Proliant Microserver Betriebssystem (14)

Frage von Yannosch zum Thema SAN, NAS, DAS ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows 7
Verteillösung für IT-Raum benötigt (12)

Frage von TheM-Man zum Thema Windows 7 ...