Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win2k8R2 füht Gelpanten Task (Aufgabe) nicht aus

Frage Microsoft Windows Server

Mitglied: killtec

killtec (Level 3) - Jetzt verbinden

19.11.2012 um 13:39 Uhr, 2732 Aufrufe, 10 Kommentare

Hallo zusammen,

ich habe hier ein Problem mit der Aufgabenplanung eines 2008R2 Servers (Updates auf aktuellem Stand).
Ich habe in der Aufgabenplanung eine Aufgabe eingestellt, die eine .bat - File aufruft. In dieser sind 3 Befehle, die nacheinander abgearbeitet werden (kopieren von div. Listen).
Der Job nennt sich "Listen kopieren".
Die Aufgabenplanung gibt das "Ergebnis der letzten Ausführung" mit (0x1) zurück. Die .bat-Datei wird nicht gestartet.
Aktuell habe ich keine Idee, was es sein kann. Kenn jemand die Lösung?

Danke.
Mitglied: GuentherH
19.11.2012 um 13:42 Uhr
Hallo.

- poste doch einmal die Befehlszeile für den Aufruf
- poste doch den Script, der ausgeführt werden soll

LG Günther
Bitte warten ..
Mitglied: Fidel83
19.11.2012 um 13:48 Uhr
Hallo

Klappt die Batch denn ohne Aufgabenplanung?

LG
Bitte warten ..
Mitglied: killtec
19.11.2012 um 13:53 Uhr
Hi,
ohne Aufgabenplanung klappt die Batch ohne Probleme.
Der Pfad der Batch steht auch in Anführungszeichen, da der Dateiname der Bach mit einem leerzeichen versehen ist.
Gleiches Problem hatte ich aber auch schon mal an einem anderen Server, da lag die Datei ohne leerzeichen im VZ Root.
(war auch im gleichen System).
Also von daher kann ich Pfad und Inhalt ausschließen.

Pfad: "D:\scripte\listen kopieren.bat"
Inhalt:
copy d:\files\bm\file1.xls d:\files\fe\file1.xls
copy d:\files\bm\file1.xls d:\files\ve\file1.xls

Gruß
Bitte warten ..
Mitglied: Ravers
19.11.2012 um 14:19 Uhr
Moin,

hatte das Problem auch vor 1-2 Wochen.
Lag an einem Dienst, der sich nicht starten lies. Welcher das war, weiß ich leider nicht mehr. Aber schau dir mal deine Dienste an. Ich denke das kein Task gestartet werden kann, egal ob Batch oder sonst was.
Abre schau mal nach ...

greetz
ravers
Bitte warten ..
Mitglied: killtec
19.11.2012 um 14:21 Uhr
Hi,
die Dienste sind es nicht (so wie es aussieht). Die Automatischen Dienste sind alle aktiv).

Gruß
Bitte warten ..
Mitglied: Fidel83
19.11.2012 um 14:42 Uhr
Wie steht es mit geänderten Passwörtern oder Nutzerrechten? Im social-technet wurde der Fehler wegen eben dieser Sachen diskutiert.

http://social.technet.microsoft.com/Forums/de-DE/windows_Serverde/threa ...
Bitte warten ..
Mitglied: holyone
19.11.2012, aktualisiert um 14:50 Uhr
Hi @killtec,
log dir mal die Ergebnisse des Copy befehls und schau mal ob er es überhaupt korrekt ausführt.

Kann mir da neben dem was @Fidel83 gesagt hat auch fehlende Rechte des angegebenen Users denken. Hast du mal testweise in der Aufgabe "Mit höchsten Privilegien ausführen" angehakt?

- holyone
Bitte warten ..
Mitglied: b11ck
19.11.2012 um 15:39 Uhr
Hi
Check doch mal das:
- Im Reiter Allgemein ist "Mit höchsten Privilegien ausführen" angekreuzt
- Im Reiter Aktion ist unter
"Programm/Skript" nur der Name der cmd-Datei
"Starten in (optional)" der Pfad zum Batch mit abschliessendem Backslash
Anschliessend mit rechte Maustaster - Ausführen testen
Gruss
Bitte warten ..
Mitglied: killtec
19.11.2012 um 15:46 Uhr
Hi,
@ Fidel83: Das Kennwort des Admins wurde seit einiger Zeit nicht geändert. Der Task ist erst seit 2 Wochen drin, das lässt sich also ausschlißen.
@ holyone: Der Haken inst nicht gesetzt. Der Task wird unter dem Kontext des Domänenadmins ausgeführt.

@ b1ck: Danke für die Hinweise. Hab das alles so eingestellt. Es hat geklappt.

Danke @ all
Bitte warten ..
Mitglied: b11ck
20.11.2012 um 18:20 Uhr

@ b1ck: Danke für die Hinweise. Hab das alles so eingestellt. Es hat geklappt.


Bitte. Hab selber lange daran herumgedoktert...
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Assembler
Assembler-Aufgabe (4)

Frage von How-To zum Thema Assembler ...

Windows Server
gelöst Server 2008 R2: Aufgabe für Windows 10 per GPO zur Verfügung stellen (1)

Frage von honeybee zum Thema Windows Server ...

Batch & Shell
gelöst Powershell oder Batch-Task: Kopiere Datei x mal und benenne diese um (2)

Frage von Lorderich zum Thema Batch & Shell ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...