Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win7 - Datei direkt auf C kein Zugriff

Frage Microsoft Windows 7

Mitglied: harfes

harfes (Level 1) - Jetzt verbinden

03.08.2010 um 09:40 Uhr, 6260 Aufrufe, 9 Kommentare

Ich habe auf einem Win7-PC (32bit) folgendes Problem: es wird ein älteres Programm auf einer Netzwerkfreigabe gestartet, dass eine (völlig harmlose, aber notwendige) Ini-Datei direkt auf C ablegt - dieser Ablageort ist vom Programm leider starr vorgegeben und kann nicht verändert werden. Als Administrator habe ich problemlos Zugriff, jedoch kann kein "normaler" User auf diese Datei zugreifen - Meldung: "Auf C:\WK.INI kann nicht zugegriffen werden.
Über Eigenschaften/Sicherheit habe ich bereits Jeder mit Vollzugriff zugefügt, das hat aber auch nicht geholfen. Ebenso habe ich einen Benutzer angelegt mit vollen Domain-Admin-Rechten - aber selbst der darf nicht zugreifen!!! Keine Ahnung, wer sich so einen Quatsch bei MS ausdenkt, aber wie kann ich's ändern???

Hartmut
Mitglied: Crusher79
03.08.2010 um 10:36 Uhr
Hi,

sollte an der UAC liegen. Genrell soll dadurch Schade abgewendet werden. Man kann UAC auch gezielt anpassen. Denn immer alles abzuschalten ist mitunter kontraproduktiv.

mfg Crusher
Bitte warten ..
Mitglied: harfes
03.08.2010 um 11:15 Uhr
Hallo Crusher,

nee, das war's leider nicht (hab' mal zum Test die UAC komplett abgeschaltet...). Soweit ich das im Internet bisher recherchieren konnte, gibt es zusätzlich sowas wie den "Integrity Level" (=IL) des Benutzers, der wohl zusätlich für Sicherheit sorgen soll. Ich vermute mal, dass da irgendeine Änderung stattfinden muss, aber welche und wie???

Nochmal: der Benutzer "Administrator" (=Domain-Admin) darf zugreifen, ein anderer Benutzer "Admin" (ebenfalls Domain-Admin) nicht...????!!! Normaler Benutzer: nix...

Hartmut
Bitte warten ..
Mitglied: goscho
03.08.2010 um 12:58 Uhr
Zitat von harfes:
Nochmal: der Benutzer "Administrator" (=Domain-Admin) darf zugreifen, ein anderer Benutzer "Admin" (ebenfalls
Domain-Admin) nicht...????!!! Normaler Benutzer: nix...
Hallo Hartmut,
hast du in den Sicherheitseinstellungen der wk.ini mal den richtigen Benutzer ausgewählt und auf Vollzugriff gestellt (domain\benutzername)?

Was sagt der Programmhersteller dazu?
Bitte warten ..
Mitglied: Connor1980
03.08.2010 um 12:59 Uhr
Hallo,

ich denke dieser Link und ff. sollten dich zum Ziel führen.
Ich denke mal, wenn du das IL für das Verzeichnis runtersetzt auf höchstens die Stufe, mit der darauf zugegriffen wird, sollte das funktionieren.

Schöner wäre natürlich eine aktuelle version der Software, oder du probierst ma den "XP-Mode" aus.

Grüße
Bitte warten ..
Mitglied: harfes
03.08.2010 um 13:13 Uhr
Hallo,

also die "normalen" Rechte sind definitiv nicht die Ursache! Es lag am IL - und den kann man mit den Bordmitteln (ICACLS.exe) auch nur für diese eine Datei einstellen (danke für den Link von Connor1980 - den hatte ich gerade vor einigen Minuten auch gefunden...und daraufhin das ICACLS entsprechend angewendet: "icacls wk.ini /setintegritylevel L"). Jetzt geht's...


Gruss,

Hartmut
Bitte warten ..
Mitglied: Crusher79
03.08.2010 um 14:02 Uhr
Dann kannst du ja das Ganze auf erledigt setzen. ;)

Sorry, die IL schwebten mir vorhin auch vor. Nur ich kam bei besten Willen net mehr auf den Namen.

ILs sind allen anderen Rechten übergeordnet. darum ist der Weg mit icacls schon mit der richtige Ansatz!

mfg Crusher
Bitte warten ..
Mitglied: DerWoWusste
03.08.2010 um 22:36 Uhr
...bleibt noch das Problem, dass das Ding zunächst mal von einem Admin erstellt werden muss.
Und noch was: ILs werden bei ausgeschalteter UAC nicht berücksichtigt - dass es bei Dir ohne UAC nicht ging (während die NTFS-Rechte stimmten), kann nicht wirklich sein, evtl. nicht neu gestartet?
Bitte warten ..
Mitglied: harfes
04.08.2010 um 09:44 Uhr
Zitat: "ILs werden bei ausgeschalteter UAC nicht berücksichtigt ..." - das kannst Du gerne mal ausprobieren, die werden definitiv beachtet! Und beim Ausschalten der UAC wird der Benutzer aufgefordert (und darauf hingewiesen) den PC neu zu starten...was ich natürlich getan habe.
Ein weiteres Kuriosum von Win 7 ist, das der Benutzer mit dem Namen "Administrator" (=Domänen-Admin) vollen Zugriff auf die Dateien mit dem IL High hat, aber ein anderer Benutzer "Admin" (mit ebenfalls Domänen-Admin-Rechten keinen Zugriff hat...das gehört wohl zu Pseudo-Sicherheitsstrategie von Microsoft...einen Sinn sehe ich darin aber nicht.

Hartmut
Bitte warten ..
Mitglied: DerWoWusste
04.08.2010 um 14:25 Uhr
Moment.
Wenn Du zur Admingruppe gehörst und Dir mittels process explorer bitte den IL von Anwendungen ansiehst, die Du startest, wirst Du sehen, dass sie den IL medium tragen (bis auf IE mit protected mode, der trägt low). Ohne UAC werden die Prozesse den IL high haben, deshalb hast Du schon recht, ILs werden berücksichtigt, was aber bei Admins nicht mehr auffällt und somit quasi das selbe ist, wie unter xp.

Der Nutzer Administrator (lokal) wird auch bei angeschalteter UAC nicht von der UAC regiert - er bildet die einzighe Ausnahem. Ein Benutzer Administrator, der Domänenadmin ist, kann keine Ausnahme bilden (und hat es in meinen Versuchen auch nicht getan).
Bitte warten ..
Ähnliche Inhalte
Windows 7
Programme stürzen auf einmal direkt ab (Win7)
gelöst Frage von deniska93Windows 76 Kommentare

Hallo, habe auf einem Windows 7 x64 Pro PC das Problem, dass auf einmal manche Programme abstürzen Bspw. VMware ...

Netzwerkgrundlagen
Zugriff auf C im Heimnetzwerk nicht möglich
Frage von NebuchadNetzwerkgrundlagen34 Kommentare

Hallöchen, ich habe ein Problem in meinem Heimnetz, ich würde gerne einrichten, dass ich von den jeweiligen PC's auf ...

LAN, WAN, Wireless
Externer Zugriff auf Win7 Client
Frage von PeterzLAN, WAN, Wireless10 Kommentare

Hallo zusammen, ich habe folgendes Problem und komme irgendwie nicht weiter. Ich möchte unseren Mitarbeitern ermöglichen, sich über einen ...

Windows 10
C: Partition direkt auf dem laufenden Rechner klonen
gelöst Frage von HanutaWindows 108 Kommentare

Hallo Zusammen, habe mir einen neuen Schleppi gekauftleider zu spät festgestellt, das er keine Wartungsklappe enthält (Fehler)bin trozdem mit ...

Neue Wissensbeiträge
Mac OS X

MacOS wo ist die Tilde ?

Tipp von Alchimedes vor 53 MinutenMac OS X

Hallo, ich hab eine MacOS qwertz Keyboard auf US Layout umgestellt da die Sonderzeichen besser ereichbar sind. Leider fehlt ...

Datenschutz

Weitere Inforamtionen zum Sicherheitsproblem BeA

Information von Penny.Cilin vor 7 StundenDatenschutz

Im folgenden ein weiterer Bericht über die Sicherheitsprobleme von Bea. Fataler Konstruktionsfehler im besonderen elektronischen Anwaltspostfach Gruss Penny

Windows 10

Systemdienste behalten nach Win10 inplace-Upgrade nicht die ggf. modifizierte Startart bei

Tipp von DerWoWusste vor 9 StundenWindows 103 Kommentare

Stellt Euch vor, Ihr habt ein Win10 System und modifiziert dort die Startart von Systemdiensten. Zum Beispiel wollt Ihr ...

Microsoft Office

Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei

Anleitung von SarekHL vor 12 StundenMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...

Heiß diskutierte Inhalte
Netzwerke
NTFS-Berechtigung
Frage von Daoudi1973Netzwerke23 Kommentare

Hallo zusammen und frohes neues Jahr (Sorry, ich bin spät dran) Meine Frage: 1- Ich habe einen Ordner im ...

Batch & Shell
AD-Abfrage in Batchdatei und Ergebnis als Variable verarbeiten
gelöst Frage von Winfried-HHBatch & Shell19 Kommentare

Hallo in die Runde! Ich habe eine Ergänzungsfrage zu einem alten Thread von mir. Ausgangslage ist die Batchdatei, die ...

Microsoft Office
Deaktivieren von Startbildschirm und Backstage-Ansicht in Office 2016 per Batch-Datei
Anleitung von SarekHLMicrosoft Office17 Kommentare

Guten Morgen zusammen! Ich habe mir gestern (auch mit Hilfe dieses Boards) ein Script gebastelt, um in Office 2016 ...

Windows 10
Netbook erkennt Soundkarte nicht - keinerlei Info zum Hersteller und Modell vom Netbook und Hardware bekannt
Frage von fyrb38Windows 1017 Kommentare

Guten Tag, meine Schwester reist in einigen Wochen für ein paar Monate ins Ausland und hat sich dafür ein ...