Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win7 Schriften automatisch installieren per MSI oder Batch nicht möglich.

Frage Microsoft Windows 7

Mitglied: ChrisM82

ChrisM82 (Level 1) - Jetzt verbinden

04.06.2013 um 16:08 Uhr, 7243 Aufrufe, 4 Kommentare, 1 Danke

Guten Tag Zusammen,

ihr seht direkt, ich bin absolut frisch hier in das Forum eingestiegen.
Ich hoffe ich erhalte von euch eine Antwort auf mein Anliegen. Bin verzweifelt.

Ich steh vor einem riesen Problem, welches ich absolut nicht verstehe. Es betrifft Windows 7 und den Fonts-Ordner.

Ich muss bald an diversen PCs drei Schriften installieren. Dies würde ich natürlich gerne per GPO erledigen.
Habe mir dazu auch schon diverse Links im Netz angesehen, wie das abläuft. MSI Paket ertellt (Schriften inkl. Reg-Werte inkl.) Läuft durch.
Zum Test habe ich zusätzlich einfach eine Textdatei kopiert. Diese landet unter Dokumente. Demnach kann ich sagen, MSI-Paket OK... Textdokument liegt nach der Installation unter Dokumente und die Reg-Werte für die Fonts sind vorhanden.

Ich bekomme die Schriften einfach nicht in den "C:\Windows\Fonts"- Ordner.
Wenn ich das Paket lokal ausführe habe ich im Anschluß die Werte in der Registry - aber die Schriften nicht im Fonts Ordner.
Es sind kurzzeitig, bis zur manuellen Aktualisierung (F5), drei leere Einträge im Fonts-Ordner zu sehen. Nach der Aktualisierung sind diese jedoch verschwunden.
Wenn ich nun händisch die Dateien kopiere, werde ich gefragt, ob ich überschreiben will...
Lösche ich die Werte aus der Registry, werde ich nicht gefragt. Neustart habe ich nach jedem dieser Schritte durchgeführt.

Nächster Versuch - Batchdatei(lokal):

xcopy Befehl wird gestartet. Hier werde ich komischerweise gefragt, ob ich überschreiben möchte. Im Fonts-Ordner sind keine Schriften zu finden - Registry sind auch keine Werte!?!? Völlig komisch.. Nach dem die Batchdatei durch ist, habe ich keine Schriften im Fonts-Ordner. Nur die Reg-Werte sind jetzt vorhanden.
Während die Batch läuft und ich mit J bestätige, kann ich sehen, wie wieder drei leere Zeilen angelegt wurden - Bis F5.

Nur wenn ich sie manuell installiere (Doppelklick/ Drag&Drop) funktionierts. Schriften landen im Ordner, Word kann damit schreiben - alles gut...
Gibts da irgendwelche "neuen" Sicherheiten im Windows 7, die verhindern, dass Schriften "automatisch" installiert werden?

Diverse Foreneinträge gelesen. Oftmals liegt es wohl an den Reg-Werten. Diese passen aber.

Mein Fazit:
System ok - habe es zusätzlich noch an dem Rechner von meinem Kollegen probiert. Gleiches Problem.
Schrift ok - händisch installiert funktioniert sie einwandfrei.
MSI-Paket ok - Testdatei kopiert - liegt nach Neustart am passenden Ort.
Batchdatei ok - Werde ja komischerweise gefragt ob ich überschreiben will.

Evtl. hat ja jemand von euch DEN Tipp... Ich bin am Ende... Augen schmerzen, Haare sind verschwunden... Solange wie ich mich heute damit beschäftigt habe, würde es mich auch nicht wundern, wenn es nur eine kleine Einstellung ist
Wald vor lauter Bäumen... ihr kennts...

Ich danke euch schonmal fürs lesen.

Viele Grüße
Chris



Mitglied: Dani
05.06.2013, aktualisiert um 00:08 Uhr
Moin Chris,
wir haben ähnliches mit GPO und Hilfe des Micorosoft Supports realisiert. Das Ticket basiert auf gruppenrichtlinien.de.

Der Support hat herausgefunden, was zusätzlich zu beachten ist.
Nun zum zweiten Punkt des o.g. Links -> ein Registereintrag wird ebenfalls auf der Zielmaschine kopiert. Hier kommt die erste Fehlersituation vor:
- wenn der Font nicht auf dem DC installiert worden ist, dann kann gar nichts auf den Zielmaschinen kopiert werden
- bitte Font erstmal auf dem DC installieren.
Dies ist als Ersatz der o.g. Installation. Bei mir wurde der Registereintrag kopiert, dennoch war der Font noch nicht installiert, nicht im Fonts verzeichniss zu sehen.
Ich habe hier noch einen weiteren Fehlerpunkt entdeckt:
- beim Kopieren wird der Font als font.ttf kopiert
- das Registry file wird als font (TrueType) mit Data: font_0.ttf; Das Registry kann somit nicht auf die richtige Datei hindeuten.

habe auch den Registereintrag als *.reg exportiert, geöffnet mittels Edit konfiguriert, dass der Name der Datei die richtige ist (font.ttf), ich habe in der GPO das Value auf font.ttf gesetzt.

Nach all diesen Korrekturen wurde letzendlich dies erriecht, was im Link beschrieben worden ist -> Font- und Registerdateien wurden erfolgreich kopiert. Nach dem Neustart war der Font installiert.
Grüße,
Dani
Bitte warten ..
Mitglied: ChrisM82
05.06.2013, aktualisiert um 09:03 Uhr
Guten Morgen Dani,

vielen Dank für deine Antwort.
Ich werde es testen, insofern ich es überhaupt kann. Habe hier leider nicht auf jede Maschine (DC) uneiingeschränkten Zugriff.

Mit Font auf DC installieren meinst du wirklich dort unter Schriften installiert?
Ich habe das Problem ja auch, wenn ich das MSI-Paket lokal auf meiner Maschine liegen habe und auch bei einer Batchdatei, die lokal liegt....

Alles sehr kurios. Ich werde sehen, ob ich an den DC gelange und ob ich diesen dann mit schriften versehen darf. Werde hier dann alles weitere schreiben.

*Nachtrag* *Nachtrag* *Nachtrag*

Font-Dateien und Regwerte abgeglichen. Hier stimmt alles.
Das mit dem DC wird schwer werden. Habe keine Berechtigung

Mich wundert es dazu aber auch, dass selbst wenn ich das MSI Paket lokal ausführe per Doppelklick die Fonts nicht installiert werden.
Auch mit xcopy Befehl in einer Batch keinen Erfolg. Hier ist der DC in meinen Augen außen vor - oder täusche ich mich?



nochmals Danke!

Viele Grüße
Chris
Bitte warten ..
Mitglied: Dani
05.06.2013 um 21:53 Uhr
Moin Chris,
wie wo warum DC kann ich dir nicht sagen. Ich weiß eben, dass es so bei uns funktioniert. Windows Server 2008R2 SP1, 64Bit. Seitdem bin ich glücklich.Wichtig ist eben auch der Neustart des Clients, erst dann werden die Fonts auch sichtbar.

Poste bitte Screesnhots von deiner GPO-Einstellungen.

Grüße,
Dani
Bitte warten ..
Mitglied: ChrisM82
06.06.2013 um 08:28 Uhr
Moin Dani,

danke dir vielmals für deine Hilfe. Habe es behoben.
Zum einen habe ich das Paket mal mit einem anderen Programm erstellt.
Dabei ist mir "wahrscheinlich" mein Fehler aufgefallen.
Blöder "Fehler", meine Dummheit - kein Plan..

Wie du sagtest: Regwerte mit Fontdateien vergleichen...
Habe ich ja auch gemacht.
Fies waren die Unterstriche am Ende "xx__.ttf"

Regedit-Datei nur ein Unterstrich... Fontdatei zwei Unterstriche. Im Texteditor SEHR schwer zu sehen ;)

Den Schuh zieh ich mir an.. Sorry..
Aber es war mir irgendwie klar, dass es an soner einer Kleinigkeit liegt, die einem im Nachhinein peinlich sein sollte.

Nochmals Danke! Thema gelöst. Haare verloren.

Gruß
Chris
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Powershell Schriften installieren und überschreiben
Frage von zamsi7Batch & Shell8 Kommentare

Hallo an alle, ich habe vor einiger Zeit bereits einen Artikel erstellt. > Wollte das Thema nun nochmals ansprechen ...

Outlook & Mail
Bei Abwesenheitsnotiz schrift wird automatisch geändert.
Frage von schurcaOutlook & Mail5 Kommentare

Hallo Admin Profis ich habe ein Problem der ich nicht nachvollziehen kann. In Outlook 2013 habe ich eine Automatische ...

Windows Server
Automatische Software Installation .MSI
gelöst Frage von Hendrik2586Windows Server8 Kommentare

Hello nochmal @ all! Ihr seit langsam sicher schon alle genervt von mir aber ich habe da ein weiteres ...

Windows Server
MSI Paket via Skript installieren
Frage von r00t-1337Windows Server7 Kommentare

Moin zusammen, ich habe ein Problem ein MSI Paket via GPO zu installieren. Es sieht wie folgt aus: 1. ...

Neue Wissensbeiträge
Internet

EU-DSGVO: WHOIS soll weniger Informationen liefern

Information von sabines vor 33 MinutenInternet

Wegen der europäische Datenschutzgrundverordnung stehen die Prozesse um die Registierunf von Domains auf dem Prüfstand. Sollte die Forderungen umgesetzt ...

Verschlüsselung & Zertifikate

19 Jahre alter Angriff auf TLS funktioniert immer noch

Information von BassFishFox vor 7 StundenVerschlüsselung & Zertifikate1 Kommentar

Interessant zu lesen. Der Bleichenbacher-Angriff gilt unter Kryptographen als Klassiker, trotzdem funktioniert er oft noch. Wie wir herausgefunden haben, ...

Windows 10

Windows 10 Fall Creators Update - Neue Funktion Hyper-V Standardswitch kann ggf. Fehler bei Proxy Configs verursachen

Erfahrungsbericht von rzlbrnft vor 18 StundenWindows 103 Kommentare

Hallo Kollegen, Da wir die Gefahr lieben, haben wir bei einigen Usern nun mittlerweile das Creators Update drauf. Einige ...

Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 20 StundenSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Heiß diskutierte Inhalte
Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement17 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...

Netzwerkmanagement
NAS über zwei weitere Ethernet Anschlüsse verbinden
gelöst Frage von Sibelius001Netzwerkmanagement16 Kommentare

Sorry - ich bin hier wahrscheinlich als kompetter IT Trottel unterwegs. Aber eventuell kann mir jemand ganz einfach helfen: ...

LAN, WAN, Wireless
Häufig Probleme beim Anmelden in WLAN
Frage von mabue88LAN, WAN, Wireless15 Kommentare

Hallo zusammen, in einem Netzwerk gibt es relativ häufig (1-2 mal pro Woche) Probleme mit der WLAN-Verbindung. Zunächst mal ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen13 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...