Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win7 - Systemfehler 5 bei NET SHARE

Frage Microsoft Windows 7

Mitglied: MartinS

MartinS (Level 1) - Jetzt verbinden

12.12.2010, aktualisiert 17:59 Uhr, 8861 Aufrufe, 2 Kommentare

Das Problem tritt bei WinXPprof nicht auf, aber jetzt bei Win7 Ultimate:

Es geht um ein CMD, mit dem ich als normaler Benutzer ein Programm starte.

Damit das Programm immer auf die 'gleichen' Dateien zugreift, diese aber durchaus an wechselnden Orten liegen, schiebe ich ihm die richtigen Verzeichnisse unter.

Das Programm greift immer auf das Laufwerk M: zu. Dies ist normaler Weise ein NAS.

Erst prüfe ich, ob es existiert mit den richtigen Daten:
05 IF EXIST "M:\NAS_vorhanden" SET MDrv=M:
Später muss ich es durch ein anderen Inhalt ersetzen:
10 NET USE M: /DELETE /YES 
11 NET SHARE USB-Drv=O:\Daten 
12 NET USE M: \\MeinPC\USB-Drv
So weit hat es unter XP sehr gut funktioniert.
Unter Win7 kommt in Zeile 11 der Fehler 'Systemfehler 5' - das sind wohl fehlende Rechte.

Ein
NET USER Administrator /active'
vor Zeile 11 bringt auch nur den gleichen Fehler.

Starte ich das CMD als Administrator, wird schon in Zeile 5 das Laufwerk nicht erkannt. Ich treibe also den Teufel mit dem Beelzebub aus.

Hat jemand eine Idee, wie beides funktionieren könnte?
Mitglied: bastla
12.12.2010 um 20:35 Uhr
Hallo MartinS!

Genügt es, wenn Du die Zeilen 11 und 12 durch
subst M: O:\Daten
ersetzt?

Grüße
bastla
Bitte warten ..
Mitglied: MartinS
14.12.2010 um 00:14 Uhr
Hallo Bastla,

das war der entscheidende Hinweis. Danke!

Mit diesem Befehl hatte ich mich noch nie beschäftigt.

Gruß, Martin
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Share-Problem? (5)

Frage von kellbidden zum Thema Windows Server ...

Windows Systemdateien
gelöst net 4.6.2 Error bei Installation (2)

Frage von leofabian zum Thema Windows Systemdateien ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Rechtliche Fragen
gelöst Geschäftsführer Email gefaked (18)

Frage von xbast1x zum Thema Rechtliche Fragen ...

Vmware
VMware ESX - Start einer VM verhindern (16)

Frage von emeriks zum Thema Vmware ...

iOS
IPhone wird ferngesteuert Hacker? (15)

Frage von Akcent zum Thema iOS ...

Vmware
gelöst Update auf ESXI 6.5 Installieren (15)

Frage von zeroblue2005 zum Thema Vmware ...