Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Win7 (u. Vista), .Net Framework kann nicht installiert werden

Frage Entwicklung Visual Studio

Mitglied: Win7User

Win7User (Level 1) - Jetzt verbinden

06.09.2009, aktualisiert 16:31 Uhr, 12991 Aufrufe, 6 Kommentare

Ich kann das Microsoft .Net Framework 3.5 nicht mit den Windows-Funktionen installieren.

Hallo,

schon bei meinem Vista (64bit) hatte ich das Problem, dass ich das Microsoft .Net Framework 3.0 (über die Windows-Funktionen) sowie 3.5 über das Installationspaket der Microsoft-Seite nicht installieren konnte.

Als ich dann endlich auf Windows 7 Prof. mit 64 bit upgraden konnte, dachte ich, das Problem wäre damit auch endlich gelöst, aber da habe ich falsch gedacht. Es kommt wenn ich die Windows-Funktion Microsoft .NET Framework 3.5.1 aktivieren möchte immer die Fehlermeldung Nicht alle Funktionen konnten aktiviert werden., ich soll neustarten und das war's dann.

Ich habe schon mehrmals sfc /scannow ausgeführt, dies hat einmal einen Fehler gefunden und behoben, gelöst hat das an meinem Problem aber leider nichts. Alle Überbleibsel von manuellen Installationen unter Vista des Frameworks habe ich gelöscht, Regcleaner durchlaufen lassen, etc.

Aktiviere ich die Funktion und klicke auf Ok werden die drei Verzeichnisse für das .Net Framework 2.0, 3.0 und 3.5 jeweils in den Unterordnern Framework und Framework64 von C:/Windows/Microsoft.Net/ angelegt, am Ende aber bis auf das für 2.0 (v2.0.50727, was allerdings geleert wird) wieder gelöscht. Ich habe (natürlich) auch schon danach dann diese Verzeichnisse manuell gelöscht.

Ich glaube das war erstmal das wichtigste.
Ich habe die Datei CBS.log mal bei http://nopaste.com hochgeladen, damit ihr euch sie anschauen könnt: CBS.log. Ich weiß nicht, was ihr davon braucht, deshalb den kompletten Teil, der nicht mehr is already in current state enthält.

Ich hoffe, ihr könnt mir helfen.

Vielen Dank!
Sebastian


Edit: Die .Net-Framework-Pakete von Microsoft.com kann ich nicht manuell installieren, dann wird immer die Meldung gezeigt, ich solle das über die Windows-Funktionen erledigen.
Mitglied: DerWoWusste
06.09.2009 um 16:52 Uhr
Vista enthält schon 3.0, W7 enthält 3.5, soweit ich weiß.
Was sagt denn Windows Update dazu, bietet das evtl. Patches zu 3.5 an oder gar (falls es "verschütt gegangen" ist) das komplette 3.5er dotnet?
Bitte warten ..
Mitglied: Win7User
06.09.2009 um 16:59 Uhr
Danke,

ja, W7 sollte 3.5 schon enthalten, wenn es über die Windows-Funktionen aktiviert wurde, was es standardmäßig ist, bei mir aber aufgrund des Upgrades von Vista (wo schon irgendwas mit den Frameworks nicht stimmte) nicht.

Windows Update? Es gibt kein Update, alles ist vollständig aktualisiert. Wie kann ich denn über Windows Update das komplette 3.5er installieren?
Bitte warten ..
Mitglied: DerWoWusste
06.09.2009 um 17:13 Uhr
Das 3.5er war von MS als Pflichtupdate eingestuft worden, müsste also von alleine über den Updatedienst angeboten werden wenn anwendbar.
Tut mir Leid, keine Ahnung. Mit dem Aktivieren von Windowsfunktionen hab ich selbst auf einem PC auch ein Problem, "Nicht alle Funktionen konnten aktiviert werden" kenne ich, das könnte evtl. ein ätzender Timeout sein. Windows rödelt bei mir da wie besch... auf der Platte rum, um dann nach 5 Minuten ca. zu sagen "Nicht alle Funktionen konnten aktiviert werden" - und gar nichts zu tun.
Laut einem Forum ist dies ein Timeout - Setup geht manifest-dateien durch, dauert das zu lange, bricht es mit Timeout ab - genaugenommen also ein Bug.
Bitte warten ..
Mitglied: Win7User
06.09.2009 um 17:17 Uhr
Verdammt. Timeout ... Wäre natürlich möglich, er kopiert ja erst fleißig und bricht dann plötzlich ab und löscht wieder alles. Die Festplatte rödelt bei mir auch wie verrückt.

Kann mir denn jemand helfen? Ich habe keine Lust, alles neu aufzusetzen.

Vielleicht versteht ja auch jemand, was die gepostete Log-Datei http://nopaste.com/p/aT97lRmCh/txt zu sagen hat...
Bitte warten ..
Mitglied: DerWoWusste
06.09.2009 um 17:26 Uhr
Ich hab zu meinem Problem selbst auch schon gegoogelt ohne Erfolg. Der einzige Tipp, der anderen helfen konnte, brachte bei mir nichts.
Es war vermutlich einer dieser Tipps: http://www.google.com/search?hl=en&rls=com.microsoft%3Aen-us&q= ...
Man sollte zwei Manifest-Dateien löschen und auf diese hat mein Vista tatsächlich wie blöd rumrerödelt, wie procmon aufzeigen konnte. Brachte aber nichts.
Bitte warten ..
Ähnliche Inhalte
Windows 10
gelöst Net Framework über Gruppenrichtlinie aktivieren (10)

Frage von DarkScabs zum Thema Windows 10 ...

Windows Tools
net Framework 4 (1)

Frage von kellbidden zum Thema Windows Tools ...

Windows Server
gelöst NET Framework 3.5 auf Windows Server 2012 R2 aktivieren - 0x800F0906 (10)

Frage von timg93 zum Thema Windows Server ...

Windows 7
gelöst Installation von Framework 4.6.1 fehlgeschlagen (5)

Frage von honeybee zum Thema Windows 7 ...

Neue Wissensbeiträge
Windows Tools

Zeit für Energiesparmodus, Bildschirmabschaltung etc. schnell anpassen

Anleitung von hannsgmaulwurf zum Thema Windows Tools ...

Linux Netzwerk

Ping und das einstellbare Bytepattern

(1)

Erfahrungsbericht von LordGurke zum Thema Linux Netzwerk ...

Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

(4)

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Heiß diskutierte Inhalte
Firewall
Richtige Grundeinstellungen der Pfsense für mein Netzwerk (12)

Frage von Spitzbube zum Thema Firewall ...

Switche und Hubs
gelöst Cisco 2960x Stacking über mehrere Etagen (12)

Frage von b3scher zum Thema Switche und Hubs ...