Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Win7 will sich mit altem KMS verbinden

Frage Microsoft Windows Netzwerk

Mitglied: Manfred15

Manfred15 (Level 1) - Jetzt verbinden

31.03.2014, aktualisiert 03.04.2014, 3480 Aufrufe, 9 Kommentare

Hallo,

ich versuche immer noch das Problem der automatischen Aktivierung von Win7-Clients zu lösen.
Über das VAMT auf dem 2008R2 Server kann man sehen, dass sich viele Clients Anfang Januar zuletzt gemeldet haben. Dies muss der Zeitpunkt gewesen sein, als der alte 2003er KMS abgeschaltet wurde.

Mit slmgr.vbs /dlv sieht man auch, dass immer noch dieser nicht mehr existente Server versucht wird, zu erreichen. Als Ergebnis kommt:

KMS-Computername aus DNS: Server2003.MeineDomain.local:1688

Dies kann ich zwar mit slmgr /skms umstellen aber nach einem Neustart steht dort wieder der alte Server. Gruppenrichtlinien und Skripte habe ich schon durchforstet und auch meine DNS-Server nach _VLMCS-Einträgen abgesucht. Im DNS steht aber nur der neuere KMS und in Skripten und Gruppenrichtlinien konnte ich gar nichts finden. Wo habe ich eventuell noch nicht geschaut?

Beste Grüße
Manfred
Mitglied: Dani
31.03.2014 um 15:50 Uhr
Hallo @Manfred15,
ich blick's langsam nicht... hier redest du von 2012R2 und nun wieder von Server 2003 und 2008.
Welche Informationen gelten nun?

Wenn du mehrere DCs hast, schau bitte alle DNS-Server durch.
Auf den Clients einfach mal gpresult ausgeben geben und nach dem alten Namen durchsuchen.


Grüße,
Dani
Bitte warten ..
Mitglied: Manfred15
01.04.2014 um 09:20 Uhr
Hi Dani,

ja, es handelt sich um zwei Posts, die sich nicht unbedingt ausschließen.
In diesem Thread habe ich das Thema von vor zwei Wochen nochmals aufgegriffen aber einen anderen Aspekt beleuchtet. Mag sein, dass durch die Lösung dieses Threads auch der damalige automatisch mit gelöst werden kann, aber davon gehe ich im Moment noch nicht aus, denn im anderen Thread bekomme ich eine Fehlermeldung, die nicht direkt mit dem gestrigen Phänomen etwas zu tun haben muss (ungültiger Lizenzkey oder Lizenzkonflikt).
Gestern ist mir nur aufgefallen, dass die überprüften Win7 Clients beim Aufruf von slmgr /dlv einen Server suchen, der schon länger nicht mehr im Netz vorhanden ist. Also einen 2003er Server haben wir hier nicht mehr als KMS, es existiert nur ein 2008R2 und auch ein 2012R2, der momentan aber abgeschaltet ist um das Problem besser einkreisen zu können.
Aber nun zu deinen Hinweisen:

DNS-Server: (DNS ist AD integriert), keine Hinweise auf den 2003er Server, der damals KMS-Server war
GPRESULT: keine Hinweise auf den 2003er Server, der damals KMS-Server war

Beste Grüße
Manfred
Bitte warten ..
Mitglied: Dani
LÖSUNG 01.04.2014, aktualisiert 03.04.2014
Guten Morgen Manfred,
können die Clients den neuen DNS-Eintrag sauber auflösen? Melden sich auch min. 25 Windows 7 Clients zeitnah beim KMS Server? Sonst wird dieser nicht aktiviert.


Grüße,
Dani

P.S. KMS ist eine empfindliche Sache (schlimmer als eine Frau).
Bitte warten ..
Mitglied: Manfred15
01.04.2014 um 12:15 Uhr
Ja, der DNS-Eintrag wird sauber aufgelöst und es werden nur die neueren KMS-Server gelistet, nicht aber der ausgesonderte 2003er. Auch sind mehr als 25 Clients im netz, sie seit geraumer Zeit auf eine Erneuerung der Aktivierung warten, somit ist die 25er Grenze vermutlich auch nicht Schuld. Woher kommt aber wohl der alte Server beim Aufruf von "slmgr /dlv"?

Beste Grüße
Manfred
Bitte warten ..
Mitglied: Dani
LÖSUNG 01.04.2014, aktualisiert 03.04.2014
Gut, das muss sicher gestellt sein.
Schau auf dem Windows 7 Client in folgenden Registrykey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SoftwareProtectionPlatform. Was steht da drin?


Grüße,
Dani
Bitte warten ..
Mitglied: Manfred15
01.04.2014 um 14:34 Uhr
Welchen Wert meinst du explizit?
DisableKeyManagementServiceHostCaching = 1
InactivityShutdownDelay=300
KeepRunningThresholdMins=15
....
oder die diversen Unterschlüssel?

Beste Grüße
Manfred
Bitte warten ..
Mitglied: Dani
01.04.2014 um 15:48 Uhr
Keinen explizit... schau dort nachdem alten Servername.


Grüße,
Dani
Bitte warten ..
Mitglied: Manfred15
02.04.2014 um 13:18 Uhr
Hallo Dani,

nein der Servername steht dort nirgends, aber ich habe schon einen Fehler entdeckt: Auf dem Server war automatisch bei der Installation eine passende Firewallregel für den Bereich DOMÄNE eingetragen worden. Diese scheint aber nicht korrekt zu sein. Wenn ich die Firewall für den Bereich DOMÄNE deaktiviere oder eine neue Regel eingehend für Port 1688 mache, kommt zumindest ein Kontakt zustande. Momentan bekomme ich zwar die Meldung, dass noch nicht genug Clients vorhanden sind, aber ich denke, dass morgen ein positiveres Ergebnis kommt

Beste Grüße
Manfred
Bitte warten ..
Mitglied: Manfred15
03.04.2014 um 09:54 Uhr
Hallo Dani,

hier ist das positive Endergebis: die Clients melden sich nun alle am neuen KMS-Server an!

Zusammengefasst lag es an mehreren Punkten:
1. bei den Clients war großenteils der alte KMS-Server (2003er) fix in der Registry eingetragen. Somit haben diese immer versucht, diesen zur Aktivierung aufzusuchen was natürlich scheitern musste. Ich habe nun alle Clients auf den aktuellen KMS (nun sogar der 2012R2er) abgeändert, so dass dorthin der Verbindungsaufbau erfolgte.
2. Auf dem 2012R2-Server gab es zwei automatisch eingerichtete Firewallregeln. Eine davon (Key Management Service) war aktiviert, aber die zweite (Schlüsselverwaltungsdienst) war deaktiviert. Dies führte wohl dazu, dass die passenden Pakete nicht akzeptiert wurden. Nach Aktivierung der zweiten Regel kamen dann die Erfolgsbotschaften, dass momentan noch nicht genug Clients zur Aktivierung zur Verfügung stehen.

Nachdem aber genug Clients angeklopft hatten (dies habe ich beschleunigt, in dem ich übergangsweise einen statischen DNS-Eintrag mit altem Namen und aktueller IP erzeugt hatte) wurden auch die anderen Rechner aktiviert.

Nun fehlen nur noch die, die momentan ausgeschaltet oder unterwegs sind

Besten Dank
Manfred
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Exchange Server
Exchange will sich mit "altem" DC verbinden (12)

Frage von oberbeck zum Thema Exchange Server ...

Windows Server
gelöst Windows Server 2012 mit Fritzbox per VPN verbinden (13)

Frage von StefanT81 zum Thema Windows Server ...

Switche und Hubs
gelöst 2 VLANs, tragged und mit link aggregation oder Verbinden oder einzeln (1)

Frage von ADORSE zum Thema Switche und Hubs ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...