Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Von WinAD auf Sambashare zugreifen funktioniert nicht

Frage Linux Samba

Mitglied: BahamutXII

BahamutXII (Level 1) - Jetzt verbinden

11.01.2012, aktualisiert 13.01.2012, 4546 Aufrufe, 8 Kommentare

Hallo, ich möchte aus meiner Windows AD Domäne auf einen Samba share zugreifen und komme nicht vorwärts hoffe Ihr könnt mir helfen.

Samba Version 3.5.6
Windows Server 2008 R2
Winbind
Kerberos
SSH

So ist die Konfiguration:

Ich habe einen Windows Server 2008 AD Server mit Windows 7 Clients. Nun habe ich einen Samba Server so eingerichtet das er sich in der Windows Domäne anmelden kann (Kerberos, Winbind). Das anmelden des Sambaservers am WinAD funktioniert auch einwandfrei. Ich habe ein Kerberosticket erhalten(mittels kinit) und wbinfo zeigt mir alle Benutzer und Gruppen aus dem AD an.
In der smb.conf habe ich angegeben das Benutzer aus dem AD xyz der Gruppe xyz das Recht haben auf den Ordner zu zugreifen(/var/www). @Domäne+gruppe. Diese Gruppe exisitiert auf dem AD Server.

Soweit so gut.

Hier das Problem:

Ich habe ein share auf dem Sambaserver angelegt @Domäne+Gruppe. Leider kann ich zwar den Ordner in der Netzwerkumgebung sehen wenn ich auf den Server klicke, aber ich kann nicht darauf zugreifen. Weder vom Sambaserver lokal mittels smbclient -L (NT_STATUS_LOGON_FAILURE)
noch vom WinAD aus (Win7 Clients) Fehler 53: Der Netzwerkpfad wurde nicht gefunden.

Hat jemand eine Idee woran das liegen könnte? Brauche dringend Hilfe!


Greetings and best regards
Ben
Mitglied: goscho
12.01.2012 um 10:30 Uhr
Hallo Ben,

ich bin jetzt kein Linux-Experte, habe aber ein paar Sambas auf NAS mit Debian eingerichtet.

Zuerst überprüfe unbedingt die Zeitsynchronität zwischen Samba und DC, am Besten stellst du auf dem Samba den DC als Zeitserver ein.
Lässt sich der Samba per Namen vom Windows PC aus auflösen?
Ist dieser im MS DNS korrekt eingetragen?

Bei meinen Sambas nutze ich immer eine Konsole (Webmin), komme halt aus der Windows-Umgebung.
Ab und an muss dann aber auch mal die Samba.conf manuell angepasst werden.
Bitte warten ..
Mitglied: BahamutXII
12.01.2012 um 10:46 Uhr
Hi goscho,

danke erstmal frü den reply. Ja das funktioniert alles. Habe zwar kein tnp eingerichtet aber der Zeitunterschied beträgt nur ein paar sekunden.
DNS geht beidseitig, von Linux sowie von dem DC.

Es muss doch eine Lösung geben, wie ich vom WinAD auf dem Sambashare zugreifen kann. Habe die Gruppen aus dem DC auf dem Sambaserver mittels "groupmap add" eingetragen. Aber leider auch kein Erfolg.....

Webmin ja? Ok ich schaus mir mal an. Müsste doch aber auch so gehn?

Greetings
Ben
Bitte warten ..
Mitglied: goscho
12.01.2012 um 11:15 Uhr
Zitat von BahamutXII:
Es muss doch eine Lösung geben, wie ich vom WinAD auf dem Sambashare zugreifen kann. Habe die Gruppen aus dem DC auf dem
Sambaserver mittels "groupmap add" eingetragen. Aber leider auch kein Erfolg.....
Ich hatte schon mal Probleme, wenn AD-Member einzeln eingetragen wurden, habe ich dann die Gruppe genommen, in der diese waren, hat es mit dem Zugriff geklappt.


Webmin ja? Ok ich schaus mir mal an. Müsste doch aber auch so gehn?
Natürlich müsste es auch so gehen. Ich bevorzuge aber GUIs.

Ich glaube, du musst den AD-Usern noch Unix User zuordnen.
Schau mal in diese Anleitung von RedHat Samba.
Bitte warten ..
Mitglied: BahamutXII
12.01.2012 um 13:09 Uhr
Ja das würde doch aber bedeuten das ich jeden Nutzer aus dem AD auch lokal anlegen muss. Das ist sehr aufwendig beider Anzahl an Nutzern.


Zitat:
Ich hatte schon mal Probleme, wenn AD-Member einzeln eingetragen wurden, habe ich dann die Gruppe genommen, in der diese waren, hat es mit dem Zugriff geklappt. <<-- Genau das ist ja das was ich nicht möchte.

Hier nochmal meine conf:

[global]
log file = /var/log/samba/log.%m
idmap gid = 10000-20000
passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
obey pam restrictions = Yes
winbind use default domain = yes
realm = domain.LOCAL
password server = domain.dc.local
passwd program = /usr/bin/passwd %u
allow hosts = xxx.xxx.2.0/24
dns proxy = No
server string = %h server
idmap uid = 10000-20000
idmap gid = 10000-20000
winbind enum users = yes
winbind enum groups = yes
path = /var/www/
unix password sync = Yes
workgroup = Arbeitsgruppe
comment = Entwicklung
syslog = 0
security = ADS
panic action = /usr/share/samba/panic-action %d
max log size = 1000
pam password change = Yes

[entwicklung]
comment = entwicklungsordner
path = /var/www/
valid users = @Domain.LOCAL+"ENTWICKLER" , @Domain.LOCAL+"IT.Admins"
read only = No
create mask = 0660
directory mask = 0770

....die Gruppen sind also eingetragen und existieren ebenfalls auch local auf dem Sambaserver. Trotzdem gehts nicht!?? Ich sitze jetzt seit drei Tagen daran. Es treibt mich in den Wahnsinn. Webmin habe ich installiert aber so recht finde ich dort auch keine Möglichkeit das so hinzubiegen wie ich das will.

Was hat es mit diesem Maschinenaccount auf sich? Der Sambaserver ist doch bereits AD Mitglied.
Ausserdem ist mir aufgefallen das mir wbinfo zwar alle AD GRuppen anzeigt aber mit passwd kann ich als AD Member natürlich nichts anfangen. Ist das das Problem? Es scheint so als seien zwar die Gruppen aus dem AD angebunden. Die Nutzer aus den Gruppen scheinen aber trotzdem keine Berechtigung zu haben sich am Server auch anzumelden. Wie löst man das?
Bitte warten ..
Mitglied: DerWoWusste
18.01.2012 um 00:18 Uhr
Moin. Falls noch aktuell: aktualisiere den Sambaserver mal umfassend. Evtl. nur ein Versionsbug. Deine Sambaversion ist veraltet.
Bitte warten ..
Mitglied: BahamutXII
18.01.2012 um 20:26 Uhr
Danke für den Tip, aber im Debain Repository ist das die aktuellste Version, Ich werds wohl auf eis legen müssen wenn das nicht klappt mit dem Versionsupdate.
Bitte warten ..
Mitglied: distel
30.01.2012 um 16:37 Uhr
Versuch mal auf einem client folgenden registrierungs schlüssel zu setzen.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"LMCompatibilityLevel"=dword:00000001

oder folge dieser anleitung:

http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p ...

dachte zwar das dieses problem bei 3.5.6 nicht mehr auftritt aber du kannst es ja mal versuchen.
Bitte warten ..
Mitglied: BahamutXII
30.01.2012 um 21:46 Uhr
Danke für den Tip. hat sich abe mittlerweile erledigt. Habe das Projekt leider aus kostengründen abbrechen müssen. Sollte ich es aber wieder versuchen, werde ich es beherzigen. Allerdings ist es mir bis heute schleierhaft wie eine einfache share freigabe solche Probleme verursachen kann. Samba ist ja nun wirklich nichts neues.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Router & Routing
Transparenter Proxy funktioniert nicht? (1)

Frage von mrserious73 zum Thema Router & Routing ...

Linux
LTSP: PXE Boot funktioniert nicht (23)

Frage von Fenris14 zum Thema Linux ...

Virtualisierung
Drucker aus einer VM heraus funktioniert nicht (5)

Frage von NCCTech zum Thema Virtualisierung ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...