Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows 2000 server NETZWERKROUTER einrichten

Frage Microsoft Windows Server

Mitglied: tomster10k

tomster10k (Level 1) - Jetzt verbinden

11.06.2005, aktualisiert 12.06.2005, 7935 Aufrufe, 12 Kommentare

Hi alle zusammen,
ich hab ein kleines Problem. Ich möchte meine windows 2000 server - maschine als zwischenrouter einsetzen.
So soll mein Netz aussehn:

Rechner A ------ | Windows 2000 server machine | ------------ | Hardware Router | ---------- INTERNET
Rechner B ------ |__________________________ |

so, jetzt möchte ich einfach nur dass sämtliche pakete von rechner A und rechner B
über die Windows-maschine zum hardware router geroutet werden. Bei windows 2000 server
gibts da ne funktion "Netzwerkrouter", geht aber irgendwie net. Hab default-route für beide netzwerkkarten
reingeschrieben , also den Hardware-router, aber er will net. was is da zu beachten?

Mit der NAT-Funktion gehts,
aber will ich net.

Achso noch eins : bitte gebt mir keine tips, von wegen "Wozu die Windows-maschine?!?!?" oder so. das is alles durchdacht. ich brauch nur hilfestellung für genau mein problem, danke :D

Gruz Tom
Mitglied: hirnibus
11.06.2005 um 19:21 Uhr
warum willst du den Umweg über den Server machen?? Der Router hat ja schon die Route funktion! Wäre einfach und Ressource sparender!! Also


Rechner B ------ |
|___________________Internet__________| Hardware Router|
Rechner A ------ |
|
|
|Windows 2000 Server|

Man kann die 2000 Maschinen als Netzwerkrouter benützen indem man das RAS Protokol benützt unter Verwaltung sollte ein Reiter zu finden sein. Einfach mit dem Assistenten einrichten Daten eingeben und fertig!!
Bitte warten ..
Mitglied: meinereiner
11.06.2005 um 19:28 Uhr
Hast du auf deinem Hardware Router eine statische Route zu deinen Clients definiert?
Bitte warten ..
Mitglied: tomster10k
11.06.2005 um 22:02 Uhr
hab ich jetzt ma probiert, aber es bringt nix. hab eingestellt, des er für mein rechner a, rechner b -Netz als gateway meinen windows 2000-router nehmen soll. da spinnt mein hardware router allerdings rum.

Gruss tom
Bitte warten ..
Mitglied: meinereiner
11.06.2005 um 22:14 Uhr
DU hast eine Route für die zwei Rechner (bzw. besser das Netz der Rechner) definiert. Aber nur für die und das Standardgateway unverändert gelassen?

Was heisst: spinnt rum?
Bitte warten ..
Mitglied: tomster10k
11.06.2005 um 22:40 Uhr
also, ich schreib dir jetzt ma meine genauen daten:

rechner a : 192.168.0.4
rechner b: 192.168.0.7
windows-server-ip : IF1 --> 192.168.0.2 ; IF2 --> 192.168.1.100 (2 Interfaces)
hardware-router-ip: 192.168.1.1

so,
meine routing tabelle vom windows-server sieht so aus:

IF 1 - Default Gateway : 192.168.1.1
IF 2 - Default Gateway : 192.168.1.1
Static Route: 0.0.0.0 mask 0.0.0.0 192.168.1.1 über IF2

so jetzt hab ich beim hardware router als static route angegeben:

Netz : 192.168.0.0 MASK 255.255.255.0 Gateway: 192.168.1.100 Hop 3

so, dann schau ich mir den verkehr an mit ethereal (packet-sniffer):

DNS - anfrage an 192.168.1.1 für GMX.DE
192.168.1.1 macht broadcast MIT REQUEST "WHO HAS 192.168.1.4" <--- mit spinnen mein ich

dass er hier anstatt 192.168.0.4 192.168.1.4 sucht und auch nonet ma den gateway anfragt. denn der broadcast war ja jeden gerichtet, also geht da nix mit gatway.

ich hoffe dir fällt was ein. ich muss sagen, du bist der erste der ma en bissi ahnung hat... ;D

Gruz Tom
Bitte warten ..
Mitglied: meinereiner
11.06.2005 um 22:52 Uhr
hmm, das Routing sieht soweit gut aus...evtl. würde ich mal das 192.168.0.0 /24 Netz durch ein 192.168.2.0 /24 ersetzen. Manchmal spinnt das erste Netz..

Ich würde es mal mit pingen versuchen..können, die Rechner z.B. www.gmx.de anpingen?

zum DNS: einen Broadrcast sollte da eigentlich gar nicht kommen. Die Auflösung sollte über eine unicast an den DNS Server gehen. Erst wenn das (und anderes) nicht klappt, sollte ein Broadcast kommen, der dann natürlich ins leere geht, da kein Rechner drauf antwortet.

Das er dann nach 192.168.1.4 fragt ist wirklich arg gesponnen.. aber wie gesagt versucht mal das Netz zu wechseln und wieweit es mit pingen geht.
Bitte warten ..
Mitglied: pc-pure
12.06.2005 um 00:55 Uhr
Jungs,

macht es euch schwer.

1. NIC 1 (Subnetz wie Clients) als interne Netzwerkkarte definieren.
2. NIC 2 (anderes Subnetz) als externe Netzwerkkarte definieren.
3. Routing und RAS aktivieren.
4. W2K erlauben intern zu routen und bei Bedarf auch extern.
5. DHCP und DNS am W2K.
6. DNS-Weiterleitung auf HW-Router (nur Weiterleitung, kein EIntrag als sekundärer Server oder so.

Das ganze Gelumpe mal neu booten und überprüfen.

Bei Bedarf statische Routen hinzufügen (in der Regel nicht nötig)
Bitte warten ..
Mitglied: tomster10k
12.06.2005 um 09:01 Uhr
was meinst du mit NIC1 als intern definieren? Wie geht das?

Danke Tom
Bitte warten ..
Mitglied: pc-pure
12.06.2005 um 09:28 Uhr
Hallo,

es gibt auch bei W2K eine Konfigurationshilfe, wo du unter anderem deine Internetverbindung konfigurierst.

Dort kannst du jeder Netzwerkkarte einen Zweck zuweisen (ob es die Karte fürs LAN ist oder ob es die Karte für die Netzwerkverbindung ist).

Schlag mich, aber ich hab im Moment keinen W2K greifbar um dir die genauen Bezeichnungen zu geben.

Anhand dieser Angaben erstellt W2K seine Routingtabellen.

Gruss

Christian
Bitte warten ..
Mitglied: tomster10k
12.06.2005 um 10:15 Uhr
also ich glaub ihr meint, wenn ich NAT einstelle, dass ich dann eine NIC für Lokales Netz und eine NIC für das "Internet" (öffentlich) wählen kann. das geht ja auch. das problem is, dass ich kein
nat will. ;D

Gruz Tom
Bitte warten ..
Mitglied: pc-pure
12.06.2005 um 11:49 Uhr
Erklär mir mal, wieso du 2 verschiedene Subnetzze willst, aber kein NAT?
Bitte warten ..
Mitglied: tomster10k
12.06.2005 um 16:42 Uhr
ok, mach ich gern. Folgende Situation:

EXT_PORT_WIN = ÖFFENTLICHER PORT VON WINDOWS MASCHINE
EXT_PORT_HARDWARE=ÖFFENTLICHER PORT VOM HARDWARE ROUTER

auf windows 2000 rechner läuft traffic shaping (cfosspeed) .
funktioniert auch subber, aber problem is, dess er mehrere
lokale ports von rechner a oder rechner b auf einen öffentlichtlichen port (EXT_PORT_WIN)
legt und über den dann über den öffentlichen port vom hardware router (EXT_PORT_HARDWARE) raus will. soweit kein problem.

Nur problem is wenn der jetzt einma über den öffentlichen port (EXT_PORT_HARDWARE) zum icq-server und danach mit gleichen öffentlichen port (EXT_PORT_HARDWARE) zum msn-server connected (was der fall is, hab in den NAT-Zuweisungen nachgesehen) , dann denkt der hardware router, dass über diesen port nur der wieder von der IP-Adresse des MSN-Servers pakete angenommen werden dürfen und nicht vom icq-server. ABER: ICQ UND MSN SERVER BENUTZEN BEIDE DEN GLEICHEN ÖFFENTLICHEN PORT (EXT_PORT_HARDWARE). folgilich:
nur ein paket kommt wieder durch und mein icq oder msn disconnecten sich. Und nein, es liegt nicht am icq protokoll, hab neuestes drauf, ausserdem is the same mit battle.net ...
so weit meine kurze beschreibung. PS ich finds schade dess mer immer alles erklären muss ;D

Gruz Tom
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Windows Server
gelöst Lokale Windows Firewall Server 2012R2 für virtuelle Maschine? (4)

Frage von 1410640014 zum Thema Windows Server ...

Windows Server
Windows-File-Server - Macs - Probleme (5)

Frage von guenthergranate zum Thema Windows Server ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

DSL, VDSL
DSL-Signal bewerten (10)

Frage von SarekHL zum Thema DSL, VDSL ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...