Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 2008 DNS Server löst Adressen nach ein paar Tagen nicht mehr richtig auf

Frage Netzwerke DNS

Mitglied: mfernau

mfernau (Level 1) - Jetzt verbinden

12.09.2014 um 10:32 Uhr, 1355 Aufrufe, 9 Kommentare

Hallo!

Dieses Problem habe ich schon seit geraumer Zeit - aber immer nur sporadisch und es lässt sich mit einem einfachen leeren des Caches beheben. Aber jedes mal, wenn es erneut auftritt, nervt es mal wieder.

Was ist das Problem?
Nach einer "Weile" (es können Tage oder Wochen sein) löst der DNS-Server (Windows 2008 R2 mit aktuellen Patches) manche Domains nicht mehr auf. Der DNS-Server ist derzeit so eingestellt, dass er unbekannte Adressen selbst auflöst (also keine Weiterleitung hinterlegt).
Firewalltechnisch ist alles korrekt. Der Server kann nach außen verbinden und abfragen.

Wie äußert sich das Problem:
Wenn ich im Browser eine solche Domain anspreche, bekomme ich die Meldung:
- Diese Webseite ist nicht verfügbar. (Chrome)
- Die Seite kann nicht angezeigt werden. (IE)

Ein 'dig' unter Linux:
$ dig forum.kde.org 
 
; <<>> DiG 9.9.5-4-Debian <<>> forum.kde.org 
;; global options: +cmd 
;; Got answer: 
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 54105 
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1 
 
;; OPT PSEUDOSECTION: 
; EDNS: version: 0, flags:; udp: 4000 
;; QUESTION SECTION: 
;forum.kde.org.                 IN      A 
 
;; Query time: 0 msec 
;; SERVER: 10.0.0.5#53(10.0.0.5) 
;; WHEN: Fri Sep 12 10:19:20 CEST 2014 
;; MSG SIZE  rcvd: 42
Meine Vermutung:
Der Server fragt eine unbekannte Domain, wenn sie das erste mal angefragt wird, entsprechend den Künsten eines DNS-Servers von außen ab. Aus welchen Gründen auch immer erhält er keine Antwort, oder interpretiert diese verkehrt. Jedenfalls bleibt das Fehlerbild so lange bestehen, bis ich beim DNS-Server den Cache leere. Tue ich dies, glingt die nächste Abfrage der fehlerhaften Domain SOFORT:
$ dig forum.kde.org 
 
; <<>> DiG 9.9.5-4-Debian <<>> forum.kde.org 
;; global options: +cmd 
;; Got answer: 
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 9857 
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1 
 
;; OPT PSEUDOSECTION: 
; EDNS: version: 0, flags:; udp: 4000 
;; QUESTION SECTION: 
;forum.kde.org.                 IN      A 
 
;; ANSWER SECTION: 
forum.kde.org.          1800    IN      CNAME   ol575.x.incapdns.net. 
ol575.x.incapdns.net.   299     IN      A       149.126.77.89 
 
;; Query time: 211 msec 
;; SERVER: 10.0.0.5#53(10.0.0.5) 
;; WHEN: Fri Sep 12 10:31:17 CEST 2014 
;; MSG SIZE  rcvd: 92
Irgendwie kann das ja nicht normal sein... Kennt das vielleicht noch jemand?

Schöne Grüße
Martin
Mitglied: keine-ahnung
12.09.2014 um 10:46 Uhr
Moin,
in der Windowsswelt nehmen wir eher nslookup ... aber Wurscht.
Der DNS-Server ist derzeit so eingestellt, dass er unbekannte Adressen selbst auflöst (also keine Weiterleitung hinterlegt).
Kannst Du das mal näher beschreiben?

LG, Thomas
Bitte warten ..
Mitglied: colinardo
LÖSUNG 12.09.2014, aktualisiert 15.09.2014
Moin,
Zitat von keine-ahnung:
in der Windowsswelt nehmen wir eher nslookup ... aber Wurscht.
> Der DNS-Server ist derzeit so eingestellt, dass er unbekannte Adressen selbst auflöst (also keine Weiterleitung
hinterlegt).
Kannst Du das mal näher beschreiben?
ich denke er macht das über die ROOT-DNS Server, was man aber eigentlich immer vermeiden sollte ... (sind meistens stark ausgelastet). Daher kommen zu 90% solche Auflösungsfehler ...

Grüße Uwe
Bitte warten ..
Mitglied: mfernau
12.09.2014 um 10:53 Uhr
Klar.
Was ich damit meine ist, dass unter 'Weiterleitungen' kein Eintrag hinterlegt ist. Also der DNS-Server löst externe unbekannte Domänen "selbst" auf (also über die root-server etc...).
Der DNS-Server ist zuständig für die interne Domain (Active Directory und noch bissl was extra), alles weitere muss er ja selbst erst einmal in Erfahrung bringen.
Bitte warten ..
Mitglied: killtec
LÖSUNG 12.09.2014, aktualisiert 15.09.2014
Hi,
mach doch eine Weiterleitung an einen Public DNS-Server z.B. Google 8.8.8.8 oder enen Telekom DNS.

Gruß
Bitte warten ..
Mitglied: mfernau
12.09.2014 um 10:59 Uhr
Zitat von colinardo:
ich denke er macht das über die ROOT-DNS Server, was man aber eigentlich immer vermeiden sollte ... (sind meistens
stark ausgelastet). Daher kommen zu 90% solche Auflösungsfehler ...

Grüße Uwe

Genau so ist das.
Ich kann unter Weiterleitungen auch einen DNS-Server von der DTAG einstellen. Aber ich bin mir zu 100% sicher, dass ich auch in solch einer Konstellation diese Probleme schon hatte. Ich probiere das aber auch gern nochmal aus.
Bitte warten ..
Mitglied: keine-ahnung
LÖSUNG 12.09.2014, aktualisiert 15.09.2014
Solltest Du ... ich nehme den DNS-Server meines jeweiligen ISP - habe ich auch noch nie Probleme gehabt.

LG, Thomas
Bitte warten ..
Mitglied: killtec
12.09.2014 um 11:49 Uhr
Ich kann hier Thomas zustimmen.

Gruß
Bitte warten ..
Mitglied: Pjordorf
12.09.2014 um 12:30 Uhr
Hallo,

Zitat von mfernau:
Ich kann unter Weiterleitungen auch einen DNS-Server von der DTAG einstellen.
Warum nicht dein(e) Router dazu nehmen. Auch wenn diese keine DNServer darstellen, machen doch alle DNS Weiterleitung. Und die sollten doch ihren DNS kennen, wenn nicht macht dein Anbieter murks.

Aber ich bin mir zu 100% sicher
Was ist 100% sicher? Vom Gefühl her oder weil du eben 100% Ausfall nachgewiesen hast?

solch einer Konstellation diese Probleme schon hatte. Ich probiere das aber auch gern nochmal aus.
Auch DNServer werden mal geändert, auch bei der Telekom usw. Da kann dann schon mal ein DNServer der 10 Jahre lang unter dieser IP erreichbar war, plötzlich nicht mehr sein oder gar ein Anmeldung haben wollen.

Wenn du dich mit den DNServer Weiterleitungen nicht beschäftigen willst, dein Router rein und gut ist. Nimmst du weiterhin Root DNS dann stelle sicher das deine DNServer auch fix genug sind, nicht durch andere Aufgaben abgelenkt werden und das du eine sehr schnelle und sehr stabile Verbindung zu den Root DNS hast (immer = 100%).

Gruß,
Peter
Bitte warten ..
Mitglied: mfernau
15.09.2014 um 10:34 Uhr
Okay, danke erstmal an alle. Ich habe nun einen öffentlichen DNS hinterlegt (derzeit den von Google) und hatte bisher keine weiteren Probleme mehr.
Ich lasse es jetzt erst einmal so eingestellt.

Schöne Grüße
Martin
Bitte warten ..
Neuester Wissensbeitrag
CPU, RAM, Mainboards

Angetestet: PC Engines APU 3a2 im Rack-Gehäuse

Erfahrungsbericht von ashnod zum Thema CPU, RAM, Mainboards ...

Ähnliche Inhalte
Debian
Debian DHCP mit windows 2012 DNS Server verbinden (4)

Frage von SpeakerST zum Thema Debian ...

Windows Server
gelöst GPOs für Windows 10 in Server 2008 R2: Erfahrungsberichte (8)

Frage von honeybee zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Server
DHCP Server switchen (25)

Frage von M.Marz zum Thema Windows Server ...

Grafikkarten & Monitore
Win 10 Grafikkarte Crash von Software? (13)

Frage von Marabunta zum Thema Grafikkarten & Monitore ...

Windows Server
Mailserver auf Windows Server 2012 (8)

Frage von StefanT81 zum Thema Windows Server ...

Backup
Clients als Server missbrauchen? (8)

Frage von 1410640014 zum Thema Backup ...