Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 2008 R2 DC, mit Exchange, Probleme mit MSEXCHANGEADTOPOLOGYSERVICE.EXE , VPN und GPO - DNS?

Frage Microsoft Windows Netzwerk

Mitglied: brookshaw

brookshaw (Level 1) - Jetzt verbinden

31.08.2010 um 12:24 Uhr, 9448 Aufrufe, 11 Kommentare

Hallo an die Gemeinde. Ich plage mich seit einigen Tagen mit einem Bundle aus Problemen auf meinem 2008 Server und steige einfach nicht dahinter.
Das Problem war vorübergehend gelöst durch Änderungen in der Registrierung betreffend IPV6, tritt jetzt wieder auf.
Ich habe in diversen Foren nach einer Lösung gesucht und vieles probiert aber komme einfach nicht weiter.
Grundsätzlich tippe ich auf ein Problem mit dem DNS und IPv6 .
Schonmal danke im Vorraus für die Unterstützung.

Folgende Umgebung, (ja ich weiß alles auf einem Server laufen zu lassen ist nicht die eleganteste Llösung aber es ist nur eine kleine Firma):

Windows 2008 R2 Server - DC
Exchange 2007 auf selber Maschine
Installierte Rollen:

DHCP, DNS, Routing und Ras, Druckserver, Fileserver, HyperV

Folgende Fehlermeldungen kriege ich nicht beseitigt:

Warnung:
Prozess MSEXCHANGEADTOPOLOGYSERVICE.EXE (PID=1716). Der Exchange Active Directory-Anbieter hat keine DNS-Einträge für die Domäne dzingelnetwork.local erhalten. DNS-Priorität und -Gewichtung für die Domänencontroller in dieser Domäne werden auf die Standardwerte 0 (Priorität) und 100 (Gewichtung) festgelegt.

Fehler:
Fehler bei der Verarbeitung der Gruppenrichtlinie. Der Versuch, die Datei "\\dzingelnetwork.local\sysvol\dzingelnetwork.local\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\gpt.ini" von einem Domänencontroller zu lesen, war nicht erfolgreich. Die Gruppenrichtlinieneinstellungen dürfen nicht angewendet werden, bis dieses Ereignis behoben ist. Dies ist möglicherweise ein vorübergehendes Problem, das mindestens eine der folgenden Ursachen haben kann:
a) Namensauflösung/Netzwerkverbindung mit dem aktuellen Domänencontroller.
b) Wartezeit des Dateireplikationsdienstes (eine auf einem anderen Domänencontroller erstellte Datei hat nicht auf dem aktuellen Domänencontroller repliziert).
c) Der DFS-Client (Distributed File System) wurde deaktiviert.

In der Registrierung habe ich folgende Einstellung bezgl. IPv6 gewählt: 0x20 bedeutet IPv6 Loopback, Tunnel, native enabled IPv vor Ipv6.

Auf dem virtuellen Netzwerkcontroller ist nur IPv4 konfiguriert.
Alle Clientzugriffe funtkionieren einwandfrei.
Sehr seltsam.
Mitglied: education
31.08.2010 um 14:53 Uhr
DNS Überprüft ob er einwandfrei arbeitet?
DFS Überprüft?
Bitte warten ..
Mitglied: brookshaw
31.08.2010 um 15:29 Uhr
Gerade das ist es ja, der DNS funktioniert soweit, zumindest werden Anfragen von den Clients aufgelöst. Das einzige was mich wundert ist dass dcdiag default-first-site-name anscheinend der Servername nicht aufgelöst wird.
DFS ist deaktiviert.
Bitte warten ..
Mitglied: SchubOZ
01.09.2010 um 09:45 Uhr
Hallo brookshaw,

ist auf dem Server IPv6 aktiviert?
Sind auf dem Server mehrere Netzwerkadapter zu einem gebündelt?

Grüße
Bitte warten ..
Mitglied: brookshaw
02.09.2010 um 15:50 Uhr
Hallo SchubOZ,

auf dem Server ist IPV6 aktiviert, in der Regististrierung habe ich angegeben IPv4 bevorzugt zu behandeln.
Auf dem Server ist zwar physikalisch nur eine Netzwerkkarte vorhanden, diese wird seit der Hyper V Installation als Switsach verwendet und es gibt einen virtuellen Adapter der identisch eingerichtet ist wie die ursprüngliche Karte.

Ich habe übrigens versucht den virtuellen adapter zu deaktivieren und auf der Netzwerkarte den switch zu deaktivieren und wie vorher einzurichten. Das Ergebnis war dass die Fehler bliebe und der Exchange nicht mehr erreichbar war.
Bitte warten ..
Mitglied: brookshaw
03.09.2010 um 14:11 Uhr
Hallo zusammen, vielleicht hat ja jemand eine Idee.
Können meine Fehler daran liegen dass der Reverse lookup nicht funktioniert?
Bitte warten ..
Mitglied: SchubOZ
03.09.2010 um 15:48 Uhr
Ein funktionierender DNS ist Grundlage für ein Windows-Netzwerk.
Hast du eine Reverse DNS Zone eingerichtet?
Bitte warten ..
Mitglied: brookshaw
03.09.2010 um 16:53 Uhr
Jetzt schon, auf den Clients wird jetzt auch in beide Richtungen aufgelöst.
AD und DNS Aaaargh, das treibt mich zum Wahnsinn.

Habe auch festgestellt dass ich auf dem Netzwerkasapter des Servers die Router IP als bevorzugten DNS eingetragen habe. Jetzt habe ich folgende TCP/IP einstellungen:

IP = IP
Subnet = Subnet
Gateway= Router IP

DNS bevorzugt = Server IP
DNS alternativ = Router IP
Bitte warten ..
Mitglied: goscho
03.09.2010 um 17:10 Uhr
Zitat von brookshaw:
Jetzt schon, auf den Clients wird jetzt auch in beide Richtungen aufgelöst.
AD und DNS Aaaargh, das treibt mich zum Wahnsinn.
Habe auch festgestellt dass ich auf dem Netzwerkasapter des Servers die Router IP als bevorzugten DNS eingetragen habe.
Hallo brookshaw,
das ist immer das selbe Spielchen, die DNS-Einstellungen des DC werden falsch konfiguriert.

Wie soll denn da eine funktionierende Namensuaflösung klappen?
>Jetzt habe ich folgende TCP/IP einstellungen:

IP = IP
Subnet = Subnet
Gateway= Router IP
Soweit korrekt, man könnte die Gateway-Adresse sogar leer lassen, wenn im DNS die Weiterleitungen korrekt eingerichtet sind (Weiterleitungen im DNS-Server).
Ich trage aber auch meist die IP-Adresse des Routers dort ein.
DNS bevorzugt = Server IP
DNS alternativ = Router IP
Würde ich nicht machen, der erste Eintrag ist korrekt, den 2. leer lassen oder einen 2. richtigen DNS-Server (zusätzlicher DC) eintragen.

Du hast nichts davon, dass bei deinem DC noch der Router als 2. DNS-Server drinsteht. Wenn der eigene DNS-Server nicht läuft oder erreichbar ist, wirst du in deinem Netzwerk nicht (vernünftig) arbeiten können, glaub mir.
Bitte warten ..
Mitglied: brookshaw
03.09.2010 um 17:59 Uhr
Hallo Goscho,

danke für die Info. Werde dann erstmal den 2. DNS aus der Config nehmen.
Jetzt ist es so dass der Gruppenrichtlinenfehler verschwunden ist. Dass führe ich aber darauf zurück dass ich die Einstellungen der Netzwerkkarte geändert habe.
Als ich den HyperV Manager installiert habe wurde mir ein virtueller Adapter eingerichtet und die verbaute Karte als Switch konfiguriert.
Bei dieser Karte habe ich nun testweise das IP4 prtokoll ektiviert und seitdem finden sich im DNS auch weitere Einträge die vorher gefehlt haben (vorher waren da nur die Hosteinträge und der NS und SOA eingetragen).

Exchangeadtopo.... meckert nun nicht mehr.

Und nun mein größtes Problem, ich kann mich per VPN nicht mehr verbinden, im VPN Verbindungsfenster auf dem Client geht es bis zu verbindung wird hergestellt mit .. WAN PPTP und ich werde aufgefordert die Zugangsdaten (Benutzerkonto Informationen) erneut einzugeben. Der genutzte Benutzer hat im Netwerkprofil Einwahlberechtigung.
Bitte warten ..
Mitglied: brookshaw
03.09.2010 um 18:23 Uhr
Habe jetzt mal in der Ereignisanzeige versucht nachzuvollziehen,

bekomme folgende Fehlermeldung:

Die Schnittstelle "{24D1E3D5-55AF-4D43-9219-8A64284640F1}" kann nicht zu dem Router-Manager für das Protokoll IP hinzugefügt werden. Fehler: Die Funktion kann nicht abgeschlossen werden.

Ausserdem steht unter Anwendungsprotokolle immer folgende Meldung:
Die Beschreibung für die Ereignis-ID "1904" aus der Quelle "HHCTRL" wurde nicht gefunden. Entweder ist die Komponente, die dieses Ereignis auslöst, nicht auf dem lokalen Computer installiert, oder die Installation ist beschädigt. Sie können die Komponente auf dem lokalen Computer installieren oder reparieren.

Falls das Ereignis auf einem anderen Computer aufgetreten ist, mussten die Anzeigeinformationen mit dem Ereignis gespeichert werden.

Die folgenden Informationen wurden mit dem Ereignis gespeichert:

res://ieframe.dll/dnserrordiagoff_webOC.htm
http://go.microsoft.com/fwlink?LinkID=45840
Bitte warten ..
Mitglied: brookshaw
06.09.2010 um 17:15 Uhr
So zusammen, danke für die Hilfe.
Zu guter letzt war das Problem wie von vielen vermutet ein DNS Problem. Außerdem hatte ich auf den Netzwerkadaptern (physikalisch und virtuell) in den erweiterten Eigenschaften beim Testen die Ip Adressen doppelt vergeben.
Jetzt habe ich folgendes konfiguriert, phys. Netzwerkadapter nur als switch TCP/IP Protokoll usw. deaktiviert.
Auf dem virtuellen Adapter ist alles wie vorher konfiguriert.
Dann zum DNS, dort habe ich beim Testen und Neueinrichten der Forwardlookup Zone die _msdcs Zone usw. geköscht.
Für alle die ein ähnliches Problem haben, einfach eine primäre Forwardlookupzone hinzufügen nach dem schema: _msdcs.domäne.endung, nach dem Neustart des netlogon dienstes füllt sich der DNS wieder mit Infos. Seitdem läuft DCdiag fehlerfrei durch und das restliche Chaos ist auch beseitigt.
VPN klappt noch immer nicht, finde auch keine Lösung.
Ich werde diese Frage erneut stellen da Sie nicht mehr zur Thread Überschrift passt.
Danke für eure Hilfe!
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst NTP Server auf einem Windows Server 2008 R2 DC standardmäßig schon drauf? (11)

Frage von M.Marz zum Thema Windows Server ...

Windows Server
gelöst Windows 2008 R2 Backup Domaincontroller als Primary DC heraufstufen (2)

Frage von adrian138 zum Thema Windows Server ...

Windows Server
gelöst Windows 2008 R2 RODC zum DC machen (4)

Frage von derLenhart zum Thema Windows Server ...

Windows Server
gelöst Oracle ODBC Treiber in Windows 2008 R2 (3)

Frage von kschi12 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...

DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...