Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows 2008 R2 iSCSI Einbindung via Multipathing Probleme MPIO

Frage Microsoft Windows Server

Mitglied: jester84

jester84 (Level 1) - Jetzt verbinden

06.03.2013, aktualisiert 22:51 Uhr, 4393 Aufrufe, 10 Kommentare

Hallo Zusammen,

habe aktuell folgendes Szenario und Problem:

Bislang hatten wir einen 2003 Server im Einsatz der via Multipathing über iSCSI an
einem Storage angebunden war und so 2 Datenträger mit mehreren Partionen darauf zur Verfügung stellt.
In der Konstellation und Konfiguration hat alles wunderbar funktioniert.

Das Storage sollte jetzt wieder via Multipathing und iSCSI, gleiche Konfiguration, an einem neueren
Server 2008 R2 eingebunden werden. Soweit funktioniert auch alles, die beiden Datenträger werden in der
Datenträgerverwaltung erkannt, eingebunden und die Partitionen und wie folgt mit Laufwerksbuchstaben versehen:

Datenträger 1: J:, H:, G:, I:, K:, R:
Datenträger 2: L:, P:, N:, O:, M:, Q:, S:

Allerdings werden die Datenträger darunter nochmals,
nur mit den Partionsgrößen und ohne Laufwerksbuchstaben sowie dem Vermerk "offline" angezeigt.
In der Ereignisanzeige steht hierzu das erkannt wurde das Datenträger 3 und Datenträger 4 auf
den selben Pfad wie Datenträger 1 und 2 verlinkt sind und daher deaktiviert werden.

Das diese hier doppelt ausgegeben werden dürfte am Multipathing liegen,
zur Behebung bietet der 2008 R2 Server das Feature MPIO was noch nicht installiert war.

Zum eigentlichen Problem:

Wenn ich dieses Feature Microsoft MPIO installiere und die Unterstützung für Microsoft iSCSI-Geräte darin aktiviere
findet er ein entsprechendes Gerät, installiert dies und startet den Server neu.

Das seltsame ist, danach ist die erwähnte doppelte Ausgabe der Datenträger in der Datenträgerverwaltung
zwar Weg, dafür taucht aber ein anderes schlimmeres Problem auf. Er zeigt zwar beide Datenträger mit Partionen
an aber es werden auf 3 Partionen ( ehemals J:,H:,G: ) keine Laufwerkbsbuchstaben vergeben, die anderen
werden wie zuvor zur Verfügung gestellt:

Datenträger 1: I:, K:, R:
Datenträger 2: L:, P:, N:, O:, M:, Q:, S:

Manuell lassen sich auch keine Buchstaben zuweisen, beim Versuch kommt nur die Meldung:
Der Vorgang konnte nich abgeschlossen werden, weil die Ansicht des Datenträgerverwaltungs-Snap-Ins nicht aktuell ist.
Aktualisieren Sie die Ansicht mit der Aktualisierungsaufgabe, besteht das Problem weiterhin
Starten Sie das Snap In und den Computer neu.

In der Ereignisanzeige konnte ich dazu leider keine Probleme oder Infos finden.
Auch eine mehrfache Neukonfiguration der iSCSI Verbindungen hat bislang zu nichts geführt.

Für jede Idee und Hilfe schonmal vielen Dank!
Mitglied: Dani
06.03.2013 um 23:12 Uhr
Moin,
hast du MPIO mit Hilfe solcher Anleitung installiert und konfiguriert?!

Davor alle Disks, Ziele, etc... entfernen. Notfalls mit einem Neustart nachhelfen.

Ein Bug ist uns noch nicht aufgefallen. Wir haben die Konstellation ca. 60mal bei uns.


Grüße,
Dani
Bitte warten ..
Mitglied: jester84
06.03.2013 um 23:39 Uhr
Guten Abend

Ja genau die Anleitung hatte ich dann auch mal durchgelesen.
Hatte es dann auch nochmal komplett von vorne versucht, also alles rausgelöscht,
dann erst MPIO installiert und dann wieder alles eingebunden.
Leider mit dem selben Ergebnis.

Das seltsame ist ja das es nur 3 Partionen des ersten Datenträgers betrifft, so als ob
die irgendwie anders wären?!
Bitte warten ..
Mitglied: Dani
06.03.2013 um 23:55 Uhr
Deine iSCSI - Netzwerkpfade sind fehlerfrei bzw. ohne Auffälligkeiten.
Sind im iSCSI Init. Pfade oder Verbindungen auf inaktiv?

Haste spaßeshalber noch ne Testmaschine wo du die LUNs einbinden könntest?
Anderenfalls würde ich evtl. den iSCSI Init. drüberinstallieren.
Bitte warten ..
Mitglied: jester84
07.03.2013, aktualisiert um 09:28 Uhr
Hab jetzt nochmal alles komplett von neuem eingebunden und es sieht erstmal besser aus.

Die doppelte Auflistung in der Datenträgerverwaltung ist weg, es scheint aber auch nur "Failover" genutzt zu werden?:

Im iSCSI Manager stehen unter dem Punkte "Ziele" die verbundenen Ziele.
Insgesamt sind es 4 (1./2./3./4.):

Bei der Auswahl von 1. oder 3. sieht das ganze so aus:
Ich gehe weiter über den Punkt "Geräte" und dann
auf "MPIO" steht dort als Lastenausgelicherichtlinie "Nur Failover"
und zwei Pfade unten die verbunden sind. Eine Versuch der Änderung der Lastenausgleichsrichtlinie
auf "Roundrobin" gibt den Fehler aus "Falsche Richtlinieeinstellungen - Falsche Parameter.
Dir Round Robin Richtlinie versucht eigehende Anforderungen gleichmäßig auf alle Verarbeitungspfade zu verteilen".

Bei der Auswahl von 2. oder 4. sieht das ganze so aus:
Ich gehe weiter über den Punkt "Geräte" dort wird nichts weiter angezeigt,
die geöffnete Liste ist leer.

Soll das so sein?

Wähle ich wieder im iSCSI Manager eines Ziele aus 1-4 und klicke auf "Eigenschaften"
wird jeweils eine "Sitzung" angezeigt. Gehe ich weiter im Menüpunkt
"MCS" ist dort jeweils als MCS Richtlinie "Roundrobin" ausgewählt
und es wird auch hier nur eine Sitzung/Verbindung angezeigt.

Müsste hier jeweils noch eine zweite Verbindung/Sitzung eingetragen sein?
Bitte warten ..
Mitglied: Dani
09.03.2013 um 11:34 Uhr
Moin,
Im iSCSI Manager stehen unter dem Punkte "Ziele" die verbundenen Ziele. Insgesamt sind es 4
Warum vier, du hast doch sicher nur 2 Connections oder?


Grüße,
Dani
Bitte warten ..
Mitglied: jester84
11.03.2013 um 08:54 Uhr
Moinmoin,

also mal kurz als Update:
Nachdem ich den MPIO und die komplette iSCSI Konfiguration noch 2x versucht habe neu zu installieren und zu
konfigurieren hat es jetzt endlich geklappt. Allerdings lässt sich dem nichts logisches abgewinnen,
vielleicht irgendwelche Setting erst beim letzten Versuch mit gelöscht worden sodass es dann geklappt hat?

4 Verbindungen sind es weil die Verkablung Redundanz etwas verteilt ist:

Am Server IP 1: 192.168.0.3
Am Server IP 2: 192.168.1.3

verbunden an:

Am Storage IP 1: 192.168.0.1
Am Storage IP 2: 192.168.0.2

Am Storage IP 3: 192.168.1.1
Am Storage IP 4: 192.168.1.2

Was mich jetzt noch wundert sind die Einstellungen bezüglich "Round Robin".
Wenn ich im iSCSI Initiator unter "Ziele" auf eine verbundenes Ziel gehe und die
"Eigenschaften" mir anzeigen lasse gibt es noch einen Unterpunkt der nennt
sich "MCS", klickt man hierrauf steht u.a. da "MCS Richtlinie" ist Round Robin gesetzt.

Wenn ich im iSCSI Initiator unter "Ziele" auf eine verbundenes Ziel gehe und "Geräte"
davon mir anzeigen lasse gibt es noch einen Unterpunkt der nennt
sich "MPIO", klickt man hierrauf steht u.a. da "Lastenausgleichsrichtlinie" hier ist "Failover" gesetzt.
Angezeigt werden dabei unten zwei Pfade die für dieses Gerät verbunden sind.
Will ich diese "Lastenausgelcihsrichtlinie" auf "Round Robin" umändern kommt nur eine Fehlermeldung
das es sich um einen falschen Parameter handelt.

Irgend etwas müsste also noch falsch gesetzt sein? Oder ist das so i.O. um Round Robin zu nutzen
das es nur unter "MCS" eingetragen ist?

Viele Grüße und Danke!
Bitte warten ..
Mitglied: Dani
11.03.2013 um 19:56 Uhr
Moin,
ich kann leider erst morgen wieder im Büro bei uns nachsehen. Weiß ich leider nicht auswendig.


Grüße,
Dani
Bitte warten ..
Mitglied: Dani
13.03.2013 um 15:19 Uhr
Moin,
also bei uns ist Round-Robin eingetragen. Allerdings werden die Optionen inzwischen über Netapp Snapdrive durchegeführt.
Ich kann aber direkt im Initiator auf Failover umstellen ohne Fehlermeldung.

Mach doch bitte mal von deiner Konfigurationen Screenshots.


Grüße,
Dani
Bitte warten ..
Mitglied: jester84
13.03.2013 um 19:52 Uhr
Hallo Dani,

ich hatte mich jetzt noch ein wenig damit auseinandergesetzt und den Hersteller kontaktiert.
Anscheinend fehlen noch entsprechende Treiber ´eonpath´ MPIO Treiber von Infortrend, also des Raidsystems
um die Round Robin Funktion nutzen zu können. Sobald möglich werde ich dies installieren und Bescheid geben
Bitte warten ..
Mitglied: jester84
02.04.2013 um 10:03 Uhr
Treiber sind installiert, die funktionalität ist aber mit Round Robin immer noch nicht gegeben.
Seltsame Sache. Werde weiter suchen...
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
gelöst Oracle ODBC Treiber in Windows 2008 R2 (3)

Frage von kschi12 zum Thema Windows Server ...

Windows Server
gelöst Windows 2008 R2 Backup Domaincontroller als Primary DC heraufstufen (2)

Frage von adrian138 zum Thema Windows Server ...

Windows Server
gelöst Windows 2008 R2 RODC zum DC machen (4)

Frage von derLenhart zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (27)

Frage von patz223 zum Thema Windows Userverwaltung ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (20)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...