Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 2008 R2 Sp1 von Stick findet Installationmedium nicht.

Frage Microsoft Windows Server

Mitglied: Lochkartenstanzer

Lochkartenstanzer (Level 5) - Jetzt verbinden

31.03.2013, aktualisiert 10.04.2013, 3053 Aufrufe, 4 Kommentare

Die Standardmethode DVD-Inhalt auf bootbaren Stick und los funktioniert mit W2K8 R2 Sp1 nicht.

Frohe Ostern Leute,

Seit ein paar tagen läßt mir folgendes Problem keine Ruhe:

Ich habe wie bisher eine bootbaren Stick erzeugt und darauf den Inhalt der DVD kopiert. Funktionierte bei unzähligen Installation ab Vista/W2K8 bis Win8/W2012 ohne Probleme

Nun habe ich das erstemal ein W2K8R2Sp1 (OEM), das Sperenzien macht. Bisher hatte ich nur W2K8R2 ohne SP mit dieser Methode installaiert.

Das Problem:

  • Das System startet ohen Probleme von Stick,
  • Fragt Installationsprache ab
  • Klick auf Jetzt installieren ist möglich und

Tadaah:
 Ein erforderlicher CD-/DVD-Laufwerksgerätetreiber fehlt.  Wenn Sie über eine Treiberdiskette, -CD, DVD, oder ein USB-Flashlaufwerk verfügen, legen Sie diese(s) jetzt ein. ...
Was nichts anderes heißt, als das er das Installationsmedium nicht findet, aber daß das kein Treiberproblem ist, denn wenn man mit Shift-F10 eine Console startet (oder per durchsuchen nachschaut) sieht man:

  • Das USB-Laufwerk ist ordnungsgemäßt gemountet.
  • Laufwerk X: (WinPE von boot.wim) ist da.
  • DVD-Laufwerk ist da, man kann auf Dateien zugreifen, wenn man eine DVD einlegt. Und man kann von DVD installieren, wenn man von dieser bootet.

Ich könnte jetzt einfach pragmatisch, das so hinnehmen und einfach von DVD installieren, allerdings will ich für Nofälle doch gerne auch einen Stick haben, denn DVDs werden gerne verlegt und ein Stick ist immer schnell erzeugt, insbesondere auch dann, wenn grad kein brenner zur Hand ist.

Ich habe in diversen Foren schon herumgesucht, habe aber nichts passendes gefunden. In einem MS-Forum gab es den tipp, den Stick abzuziehen und dann an einen anderen Port zu stecken und die Installation nochmal ab "Jetzt installieren" zu starten. hat leider nicht geholfen.

Auch die diversen Tipps, das RAID vom Controller aufzulösen und AHCI statt RAID-Modus zu verwenden brachten keine Abhilfe. Einen Legacy/IDE-Modus hat das Board (Intel S1200BTL) nicht. Nachtrag4: ich habe die "legacy-Optionen gefunden. Bringen aber keinen Fortschritt. /Nachtrag


Nachdem ich jetzt mehrere Stunden da hineininvestiert habe, wende ich mich hilfesuchend an Euch:

Weiß jemand, woran W2K8R2 (und andre Windows-Versionen ab Vista/W2K8) ihr Installationsmedium erkennen? Denn das es da ist ist eindeutig, weil ich per cmd oder Durchsuchen an diese Dateien komme. Und eine eingelegte DVD mit diesen Dateien wird ja auch erkannt.

Klar, ich könnte einfach auch mit imagex/apply das System vom Stick auf die Platte klatschen, aber das ist nicht der Sinn meiner Übung.

Schönen Abend noch,

lks


PS: Ja, der Onboard-Controller ist zwar Fakeraid, ist aber für den Anwendungsfall ausreichend.


Nachtrag1:

  • Ein Test in einer virtuellen Maschine führte zum gleichen Ergebnis.
  • Und ja, alle Dateien auf der DVD sind auch auf dem Stick. Ein "diff -rq" brachte keine Unterschiede zutage.

Nachtrag2:

  • In diversen Foren wird gesagt, daß es ein kaputtes DVD-Image sein könnte. das ist aber hier auszuschließen, da es von der DVD geht und die Dateien auf dem Stick alle indentisch mit denen auf der DVD sind.

Nachtrag3:

  • Bei der DVD-Installation kommt übrigens auch die Meldung, daß er keine DVD-treiber hat. Allerdings ist die Fehlermeldung falsch und W2K8R2 will eigentlich den Treiber für die HDDs. Nachdem es diesen bekommen hat, macht es weiter. Leider nur in der DVD-version, in der Stickversion nicht (wie ich oben schon ausgeführt hatte).




Lösung


Ihr werdet es nciht glauben, die Lösung war trivial: Einfach ein funktionierendes DVD-Laufwerk benutzen.

Manchmal sieht man vor lauter Bäumen den Wald nicht. Ich habe die OEM-DVD per dd auf eine lokale Platte in eine ISO-Datei kopiert und diese als Grundlage für das Arbeiten benutzt. Also gemountet und davon die Dateien herunterkopiert, oder auch später auf einem Win7-System diese Datei gemountet und dort nochmal die Dateien herunterkopiert. Fakt ist, die ISO war kaputt, aber keines der Mountprogramme hat einen fehler gemeldet! Ich hatte ja testweise nochmal die Dateien direkt mit der DVD verglichen und da wurden auch keine Abweichungen festgestellt.

Heute bin ich wieder dazugekommen, an dem Problem weiterzuschrauben und habe "aus Versehen" ein anderes DVD-Laufwerk benutzt und dabei festgestellt, daß die md5-Prüfsummen der Iso-Dateien voneinander abweichen. Dadurch "aufgewacht" habe ich alles nochmal durchgeprüft und siehe da, das erste Laufwerk hatte offensichtlich immer den gleichen Lesefehler mit der DVD, auch nach mehrmaligen Versuchen. Nachdem ich die Ursache gefunden habe und den Fehler
versucht habe auf dem ursprünglichen Laufwerk zu wiederholen, funktioniert das Mistding wieder normal.

Fazit: Die althergebrachte Methode eine Windows-DVD ab Version Win6/Win2008 einfach auf einen bootbaren USB-Stick zu kopieren funktioniert immer noch. Wenn das Windows die installationsdateien nicht findet, ist die ISO oder einige der Dateien darauf kaputt.

Diesen ganzen Ärger könnte MS uns ersparen, wenn die auf jede DVD eine Liste mit Prüfsummen für die Dateien packen würden, wie das z.B. bei Linuxdistributionen üblich ist.



Update 10.4.2013:

Wie weiter unten ausgeführt sind die Methoden das USB-Downloadtool von MS für Windows 7 und "händisch" per diskpart & Xcopy identisch.
Mitglied: Dani
01.04.2013 um 00:04 Uhr
Moin Lkz,
Hast du versucht mit dem Tool Windows 7 USB/Downloadtool versucht? Ist laut Support für alle Serverversionen gedacht. Nutzen wir für Win 7, Win 8, Server 2008 /R2 SP1, Server 2012 problemlos.


Grüße,
Dani
Bitte warten ..
Mitglied: Lochkartenstanzer
01.04.2013 um 00:16 Uhr
Zitat von Dani:
Moin Lkz,
Hast du versucht mit dem Tool Windows 7 USB/Downloadtool versucht? Ist laut Support für alle Serverversionen gedacht. Nutzen
wir für Win 7, Win 8, Server 2008 /R2 SP1, Server 2012 problemlos.


Hallo Dani,

Nein habe ich nciht versucht, aber soweit ich Informiert bin, macht das auch nichts anderes, als die Schritte:

  • diskpart clean
  • diskpart create partition
  • diskpart format
  • diskpart active
  • xcopy DVD: USB:

zusammenzufassen.

Und die Dateien sind ja auch alle korrekt rüberkopiert, der Inhalt des Sticks ist identisch mit der DVD, der Stick bootet in die Installation hinein, nur will das verd***te windows nicht weitermachen, obwohl alle Laufwerke da und sichtbar sind.

ich werde morgen mal testhaber auch die Tool-Variante probieren, verspreche mir aber nicht allzuviel davon. Wie gesagt, die Installation mit der DVD selbst funktioniert.
Bitte warten ..
Mitglied: Dani
01.04.2013 um 01:07 Uhr
Ich kann's dir leider nicht sagen. Bisher durfte ich meistens die Erfahrung machen, dass irgendwo ein kl. Unterschied bzw. Datei geschrieben wird die nicht dokumentiert ist.

Das Tool kommt wohl mit Sticks die größer als 4GB sind nicht klar (mehrmals versucht). Ich habe aktuell keine Sticks zur Hand aber könntest du ein "diff" erzeugen zur DVD?

Wir nutzen eben zu 99% den vorgeschlagenen Weg von Microsoft, da im Fehlerfall der Support den Fehler suchen darf.


Grüße,
Dani
Bitte warten ..
Mitglied: Lochkartenstanzer
10.04.2013 um 16:13 Uhr
Zitat von Dani:

Das Tool kommt wohl mit Sticks die größer als 4GB sind nicht klar (mehrmals versucht). Ich habe aktuell keine Sticks
zur Hand aber könntest du ein "diff" erzeugen zur DVD?


Habe es inzwischen ausprobiert, weil ich es wissen wollte:

  • ISO per dd von W2K8 R2 Sp1 (OEM) erzeugt.
  • Mit den Tool auf lexar 64GB-Stick (USB3.0) kopieren lassen
  • Das Tool hat den Stick auf NTFS formattiert und alles draufkopiert. Kam nur eine Fehlermeldung, daß BCD-Boot den Stick nicht bootbar machen könne (was aber nicht gestimmt hat).
  • Ein rekurisves Diff über die DVD und den Stick hat keine Unterschiede in den Datetein offenbart, nicht ein einziges Byte.
  • Der Stick war bootbar und hätte mir auch ein W2K8R2 auf mein Testsystem draufgeknallt, wenn ich es denn gelassen hätte (Habe bei der Festplattenauswahl abgebrichen).

Fazit:

Diskpart & xcopy/robocopy reichen, um so einen Stick zu erzeugen.

lks
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Oracle ODBC Treiber in Windows 2008 R2 (3)

Frage von kschi12 zum Thema Windows Server ...

Windows Server
gelöst Windows 2008 R2 Backup Domaincontroller als Primary DC heraufstufen (2)

Frage von adrian138 zum Thema Windows Server ...

Windows Server
gelöst Windows 2008 R2 RODC zum DC machen (4)

Frage von derLenhart zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (14)

Frage von liquidbase zum Thema Windows Update ...

DSL, VDSL
Problem mit variernder Internetgeschwindigkeit (12)

Frage von schaurian zum Thema DSL, VDSL ...