Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 2008R2 Domäne und Windows7 Clients. Auf Clients keine Netzwerklaufwerke als Installationsordner auswählbar

Frage Microsoft Windows Netzwerk

Mitglied: siegit

siegit (Level 1) - Jetzt verbinden

21.07.2011, aktualisiert 20:33 Uhr, 7019 Aufrufe, 6 Kommentare

Ist-Situation:
1x Windows 2008R2 Foundation; Frisch aufgesetzt
2x Windows 7 Prof Clients

Nutzer mit Domänenbenutzerrechten und lokalen Administrationsrechten angelegt. Diese Nutzer haben ein Netzlaufwerk H: gemappt. Schreib und Lese Rechte sind vergeben und funktionieren auch im Explorer.
Nur wenn ich ein Programm intstallieren will, zeigt er mir dieses gemappte Laufwerk dort nicht zur Auswahl an.

Ich kann es soweit eingrenzen, dass es kein Problem mit Windows 7 ist (ein weiteres Gerät, dass nicht an die Domäne angebunden ist, aber Netzwerklaufwerke gemappt hat, kann im Installationsprogramm drauf zugreifen. Ebenfalls ein WinXP System, dass sich nun testweise in der Domäne befindet.) Das Programm kann (und fordert es ja auch

In den Gruppenrichtlinien dürfte vermutlich ein entsprechender Eintrag vorhanden sein, aber ich finde den partout nicht

Edit: Als Dom-Admin klappts auch nicht.
Mitglied: kingkong
21.07.2011 um 22:41 Uhr
Ein Programm auf einem Netzlaufwerk installieren? Ich hoffe, das ist auch ein Programm, was das kann - es gibt einige Gegenbeispiele. Kannst Du uns sagen, welches Programm es ist? Würde vielleicht helfen...
Bitte warten ..
Mitglied: siegit
21.07.2011 um 22:52 Uhr
Kann das Programm. Es fordert während der Installationsroutine zur Angabe eines Verzeichnisses (in diesem falle das geforderte Netzwerklaufwerk) auf, wo mehrere Konfigurationsdateien liegen, auf die zugegriffen werden soll. Ist alles so OK auch laut Doku und Hersteller.
Die Installationsroutine beherrscht es. Habe mich nun Spaßeshalber mal lokal aan den PCs angemeldet und die Laufwerke gemappt. Auch das klappt dann aus der Installationsroutine mit dem Zugriff. Nur sobald ich als Domänen User arbeite klappt es nicht. S.h. für mich, da fehlen Rechte (kann ich mir nicht vorstellen, da der User zu dem Zeitpunkt Domänen Admin war) oder es sind Gruppenrichtlinien, die einen Zugriff verhindern (was ich weiterhin vermute).

Der Hersteller hat nur leider um 18 Uhr seine Hotline dicht gemacht hat und den letzten "Supporter" den ich am Ohr hatte absolut keine Ahnung hatte, ich aber nicht unbedingt bis morgen Früh warten will, wenn ich die Klamotten beim Kunden aufbaue.
Bitte warten ..
Mitglied: kingkong
21.07.2011 um 23:20 Uhr
Gibts von der Version eine "normale" und eine Enterprise-Version? Könnte ein Unterscheidungskriterium sein...
Bitte warten ..
Mitglied: jsysde
21.07.2011 um 23:21 Uhr
Kann es sein, dass du hier am "elevated mode" scheiterst?
http://www.winability.com/how-to-make-elevated-programs-recognize-netwo ...

Wir haben "EnableLinkedConnections" per GPO durchgesetzt, nicht per händischem Reg-Eintrag - aber zum Testen erstmal nur ein System hernehmen.

Cheers,
jsysde
Bitte warten ..
Mitglied: siegit
22.07.2011 um 14:13 Uhr
Dankeschön jsysde, genau das wars.

Habe es nun per Regedit gelöst. Bei so einer kleinen umgebung ist das ja schnell erledigt.

Habe es auch per ADM import probiert, aber das hat leider keinen Erfolg gebracht. Oder ist fürr Win2008R2 noch eine größere Änderung am Code notwendig?

; ADM Template Creation/Modifying Date: 30.10.2008 15:48:18 
; ADM Template Author: norbert 
; ADM Template created by gpaddit (http://www.gpaddit.com) - M.Heitbrink & E.Grandel GbR 
 
Class Machine  
	CATEGORY "Vista UAC"  
 
		POLICY "Enable Linked Connections"  
			#IF VERSION  >=  4 
				SUPPORTED !!Supported_Vista  
			#ENDIF 
 
			EXPLAIN !!Hlp_EnableLinkedConnections 
			KEYNAME "SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System" 
 
			PART "Activate linked connections" Checkbox 
				VALUENAME "EnableLinkedConnections" 
				DEFCHECKED 
				VALUEON "1" 
 
				VALUEOFF DELETE 
 
			END PART 
 
		END POLICY ;Enable Linked Sessions 
 
	END CATEGORY ;Vista UAC 
 
 
[STRINGS] 
 
Hlp_EnableLinkedconnections="With activated User Account Control in Windows Vista network drives are not mapped with logonscripts, which are assigned via Group Policy.\n\n\nEnable this policy if this problem exists.\n\nCAUSE\nThis problem occurs because User Account Control treats members of the Administrators group as standard users. Therefore, network shares that are mapped by logon scripts are shared with the standard user access token instead of with the full administrator access token. \n\nWhen a member of the Administrators group logs on to a Windows Vista-based computer that has User Account Control enabled, the user runs as a standard user. Standard users are members of the Users group. If you are a member of the Administrators group and if you want to perform a task that requires a full administrator access token, User Account Control prompts you for approval. For example, you are prompted if you try to edit security policies on the computer. If you click Allow in the User Account Control dialog box, you can then complete the administrative task by using the full administrator access token. \n\nWhen an administrator logs on to Windows Vista, the Local Security Authority (LSA) creates two access tokens. If LSA is notified that the user is a member of the Administrators group, LSA creates the second logon that has the administrator rights removed (filtered). This filtered access token is used to start the user’s desktop. Applications can use the full administrator access token if the administrator user clicks Allow in a User Account Control dialog box. \n\nIf a user is logged on to Windows Vista and if User Account Control is enabled, a program that uses the user’s filtered access token and a program that uses the user’s full administrator access token can run at the same time. Because LSA created the access tokens during two separate logon sessions, the access tokens contain separate logon IDs. \n\nWhen network shares are mapped, they are linked to the current logon session for the current process access token. This means that, if a user uses the command prompt (Cmd.exe) together with the filtered access token to map a network share, the network share is not mapped for processes that run with the full administrator access token.\n\nhttp://support.microsoft.com/kb/937624/en-us" 
Supported_Vista="at least Windows Vista"
Bitte warten ..
Mitglied: DerWoWusste
23.07.2011 um 16:52 Uhr
Wenn Du Probleme mit ADMs hast: nutz doch GPPs, um Regeinträge zu setzen, die machen ADMs überflüssig. Siehe http://support.microsoft.com/kb/943729
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows 10
Raspberry Windows 10, Domäne, Remote Desktop (4)

Frage von opc123 zum Thema Windows 10 ...

Windows Server
gelöst RDH 2012R2 in 2008R2-Domäne mehrfache Anmeldung nötig (4)

Frage von YotYot zum Thema Windows Server ...

Windows Server
gelöst WebDav unter Windows 2008R2 (1)

Frage von BPeter zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (20)

Frage von Xaero1982 zum Thema Microsoft ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Festplatten, SSD, Raid
M.2 SSD wird nicht erkannt (14)

Frage von uridium69 zum Thema Festplatten, SSD, Raid ...