Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows 2k8 R2 Bluescreen 0xc0000001

Frage Microsoft Windows Server

Mitglied: ByteKiller

ByteKiller (Level 1) - Jetzt verbinden

21.01.2013 um 18:03 Uhr, 4687 Aufrufe, 7 Kommentare

STOP: c00002e2 Directory Services could not start because of the following error: A device attached to the system is not functioning. Error Status: 0xc0000001. Please shutdown this system and reboot into Directory Services Restore mode, check the event log for more detailed information.

Hallo,

ich habe einen Windows 2k8 R2 Server (Domaincontroller + Exchange 2010; VMware Maschine) (Ich weiß keine ideale Combo ).
Den habe ich gerade neugestartet und bekomme dann den o.g. Bluescreen.

Das Problem wurde hier http://daddyr.blogspot.de/2012/06/win2008r2-dc-blue-screen-on-startup.h ... auch schon mal beschrieben. Nur war er leider nicht so erfolgreich...

- CheckDisk ist gearde durchgelaufen und hat nichts bemängelt.
- Komm ich von WinPE (Starthilfe) an das EventLog?
- Der Domaincontroller ist ertmal Nebensache. Wichtig ist der Exchange.
- Was macht die Verzeichnisdienstwiederherstellung? Kann man die verwenden oder sollte man vorher Glückstee trinken?

Für jeden Vorschlag bin ich euch unendlich dankbar
MfG
ByteKiller


Mitglied: Pjordorf
21.01.2013 um 21:48 Uhr
Hallo,

Zitat von ByteKiller:
(Domaincontroller + Exchange 2010
Ups.

- Komm ich von WinPE (Starthilfe) an das EventLog?
Je nachdem was dein WinPE noch alles bietet kannst du die Logs sogar Lesen. Wenn dein WinPE noch eine Filebrowser oder ähnlich hat kannst du soagr die Logs kopieren usw.

- Der Domaincontroller ist ertmal Nebensache. Wichtig ist der Exchange.
Falsch. Dir ist schon klar das ein Exchange ohne AD eben nicht läuft? Dein DC (AD) hat also zwnagsläufig vorrang.

- Was macht die Verzeichnisdienstwiederherstellung?
Es stellt das Verzeichniss wieder her, so wie der Name es einem sugeriert.

Kann man die verwenden
Ja, sofern du auch die nötigen Datensicherung(en) hast.

oder sollte man vorher Glückstee trinken?
Hilft nicht wirklich ohne Datensicherung, oder?

Gruß,
Peter
Bitte warten ..
Mitglied: ByteKiller
22.01.2013 um 05:07 Uhr
Zum Domaincontroller... da gibts einen zweiten.
Also die Kiste ist platt da ist nichts mehr zu machen.
Setzen gerade einen neuen Exchange auf ... ohne AD ;)
Wenn das alles klappen sollte schreibe ich dann hier mal meine Erfahrungen und Probleme nieder.
Bitte warten ..
Mitglied: Pjordorf
22.01.2013 um 09:41 Uhr
Hallo,

Zitat von ByteKiller:
Wenn das alles klappen sollte schreibe ich dann hier mal meine Erfahrungen und Probleme nieder.
Vor allem wie du dein Exchange zum laufen bekommen hast ohne ein AD zu nutzen

Gruß,
Peter
Bitte warten ..
Mitglied: Ausserwoeger
22.01.2013 um 16:01 Uhr
Zitat von Pjordorf:
Vor allem wie du dein Exchange zum laufen bekommen hast ohne ein AD zu nutzen

Gruß,
Peter

?? Er schreibt doch oben das er einen Zweiten DC hat ? Er muss ja nur den DC zum Primären DC machen und die FSMO Rollen übernehmen und den alten Primären DC aus der Domain entfernen.

Den Exchange neu instllieren und die Datenbank wieder einbinden. Die User den Postfächern zuordnen usw.

LG
Bitte warten ..
Mitglied: Pjordorf
22.01.2013 um 16:41 Uhr
Hallo Ausserwoeger,

Zitat von Ausserwoeger:
?? Er schreibt doch oben das er einen Zweiten DC hat ?
Du hast es nicht verstanden, oder Das ist doch klar das er einen DC hat (sogar eine 2ten). Aber du hast schon sein
Setzen gerade einen neuen Exchange auf ... ohne AD ;)
gelesen und verstanden? Vor allem sein Smiley

@all
AD <> DC

Gruß,
Peter
Bitte warten ..
Mitglied: ByteKiller
22.01.2013 um 17:06 Uhr
ok da ist der smiley vlt bissel missverständlich, sry. ich meinte einen dedizierten Exchange Server.. so besser?
Bitte warten ..
Mitglied: ByteKiller
22.01.2013 um 17:10 Uhr
So da versuche ich mal nach der Nachtschicht, mich noch mal zusammenzureißen und erzähl was mir so wieder fahren ist:

Also wie gesagt das betroffene System war ein Domaincontroller mit Exchange Server. Wir haben uns nach einiger Begutachtung dafür entschieden, dass es die praktikabelste Lösung ist den Server neuaufzusetzen. Und wollten dabei die Kombination DC/Exchange nicht wieder haben, da sie u.a. auch von M$ nicht empfohlen wird. Da es einen zweiten DC gibt, der auch alle FSMO inne hat sollte ja die Exchange Wiederherstellung kein Problem sein...

Die Exchange Wiederherstellung ist aber an einige Voraussetzungen geknüpft (http://technet.microsoft.com/de-de/library/dd876880%28v=exchg.141%29.as ...). So muss zum Beispiel derselbe Rechnername verwendet werden, wie bei der alten Instanz und auch die "physikalischen" Eigenschaften müssen dem zu ersetzenden System entsprechen. Damit fingen die "kleinen" Probleme an.

Den alten Exchange konnten wir nicht mehr ordnungsgemäß depromoten (Konnte nur noch in der Verzeichniswiederherstellung gestartet werden). Dazu noch eine Anmerkung... Ist die Kombination DC/Exchange installiert kann man auch nicht mehr depromoten (ich hatte das schon mal versucht). Auf jeden Fall musste das Computerkonto des korrupten DCs aus dem AD raus, damit man mit demselben Namen wieder ein Domainmitgliedserver anmelden konnte.

Das Löschen des Kontos wurde uns aber aufgrund fehlender Rechte verweigert (Wir = DomainAdmin). Nun gibt es im Netz viele lange und ewige Anleitungen, wie man mit diversen und teils kryptischen cmdlets do ein Verzeichnisobjekt löschen kann. Das war uns aber zu heikel und undurchsichtig. Folgendes haben wir gemacht, wobei ich nicht sagen kann was wir auch weglassen hätten können:
- In der DC-GPO die Admingruppe der Richtliche "Enable computer and user accounts to be trusted for delegation" hinzugefügt
- In "Active Directory Sites and Services" den Verweis auf den DC gelöscht (das ging)
- Verweise im DNS korrigiert
- Beim Kontoobjekt die Eigenschaft vor versehentlichem Löschen schützen entfernt. (Erst hinzugefügt, dann nochmal explizit abgewählt)
- Vlt. sollte man auch hier noch mal genauer lesen ;) : http://support.microsoft.com/kb/216498/de-de

Dann konnten wir den neuen Server in die Domain heben.

Die Wiederherstellung des Exchange mussten wir auch öfters laufen lassen... bzw. wieder von vorn beginnen.
- Man benötigt die zuletzt installierte Exchangeversion oder höher. (Bei uns war Exchange 2010 SP1 installiert, brauchten also das entsprechende Medium)
- Bei der Wiederherstellung müssen die Abhängigkeiten schon installiert sein (.NET 3.5., FilterPack (bei uns Version 2), IIS)
- Das neue Serverkonto muss in der Gruppe ExchangeServers sein. Sonst ist der Zugriff auf das AD nicht möglich und die Dienste starten nicht. Bei uns ist da immer die Installation des Hub-Transportdienstes bei 98% ausgestiegen (er wartet brav 20min, ob der Dienst nicht doch startet -.-)

Und irgendwann... hurra der Exchange war wieder da. Wie ich es z.Z. beurteilen kann mit all seinen Einstellungen (Sendekonnektoren usw.) Das SSL Zertifikat mit seinen Zwischenzertifikaten haben wir per Hand nach tragen müssen.
Damit aber nicht genug… Die Datenbanken wollten ja auch wieder eingespielt werden. Die Mailbox für den Öffentlichen Ordner hat keine großen Probleme bereitet. Aber die Postfachfachdatenbank war so vom alten System nicht mehr zu gebrauchen. Unzählige Logfiles waren/sind korrupt. Das eseutil konnte uns da auch nicht mehr wirklich helfen. Wir haben dann eine Wiederherstellung eines Backups an geschupst… das dauert natürlich. Ohne es genau zu wissen, aber mir wurde gesagt, dass das wohl erfolgreich war und zumindest die Datenbank wieder eingehängt ist.

Sollte ich was vergessen haben versuche ich, das bei Gelegenheit zu ergänzen...
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
"Do you trust this printer" bei jedem Druck von Citrix via Server 2k8 R2 (2)

Frage von diematrix125 zum Thema Windows Server ...

Windows Server
ACrobat Reader DC und RDP Server unter Server 2K8 R2 (4)

Frage von SDS-Junkie zum Thema Windows Server ...

Windows Server
gelöst Oracle ODBC Treiber in Windows 2008 R2 (3)

Frage von kschi12 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...

Peripheriegeräte
Wlan stört Funkmaus (11)

Frage von Falaffel zum Thema Peripheriegeräte ...

Peripheriegeräte
gelöst USB Festplatte verliert Laufwerksbuchstabe (9)

Frage von cese4321 zum Thema Peripheriegeräte ...