Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 7 Deployen mit einer Antwortdatei - Produkt Key und Computername

Frage Microsoft Windows Server

Mitglied: drphake

drphake (Level 1) - Jetzt verbinden

14.09.2011 um 13:49 Uhr, 9775 Aufrufe, 2 Kommentare

Hallo zusammen,

ich arbeite gerade an einem WDS-Server zum verteilen von Windows 7.

Meine bisherigen Schritte:
- Installation eines "MasterClients"
- Updaten (neuester Stand)
- Installation von (Office, 7Zip, etc...)

Sysprep:
- Ausgeführt und in Überwachungsmodus gestartet
- Zuvor erstellten Benutzer gelöscht
- Sysprep /Verallgemeinert /OOBe /Herunterfahren

Image:
- Mit einem WinPE USB-Stick MasterClient neue gestartet
- Image gezogen mit ImageX

WDS-Server:
- Installiert/eingerichtet
- DCHP konfiguriert
- Erstelltes Image eingebunden

Antwortdatei:
Die zu installierenden Rechner sollen mit Hilfe einer Antwortdatei automatisch installiert werden, das funktioniert auch soweit so gut.
- Sprache wird ausgewählt
- Image (wird und soll manuell ausgewählt werden)
- Partitionierung erfolgt automatisch
- Installation ist im Gange
- Einbinden in eine Lokale Arbeitsgruppe
- Erstellen eines Lokalen Benutzerkontos

Alles verläuft wunderbar, nur leider bekomme ich es nicht auf die Reihe, den Produkt Key (Volumenlizenz) mitzugeben...
Ebenso möchte ich den Computernamen bei der Installation selber vergeben, was auch nicht klappt...

Vorne weg, ich arbeite mit 2 Antwortdateien.
Die erste (WinPE) ist in den Eigenschaften des Servers unter Client eingebunden, welche folgende Einstellungen beinhaltet:
- Setup Language
- Disk Configuration
- WindowsDeploymentServices

Die Imagespezifische Antwortdatei poste ich lieber einmal

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="specialize">
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<SystemLocale>de-DE</SystemLocale>
<UILanguage>de-DE</UILanguage>
<UILanguageFallback>de-DE</UILanguageFallback>
<UserLocale>de-DE</UserLocale>
</component>
<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<Identification>
<JoinWorkgroup>Testgroup</JoinWorkgroup>
</Identification>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<AutoLogon>
<Enabled>false</Enabled>
</AutoLogon>
<BluetoothTaskbarIconEnabled>false</BluetoothTaskbarIconEnabled>
<ComputerName/>
<ProductKey>xxxx-xxxx-xxxx-xxxx-xxxx</ProductKey>
<RegisteredOwner>firma</RegisteredOwner>
<ShowWindowsLive>false</ShowWindowsLive>
<RegisteredOrganization>firma</RegisteredOrganization>
<DoNotCleanTaskBar>true</DoNotCleanTaskBar>
<DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
<CopyProfile>false</CopyProfile>
<TimeZone>W. Europe Standard Time</TimeZone>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<InputLocale>de-DE</InputLocale>
<SystemLocale>de-DE</SystemLocale>
<UILanguage>de-DE</UILanguage>
<UserLocale>de-DE</UserLocale>
<UILanguageFallback>de-DE</UILanguageFallback>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<UserAccounts>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Password>
<Value>cABpAGwAbwB0AEcALQAyADAANwBQAGEAcwBzAHcAbwByAGQA</Value>
<PlainText>false</PlainText>
</Password>
<Description>itbss</Description>
<DisplayName>itbss</DisplayName>
<Group>Administratoren</Group>
<Name>itbss</Name>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
<RegisteredOwner>firma</RegisteredOwner>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
<NetworkLocation>Work</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
</OOBE>
</component>
</settings>
<settings pass="generalize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance;>"
<OEMInformation>
<Manufacturer>firma</Manufacturer>
<HelpCustomized>false</HelpCustomized>
</OEMInformation>
<RegisteredOwner>firma</RegisteredOwner>
<BluetoothTaskbarIconEnabled>false</BluetoothTaskbarIconEnabled>
<DoNotCleanTaskBar>true</DoNotCleanTaskBar>
<RegisteredOrganization>firma</RegisteredOrganization>
</component>
</settings>
<cpi:offlineImage cpi:source="wim://Computername/reminst/exporte/win7.wim#Windows 7 Enterprise" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>

Für Ideen und Anregungen bin ich sehr dankbar.

Gruß
Mitglied: Edi.Pfisterer
16.09.2011 um 22:36 Uhr
Hallo!

Alles verläuft wunderbar, nur leider bekomme ich es nicht auf die Reihe, den Produkt Key (Volumenlizenz) mitzugeben...
Ebenso möchte ich den Computernamen bei der Installation selber vergeben, was auch nicht klappt...

Schön, dass Du schon fast Alles zum Laufen gebracht hast.
Zu Deinen 2 Sorgenkindern:

ad Key:

Die gute Nachricht: Product Key brauchst Du bei einer Volumenlizenz nicht in der XML zu hinterlegen!
Die schlechte Nachricht: Du wirst einen Key Management Service (KMS) benötigen, der allerdings recht einfach zu installieren ist.
Eine Anleitung findest Du beispielsweise hier: http://www.microsoft.com/austria/education/msach_kms.mspx bzw. dann
http://www.microsoft.at/admp/A22A1F25-E28D-4137-8944-3CD6A06775AC/Windo ...
Passt nicht nur für Schulen, sondern generell für die Verwendung eines Volumelicensekeys.

ad Computername:
ich würde mal versuchen, den Eintrag <computername/> aus Deiner xml komplett zu entfernen....
(ich habe irgendwo gehört, dass Du dann zur manuellen Eingabe des Namens bei der Installation aufgefordert wirst. Ich habe das aber noch nie getestet)
[abgesehen davon wäre dies - falls es funtioniert - nur für die Erstinstallation der Clients ratsam, danach empfiehlt sich jedenfalls folgendes]

Hinterlege in der XML folgendes:
<ComputerName>%MACHINENAME%</ComputerName>

als %MACHINENAME% wird nun

entweder
der bereits im AD hinterlegte (= prestaged) Name verwendet (da Du
a) den Client zuvor mit seiner GUID im AD manuell angelegt hast oder
b) der Cleint bereits vor der Installation via WDS im AD war (er hat ja immer noch die selbe GUID und wird daher wieder in der selben OU landen mit dem selben Namen...)

oder
der default Name, den Du im WDS eingestellt hast (MAC, SSID, etc) verwendet.



Bei dieser Gelegenheit kann ich dir 2 funktionierende XML-Dateien für eine Volume License anbieten, die die Clients der Domäne hinzufügen (und bei mir immer funktioniert haben!):
http://www.schulnetz.info/xml-datei-fur-wds-windows-7/


Hoffe, Dir etwas geholfen zu haben,
gutes Gelingen,
lg
Edi
Bitte warten ..
Mitglied: Edi.Pfisterer
28.09.2011 um 10:21 Uhr
@drphake:
Gern geschehen, freut mich immer, wenn sich jemand erkenntlich zeigt...

lg
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Windows Mobile
gelöst Windows 10 Phone Encryption - Recovery Key? (1)

Frage von DerWoWusste zum Thema Windows Mobile ...

Windows 10
Klappt es noch mit 7 Key Windows 10 zu aktivieren? (10)

Frage von zeroblue2005 zum Thema Windows 10 ...

Windows Server
Windows Server 2012 R2 Key auslesen (7)

Frage von itisnapanto zum Thema Windows Server ...

Windows 10
Windows 10 upgrade und Key im Unternehmen (7)

Frage von nightwishler zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (15)

Frage von JayyyH zum Thema Switche und Hubs ...

DSL, VDSL
DSL-Signal bewerten (13)

Frage von SarekHL zum Thema DSL, VDSL ...