Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows 7 - dsa.msc als Domain-Admin ausführen

Frage Microsoft Windows 7

Mitglied: suvv7777

suvv7777 (Level 1) - Jetzt verbinden

05.11.2010 um 10:52 Uhr, 18665 Aufrufe, 8 Kommentare

Guten Tag,

ich habe mal wieder ein Problem. ;)

Seit gestern nutze ich (als letzter in der ganzen IT-Abteilung +hust+) nun also auch Windows 7 Enterprise (x64), konnte mich damit aber noch nicht so richtig anfreunden. Vor allem folgendes regt mich gerade sehr auf:

Da ich recht häufig, die Active Directory (Users & Computers) nutze und diese natürlich als Domain-Admin ausführen möchte, bleibt mir bislang nur der Weg, auf eine Verknüpfung rechtszuklicken bei gedrückter Shift-Taste um es dann mit einem anderen Domain User (mein Admin Account) auszuführen. Unter XP konnte man wunderschön einstellen, beim Öffnen einer bestimmten Anwendung, nach alternativen Credentials zu fragen. Oder man hat sich ein runas-Script gebaut und musste sogar nur noch sein Passwort eingeben.

Genau das habe ich jetzt unter Windows 7 versucht und bin der Verzweiflung nahe.

Wenn ich einfach

runas /user:domain\meinadmin %SystemRoot%\system32\dsa.msc

verwende, sagt er mir, dass dsa.msc keine gültige Win32 Anwendung ist. Also habe ich folgendes versucht (was sogar als Beispiel in der runas-Hilfe angegeben is):

runas /user:domain\meinadmin "mmc %windir%\system32\dsa.msc"

Hier bekomme ich die wunderschöne Fehlermeldung "740 Der angeforderte Vorgang erfordert erhöhte Rechte".

Wenn ich das ganze in eine cmd eingebe, die ich als Domain-Admin ausgeführt habe, funktioniert es leider genau so wenig (wäre aber ohnehin wenig praktikabel).

Es muss doch irgendeine Möglichkeit geben, sich ein Script zu basteln, dass die Active Directory ausführt mit einem von mir ausgewählten Domain-Account.

Über Vorschläge und Tipps würde ich mich riesig freuen.

DANKE!
Mitglied: whatever
05.11.2010 um 11:21 Uhr
Hallo suvv7777,

einfach eine Verlinkung auf den Desktop, Schnellstartleiste, etc machen oder rechte Maustaste auf dsa.msc und "an Taskleiste o. Startmenü anheften" auswählen.
Dann in die Eigenschaften der Verlinkung gehen und "Erweitert" auswählen und dort "Als Administrator ausführen" anklicken.

Wenn Du jetzt Deine Verlinkung anklickst kommt die Abfrage. Du musst zwar noch Deinen "meinadmin" eintragen und nicht nur das Passwort, aber das ist ja vielleicht zu ertragen, wenn der Name nicht zu kompliziert ist :D

Das wäre jetzt meine spontane Idee auf die Schnelle.

Gruß
whatever
Bitte warten ..
Mitglied: IT-Kean
05.11.2010 um 11:22 Uhr
Moin,

schau mal in diese Richtung http://www.microsoft.com/downloads/details.aspx?FamilyID=7d2f6ad7-656b- ... damit wird dir bestimmt geholfen.
Bitte warten ..
Mitglied: suvv7777
05.11.2010 um 14:01 Uhr
Nein, leider funktioniert das so nicht. Es erscheint keine Abfrage, sondern das Programm wird einfach mit lokalen (!) Admin-Rechten gestartet, was mir aber in der AD leider wenig bringt.
Bitte warten ..
Mitglied: suvv7777
05.11.2010 um 14:03 Uhr
Ich möchte ja nicht diese Programme haben oder installieren, sondern lediglich als Admin starten. Aber scheinbar ist das bei Windows 7 tatsächlich zu viel verlangt...
Bitte warten ..
Mitglied: whatever
05.11.2010 um 14:50 Uhr
???
Dein Rechner/Account ist doch in der(selben) Domäne, oder nicht?
Also bei mir funktioniert das tadellos - Win 7 Ultimate x64. Die Domäne ist automatisch schon eingetragen [unter dem Kennwort steht "Domäne: ***"] in der Abfrage.
Ich gebe meinen Adminnamen und das Kennwort ein und die Anwendung wird unter dem User gestartet. Lediglich bei "Fremdrechnern" ist es immer etwas nervig.

Bin mir jetzt also etwas unsicher, warum das bei Dir nur mit dem lokalen Admin will bzw. warum gar keine Abfrage kommt.
Dein User-Account hat nur Benutzerrechte oder nicht?! An der UAC rumgespielt?
Bitte warten ..
Mitglied: suvv7777
05.11.2010 um 15:09 Uhr
Ok, evtl. könnte es daran liegen, dass mein User-Account lokale Admin-Rechte hat. Dann gilt es jetzt abzuwägen, was ich öfter brauche. Aber erstmal teste ich jetzt, ob das der Grund ist.
Bitte warten ..
Mitglied: whatever
05.11.2010 um 15:30 Uhr
Ist garantiert der Grund Da fehlt halt die zusätzliche Abfrage.
Dann müsstest Du eher mit Shift+rechte Maustaste auf's Icon klicken und "als anderer Benutzer ausführen" auswählen. Damit geht's ebenfalls.
Bitte warten ..
Mitglied: freakms
03.06.2013 um 07:35 Uhr
Himmel...danke @whatever ... das ich nicht selber auf die Idee gekommen bin ...klar mit Shit-rechte Maus wird das als anderer Benutzer ausführen sichtbar...

Habe genau das gleiche Problem gehabt. Mein User ist hier lokaler admin und es fehlte die Abfrage...Danke du hast mir den Tag gerettet!
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...