Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 7 Home Premium löst keine langen subdomains auf

Frage Microsoft Windows Netzwerk

Mitglied: DerHammer

DerHammer (Level 1) - Jetzt verbinden

04.03.2010 um 12:04 Uhr, 5336 Aufrufe, 9 Kommentare

Hallo,

wir haben einen kleinen Atom Nettop mit Windows 7 Home Premium hier stehen. Nachdem alles wichtige installiert ist, ist uns aufgefallen das unsere internen Projekt Seiten nicht funktionieren. Windows 7 scheint Subdomains ab einer bestimmten länge abzuschneiden oder einfach nicht auf zu lösen.

Unsere Interne Domain Syntax sieht wie folgt aus : projekt_name.server.firmenname.intern

Ich habe das nun mit mehreren Projekten ausprobiert und es scheint so als taucht der Fehler nur auf wenn der Projektname länger als 7 Zeichen ist. (Ist leider bei 90% der fall)

Insgesammt komme ich dann auf (8+8+10+6) = 32 Zeichen.

Ein nslookup liefert übrigens das korrekte Ergebnis.

Kann mir da jemand weiterhelfen? Habe sonst nichts passendes dazu gefunden.

- DerHammer
Mitglied: Snowman25
04.03.2010 um 12:43 Uhr
vllt. mal mit einem anderen Browser versuchen?
Bitte warten ..
Mitglied: DerHammer
04.03.2010 um 13:07 Uhr
Das Problem tritt sowohl mit IE8 als auch mit Firefox 3.5 auf.
Bitte warten ..
Mitglied: Snowman25
04.03.2010 um 13:11 Uhr
Eigenartig...
Geht nslookup auch über den gleichen DNS?
Könntest du mal eine Beispiel-URL posten?
Gruß
Snow
Bitte warten ..
Mitglied: DerHammer
04.03.2010 um 15:29 Uhr
Rechner läuft mit DHCP und bekommt unseren internen DNS Server (bind9) mitgeteilt. Der wird auch von nslookup benutzt.

Hier ein Beispielt welches ich zum testen des Fehlers eingerichtet habe:

Funktioniert: abcdef.arbeit01.xxxxxxxxxx.intern
Funktioniert nicht: abcdefg.arbeit01.xxxxxxxxxx.intern

Beide zeigen auf den gleichen Server.
Bitte warten ..
Mitglied: Snowman25
04.03.2010 um 15:34 Uhr
Zitat von DerHammer:
Funktioniert nicht: abcdefg.arbeit01.xxxxxxxxxx.intern
nslookup kann richtig auflösen aber über einen Browser wird es nicht mehr richtig aufgelöst?
Sind hosts, networks, etc. alle richtig? (also die Dateien)
Bitte warten ..
Mitglied: DerHammer
05.03.2010 um 09:48 Uhr
Dort stehen nur die Standardeinträge. Nichts außergewöhnliches.

Edit.: Erste Frage übersehen. nslookup löst richtig auf nur die Browser verweigern Ihren Dienst. Hat bestimmt wieder etwas mit der beschnittenen Windows Version zu tun.
Bitte warten ..
Mitglied: DerHammer
05.03.2010 um 13:38 Uhr
Habe nun zumindest herausgefunden warum die Auflösung von kurzen Namen funktioniert. Laut Wireshark erfolgt die Auflösung per netbios. Er ignoriert die suffixe unseres internen LANs komplett und fragt nur abcdef.arbeit01 ab. Da netbios ja nur recht kurze namen zulässt funktioniert es nicht mehr bei längeren Domains.
Also ignoriert die Home version die DNS-Suffixe die ich sogar extra eingetragen habe. Wirklich Top.

Gibts dafür einen Registry Trick oder etwas in der Richtung?
Bitte warten ..
Mitglied: Snowman25
05.03.2010 um 13:53 Uhr
Sendet dein DHCP auch NetBIOS-Einstellungen an die Clients?
Vllt. sind die ja falsch.
Bitte warten ..
Mitglied: DerHammer
05.03.2010 um 14:16 Uhr
So ich habe die Lösung.

Das super Windows 7 ignoriert die DNS-Suffixe die man in den Netzwerkeinstellungen unter TCPIP v4 / erweitert / dns eintragen kann. Um das zu fixen einfach in der Registry "HKLM\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient" öffnen (oder anlegen wenn nicht vorhanden) und deinen dword eintrag mit dem Namen "AppendToMultiLabelName" hinzufügen. Diesen auf 1 setzen, neu starten und alles funktioniert wie es soll.

Premium.
Bitte warten ..
Ähnliche Inhalte
Windows 7
Startproblem mit Windows 7 Home Premium
Frage von Dad2802Windows 73 Kommentare

Beim Kaltstart des PC zeigt sich in den letzten Tagen immer wieder ein Blue Screen, mit den unterschiedlichsten Fehlermeldungen, ...

Windows 7
Windows 7 Home Premium ISO - wo downloaden?
Frage von deckard2019Windows 79 Kommentare

Hallo. Ich habe eine Frage zu den Windows 7 ISOs, die ich auf der Microsoft Website downloaden kann. Ich ...

Windows 7
Bluescreen F4 beim booten von Windows 7 x64 Home Premium
Frage von BruehwurstWindows 71 Kommentar

Ich habe ein Problem bei meinem Laptop (Asus N75SL) und zwar lässt dieser sich nicht mehr hochfahren (auch nicht ...

Windows Update
Neu aufgesetztes Windows 7 Home Premium installiert keine Updates
gelöst Frage von Alex.SpWindows Update16 Kommentare

Guten Tag, ich habe das Problem, dass auf einem neu aufgesetzten Windows 7 (die D:/ Partition wurde vom alten ...

Neue Wissensbeiträge
Sicherheit

TLS-Zertifikat und privater Schlüssel von Microsofts Dynamics 365 geleakt

Information von Penny.Cilin vor 1 StundeSicherheit

Microsoft hat versehentlich das TLS-Zertifikat inklusive dem privaten Schlüssel seiner Business-Anwendung Dynamics 365 geleakt. TLS-Zertifikat und privater Schlüssel von ...

Viren und Trojaner

Deaktivierter Keylogger in HP Notebooks entdeckt

Information von bitcoin vor 23 StundenViren und Trojaner1 Kommentar

Ein Grund mehr warum man Vorinstallationen der Hersteller immer blank bügeln sollte Der deaktivierte Keylogger findet sich im vorinstallierten ...

Router & Routing

Lets Encrypt kommt auf die FritzBox

Information von bitcoin vor 1 TagRouter & Routing

In der neuesten Labor-Version der FB7490 integriert AVM unter anderem einen Let's Encrypt Client für Zugriffe auf das Webinterface ...

Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 4 TagenInternet21 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Brainstorming, einfachste Option 1 getrenntes LAN (mit WAN zugang)
Frage von 132954LAN, WAN, Wireless13 Kommentare

Hi, folgendes: Wir bekommen eine Glasfaser Leitung, Und das sollte Optional so aussehen: Ein Modem/Router für das WAN, ein ...

Batch & Shell
Trusted Sites für alle User auf dem PC einpflegen
Frage von xXTaKuZaXxBatch & Shell12 Kommentare

Aufgabestellung: Es sollen auf 1 PC (bzw. mehreren PCs) vertrauenswürdige Sites per Powershell eingetragen werden, die für alle User ...

Netzwerkgrundlagen
Hi eine blöde frage. xD
Frage von 132954Netzwerkgrundlagen12 Kommentare

Also: Habe 2012 r2 essentials neuinstalliert, allerdings installiert diese version ja gleich diesen gangen AD kram mit, den hab ...

Netzwerkmanagement
Firefox Profieles im Roaming
gelöst Frage von Hendrik2586Netzwerkmanagement12 Kommentare

Hallo liebe Leute. :) Ich hab da ein kleines Problem, welches anscheinend nicht unbekannt ist. Wir nutzen hier in ...