Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 7 PC clonen (inkl. Settings) - Sysprep nötig?

Frage Microsoft Windows 7

Mitglied: mc-doubleyou

mc-doubleyou (Level 2) - Jetzt verbinden

06.03.2014, aktualisiert 14:14 Uhr, 3941 Aufrufe, 11 Kommentare

Hallo zusammen,

ich habe ein Problem mit Sysprep und frage mich daher ob ich evtl. auch ohne arbeiten könnte.

Aber erst mal mehr Details zum Prototypen:

- Windows 7 PC
- Aktivierung von Office und installierte Programme
- Alle benötigen Benutzer bestehen und passende Policys
- Security Policy definiert

Wenn ich nun aber Sysprep durchführe (derzeit: sysprep /generalize /oobe /shutdown) habe ich folgende Probleme:

- Wenn ich den zusätzlich sinnlosen User (Administrator) lösche wird mein lokaler Admin deaktiviert (der einzige )
- durch die Änderung der SID wird die einem Benutzer zugeteilte Policy sinnlos und er erscheint nicht wie gewünscht
- sämtliche Gerätetreiber sind nicht mehr aktiv

Der Clone soll mit snapshot erstellt werden.
PCs werden zwar in Netzwerken aber ohne AD, WSUS oder ähnlichem betrieben.

Irgendwelche Ideen?

Danke!

LG mcdy
Mitglied: Lochkartenstanzer
06.03.2014 um 14:14 Uhr
Zitat von mc-doubleyou:

Der Clone soll mit snapshot erstellt werden.
Irgendwelche Ideen?

Einafch image mit dd kopieren und umbennen?

lks
Bitte warten ..
Mitglied: mc-doubleyou
06.03.2014 um 14:26 Uhr
Hey lks,

die Frage "Irgendwelche Ideen" bezog sich eher auf den Bereich oben als auf das Clone erstellen, clonen ist mit Abstand mein kleinstes Problem.

LG mcdy
Bitte warten ..
Mitglied: Lochkartenstanzer
06.03.2014 um 14:57 Uhr
Zitat von mc-doubleyou:

die Frage "Irgendwelche Ideen" bezog sich eher auf den Bereich oben als auf das Clone erstellen, clonen ist mit Abstand
mein kleinstes Problem.

Dann laß doch den Sysprep weg.Wenn Du dem Klon einen neune Namen verpaßt udn in die domain aufnimmst, bekomtm der eh eine neue SID.

lks
Bitte warten ..
Mitglied: wisebeer
07.03.2014 um 07:32 Uhr
Warst du beim Erstellen der Referenzmaschine im Audit Modus? Dabei werden solche Änderungen ins Image übernommen. Lg
Bitte warten ..
Mitglied: Monschu
07.03.2014 um 08:39 Uhr
Hi,
NewSID schon ausprobiert und dessen Auswirkungen getestet?
Wenn du keine neuen SIDs generierst kannst du mit einigen Server-Client Anwenundgen Probleme bekommen, z.B. AV Scanner wie SEP die tauchen dort dann von doppelt bis zehnfach auf (nicht schön das aufzuräumen ;) ).
Gruß
Bitte warten ..
Mitglied: Penny.Cilin
LÖSUNG 07.03.2014, aktualisiert 13.03.2014
Zitat von Monschu:

Hi,
NewSID schon ausprobiert und dessen Auswirkungen getestet?
Wenn du keine neuen SIDs generierst kannst du mit einigen Server-Client Anwenundgen Probleme bekommen, z.B. AV Scanner wie SEP die
tauchen dort dann von doppelt bis zehnfach auf (nicht schön das aufzuräumen ;) ).
Gruß


Hallo,

NewSID wird nicht mehr unterstützt. Siehe Marks Blog
Stattdessen sollte man Sysprep nutzen.


Gruss Penny.
Bitte warten ..
Mitglied: colinardo
LÖSUNG 07.03.2014, aktualisiert 13.03.2014
Zitat von wisebeer:
Warst du beim Erstellen der Referenzmaschine im Audit Modus? Dabei werden solche Änderungen ins Image übernommen. Lg
Das ist der richtige Hinweis, die Treiber etc. erst hinzufügen nachdem du die Maschine mit Sysprep im Systemüberwachungsmodus gestartet hast. Dann überstehen die Treiber das Generalize

/audit  - startet den Computer im Überwachungsmodus neu. Mit dem Überwachungsmodus kann man Windows zusätzliche Treiber oder Anwendungen hinzufügen. Außerdem kann eine Installation von Windows getestet werden, bevor diese an einen Endbenutzer weiter gegeben wird.
Grüße Uwe
Bitte warten ..
Mitglied: mc-doubleyou
07.03.2014, aktualisiert um 13:17 Uhr
Hallo,

nachdem ich nun in den Audit Mode gewechselt bin und da "neue" Fehler behoben habe klappt sysprep gar nicht mehr:

schwerwiegender Fehler bei der Systemvorbereitung des Computers

Folgende Änderungen wurde von mir im Audit Mode vorgenommen:

- Grafikkartentreiber installiert (was sonst Standard VGA)
- Office aktivieren (war sonst nicht aktiviert)
- Schattenkopien aktivieren (waren sonst auch nicht aktiv)

Für meine bisherigen Probleme habe ich teilweise Lösungen gefunden

- Wenn ich den zusätzlich sinnlosen User (Administrator) lösche wird mein lokaler Admin deaktiviert (der einzige face-sad )
|_ Benutzer wird nun mittels SetupComplete.cmd gelöscht
- durch die Änderung der SID wird die einem Benutzer zugeteilte Policy sinnlos und er erscheint nicht wie gewünscht
|_ Policy wird mittels SetupComplete wieder zugeteilt
- sämtliche Gerätetreiber sind nicht mehr aktiv
|_ bisher keine Lösung

Danke!

LG mcdy
Bitte warten ..
Mitglied: wisebeer
07.03.2014 um 13:36 Uhr
Am besten wäre die Maschine neu aufzusetzen und beim ersten Installationsdialog mt Strg, Shift und F3 in den Audit-Modus zu wechseln, dann alle Änderungen vornehmen und erst dann Sysprep ausführen. Dann ziehst du dein Image (zB mit Clonezilla) und dann kannst du ans Verteilen gehen. Die Eingaben bei Erstinstallation sind minimal, wenn du nur wenige Rechner machst zahlt sich eine Antwortdatei vermutlich nicht aus. Lg Martin
Bitte warten ..
Mitglied: mc-doubleyou
13.03.2014 um 16:57 Uhr
Hallo zusammen,

wir arbeiten nun doch, anders ist es scheinbar nicht möglich, mit einer Kombination aus sysprep und SetupComplete sowie einem Antwort File.
Ein Problem bleibt, aber dafür eröffne ich eine eigene Frage.

Danke!
Bitte warten ..
Mitglied: KevinDreher
27.03.2014 um 08:19 Uhr
Hallo mcdy,

erstmal finde ich es echt super, dass du solche Sachen ansprichst.
Bezüglich deines Problems.
Wenn du das Windows bloß sichern möchtest, um es nachher wieder auf den gleichen PC zu bringen kannst du das auch ohne Sysprep machen z.B. mit der Windows Sicherung oder einem Programm wie Acronis True Image etc.

Wenn du das Windows/Image jedoch auf mehrere Rechner verteilen möchtest, musst du zwangläufig zum Sysprep greifen, weil du sonst Lizenzprobleme bekommen könntest, da Microsoft dies nur mit einem Sysprep genehmigt.

Nun zu deinen Problemen.
Den deaktivierten lokalen Administrator kannst du durch eine Antwortdatei auch mit dem Sysprep lösen. Stichwort: unattend.xml. Diese Datei kannst du mit dem WAIK und dem Windows-System-Image-Manager erstellen und den lokalen Admin dort definieren. siehe http://technet.microsoft.com/de-de/library/dd744516(v=ws.10).aspx


Soweit ich weiß, sollten lokale Gruppenrichtlinien nach einem Sysprep bestehen bleiben, wenn du diese mit dem Gruppenrichtlinien-Editor erstellt hast.

Treiber sollten ohne /generalize kein Problem sein.

Office mit dem Image aktiviert zu halten ist lizenzbedingt auch schwierig, da es dann ja auch möglich wäre eine 1-Rechner-Lizenz zu verteilen und diese aktiviert bleibt. Das müsste man trotzdem noch selber machen denk ich.

Ich hoffe ich konnte dir etwas helfen.

Mit freundlichen Grüßen
Kevin Dreher
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Heiß diskutierte Inhalte
Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

Grafikkarten & Monitore
Tonprobleme bei Fernseher mit angeschlossenem Laptop über HDMI (11)

Frage von Y3shix zum Thema Grafikkarten & Monitore ...

Microsoft Office
Keine Updates für Office 2016 (11)

Frage von Motte990 zum Thema Microsoft Office ...