Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 7 RC1 - Herunterfahren, Shutdown Problem

Frage Microsoft Windows 7

Mitglied: BarkingSheep

BarkingSheep (Level 1) - Jetzt verbinden

21.05.2009, aktualisiert 11:39 Uhr, 29482 Aufrufe, 17 Kommentare

Meine Version von Windows 7 RC1 will nicht korrekt herunterfahren. Egal ob ich neu starten oder herunterfahren auswähle, das OS hängt beim Herunterfahren-Bildschirm dauerhaft fest. USB-Geräte werden manchmal abgeschaltet, der PC wird aber nie vollends heruntergefahren.

An installierter Software ist nur AntiVir drauf, was eventuell Probleme erzeugen könnte. Falls jemand Rat weiß oder auch wie ich an eine Log-Datei o.ä. für dieses Problem dran käme, wäre ich sehr dankbar!
Mitglied: education
21.05.2009 um 11:49 Uhr
wirf mal den antivir runter ob das problem dann auch noch ist. das selbe problem hatte ich mal mit XP+antivir vielleicht hilft es
Bitte warten ..
Mitglied: LotPings
21.05.2009 um 12:36 Uhr
Hallo BarkingSheep.

Also ich habe mit dem RC (64bit) und Antivir keine Probleme.
Die hatte ich aber mit der Beta. Hast du neu installiert?

Ich tippe auch eher auf Hardware/Treiberprobleme.

Hast du in der Ereignisanzeige die Windows-Protokolle schon durchgearbeitet?
Das geht schneller wenn du einen Filter setzt der erstmal die Information-Einträge ausblendet.

Gruß
LotPings
Bitte warten ..
Mitglied: BarkingSheep
21.05.2009 um 12:59 Uhr
Dieser Fehler hier ist zweimal aufgetreten:

Name der fehlerhaften Anwendung: ehshell.exe, Version: 6.1.7100.0, Zeitstempel: 0x49ee983b
Name des fehlerhaften Moduls: wmvcore.dll, Version: 12.0.7100.0, Zeitstempel: 0x49eea66c
Ausnahmecode: 0xc0000006
Fehleroffset: 0x000c589a
ID des fehlerhaften Prozesses: 0x%9
Startzeit der fehlerhaften Anwendung: 0x%10
Pfad der fehlerhaften Anwendung: %11
Pfad des fehlerhaften Moduls: %12
Berichtskennung: %13


Dieser ist vorhin bei einem Bluescreen vorhin nach dem fehlerhaften Herunterfahren aufgetreten:

Volumeschattenkopie-Dienstfehler: Beim Abfragen nach der Schnittstelle "IVssWriterCallback" ist ein unerwarteter Fehler aufgetreten. hr = 0x80070005, Zugriff verweigert
. Die Ursache hierfür ist oft eine falsche Sicherheitseinstellung im Schreib- oder Anfrageprozess.

Vorgang:
Generatordaten werden gesammelt

Kontext:
Generatorklassen-ID: {e8132975-6f93-4464-a53e-1050253ae220}
Generatorname: System Writer
Generatorinstanz-ID: {7d8a51da-1e7e-4d9e-b023-6a1761f4ec6a}
Bitte warten ..
Mitglied: 78632
21.05.2009 um 13:04 Uhr
Du solltest vielleicht alle gestellten Frage beantworten.
Bitte warten ..
Mitglied: BarkingSheep
21.05.2009 um 13:11 Uhr
Zitat von LotPings:

Also ich habe mit dem RC (64bit) und Antivir keine Probleme.
Die hatte ich aber mit der Beta. Hast du neu installiert?

32bit RC1 komplett neu installiert, vorher war XP drauf. Antivir ist auch deinstalliert jetzt, keine Änderung da.


Hast du in der Ereignisanzeige die Windows-Protokolle schon
durchgearbeitet?
Das geht schneller wenn du einen Filter setzt der erstmal die
Information-Einträge ausblendet.

Siehe die zwei Logs im zweitletzten Post. Das waren die zwei größten vorkommenden Fehler.
Bitte warten ..
Mitglied: LotPings
21.05.2009 um 13:18 Uhr
Zitat von BarkingSheep:

Dieser ist vorhin bei einem Bluescreen vorhin nach dem fehlerhaften
Herunterfahren aufgetreten:

Die Formulierung ist gut Du meinst, du hast die Kiste ausgeknippst - oder ?

Ob das ein ursächlicher Fehler ist oder Folgefehler vom Ausschalten kann ich nicht entscheiden.

Ich würde den ProcExplorer laufen lassen um zu sehen was beim Runterfahren passiert und wo er evtl. hängt.

Gruß
LotPings

PS: Welche Version 32/64Bit und welche Hardware hast du denn in der Kiste? Aktuell/erprobt/Geriatrisch?
Bitte warten ..
Mitglied: 78632
21.05.2009 um 13:18 Uhr
Deaktiviere mal testweise den Dienst "Volumeschattenkopie" und prüfe, ob der Fehler dann auch noch auftritt.

ehShell.exe und wmvcore.dll sind Bestandteile des Microsoft Media Centers.
Vielleicht ist bei dir da was aktiv, das nicht beendet werden kann.
Bitte warten ..
Mitglied: BarkingSheep
21.05.2009 um 14:47 Uhr
Zitat von 78632:
Deaktiviere mal testweise den Dienst "Volumeschattenkopie"
und prüfe, ob der Fehler dann auch noch auftritt.

ehShell.exe und wmvcore.dll sind Bestandteile des Microsoft Media
Centers.
Vielleicht ist bei dir da was aktiv, das nicht beendet werden kann.





Volumenschattenkopie ist bereits beendet, geht trotzdem nicht. Folgende Warnung steht noch beim Herunterfahren:

Es wurde festgestellt, dass Ihre Registrierungsdatei noch von anderen Anwendungen oder Diensten verwendet wird. Die Datei wird nun entladen. Die Anwendungen oder Dienste, die Ihre Registrierungsdatei anhalten, funktionieren anschließend u. U. nicht mehr ordnungsgemäß.

DETAIL -
2 user registry handles leaked from \Registry\User\S-1-5-21-420852453-930739516-1665301470-1001:
Process 2460 (\Device\HarddiskVolume1\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-420852453-930739516-1665301470-1001
Process 2092 (\Device\HarddiskVolume1\Windows\System32\PrintIsolationHost.exe) has opened key \REGISTRY\USER\S-1-5-21-420852453-930739516-1665301470-1001

und

Es wurde festgestellt, dass Ihre Registrierungsdatei noch von anderen Anwendungen oder Diensten verwendet wird. Die Datei wird nun entladen. Die Anwendungen oder Dienste, die Ihre Registrierungsdatei anhalten, funktionieren anschließend u. U. nicht mehr ordnungsgemäß.

DETAIL -
1 user registry handles leaked from \Registry\User\S-1-5-21-420852453-930739516-1665301470-1001_Classes:
Process 2460 (\Device\HarddiskVolume1\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-420852453-930739516-1665301470-1001_CLASSES


Mein System sieht wie folgt aus:

Intel Core2Duo E6750 2,66 GHz
Gigabyte GA-P35-DS3L P35 Rev. 2.0
2GB RAM
NVIDIA GeForce 8800 GTS
Bitte warten ..
Mitglied: 78632
21.05.2009 um 15:11 Uhr
Die Warnung kannst du ignorieren. Die wird seit Vista durch einen in Windows integrierten Dienst behandelt, der unter XP noch separat installiert werden musste.

http://support.microsoft.com/kb/947238/de
Bitte warten ..
Mitglied: BarkingSheep
21.05.2009 um 16:23 Uhr
So der Bluescreen ist nochmal aufgetaucht (und wurde dann mit Kaltstart "behoben" ;) )

Die Fehlermeldung sah wie folgt aus:

Driver_Power_State_Failure

Ich solle caching oder shadowing Optionen im BIOS ausschalten, habe aber im selbigen (Award) keine gefunden.

Beim Windows Neustart erschien dann noch folgende Info:

Problemsignatur:
Problemereignisname: BlueScreen
Betriebsystemversion: 6.1.7100.2.0.0.256.1
Gebietsschema-ID: 1031

Zusatzinformationen zum Problem:
BCCode: 9f
BCP1: 00000003
BCP2: 8577C690
BCP3: 8292AAE0
BCP4: 8676FA30
OS Version: 6_1_7100
Service Pack: 0_0
Product: 256_1


Würde eine .dmp Datei irgendwie helfen, den Fehler zu lokalisieren? Hab schonmal weiter gesucht und da hatte wer Probleme mit zwei Festplatten, deren Treiber wohl nicht verifiziert waren...
Bitte warten ..
Mitglied: 78632
21.05.2009 um 16:30 Uhr
Möglicherweise hängt das mit dem eingestellten Energieschema zusammen. Hast du vielleicht den Ruhemodus aktiviert? Dann deaktivieren den mal. > Powercfg -H off
Auf jeden Fall hängt es aber mit Treibern für Hardware zusammen, die die Energieoptionen nicht korrekt oder nicht ausreichend unterstützen.

Hinweise zum Fehler:
http://msdn.microsoft.com/en-gb/library/ms795679.aspx
Bitte warten ..
Mitglied: BarkingSheep
21.05.2009 um 16:56 Uhr
Ruhezustand war deaktiviert, der einzige aktivierte Energiesparmodus ist Bildschirm nach 15min ausschalten.

Der genaue Fehlercode lautete: : 0x0000009f (0x00000003, 0x8577c690, 0x8292aae0, 0x8676fa30).

Ergo "A device object has been blocking an IRP for too long a time." Sprich ein I/O request packet (IRP) wurde nicht korrekt beendet, da es durch ein Gerät blockiert wurde.

Wie lokalisiere ich jetzt das Problem genau?

Danke schonmal für die hilfreichen Antworten, ich krieg das noch ans Laufen!
Bitte warten ..
Mitglied: 78632
21.05.2009 um 17:20 Uhr
Fang mal mit msconfig > Diagnosesystemstart an. Wenn damit kein Fehler mehr auftritt, würde ich danach erst mal alle Hardware deaktivieren, die nicht zwingend benötigt wird und dann nacheinander wieder aktivieren.
Bitte warten ..
Mitglied: 78632
21.05.2009 um 17:29 Uhr
Vielleicht hilft dir der ProcessExplorer von MS/Sysinternals, den entsprechenden Treiber über die Fehleradresse rauszubekommen.
Wenn du dir über View > Show LowerPlane > Show DLLs unten in den Spalten noch die BaseAddress anzeigen lässt, kannst du oben auf SYSTEM klicken und die Adresse suchen.
Bitte warten ..
Mitglied: BarkingSheep
21.05.2009 um 17:35 Uhr
Also mit Diagnosestart funktioniert das Herunterfahren und neu starten einwandfrei. Den guten ProcessExplorer nutze ich auch gerne, werde mich gleich drum kümmern und (hoffentlich) die Lösung dann hier posten.

Thanks so far!
Bitte warten ..
Mitglied: BarkingSheep
21.05.2009 um 22:39 Uhr
Also blablanick schonmal vielen Dank, bin dem Problem jetzt genau auf die Schliche gekommen.

Es hängt mit dem Audiotreiber zusammen, bzw. wenn man über msconfig geht dem Dienst "Windows-Audio" oder "Windows-Audio-Endpunkterstellung" (nach ca. 40 Test-Neustarts mit allem an und aus in Blöcken ;) ).

Das problema grande ist wohl, dass ich mit zwei Soundkarten arbeite. Der OnBoard (diese macht keine Probleme) und der M-Audio Delta Audiophile 2496, deren Treiber noch nicht Windows 7 optimiert sind und somit den Fehler beim Herunterfahren verursachen. Die aktuellen Treiber für die 2496 sind logischerweise installiert, andere Treibervarianten wie 64bit Version funktionieren auch nicht, auf Sound verzichten möchte ich aber deswegen nicht. ;)
Bitte warten ..
Mitglied: 78632
21.05.2009 um 23:05 Uhr
Schön, dass du wenigstens die Ursache eingekreist hast.

Da bleibt dir offenbar im Moment nur die Möglichkeit, dir 2 Scripte zu erstellen: Eines zum Herunterfahren, in dem du vor Shutdown den Dienst deaktivierst (mit SC) und eines, mit dem du nach dem Hochfahren den Dienst wieder aktivierst.

Wenn es mit dem Deaktivieren der Audiophile klappen soll, kannst du statt des Deaktivierens des Dienstes das MS-Tool DevCon im Kompatibilitätsmodus (!) verwenden. Zum vernüftigen Arbeiten damit musst du allerdings die UAC komplett ausschalten, sonst bekommst du nichts zu sehen. ;)

http://support.microsoft.com/kb/311272/de

Möglicherweise gibt es in Windows 7 ein ähnliches Tool zur Geräteverwaltung in der Konsole. Ich habe aber nicht groß danach gesucht und auch nichts dazu gefunden.
Bitte warten ..
Neuester Wissensbeitrag
Festplatten, SSD, Raid

12TB written pro SSD in 2 Jahren mit RAID5 auf Hyper-VServer

Erfahrungsbericht von Lochkartenstanzer zum Thema Festplatten, SSD, Raid ...

Ähnliche Inhalte
LAN, WAN, Wireless
gelöst Windows 10 - Wake on Lan Problem (4)

Frage von Jannis92 zum Thema LAN, WAN, Wireless ...

Windows 10
gelöst Wake on Lan unter Windows 10, mal ein anderes Problem (9)

Frage von 333com zum Thema Windows 10 ...

Windows Server
gelöst Windows Server 2012 - Remote Login Problem (2)

Frage von Loginfriek zum Thema Windows Server ...

Windows 10
gelöst Herunterfahren RDP Windows 10 verhindern (4)

Frage von micha055 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...