Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows 7 mit Windows Server 2008 R2 Verbindungsabbrüche, Win XP Rechner nicht betroffen.

Frage Microsoft Windows Server

Mitglied: Warromat

Warromat (Level 1) - Jetzt verbinden

25.08.2013 um 23:11 Uhr, 3938 Aufrufe, 5 Kommentare

Guten Tag zusammen.

Ich weiß einfach nicht weiter und benötige Hilfe.

Folgendes Szenario bei einem Kunden: (beschreibe ausführlich, damit kaum Fragen offen bleiben)

Kleines Netzwerk mit einem Windows Server 2008 R2 Standard mit SP1 und allen aktuellen Patches,
2 Windows 7 Pro 64 Bit Arbeitsrechner mit SP1 und allen aktuellen Updates. Einer per Intel Wlan angebunden, der andere per Gigabit Switch per LAN-Kabel.
Dazu 5 Stationen mit Win XP Pro SP3 teilweise per Gigabit LAN, teilweise am gleichen Wlan-AP wie der Win 7 Rechner.

Auf dem Server läuft DNS, WINS, DC und eine Poet-Datenbank. dazu noch einige Ordnerfreigaben auf die alle Stationen Vollzugriff haben (von der Software, die auch den Poet braucht so nötig). Der DNS und DC wird aktuell nicht genutzt. Die PCs haben lokale Userprofile und in einer Arbeitsgruppe.
Als DNS und GW ist aktuell eine Fritz.Box mit der IP 192.168.100.1 zuständig. (I-Net Router) Eine 2. Fritz.Box ist mit DNS und DHCP in dem Subnet 192.168.178.* aktiv. Ist für einen Wartungszugang spezieller Maschinen. Befindet sich aktuell am gleichen Switch.
Der Server hat die IP 192.168.100.2, der Wlan AP die 192.168.100.5. Firewall am Server ist aus.
Alle IPs der PCs statisch, ein DHCP für die Handys des Kunden ist im Bereich von 192.168.100.200 - 192.168.100.230 auf der Fritz.Box (älteres Modell) aktiv.

Habe den Kunden mit diesem Setup übernommen. Aktuell sollen die PCs nicht in die Domäne.

Es kommt jetzt NUR an den Windows 7 Stationen in unregelmäßigen Abständen zu Abbrüchen bei den Freigaben und der Poet Datenbank.
D.h. Verbunde Netzlaufwerke bekommen ein rotes "x", Netzwerkfreigaben sind nicht mehr erreichbar, obwohl schon geöffnet, und die Anbindung an die Datenbank geht verloren -> das Programm stürzt ab. Zu dem Zeitpunkt kann weder per IP noch per UNC auf den Server zugegriffen werden. Ping geht aber zu jeder Zeit. Die Win XP Stationen arbeiten normal weiter, als ob nichts passiert ist.
Teilweise gibt es auch Probleme, wenn die Anwendung, die auf die Poet-DB zugreift direkt nach dem Windowsstart gestartet wird. Es ist dann keine Verbindung möglich. Nach einem erneutem Start der Anwendung geht es dann meistens.

Das Ganze ist nach ca. 30s - 2 Min wieder vorbei und alles lässt sich wieder starten / zugreifen. Eingegeben Daten / Änderungen an geöffneten Dateien sind dann leider futsch. Passiert mehrfach pro Stunde, daher kein haltbarer Zustand.

Aktuell habe ich als "Workaround" ein Ping-Command alle 5 Sek. an den Server und die Fritz Box in einer Batch-Schleife im Autostart. Das hilft und es treten KEINE Verbindungsabbrüche mehr auf. Das kann ja aber nicht nötig sein normal.

Folgendes habe ich schon erfolglos probiert:

An den Windows 7 Stationen:
- statt UNC-Pfade IP-Pfade
- andere, freie statische IPs und Computernamen (es gab mal eine Fehlermeldung beim Netzlaufwerk, das der Clientname schon vorhanden wäre, allerdings nach einem Abbruch)
- Server als DNS, Eintrag in hosts Datei (da IP-Pfad auch nicht mehr erreichbar wohl kein Netbios Problem)
- ALLE Energiesparoptionen von Windows und der NIC ausgeschaltet (auch Green Ethernet usw.) auch verschiedene Offload Einstellungen der NIC
- IPv6 komplett deaktiviert (natürlich auch die NIC-Bindung) und: netsh interface ipv6 set teredo disable, netsh int ipv6 isatap set state disabled, netsh int ipv6 6to4 set state disabled
- net config server /autodisconnect:-1
- netsh interface tcp set global autotuning=disabled
- WINS Server-Eintrag entfernt
- Lanmanworkstation-KeepConn Key auf 65535 in der Registry
- alle Netzlaufwerke getrennt

Am Server:
- SP1 installiert (läuft mit und ohne nicht)
- net config server /autodisconnect:-1
- LanmanServer\Parameters] "autodisconnect"=dword:ffffffff in Registry
- \Tcpip\Parameters "KeepAliveTime"=dword:900000 (15 Minuten) Problem mit den Standard 2h aber auch schon vorhanden
- neue Freigaben, Server Neustart
- Server NIC WINS auf eigenen WINS Server gelegt

Da die Windows 7 Clients einmal ein AIO-PC mit Intel Wlan und einmal ein Desktop mit Realtek LAN sind, schließe ich ein Treiber oder Hardware Problem aus. Der Wlan AP dürfte auch ausscheiden, da auch über LAN Probleme bestehen (PC und Server hängen am gleichen Switch). Switch schließe ich auch aus, da die XP Clients an dem wunderbar laufen.

Hab mal einen Nachmittag mit mehreren Abbrüchen den MS Network Monitor laufen lassen. Das einzige, was da an Fehlern häufiger kommt:

System SERVER BACKOFFICE SMB2 SMB2:R - NT Status: System - Error, Code = (52) STATUS_OBJECT_NAME_NOT_FOUND IOCTL (0xb) {NbtSS:3727, TCP:3726, IPv4:46}

System SERVER BACKOFFICE SMB2 SMB2:R - NT Status: System - Error, Code = (296) STATUS_FILE_CLOSED QUERY INFORMATION (0x10) {NbtSS:3727, TCP:3726, IPv4:46}

System SERVER BACKOFFICE TCP TCP:[ReTransmit #91646]Flags=...AP..., SrcPort=NETBIOS Session Service(139), DstPort=49279, PayloadLen=152, Seq=1153131668 - 1153131820, Ack=2435070608, Win=63680 {TCP:3728, IPv4:46}

System SERVER BACKOFFICE SMB2 SMB2:R - NT Status: System - Error, Code = (288) STATUS_CANCELLED CHANGE NOTIFY (0xf) , File=NULL@#91729 {SMB2:3735, NbtSS:3727, TCP:3726, IPv4:46}

SERVER BACKOFFICE ICMP ICMP:Destination Unreachable Message, Port Unreachable, 192.168.100.2:137 {IPv4:46}

System BACKOFFICE SERVER SMB2 SMB2:C TREE DISCONNECT (0x4), TID=0xd {NbtSS:3429, TCP:3428, IPv4:46}

System SERVER BACKOFFICE SMB2 SMB2:R TREE DISCONNECT (0x4) {NbtSS:3429, TCP:3428, IPv4:46}


Bin aber kein Guru im Lesen von solchen Frames...kann gerne das Capture auch noch zur Verfügung stellen.


Die Abbrüche treten unregelmäßig auf. Mal ein paar Stunden ohne Probleme (meistens, wenn an den PCs gearbeitet wird, und Daten transferiert werden), dann wieder alle paar Minuten Abbrüche.


Bitte um Hilfe und werde gerne Tipps testen und das Ergebnis für andere hier reinschreiben!

Vielen Dank!

Gregor
Mitglied: eisenkarl
26.08.2013 um 09:50 Uhr
Könnte ein DNS Problem sein, zur Not evtl mal die hosts Datei anpassen, zudem würde ich Antivirensoftware mal checken...
Bitte warten ..
Mitglied: heilgecht
26.08.2013 um 11:02 Uhr
Hallo,

läuft die Uhr auf Server synchron mit Clients?

MfG.
Bitte warten ..
Mitglied: Warromat
26.08.2013, aktualisiert um 22:44 Uhr
Hallo eisenkart und heilgecht!

Vielen Dank für die Hilfestellung!

Fester Eintrag in der hosts "192.168.100.2 server" ohne Erfolg.
DNS kann ich aber auch eigentlich ausschließen, da die direkte IP als Adresse dem gleichen Fehler unterliegt.

Antivirensoftware auch komplett deaktiviert und Neustart von Windows ohne Erfolg.
Kann ich auch ausschließen, da ich bereits Windows 7 an dem Wlan Gerät neu aufgesetzt habe und der Fehler auch ohne Schutzsoftware kommt.

Habe Testweise heute ein Netzlaufwerk eingerichtet. Da kam direkt nach dem Neustart des WIndows 7 LAN PCs:

"Fehler bei der erneuten Verbindungsherstellung von F: mit
\\SERVER
Microsoft Windows Network: Der lokale Gerätename wird bereits verwendet.

Die Verbindung wurde nicht wiederhergestellt."

Der lokale Gerätename des PCs ist Backoffice...diesen gibt es nur 1x in LAN. Der Zugriff auf das Netzlaufwerk war erst nach ca. 1 Min wieder möglich.
Zugriff per \\Server ging, aufruf der Ordnerstruktur hat aber sehr lange gedauert...

Wieso beseitigt ein einfacher PING alle paar Sekunden das Problem? Das muss doch irgendein versteckter Timeout oder eine Energyspareinstellung sein, die sich vor mir versteckt...

Mfg Gregor

Edit:

Habe bei den Windows 7 LAN PC auf den DNS Server auf dem Windows Server umgestellt und diesen vorher fürs interne Netz und Internet eingerichtet.
Leider wieder nach ner Stunde oder so ist der Kontakt zur Datenbank abgebrochen und das Programm abgestürzt.
Bitte warten ..
Mitglied: Warromat
27.08.2013 um 13:34 Uhr
Edit2: Zeit syncen sich alle Maschinen übers Inet mit dem MS Server.
Bitte warten ..
Mitglied: Jocki278
16.10.2013 um 11:25 Uhr
Hallo!

Hast die Energyspareinstellungne der Netzwerkkarten am Client überprüft?

lg

jocki
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Tools
gelöst Aussendienst Datensynchronisierung (12)

Frage von lighningcrow zum Thema Windows Tools ...

Windows Server
Suche passender Treiber (12)

Frage von stolli zum Thema Windows Server ...

Peripheriegeräte
Wlan stört Funkmaus (11)

Frage von Falaffel zum Thema Peripheriegeräte ...

Peripheriegeräte
gelöst USB Festplatte verliert Laufwerksbuchstabe (9)

Frage von cese4321 zum Thema Peripheriegeräte ...