Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 7 Sysprep Treiber einbinden

Frage Microsoft Windows 7

Mitglied: 108129

108129 (Level 1)

24.09.2012, aktualisiert 12:41 Uhr, 7157 Aufrufe, 1 Kommentar

Hallo,

ich habe leider erneut ein Problem mit dem Sysprep bei Windows 7 und hoffe, mir kann jemand von euch weiterhelfen!?

Ich soll für 4 verschiedene Notebooktypen des selben Herstellers ein "Image für alle" erstellen. Laut meiner Recherche im Internet kann man in der Antwortdatei einfach einen Pfad zu einem Ordner angeben, wo die besagten Dateien der Treiber in Unterordnern abgelegt sind. Windows Setup "sucht" in diesen Unterordnern nach benötigten Treibern und fügt diese dem Driverstore hinzu. Soweit die Theorie ...

Hier der Auszug aus meiner Antwortdatei für das Sysprep:

01.
<settings pass="offlineServicing"> 
02.
        <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64"> 
03.
            <EnableLUA>false</EnableLUA> 
04.
        </component> 
05.
        <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="amd64"> 
06.
            <DriverPaths> 
07.
                <PathAndCredentials wcm:action="add" wcm:keyValue="1"> 
08.
                    <Path>C:\Drivers</Path> 
09.
                </PathAndCredentials> 
10.
            </DriverPaths> 
11.
        </component> 
12.
</settings>
Doch leider fehlen den Notebooks viele Treiber nach Beendidung der Systemvorbereitung. Im Gerätemanager ist ersichtlich, dass sogar Treiber für Systemgeräte wie Ethernet-Controller oder Chipsatz fehlen, obwohl diese im lokalen Ordner abgelegt wären.

Könnte es sein, dass die Treiber im Sektor "offlineServicing" schlichtweg zu diesem Zeitpunkt überhaupt nicht mehr berücksichtigt werden? Man kann Treiber auch im Sektor "Audit" einbinden, doch diesen verwende ich bei Sysprep überhaupt nicht.

Soll ich mir einen anderen Weg überlegen, wie z.B.: die Einbindung der Treiber über DISM im Offline-Image?

Danke für eure Hilfe im Voraus!

Gruß Markus
Mitglied: 108129
25.09.2012 um 15:03 Uhr
Da mir leider keiner auf die Schnelle weiterhelfen konnte, recherchierte ich einige Stunden im Internet und führte auch etliche Tests durch, um zu folgender Erkenntnis zu kommen:

Der Sektor "offlineServicing" in der Antwortdatei behandelt nur Vorgänge, die im Offline-Image durchgeführt werden, d.h.: dieser Sektor ist zu diesem Zeitpunkt bereits überschritten und kommt gar nicht erst zur Anwendung.
Der Sektor "auditSystem" für den Überwachungsmodus wird nur angewandt, wenn man Sysprep mit dem Parameter /audit ausführt, welchen ich aber nicht verwenden kann, da ich die Out-of-Box-Experience /oobe benötige.
Demnach gibt es in meinem Fall mittels Antwordatei keine Möglichtkeit, so Treiber einzubinden.

Und hier ein kleiner Workaround, den ich im WWW gefunden habe:

http://community.spiceworks.com/how_to/show/2818

Meine Tests verliefen erfolgreich, Danke hierfür dem Verfasser des Artikels.
Bitte warten ..
Ähnliche Inhalte
Windows Installation
gelöst Surface Pro 4 Windows 10 Sysprep (6)

Frage von Belloci zum Thema Windows Installation ...

Windows 7
Windows 7 Sysprep - neue SID generieren (5)

Frage von xenon2008 zum Thema Windows 7 ...

Neue Wissensbeiträge
Heiß diskutierte Inhalte
Windows Systemdateien
NTFS und die Defragmentierung (23)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

LAN, WAN, Wireless
Zwei Subnetze mit je eigenem Router und Internetzugang verbinden (17)

Frage von hannsgmaulwurf zum Thema LAN, WAN, Wireless ...

Windows Server
WIndows Server 2016 core auf dem Intel NUC NUC5i5RYK i5 5250U (17)

Frage von IxxZett zum Thema Windows Server ...