Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows 7 - VPN an SBS 2003 geht nicht

Frage Microsoft Windows 7

Mitglied: ctietje

ctietje (Level 1) - Jetzt verbinden

18.07.2011, aktualisiert 18.10.2012, 7156 Aufrufe, 6 Kommentare

Mein neues Notebook wird mit Windows 7 64-Bit betrieben. Ich bekomme keine Autorisierung in einer VPN-Verbindung. Andere Rechner am gleichen Server mit XP und Vista funktionieren.

Kennt jemand das Problem und hat er oder sie dafür eine Lösung?

Zur Detaillierung und Wiederholung: Die mit den Assistenten jeweils erstellten VPN-Verbindungen funktionieren bislang von allen XP- und Vista-Notebooks mit dem selben User-Login ohne Problem. Beim gleichen User auf Windows 7 erstellter VPN-Verbindung wird der Server gefunden, Benutzername und Kennwort überprüft. Das Login misslingt schließlich mit Fehler 800. Das Zertifikat, die User-Daten, die Adresse des Servers sind alle identisch und funktionieren. Die Firewall lässt GRE-Pakete durch, es funktioniert ja schließlich auch mit XP und Vista.

Was wird in Windows 7 zusammen mit SBS 2003 anders gemacht? Sind die überhaupt kompatibel?
Mitglied: aqui
18.07.2011 um 11:25 Uhr
Ja, sind sie. Win 7 erzwingt allerdings MS Chapv2 mit einem 128bit Schlüssel. Das kannst du in den Client Optionen einstellen. Wenn du die alten Clients mit normalem CHAP und 56 bit laufen lassen hast kann es natürlich ein problem geben.
Das kann man aber aus deiner sehr oberflächlichen Schilderung leider nur erraten Ein Blicks ins Ereignis Log sollte dir aber mehr Licht ins Dunkel bringen....
Ansonsten wie immer Wireshark Sniffer dazwischen und sehen was beim VPN Verbindungsaufbau schief läuft. Dann erkennt man ebenso sofort die Ursache !
Bitte warten ..
Mitglied: Phalanx82
18.07.2011 um 13:23 Uhr
Zitat von ctietje:
Kennt jemand das Problem und hat er oder sie dafür eine Lösung?

Jepp, wahrscheinlich...

Das Login misslingt schließlich mit Fehler 800.
< Die Firewall lässt GRE-Pakete durch, es funktioniert ja schließlich auch mit XP und Vista.

Ja und vergisst Du da nicht irgendwas...? Denk mal einen Augenblick lang nach, vielleicht kommst Du
darauf...? Nein?! Ok ich sags Dir: Da fehlt Port 1723 in den Firewall Regeln für PPTP VPN Verbindungen.

Was wird in Windows 7 zusammen mit SBS 2003 anders gemacht? Sind die überhaupt kompatibel?

Siehe Kommentar von Aqui falls es trotz des Ports 1723 nicht funktionieren sollte.


Mit freundlichen Grüßen.
Bitte warten ..
Mitglied: aqui
18.07.2011, aktualisiert 18.10.2012
Zu seiner Ehrenrettung muss man aber sagen das es mit der gleichen FW Konfig und XP und Vista Clients ja sauber rennt.
Es ist also was protokollspezifisches unter Win 7. Vermutlich also die Verschlüsselung oder er hat wie immer den Modus auf "Auto" stehen statt auf "PPTP" zu klicken !
http://www.administrator.de/wissen/vpns-einrichten-mit-pptp-117700.html ...
Bitte warten ..
Mitglied: ctietje
18.07.2011 um 16:55 Uhr
Meine Frage ist, ob jemand eine Lösung weiß? Allgemeine Antworten (Theoretiker: Ich weiß wie es gehen müsste! Nur leider geht es so nicht!) helfen nicht weiter. Hat es schon jemand mit Windows 7 erfolgreich gemacht; wenn ja wie eingestellt (Praktiker: Ich weiß zwar nicht warum, aber es geht ...)? Der Link zu Anleitung zeigt es auch nicht mit Win7, wenn ich genau genug geschaut habe.
Nachzudenken brauchte ich nicht lange, da VPN seit Jahren über den freigeschalteten Port 1723 läuft, aber eben erfolgreiche VPN-Verbindungen nur von XP und Vista aus, allerdings bislang nicht am ersten und bislang einzigen Windows-7-Notebook. GRE und Port 1723 werden also weitergeleitet, funktionieren bei XP und Vista.

Wenn es an Verschlüsselung und/oder Zertifikat liegt, wie stellt man das ein? Im Assistenten von Windows 7 habe ich schon alles naheliegende probiert, natürlich auch Automatische/PPTP/L2TP.
Bitte warten ..
Mitglied: aqui
19.07.2011 um 11:27 Uhr
Die Screenshots sind bei Win 7 PPTP Client bzw. seinen Settings absolut identisch zu denen von XP in sofern ist die Bemerkung obsolet oder du hast noch gar nicht in diese Settings gesehen
Auch bei Win 7 stellst du im Reiter "Sicherheit" dort die Datenverschlüsselung und die Protokollvarianten ein. Mit an Sicherheit grenzender Wahrscheinlichkeit hast du genau dort die Diskrepanz zw. XP/Vista und Win7. Automatisch ist de facto falsch, denn es muss dediziert auf PPTP stehen, da du ja PPTP verwendest !
Fakt ist das es auch mit Win 7 absolut problemlos klappt...egal welchen PPTP Server man verwendet !
Bitte warten ..
Mitglied: ctietje
20.07.2011 um 18:05 Uhr
Die Firewall auf dem Notebook war's, anscheinend für das Protokoll zurück nach Anmeldung auf dem Server! Ich hatte zwar GRE schon freigeschaltet. Ich musste aber eine zusätzliche eigene Regel aufstellen, die alle IP-Adressen für GRE freischaltet, nicht nur die internen aus unserem Netz?

geprüft: Es lag definitiv an der Firewall des Notebooks, das sich einwählen wollte. Auf dem Router war GRE schon seit Jahren durchgeleitet. Das allein hat mit XP und Vista gereicht, obwohl die beide auch die gleiche F-Secure-Firewall hatten. Auf dem Notebook mit Windows 7/64 Bit habe ich eine neue Version von F-Secure installiert. Dort war als Standardregeln auch schon GRE zugelassen, aber nur wie früher für alle IPs aus dem eigenen Netz. Neuerdings musste ich GRE für alle IP-Adressen freischalten, dann ging's.
Bitte warten ..
Neuester Wissensbeitrag
Internet

Unbemerkt - Telekom Netzumschaltung! - BNG - Broadband Network Gateway

(3)

Erfahrungsbericht von ashnod zum Thema Internet ...

Ähnliche Inhalte
Exchange Server
gelöst Neue email auf sbs 2011 geht nur mit internen emailabsendern (6)

Frage von jensgebken zum Thema Exchange Server ...

Windows Server
gelöst Serverumzug SBS 2003 nach 2012R2 ohne Active Directory (2)

Frage von step777 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Switche und Hubs
Trunk für 2xCisco Switch. Wo liegt der Fehler? (17)

Frage von JayyyH zum Thema Switche und Hubs ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...

DSL, VDSL
DSL-Signal bewerten (14)

Frage von SarekHL zum Thema DSL, VDSL ...