Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Deployment: unattend.xml stoppt bei Disk partitionierung

Frage Microsoft Windows Installation

Mitglied: SIPSIP

SIPSIP (Level 1) - Jetzt verbinden

18.02.2015 um 13:37 Uhr, 704 Aufrufe, 5 Kommentare

Hallo zusammen, ich mal wieder ^^

Ich automatisiere die Installation von Windows Server Essentials 2012 R2 mit einem unattend.xml, was leider nur mit einer Partition klappt und hier benötige ich Hilfe...
Selbstverständlich habe ich meine Konfiguration schon mit etlichen aus diversen Foren verglichen, jedoch nicht herausgefunden woran es liegt.
Hier meine Disk Konfiguration:
01.
<DiskConfiguration> 
02.
                <WillShowUI>OnError</WillShowUI> 
03.
                <Disk wcm:action="add"> 
04.
                    <CreatePartitions> 
05.
                        <CreatePartition wcm:action="add"> 
06.
                            <Order>1</Order> 
07.
                            <Size>350</Size> 
08.
                            <Type>Primary</Type> 
09.
                        </CreatePartition> 
10.
                        <CreatePartition wcm:action="add"> 
11.
                            <Order>2</Order> 
12.
                            <Type>Primary</Type> 
13.
                            <Size>100000</Size> 
14.
                            <Extend>true</Extend> 
15.
                        </CreatePartition> 
16.
                    </CreatePartitions> 
17.
                    <ModifyPartitions> 
18.
                        <ModifyPartition wcm:action="add"> 
19.
                            <Active>true</Active> 
20.
                            <Format>NTFS</Format> 
21.
                            <Label>boot</Label> 
22.
                            <Order>1</Order> 
23.
                            <PartitionID>1</PartitionID> 
24.
                        </ModifyPartition> 
25.
                        <ModifyPartition wcm:action="add"> 
26.
                            <Order>2</Order> 
27.
                            <PartitionID>2</PartitionID> 
28.
                            <Label>system</Label> 
29.
                            <Format>NTFS</Format> 
30.
                        </ModifyPartition> 
31.
                    </ModifyPartitions> 
32.
                    <DiskID>0</DiskID> 
33.
                    <WillWipeDisk>true</WillWipeDisk> 
34.
                </Disk> 
35.
                <Disk wcm:action="add"> 
36.
                    <CreatePartitions> 
37.
                        <CreatePartition wcm:action="add"> 
38.
                            <Order>1</Order> 
39.
                            <Size>100000</Size> 
40.
                            <Type>Primary</Type> 
41.
                        </CreatePartition> 
42.
                    </CreatePartitions> 
43.
                    <ModifyPartitions> 
44.
                        <ModifyPartition wcm:action="add"> 
45.
                            <Active>true</Active> 
46.
                            <Extend>true</Extend> 
47.
                            <Format>NTFS</Format> 
48.
                            <Letter>E</Letter> 
49.
                            <Order>1</Order> 
50.
                            <PartitionID>1</PartitionID> 
51.
                        </ModifyPartition> 
52.
                    </ModifyPartitions> 
53.
                    <DiskID>1</DiskID> 
54.
                    <WillWipeDisk>true</WillWipeDisk> 
55.
                </Disk> 
56.
            </DiskConfiguration>
Wenn ich nur eine Partition z.B. 100GB definiere läuft die Installation problemlos durch...
Festplatten sind beide 500GB (2x Raid 1)

Danke und Grüsse
Mitglied: Dani
18.02.2015 um 15:22 Uhr
Hallo,
und was ist dein Ziel?


Gruß,
Dani
Bitte warten ..
Mitglied: SIPSIP
18.02.2015, aktualisiert um 15:49 Uhr
Hallo Dani

- auf der ersten Festplatte C:100GB und D: Rest
- auf der zweiten eine Partition also 500GB

Ich hab auch schon versucht ob es mit der Windows System Partition von 350MB klappt, jedoch hat sich nichts geändert. Weiss aber auch nicht ob ich irgendwo angeben muss das dies die reservierte Windows Partition sein soll.
<InstallTo> hab ich dabei entsprechend angepasst

Grüsse
Bitte warten ..
Mitglied: Dani
19.02.2015 um 22:42 Uhr
Guten Abend @SIPSIP,
mit Hilfe dieses Blogartikel solltest du deine zwei Wünsche (den ersten auf jeden Fall) hinbekommen.

Wichtig ist, dass du herausfindest, welche Festplatte welche Disk ID hat. Dazu könntest du eine Windows DVD booten und bei der Partitionierungsübersicht sieht man es.


Gruß
Dani
Bitte warten ..
Mitglied: SIPSIP
20.02.2015 um 09:05 Uhr
Okey, dank dir
Ich werde es nächste Woche nochmals versuchen.
Bitte warten ..
Mitglied: SIPSIP
20.02.2015, aktualisiert um 13:21 Uhr
Ich konnte die neue Konfiguration gerade testen, leider klappt es immer noch nicht. An der Stelle wo die Installation starten würde bleibt es einige Sekunden bei 0% und dann erscheint eine Fehlermeldung, dass Disk0 nicht gefunden werden konnte und die <DiskConfiguration> fehlerhaft sei (0x80300025).

Komisch nur das es dann mit nur einer Partition funktioniert.... Vielleicht sollte ich noch erwähnen, dass ich zuerst den RAID Treiber laden muss damit die Festplatten überhaupt angezeigt werden (was aber nun gut klappt). Hier noch die aktuelle Konfiguration, evtl sieht jemand mein Fehler:
01.
            <DiskConfiguration> 
02.
                <WillShowUI>OnError</WillShowUI> 
03.
                <Disk wcm:action="add"> 
04.
                    <CreatePartitions> 
05.
                        <CreatePartition wcm:action="add"> 
06.
                            <Order>1</Order> 
07.
                            <Size>100000</Size> 
08.
                            <Type>Primary</Type> 
09.
                        </CreatePartition> 
10.
                        <CreatePartition wcm:action="add"> 
11.
                            <Order>2</Order> 
12.
                            <Extend>true</Extend> 
13.
                            <Type>Primary</Type> 
14.
                        </CreatePartition> 
15.
                    </CreatePartitions> 
16.
                    <ModifyPartitions> 
17.
                        <ModifyPartition wcm:action="add"> 
18.
                            <Active>true</Active> 
19.
                            <Extend>false</Extend> 
20.
                            <Format>NTFS</Format> 
21.
                            <Label>System</Label> 
22.
                            <Letter>C</Letter> 
23.
                            <Order>1</Order> 
24.
                            <PartitionID>1</PartitionID> 
25.
                        </ModifyPartition> 
26.
                        <ModifyPartition wcm:action="add"> 
27.
                            <Active>true</Active> 
28.
                            <Format>NTFS</Format> 
29.
                            <Label>Daten</Label> 
30.
                            <Letter>D</Letter> 
31.
                            <Order>2</Order> 
32.
                            <PartitionID>2</PartitionID> 
33.
                        </ModifyPartition> 
34.
                    </ModifyPartitions> 
35.
                    <DiskID>0</DiskID> 
36.
                    <WillWipeDisk>true</WillWipeDisk> 
37.
                </Disk> 
38.
                <Disk wcm:action="add"> 
39.
                    <CreatePartitions> 
40.
                        <CreatePartition wcm:action="add"> 
41.
                            <Extend>true</Extend> 
42.
                            <Order>1</Order> 
43.
                            <Type>Primary</Type> 
44.
                        </CreatePartition> 
45.
                    </CreatePartitions> 
46.
                    <ModifyPartitions> 
47.
                        <ModifyPartition wcm:action="add"> 
48.
                            <Active>true</Active> 
49.
                            <Format>NTFS</Format> 
50.
                            <Label>Backup</Label> 
51.
                            <Letter>E</Letter> 
52.
                            <Order>1</Order> 
53.
                            <PartitionID>1</PartitionID> 
54.
                        </ModifyPartition> 
55.
                    </ModifyPartitions> 
56.
                    <DiskID>1</DiskID> 
57.
                    <WillWipeDisk>true</WillWipeDisk> 
58.
                </Disk> 
59.
            </DiskConfiguration> 
60.
            <ImageInstall> 
61.
                <OSImage> 
62.
                    <InstallTo> 
63.
                        <DiskID>0</DiskID> 
64.
                        <PartitionID>1</PartitionID> 
65.
                    </InstallTo> 
66.
                    <InstallToAvailablePartition>false</InstallToAvailablePartition> 
67.
                    <WillShowUI>OnError</WillShowUI> 
68.
                    <InstallFrom> 
69.
                        <MetaData wcm:action="add"> 
70.
                            <Key>/IMAGE/NAME</Key> 
71.
                            <Value>Windows Server 2012 R2 SERVERSOLUTION</Value> 
72.
                        </MetaData> 
73.
                    </InstallFrom> 
74.
                </OSImage> 
75.
            </ImageInstall> 
76.
            <UserData> 
77.
                <ProductKey> 
78.
                    <Key>11111-11111-11111-11111-1111</Key> 
79.
                    <WillShowUI>OnError</WillShowUI> 
80.
                </ProductKey> 
81.
                <AcceptEula>true</AcceptEula> 
82.
                <FullName>saadmin</FullName> 
83.
                <Organization>firmenname</Organization> 
84.
            </UserData> 
85.
            <UseConfigurationSet>true</UseConfigurationSet> 
86.
        </component> 
87.
        <component name="Microsoft-Windows-PnpCustomizationsWinPE" processorArchitecture="amd64" publicKeyToken="31bf33856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"> 
88.
            <DriverPaths> 
89.
                <PathAndCredentials wcm:action="add" wcm:keyValue="1"> 
90.
                    <Path>%configsetroot%driver\</Path> 
91.
                </PathAndCredentials> 
92.
            </DriverPaths> 
93.
        </component>
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(3)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Windows Bereitstellungsdienst und .xml-Datei erstellen (1)

Frage von 131275 zum Thema Windows Server ...

Windows Server
gelöst Windows Deployment Services (WDS): Images auf unterschiedlicher Hardware (21)

Frage von get-command zum Thema Windows Server ...

Windows Tools
Sysprep Auditmode: User anlegen via lusrmgr. VS Unattend.xml (1)

Frage von dankon7goo zum Thema Windows Tools ...

Windows Installation
Windows Deployment Services-Angepasstes Image verwenden

Frage von Source3245 zum Thema Windows Installation ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
Outlook 2010 findet ost datei nicht (18)

Frage von Floh21 zum Thema Outlook & Mail ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...