Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Explorer, Datei umbenennen, Dateiname wird automatisch markiert

Frage Internet Webbrowser

Mitglied: marc-1303

marc-1303 (Level 2) - Jetzt verbinden

19.05.2011 um 15:31 Uhr, 14619 Aufrufe, 12 Kommentare

Guten Tag

Wir haben vor 3 Wochen von SBS 2003 auf SBS 2011 migriert. Soweit läuft alles gut.

Jetzt meldet sich ein User, dass er im Windows Explorer beim Umbenennen von Dateien ein Problem hat.
Ich habe das kurz getestet, bei mir und auch bei allen anderen Usern tritt dasselbe Verhalten auf
(Clients sind XP SP3, Vista SP2 und Win7 SP1)

Wenn ich im Windows Explorer eine Datei markiere und umbenennen will (egal ob Rechtsklick umbenennen,
oder in kurzer Folge 2 x anklicken, nicht doppelklicken) ist erst mal der ganze Dateiname (mit Ausnahme der Erweiterung)
markiert. So weit so gut. Wenn ich jetzt in den Dateiname klicke um z.B. diesen nur zu ändern habe ich gerade mal 2-3 Sekunden
Zeit, bis der Dateiname automatisch wieder markiert wird. Wenn ich dann reinschreibe ist logischerweise der Dateiname überschrieben.

Ich kann mir fast nur Vorstellen, dass dieses Verhalten über die Gruppenrichtlinien vom SBS 2011 rein gekommen ist. Auf dem alten Server
hatten wir dieses Verhalten nie.

Zu sagen ist aber auch, dass die Daten seit der Migration nicht mehr auf dem Server sondern auf einem NAS liegen.
Ich kann's mir zwar nicht vorstellen, aber möglicherweise hat auch dieses irgendwie damit zu tun.

Ich habe lange gegoogelt aber nichts dazu gefunden. Vielleicht hat jemand von Euch auch schon damit gekämpft und eine Lösung gefunden.

Gruss
Marc
Mitglied: LittleFlame
19.05.2011 um 15:37 Uhr
Hallo marc_1303,

Wenn ich jetzt in den Dateiname klicke um z.B. diesen nur zu ändern habe ich gerade mal 2-3 Sekunden
Zeit, bis der Dateiname automatisch wieder markiert wird. Wenn ich dann reinschreibe ist logischerweise der Dateiname
überschrieben.

Wenn ich das richtig verstehe, klickst du also in den Dateinamen, welcher bereits für das Umbenennen markiert ist (Also komplett markiert mit anzeige des Cursors am Ende) um die Stelle auszuwählen, an der du den Dateinamen verändern willst.
Jedoch markiert sich nach 2-3 Sekunden wieder der komplette Dateiname was bei einer Eingabe ein Überschreiben des kompletten Dateinamens verursacht.

Hab ich das so richtig erfasst?


Grüße
LittleFlame
Bitte warten ..
Mitglied: marc-1303
19.05.2011 um 15:40 Uhr
Hallo LittleFlame

Ganz genau so verhält es sich. Ich hab's vermutlich etwas umständlich formuliert.
Das tönt ja fast, wie wenn Du für dieses Problem eine Lösung bereit hättest

Gruss
Marc
Bitte warten ..
Mitglied: Connor1980
19.05.2011 um 16:37 Uhr
Hallo Marc,

konnte ich eben nachstellen, aber nur bei frisch kopierten Dateien:
Outlook 2010, beliebiger Anhang einer eMail per Drag&Drop in ein Netzlaufwerk kopiert. 1. Klick auf die Datei: Dateiname ohne extension markiert, 2. Klick ans Ende zwischen letzten Buchstaben und Punkt vor der extension, dann wird sofort der Dateiname markiert. Das passiert nur einmal. Was mir hierbei auffiel: Windows sortiert die Dateien in dem Moment neu, evtl. hängt es damit zusammen?

Ist mir bisher nie aufgefallen, weil ich es grundsätzlich anders handhabe. Eine Lösung kann ich nicht anbieten.


Grüße
Bitte warten ..
Mitglied: marc-1303
19.05.2011 um 16:47 Uhr
Hallo Connor1980

Bei mir tritt es bei allen Dateien auf. Und es verschwindet auch nicht nach dem 1. Versuch.
Auch beim 2., 3. 4. usw. Versuch dasselbe Verhalten. Ich habe jeweils nur 2-3 Sekunden Zeit den Cursor am richtigen Platz zu platzieren und mit Schreiben zu beginnen.
Sobald ich dann schreibe ist's gut. Dann wird nichts mehr automatisch markiert.

Das mit der Neusortierung ist mir noch gar nicht aufgefallen.

Gruss
Marc
Bitte warten ..
Mitglied: Connor1980
19.05.2011 um 20:52 Uhr
Zitat von marc-1303:
Hallo Connor1980

Bei mir tritt es bei allen Dateien auf. Und es verschwindet auch nicht nach dem 1. Versuch.
Auch beim 2., 3. 4. usw. Versuch dasselbe Verhalten.
Das wir usn nicht missverstehen: kopiere ich die datein wieder und möchte sie auf diesem weg umbenennen, habe ich das gleiche Phänomen wieder. Es lässt sich also belibieg oft reproduzieren.
Bitte warten ..
Mitglied: Nakata
20.05.2011 um 10:14 Uhr
Kann es eventuell sein, dass das NAS (als Netzlaufwerk verbunden?) von den Rechnern aus indiziert wird ? Dann kann es sein, dass während des Umbennens der Inidzierungsdienst nachschaut ob neue Dateien vorhanden sind und somit der Name einmal abgetastet wird (intern von windows markiert). Nur ne Idee.
Bitte warten ..
Mitglied: marc-1303
24.05.2011 um 07:54 Uhr
Hallo Nakata, Hallo Alle

Sorry. Ich war ein paar Tage nicht im Büro.
Mit der Indizierung hat es vermutlich nichts zu tun. Ich hab das geprüft. Es werden nur ein paar lokale Laufwerke indiziert.

Ich vermute, dass es mit der automatischen Sortierung im Win Explorer zu tun hat. Sobald ich eine Datei umbenenne wird diese in die richtige alphabetische Reihenfolge gebracht.
Diese Sortierung findet so ca. alle 4-5 Sek. statt. Und eben in diesem Takt wird beim Umbenennen einer Datei auf der ganze Dateiname wieder vollständig markiert.
Gibt es eine Möglichkeit, diese Sortierung per Registry auszuschalten? Wenn's dann daran liegt könnte ich gut damit leben...

Gruss
Marc
Bitte warten ..
Mitglied: forum-merlin
03.06.2011 um 07:58 Uhr
Hallo an Alle!

Ich habe das gleiche Problem. So wie Ihr es alle beschrieben und bestätigt habt.
Ich benenne wirklich sehr oft und viel Files um, da ich ziemlich viele Templates erstelle.

Bei mir ist es so, dass ich ein Windows 7 64bit habe, keinen SBS in Sichtweite, aber dafür ein QNAP TS-219p NAS.

Ich kann mich wirklich täuschen, aber das Problem tritt bei mir erst seit heute auf.
Geändert habe ich auf dem WIN System wirklich nix!
Nichtmal ein WIN Update das ich irgendwie installiert hätte.
Und Automatische Updates habe ich so eingestellt, dass ich erstmal nur informiert werde.

Was ich aber geändert habe ist die Firmware auf dem NAS. Die ist seit heute ebenfalls ganz aktuell, und seit dem meine ich das Problem zu haben.

Gibt es hierzu vielleicht schon eine Lösung?
Denn um ehrlich zu sein, das NERVT schon ganz ganz heftiiiiig!!!!

Ich danke Euch schonmal

Gruß
Holger
Bitte warten ..
Mitglied: marc-1303
15.06.2011 um 07:33 Uhr
Guten Tag alle

Man soll ja den Tag nicht vor dem Abend loben. Gerade eben habe ich die neuen (in meinem Fall 21) Windows-Updates eingespielt, die Kiste neu gestartet und nachgeschaut ob das von mir beschriebene Problem noch da ist. Im Moment sieht's so aus, wie wenn das Problem mit einem der Updates eliminiert worden wäre. Aber ich werde jetzt nicht in Euphorie ausbrechen. Wenn's nach ein paar Tagen immer noch wunschgemäss funktioniert werde ich den Beitrag als gelöst markieren.

Grüsse
Marc
Bitte warten ..
Mitglied: bugmenot2
15.03.2012 um 16:24 Uhr
Hat jemand dazu eine Lösung gefunden?
Scheint so, dass niemand eine Lösung gefunden hat.
Bitte warten ..
Mitglied: marc-1303
16.03.2012 um 08:43 Uhr
Guten Tag bugmenot2

Tatsächlich hat sich das Problem bei mir (von selbst) behoben. Leider habe ich keine Ahnung wie.
Vielleicht mit einem Windows-Update, vielleicht aber auch im einem Firmware-Upgrade auf dem NAS.
Wer weiss das so genau?? Bei den Windows-Updates weiss man ja nicht so genau was man untergeschoben bekommt.
Im Changelog der NAS konnte ich keinen Hinweis auf diese Fehlerbehebung finden.

Es kann also auch jederzeit wieder auftreten.

Leider kein wirklich guter Bescheid für jene, die sich immer noch mit diesem Problem herumschlagen müssen.

Grüsse
Marc
Bitte warten ..
Mitglied: jaskolski.lewis
20.12.2015 um 12:42 Uhr
Hallo,

hat hierzu jemand schon eine Lösung gefunden, bzw. weiß woher dieses Verhalten kommt?
Ich habe das selbe Problem.

Ich habe Win7 (64Bit) und ein NAS, welches als Netzlaufwerk eingebunden ist.
Windows, als auch das NAS sind auf dem aktuellen Stand. Das Problem bestand aber schon seit dem Wechsel auf Windows 7.

Wenn ich z.B. eine Datei über die Kommandozeile des NAS umbenenne und dann innerhalb der ersten paar Sekunden über das Netzlaufwerk diese Datei erneut mit F2 umbenennen will, wird zunächst der gesamte Dateiname (ohne Erweiterung) markiert (soweit normal), aber wenn ich nun einen Teil des Dateinamens mit der Maus auswähle, springt die Markierung automatisch wieder auf den vollen Dateinamen (ohne Erweiterung) zurück.

Das nervt tierisch.
Wenn ich ein paar Sekunden nach dem ersten Umbenennen warte, passiert das nicht und es passiert auch nicht bei älteren Dateien, nur wenn die Datei oder der Dateiname neu ist.

Meine Vermutung liegt auch sehr stark an irgend einem Erkennungsdienst, der seit Windows 7 implementiert wurde.

Hat jemand noch eine Idee das abzustellen?

Danke
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(1)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Windows-Explorer funktioniert nicht mehr Windows Server 2008 R2 (4)

Frage von Zeus0815 zum Thema Windows Server ...

Batch & Shell
Windows Explorer hängt sich bei Powershell Script auf (5)

Frage von zamsi7 zum Thema Batch & Shell ...

Windows 10
gelöst Unter Windows 10 Datei,Ordner INFO Fenster (5)

Frage von It-ogut zum Thema Windows 10 ...

Windows 10
Windows 10 sperrt mein PC automatisch nach gewisser Zeit (5)

Frage von 97973 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (34)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Windows Server
Server 2008R2 startet nicht mehr (Bad Patch 0xa) (18)

Frage von Haures zum Thema Windows Server ...