Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows-Installationsprobleme bei IBM-Notebook X20

Frage Microsoft Windows Installation

Mitglied: zephyrraina

zephyrraina (Level 1) - Jetzt verbinden

03.12.2004, aktualisiert 21.12.2004, 9929 Aufrufe, 23 Kommentare

NTLDR fehlt angeblich

Hallo zusammen,

ich habe ein Notebook von IBM, Modell X20 (600 MHz, 128 MB RAM, 20 GB HDD), ohne Betriebssystem.

Aufgrund der flachen Bauweise hat das Gerät weder ein Disketten- noch ein CD-ROM-Laufwerk. Die optional erhältliche Docking-Station (Ultrabase) besitze ich leider nicht.

Die fehlenden Laufwerke gestalten die Installation von Windows XP Pro sehr schwierig. Meine diesbezüglichen Internetrecherchen führten zu folgener Vorgehensweise:

Zunächst habe ich die Festplatte in einen USB-Wechselrahmen eingebaut, zwei Partitionen mit FAT32 eigerichtet und auf die zweite Partition den CD-Inhalt von Winmdows XP kopiert. Anschließend habe ich die Festplatte in ein anderes Notebook eingebaut und dort die Installation mittels Notstartdiskette von der zweiten Festplattenpartition gestartet.

Nachdem die Dateien kopiert waren und das erste Reboot anstand, wurde der Rechner heruntergefahren und ausgeschaltet. Die Festplatte war nun bootfähig.

Es folgte der Einbau der Festplatte in das IBM-Notebook, um dort die Installation abzuschließen. Während des Bootens kam dann die Meldung: NTLDR fehlt!

Eine Kontrolle der Festplatte ergab, dass sich die angeblich fehlende NTLDR-Datei jedoch im Bootverzeichnis C:\ befand. Warum das Gerät die fehlende Datei anmahnt, ist mir daher schleierhaft.

Ich weiß nun nicht mehr, was ich noch machen kann, um das Betriebssystem auf dem Notebook zu installieren. Auch das Aufspielen eines vorhandenen XP-Festplattenimages führte zu keinem Ergebnis. Der Rechner zeigte in diesem Falle während des Bootvorganges lediglich einen blinkenden Cursor. Normalerweise müsste der Rechner doch eigentlich Hochfahren, um dann im Laufe des Bootvorganges, aufgrund der inkompatiblen Treiber irgendwann einen Bluescreen anzuzeigen.

Es wäre nett, wenn Ihr mir Tipps zur Behebung des Problems geben könntet.

Vielen Dank im voraus.
Mitglied: LarsJakubowski
03.12.2004 um 11:09 Uhr
Hallo,

na das ist ja mal schön kniffelig
Aber versuchen wir es doch mal.
Da Du ja im Besitz einer externen USB Variante bist, ist es schon was einfacher.

Bau die Platte noch einmal um. Also in den USB Ramen. Formatiere die Platte komplett.

Besorg Dir aus dem Internet irendwas DOS mäßiges. Meinet wegen auch irgendwas mit Linux, von dem Du booten kannst. Das spiellst Du auf die 1. Partition. Auf die 2. spielst Du den gesamten Inhalt der XP CD.

So weit ganz einfach.

Nun baust Du die Platte wieder in den lap ein und bootest. Jetzt sollte entweder DOS, oder was anderes was Du installiert hast, starten.

Von hier aus kannst Du nun das Setup von Windows aufrufen und XP installieren.

Nun sollte nichts mehr schief gehen können.

So würde ich es einmal versuchen.


Hoffe ich konnte DIr helfen.

Ciao Lars
Bitte warten ..
Mitglied: zephyrraina
03.12.2004 um 11:41 Uhr
Hallo Lars,

vielen Dank für Deine Antwort.

Vielleicht eine blöde Frage, aie kann ich denn ein bootfähiges DOS auf eine USB-Wechselplatte unter Windows XP aufspielen??

Danke schonmal.
Bitte warten ..
Mitglied: LarsJakubowski
03.12.2004 um 11:46 Uhr
Hi,

klar, das ist kein Problem.
Es wird ja nicht richtig installiert, sondern im Prinzip nur auf die Platte gelegt. So ist es z. B. mit Kaldera DOS.
Das wird von Symantec für Ghost eingesetzt.

Musst Du halt nur noch organiseren.

Ciao Lars
Bitte warten ..
Mitglied: zephyrraina
03.12.2004 um 12:02 Uhr
Hy,

kann ich z.B. den Inhalt einer Notstartdiskette von Windows ME auf die Platte kopieren und das Gerät bootet dann direkt von der Platte. Wird denn auf der Platte kein Master Boot Record benötigt, damit der Bootvorgang beginnen kann?

Fragen über Fragen... Hoffentlich nerve ich Dich nicht!

Beim raus- und reinstöpseln der Festplatten in meinen funktionierenden Notebook habe ich mir gestern dann auch nochmal eben nebenbei den Festplattenconnector zerstört - jetzt läuft dieses Notebook auch nicht mehr (aber das ist wieder ein anderes Thema)...

Danke.
Bitte warten ..
Mitglied: LarsJakubowski
03.12.2004 um 12:09 Uhr
Hi,

natürlich nervst Du nicht. Hier nervt niemand, der Fragen oder Probleme hat.
Jeder fängt mal klein an. Niemand wird mit dem Wissen geboren.

Wer Fragen hat und sind sie noch so einfach, der soll sie stellen.

"Es gibt keine blöden Fragen, sondern nur blöde Antworten" Zitat meiner Oma!

ALso nun zu dem Problem.

Einen MBR (Master Boot Record) ist ja auf der Platte drauf. Den zertört man sich nicht so. Es sei denn, Du machst ein Low Level Format.
Aber davon gehe ich mal nicht aus. Du hast mit Sicherheit nur Format C:\ eingegeben. Dann ist er enthalten.

Also mach dir um den MBR mal keine Gedanken.

Klar kannst Du die Diskette kopieren und dann von der aus weiter arbeiten. Die Idee ist gut.

Erinnere mich daran, das selber früher viel gemacht zu haben.

Das läuft also auch. Dabei wird ja auch nichts installiert, sondern die Programme werden ja in den RAM geladen.

Versuch mal. Das läuft mit Sicherheit.

Ciao Lars
Bitte warten ..
Mitglied: zephyrraina
03.12.2004 um 19:16 Uhr
Hy,

ich krich die Frengeln...

Das Diskettenlaufwerk meines PC ist offenbar defekt und ich komme an die Dateien auf der Notstart-Diskette nicht ran.

Mein bislang funktionierendes zweites Notebook hat gleichfalls den Dienst quittiert, so dass ich das dortige Diskettenlaufwerk nicht nutzen kann.

Die bootmec.exe (Bootdisk Windows ME) verlangt beim Entpacken aber immer ein funktionierendes Diskettenlaufwerk - ich werde hier bald wahnsinnich - das kann alles nicht mehr wahr sein, das träume ich nur...

Weiß einer, wie ich den Pfad A: in der bootmec.exe beeinflussen kann, so dass ich die Dateien direkt auf der Festplatte entpacken kann?

Danke schonmal...
Bitte warten ..
Mitglied: zephyrraina
03.12.2004 um 20:29 Uhr
Hallo Lars,

ich habe jetzt den Inhalt einer MS-DOS-6.22-Startdiskette auf die Platte gepackt und den Inhalt der Dateien "autoexec.bat" und "config.sys" auf C: angepasst. Es erscheint nach dem Booten folgende Meldung:

Datenträger entfernen
Neustart: Taste drücken

Da Festplatte C: der einige Datenträger im System ist, wird ein Enfernen nicht viel bringen...

Haste noch eine Idee, bevor ich das Notebook aus dem Fenster schmeiße und ich mich auf dem Boden erhänge?

Gruß
Bitte warten ..
Mitglied: LarsJakubowski
03.12.2004 um 20:32 Uhr
Ja, da gibts einen Trick.
Wird die Autoxec.bat denn ausgeführt, oder nicht? Ich meine bevor die Meldung kommt?

Lars
Bitte warten ..
Mitglied: zephyrraina
03.12.2004 um 20:39 Uhr
Nein, es passiert im Prinzip garnix. Speicher wird hochgezählt und das ganze Pipapo, und dann erscheint nach einigen Sekunden die besagte Meldung auf dem Display...

Ich hab mir über Emule nochmal eine andere Bootdisk gezogen namens: Win-Boot Disk For All Windows 95-98-Me-Nt-w2K-Xp Home-Xp Pro. Die kann ich auch nochmal ausprobieren...

Aber lass mal Deinen Vorschlag hören...
Bitte warten ..
Mitglied: LarsJakubowski
03.12.2004 um 20:47 Uhr
Wenn die Autoxec nicht ausgeführt wird, dann stimmt da was nicht.
Das Dateisystem ist auf FAT oder FAT32?

Entweder hast Du einen Fehler in der Config.sys oder autoxec.bat.


Gib mal den Begriff Bootdiskette download ein.

Da gibts ein paar gute Ansätze.

Ich erinnere mich auch nicht mehr genau an den Trick. Aber ich überlege
Bitte warten ..
Mitglied: zephyrraina
03.12.2004 um 20:54 Uhr
Also,

Dateisystem ist FAT32, da ich unter Win XP (im USB-Wechselrahmen) nur unter FAT32 oder NTFS auswählen kann.

Hier nun die Inhalte von autoexec.bat und config.sys (angepasst):

autoexec.bat

@ECHO OFF
C:\MSDOS622\SMARTDRV.EXE /X
PROMPT $p$g
PATH C:\MSDOS622
MODE CON CODEPAGE PREPARE=((850) C:\MSDOS622\EGA.CPI)
MODE CON CODEPAGE SELECT=850
KEYB BE,,C:\MSDOS622\KEYBOARD.SYS

config.sys

LASTDRIVE=Z
DEVICE=C:\MSDOS622\SETVER.EXE
DEVICE=C:\MSDOS622\HIMEM.SYS
DOS=HIGH
COUNTRY=032,,C:\MSDOS622\COUNTRY.SYS
DEVICE=C:\MSDOS622\DISPLAY.SYS CON=(EGA,,1)
FILES=30

Die besagten Ordner befinden sich gleichfalls auf der Platte.

Gruß

RAINER
Bitte warten ..
Mitglied: zephyrraina
03.12.2004 um 20:58 Uhr
Hy,

habe auch hier schonmal geschaut, ist aber etwas unübersichtlich: http://www-1.ibm.com/cgi-bin/pc/support/supportR5lite/pagegen/qtechinfo ...

Gruß
Bitte warten ..
Mitglied: zephyrraina
11.12.2004 um 18:30 Uhr
So,

ich habe gestern eine Docking-Station bekommen, in der ein Diskettenlaufwerk eingebaut ist.

Zuvor habe ich die Notebookplatte im USB-Wechselrahmen mit FAT32 ohne Quick-Format (habe ich bislang immer ausgewählt) formatiert und wieder in das Notebook eingebaut. Die Folge war, dass ich nach dem Bootvorgang von der DOS-Notstartdiskette keinen Zugriff auf C: hatte.

Also wieder von vorne: mit fdisk Partition gelöscht und neue Partition angelegt. Danach format C:.

Dann testweise eine Datei von A: nach C: kopiert und geschaut, ob ich die Datei auf C: finde (dir-Befehl) - klappte.

Platte wieder in USB-Wechselrahmen eingebaut und den Inhalt der Windows XP-CD auf C: kopiert, in Notebook eingebaut und mit Notstartdiskette gebootet.

Nach erstem Neustart bootet das Gerät jetzt wahrhaftig von der Platte - ich bin ja mal gespannt, wie es weitergeht und werde Bericht erstatten.

Auf diesem Weg erstmal vielen Dank für Eure Hilfe.

Gruß

zephyrraina
Bitte warten ..
Mitglied: mjvdl
11.12.2004 um 20:12 Uhr
Hi,
ich sitze seit exakt drei Tagen genau an dem selben Problem. Habe auch einen gebrauchten X20 gekauft (Ebay) und versuche verzweifelt W2k zu installieren.

Ich habe mittlerweile die Vermutung, dass das Bios keine C-Partitionen größer 4096 MB verträgt...
Jetzt habe ich eine kleinere C-Partition angelegt und diese mit W98 Startdateien bootbar gemacht.
Auf D befinden sich die W2k files und gerade habe ich zum x-ten Mal die Installation gestartet....

Ich halte Dich auf dem Laufenden. Wenn Du erfolgreich warst, dann sag bitte kurz Bescheid. "mail.jvdl at gmx.de" Oder wir telephonieren mal...

Gruss
Jürgen
Bitte warten ..
Mitglied: zephyrraina
11.12.2004 um 21:21 Uhr
Hast Du an dem gerät eine Docking-Station bzw. ein Diskettenlaufwerk oder ein CD-ROM-Laufwerk?
Bitte warten ..
Mitglied: mjvdl
13.12.2004 um 14:55 Uhr
Nein, habe leider keine Dockingstation, ich bekomme morgen aber eine geliehen, mal sehen wie es dann weitergeht. Interessanterweise habe ich drei Festplatten, die in anderen laptops zumindest booten (W2k, WXP und ME) in diesem X20 nicht dazu gebracht zu booten. Selbst ein Bios update hat nicht geholfen...
Bitte warten ..
Mitglied: zephyrraina
13.12.2004 um 15:28 Uhr
Hi,

also, bei mir läuft jetzt alles. Habe die folgende Installation jetzt mit zwei verschiedenen Festplatten, ohne BIOS-Update, durchgeführt:

Mit einer Windows ME-Notstartdiskette gebootet. Fdisk aufgerufen und die bestehenden Partitionen auf C: gelöscht. Neue primäre Partition angelegt und diese aktiv gemacht (alles mit Fdisk!).

Erneut von Notstartdiskette gebootet und die Platte formatiert. Dann Umbau der Platte in USB-Wechselrahmen und den Inhalt der Windows XP-CD auf die Notebookplatte kopiert. Wieder Umbau in das Notebook.

Nochmals von Notstartdiskette gebootet, Smartdrv ausgeführt (sonst wartet man sich zu Tode!). In C:\i386 gewechselt und dort die Datei winnt.exe aufgerufen - die Installation beginnt.

Nach dem Kopiervorgang kommt die Meldung "Dieser Teil der MS-DOS basierten... Entfernen Sie die Diskette aus dem Laufwerk und drücken Sie ENTER."

Nun bootet das Notebook von Festplatte und man kann die Installation abschließen. Bei mir wurden alle Komponenten automatisch erkannt und die Treiberdateien installiert. Die Bildschirmauflösung war nach Abschluss der Installation 1.024 x 768. Anschließend SP2, Antivirus und den ganzen Schmockes drauf - fettich.

Ohne ein Disketten- bzw. CD-ROM-Laufwerk geht da wahrscheinlich nix. Wichtig ist, die Partitionierung und Formatierung der Platte im Notebook durchzuführen. Ich habe diese Tätigkeiten zunächst im USB-Wechselrahmen vorgenommen und konnte dann das Notebook aber nicht von der Platte booten. Verschiedentlich kam auch die Meldung: "NTLDR fehlt", was aber nicht stimmte.

Viel Spass und sag mal Bescheid, ob's läuft.

Gruß

zephyrraina
Bitte warten ..
Mitglied: mjvdl
14.12.2004 um 13:32 Uhr
Hi,
ich habe die Installation jetzt genauso durchgeführt, wie Du es beschrieben hast und es funktioniert. Ich habe bisher die Festplatte im USB Rahmen formatiert, genau wie Du. ich denke daran lag es.

Jetzt freue ich mich aber über ein wirklich cooles Notebook.

Danke und machs gut.
Jürgen
Bitte warten ..
Mitglied: ProTest
16.12.2004 um 16:35 Uhr
Seit 2000 wird gemeckert ... wenn das System "bewegt" wird.

Ich würde mich nach nem Externen Laufwerk (USB, Parallelport) umsehn ...
Bitte warten ..
Mitglied: zephyrraina
16.12.2004 um 16:59 Uhr
Hi Jürgen,

sag mal, funktioniert bei Dir das Mikrofon (sowohl das eingebaute als auch ein externes) auch nicht?

In der Systemsteuerung unter "Sounds und Audiogeräte", "Audio", "Soundaufnahme" steht bei mir "Keine Aufnahmegeräte" und alles ist dort abgeblendet. Ich habe mir schon den Wolf gefummelt, bekomme dieses Problem jedoch nicht in den Griff.

Gruß

zephyrraina
Bitte warten ..
Mitglied: zephyrraina
16.12.2004 um 17:03 Uhr
Hi ProTest,

ehrlich gesagt, habe ich Deine Anmerkung nicht verstanden - was meinst Du?
Bitte warten ..
Mitglied: mjvdl
17.12.2004 um 21:44 Uhr
Das mit dem Micro habe ich noch nicht ausprobiert, sorry. Werde das mal am Woe tun. Was mich wundert, dass ich zwar einen Netzwerkanschluss sehen kann, aber wohl keine NIC installiert/aktiviert ist. Hatte das X20 standardmäßig keine NIC, oder ist nur mein spezielles Model gehandicapt?

Ciao
Jürgen
Bitte warten ..
Mitglied: zephyrraina
21.12.2004 um 12:11 Uhr
Hi Jürgen,

also, in meinem Gerät ist eine 10/100 MBit-Netzwerkkarte eingebaut, die auch erkannt wurde und einwandfrei funktioniert. Ich kann Dir auch mal ein diesbezügliches Bild zumailen. Schau doch mal im BIOS nach, ob Du die Karte dort erst aktivieren musst, oder befindet sich auf der Rückseite des Gerätes gar kein Anschluss?

Mein Mikroproblem ist zwar nicht gelöst, das tut der Sache aber keinen Abbruch; das Gerät ist trotzdem spitze.

Gruß und ein schönes Weihnachtsfest wünscht

zephyrraina
Bitte warten ..
Neuester Wissensbeitrag
Batch & Shell

Batch Script Editor - Programmvorstellung des Entwicklers

(6)

Tipp von wowItsDoge zum Thema Batch & Shell ...

Ähnliche Inhalte
Windows Netzwerk
gelöst Statischer DNS-Server wird nach Sekunden automatisch gelöscht (Windows 10) (8)

Frage von walterwhite zum Thema Windows Netzwerk ...

Windows Server
Windows 2012 R2 RemoteFX auf Windows 10 Pro (4)

Frage von onkel87 zum Thema Windows Server ...

Windows Server
Windows Server - Grundlegende Fragen (18)

Frage von Dragan123 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Festplatten, SSD, Raid
Suche richtig schlechte SSD und HDD (32)

Frage von Hyperion69 zum Thema Festplatten, SSD, Raid ...

Windows Server
Windows Server - Grundlegende Fragen (18)

Frage von Dragan123 zum Thema Windows Server ...

Batch & Shell
gelöst PowerShell Transpose Objects und Memoryleak (11)

Frage von agowa338 zum Thema Batch & Shell ...

Windows Netzwerk
gelöst Statischer DNS-Server wird nach Sekunden automatisch gelöscht (Windows 10) (8)

Frage von walterwhite zum Thema Windows Netzwerk ...