Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows SBS 2003 Server lässt POST nicht zu

Frage Microsoft Windows Server

Mitglied: alijoschi

alijoschi (Level 1) - Jetzt verbinden

16.12.2010 um 09:24 Uhr, 2944 Aufrufe, 10 Kommentare

Hi Leute! Ich bin neu hier im Forum und hab sofort eine kniffliges Problem für euch.

Ich habe ein VB Prog. geschrieben mit dem ich über inet.execute versuche ein POST mit XML abzusetzen. Sobald ich das gemacht habe warte ich auf eine Antwort vom Server. Habe das schon auf ca. 100 Clients installiert immer ohne Problem. Jetzt wollte ich das ganze auf einen SBS 2003 Server installieren. Soweit so gut. Wenn ich nun auf dem SBS das INET.EXECUTE ausführen bekomme ich aber keine Antwort vom Zielserver. Hab schon mit dem Admin von dem Server gesprochen und er meinte das von Ihm aus alles funktionieren sollte. Leider ist dem nicht so. Wenn ich das LOG am Zielserver ansehe kommt da leider nichts an. Kein LOGIN garnichts. Vielleicht sind hier fähige Leute die mir vielleicht eine Tipp geben können. Würd mich riesig darüber freun.

Mit freundlichen Grüßen alijoschi
Mitglied: maretz
16.12.2010 um 09:30 Uhr
Moin,

die Win-Server haben normalerweise die Internet-Sicherheit aktiviert (öffne mal den IE dort und versuche auf irgendeine Seite zu gehen -> sollte ne Warnung kommen das du eben das sichere Browsen oder so erst deaktivieren musst).

Die alternative: Gibt es ggf. nen Zwangsproxy der noch eingetragen werden muss? Kannst du auf dem Server überhaupt ins Internet (ab und an stehen die ja in nem sonderbereich der eben KEINEN internetzugriff erlaubt...)
Bitte warten ..
Mitglied: alijoschi
16.12.2010 um 10:34 Uhr
Hallo!

Herzlichen dank für deine rasche Antwort. Mit dem Server kann ich ganz normal im Internet surfen. Der Server selbst ist über eine Öffentliche IP erreichbar. Zur erklärung: Mehrer Benutzer verbinden sich per Remote auf den Server und haben dann abhängig von Benutzer und Passwort ihren eigenen Desktop. (Terminalserver) Ich glaube das Problem liegt daran das die aufgelöste IP von Zielserver auf den Localhost umgeleitet wird und ich deshalb nicht hinauskomme. Habe von versucht mit TCPVIEW mitzusehen was genau passiert. Da ich aber sehr sehr selten mit solchen sachen zu tun habe weiß ich keinen rat mehr.

Mit freundlichen Grüßen
Bitte warten ..
Mitglied: maretz
16.12.2010 um 10:47 Uhr
kannst du denn auch nen proxy ausschließen der dazwischen hängt?
Bitte warten ..
Mitglied: alijoschi
16.12.2010 um 11:09 Uhr
Nein leider nicht aber wie könnte ich das kontrollieren ob da ein Proxy dazwischen ist?
Bitte warten ..
Mitglied: maretz
16.12.2010 um 11:18 Uhr
z.B. mal im IE gucken ob da nen Proxy eingetragen ist (oder welchen browser die auch immer nutzen)
Bitte warten ..
Mitglied: alijoschi
16.12.2010 um 12:08 Uhr
Im Internetexplorer ist kein Proxy eingetragen. Also gehe davon aus das Ohne Proxy gearbeitet wird.
Bitte warten ..
Mitglied: maretz
16.12.2010 um 12:29 Uhr
gut - dann sind wir einen schritt weiter. Arbeitest du auf normalen Ports (d.h. Port 80 für HTTP) oder blockt da ggf. eine Firewall was raus? Ist ggf. in der Firewall ne einstellung das du zu große Post-Requests nicht absetzen darfst?

Kannst du den Ziel-Server anpingen und bekommst auch die richtige IP zurück?

Was meinst du mit "umgeleitet werden" - steht ggf. in der lmhosts nen Eintrag drin der deine Zieldomain auf localhost umlenkt?
Bitte warten ..
Mitglied: alijoschi
16.12.2010 um 12:45 Uhr
POST wird auf port 443 (HTTPS) abgesetzt. Wenn ich versuche am server auf die Firewalleinstellung zuzugreifen kommt: Windows Firewall cannot run because another program or service in running that might use the network address translation component(IPNAT.SYS). Hardwarefirewall laut auskunft von Serveradmin nicht vorhanden. Den Zielserver zu Pingen ist nicht möglich weder vom Server noch von meinen PC. Ich gehe davon aus das dies beim Zielserver ausgeschalten wurde.

In der IMHOSTS finde ich überhaupt keine einträge
Bitte warten ..
Mitglied: maretz
16.12.2010 um 13:37 Uhr
gut - fangen wir einfach an:

Darfst du überhaupt mit nem Ping raus? Kläre mal ob das auf dem Zielsystem wirklich ausgeschaltet wurde oder bei euch geblockt wird...

Dann: Hast du denn das Zertifikat für die HTTPS-Seite in deinem Programm drin? Sonst gibts ne Sicherheitswarnung -> und dein Programm kann die ja schlecht einfach akzeptieren.

Das mit der Win-Firewall ist schon ok... dann haben die wohl den Win-Server gleich mit als Router genommen... Ich frag mich zwar was einen reitet sowas zu tun (SO kostenintensiv ist nen 08/15-Router heute ja nicht mehr!), aber natürlich machbar...

und mach mal ein tracert www.deinzeilserver.de -> selbst ohne Ping solltest du sehen können ob das überhaupt in die richtige Richtung läuft...
Bitte warten ..
Mitglied: alijoschi
16.12.2010 um 14:43 Uhr
Habe einen PING auf www.google.at gemacht. Das hat funktioniert. Gehe also davon aus das ich bin PING raus darf.

In meinem Programm muss ich kein Zertifikat einbinden. Das Gegenstück, also am zielserver, da läuft so einen ART SOAP Server der einfach die Logindaten kontrolliert, wenn diese OK sind dann nimmt er das XML an und gibt mir ein Response mit OK oder ERROR. Aber ich bekomm überhautp keine Rückmeldung.

Hab das jetzt mit tracert versuch (auf mehreren Systeme) und überall komme ich gleich weit.
Bitte warten ..
Neuester Wissensbeitrag
Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (32)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...