Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows SBS 2008 SP2 Telefonieserver - Leitungsbenutzer festlegen

Frage Microsoft Windows Server

Mitglied: MysteryGuy

MysteryGuy (Level 1) - Jetzt verbinden

09.01.2012, aktualisiert 18.10.2012, 9809 Aufrufe, 9 Kommentare

Hallo,

ich habe auf einem Windows SBS 2008 SP2 den Microsoft Telefonieserver aktiviert und möchte jetzt die Leitungsbenutzer vom TAPI-Treiber der Telefonanlage bearbeiten. Das funktioniert scheinbar auch wie gewünscht. Wenn ich aber die MMC-Konsole schließe und erneut öffne, fehlen die meisten zuvor festgelegten Benutzer wieder.

Beispiel:

Leitungsname Benutzer
EXT0010 User01
EXT0011 User02
EXT0012 User03, User01
EXT0013 User03, User04
EXT0014 User04, User02

nach Schließen und Öffnen der MMC-Konsole

Leitungsname Benutzer
EXT0010 User01
EXT0011
EXT0012 User01
EXT0013 User04
EXT0014 User04            

Die hier im Bespiel angegebene Konstellation ist nur eine Möglichkeit. Es geht darum, dass von den ursprünglichen festgelegten Benutzern, nur noch User01 und User04 angezeigt werden. Wie ich diese zuordne ist dabei völlig egal. Es verschwinden immer die gleichen Benutzer nachdem erneuten Öffnen der MMC-Konsole. Alle Benutzer wurden über die Windows SBS Console mit der Benutzerrolle: Standarbenutzer angelegt. Leg ich einen neuen Benutzer an, kann ich diesen ohne Probleme benutzen. Vom Gefühl her würde ich sagen, dass alle älteren Benutzer von diesem Problem betroffen sind. Sprich Benutzer, die ich direkt nach der Installation des Server angelegt habe. Da es keine Fehlermeldung gibt oder ein Ereignisprotokolleintrag, bin ich ratlos, was ich dagegen machen. Alle betroffenen Benutzer neuanlegen möchte ich eigentlich nicht.
Mitglied: keine-ahnung
09.01.2012 um 20:28 Uhr
Hi,

was passiert denn, wenn Du die TAPI nicht über die user, sondern über die IP der Geräte verteilst? Geht das nicht? Ich laufe gerade über etwas dünnes Eis, weil ich nicht den MS-TAPI-Server nutze, sondern den meines CTI-Herstellers. Ich kann mich aber dunkel erinnern, auf einem SBS 2003 mal den MS-TAPI-Server über die IP die Leitungsberechtigungen verteilen lassen zu haben ... Eventuell geht das in W2K8 ja auch ...

LG, Thomas
Bitte warten ..
Mitglied: schrotti66
11.01.2012 um 07:37 Uhr
Hallo,
bei mir ist das Eis ebenfalls ziemlich dünn.
Aber,
Sowohl bei w2k3 als auch bei w2k8 kenne ich es so,
daß man sich erst mal local anmelden muß, um dann einen localen Benutzer nehmen muß, mit dem der Tapi-Telefonieserver gestartet wird.
Die Zuweisung kann dann wieder als Domänenbenutzer stattfinden..

Ob das auch beim SBS gilt, ist die nächste Frage

stefan
Bitte warten ..
Mitglied: MysteryGuy
12.01.2012 um 13:32 Uhr
Hallo Thomas,

wenn ich mit der rechten Maustaste auf eine Leitung klicke bietet mir das Kontextmenü "Benutzer bearbeiten..." und "Hilfe" an. Sollte das per IP-Adressen gehen, sehe ich keine Möglichkeit, das festzulegen. Ich würde viel lieber verstehen, was da schief läuft. Warum funktioniert das mit 2-3 Benutzer völlig normal mit anderen aber nicht. Und warum kann ich Benutzer ohne Fehlermeldung festlegen, die dann nach erneuten öffnen der Konsole wieder weg sind. Wird irgendwo evtl. doch was protokolliert was ich nicht sehe, oder kann ich sowas irgendwo aktivieren.

LG, Marco
Bitte warten ..
Mitglied: MysteryGuy
12.01.2012, aktualisiert 18.10.2012
Hallo Stefan,

du hast völlig recht mit deinen Ausführungen. Nach der Installation des Windows SBS 2008 war der lokale Administrator deaktiviert. Nach der Aktivierung des Lokalen-Admins, habe ich mich mit diesem angemeldet, um einen Telefonieadministrator festzulegen und um den Telefonieserver zu aktivieren. Naja, vorher waren schon noch paar Anpassung mit ldp.exe (http://www.administrator.de/forum/tapi-unter-windows-server-2008-r2-135 ...) mit der traumhaften Microsoft Übersetzung nötig. Bis dahin hat auch alles scheinbar funktioniert. Jetzt war ich also an dem Punkt wo ich festlegen wollte, welcher Benutzer auf welche Leitung Zugriff hat. Und das mit mäßigen Erfolg. Das was ich eben nicht verstehe, warum kann ich bestimmte Benutzer festlegen ohne das er Sie nach dem Schließen der MMC-Konsole vergisst, andere aber nicht. Ich habe auch alle Benutzer über die SBS Console angelegt ohne irgendwelchen SchnickSchnack mit dem Standardbenutzer Template. Und das Interessante ist ja, dass wenn ich jetzt neue Benutzer anlege, funktionieren die ja auch. Meine Vermutung ist das bei irgendeinen Microsoft Update etwas verändert wurde, was auf bereits angelegt Benutzer nicht übernommen wurde. Und damit darf ich mich jetzt rumärgern.

Ich freue mich über jeden Input. Vielleicht denk ich auch viel zu kompliziert.

LG, Marco
Bitte warten ..
Mitglied: MysteryGuy
23.01.2012 um 22:07 Uhr
Hier die Lösung,

löscht die Datei C:\Windows\tapi\tsec.ini (in ihr sind Telefonieadministratoren und Leitungsbenutzer gespeichert). Startet den Dienst Telefonie (tapisrv) neu. Anschließend muss man aber Telefonieadministratoren und Leitungsbenutzer neu festlegen.

Evtl. reicht auch simples bearbeiten der Datei C:\Windows\tapi\tsec.ini. Habe ich leider nicht probiert.
Bitte warten ..
Mitglied: heax2
25.01.2012 um 23:50 Uhr
Hallo wie hast du das hinbekommen, dass der TAPI Service aktiviert werden konnte. Ich habe auch die Anleitung von MS durchgeführt jedoch weiterhin ohne Erfolg. Vielleicht kannst du mir helfen.
Bitte warten ..
Mitglied: heax2
25.01.2012 um 23:59 Uhr
Hallo kannst du mich unterstützen. Ich bekomme das aktivieren von TAPI SERVER unter Telefonie nicht hin. Wie hast du das geschafft?
Bitte warten ..
Mitglied: SirAliks
04.02.2012 um 14:21 Uhr
Ahoi,

vorab:
@MysteryGuy, das könnte dir helfen:
Etwas seltsames passierte mir beim wiederholten re-installieren von TAPI Server. Die tsec.ini Sicherheitsberechtigungen haben nicht gestimmt, so konnte ich nach der Neuinstallation keine Benutzer mehr per MMC eintragen bzw. die alten blieben erhalten.
Abhilfe verschaffte mir die volle Berechtigung für "jeder" auf die tsec.ini Datei.

Unser Dilemma:

wir haben z.Z: ein ähnliches, wenn nicht sogar das gleiche Problem und es NERVT!

System:
Server 2008 Standard x64 mit aktuellen Updates
HiPath Tapi 170 V2.0 R 1.66.0

Anmerkung:
Wir haben eine ältere TAPI Version auf nem Windows 2000 Server zu laufen ohne Probleme, dort haben wir zum Teil >15 Benutzer / Line zugewiesen.


Das Problem äußert sich wie folgt:

Ein Benutzer kann nicht auf mehr als 7 TAPI Lines zugewiesen werden. Das MMC SnapIn zeigt stehts die 7 letzten Zuweisungen pro Line an, aber nie mehr als 7.
Ein Blick in die tsec.ini verrät, dass dort auch nix weiter passiert. Ergo die Oberfläche spinnt rum beim eintragen, oder?

Ich habe die alte tsec.ini vom Windows 2000 Server übernommen und auch mal eine achte Line ID per Hand eingetragen und siehe da, er zeigt die alte Konfiguration bzw. den manuellen Eintrag
auch in der Oberfläche an. Leider schmeißt er dann beim editieren per Oberfläche wieder alle Benutzer raus...toll.

Ob das manipulieren der tsec.ini auch eine brauchbare Lösung ist und die Telefone auch den Tapiserver ansprechen werde ich gleich herausfinden.


BTW:
Telefonieserver läuft ohne Probleme unter dem Domäne\Administrator Konto
Tapi Server unter lokales System



NACHTRAG:

Also ich kann nun mehr als 20 benutzer pro TAPI Line festlegen, aber nur wenn ich direkt die tsec.ini direkt bearbeite. Jedwede konfiguration per MMC ist fatal.
Die Tapi leitungen funktionieren auch soweit vollständig im Testbetrieb.
Sofern man sich die Line IDs sorgfältig notiert ist die Administration hintenrum sogar noch etwas einfacher als per MMC.

Ein ähnliches vorgehen wird hier geschildert:

http://www.tek-tips.com/viewthread.cfm?qid=1100699

lg
alex
Bitte warten ..
Mitglied: SirAliks
13.02.2012 um 15:18 Uhr
Nachtrag Nummero 2:

Also unser TAPI bzw. Telefonieserver stürzt im produktiven Betrieb leider mehrmals ab. D.h. wenn mehr als 3-4 Leute beginnen im CallCenter zu arbeiten.
Bis jetzt startet sich der Dienst immer wieder neu, aber das ist kein akzpetabler Zustand.

Wir haben schon ein Ticket bei Siemens aufgegeben(da Tapi Server für HiPath 3800).

Wir werden dann testen, ob es an dem Zuviel an Benutzern pro Line liegt, oder ob es ein generelles Problem mit dem Tapi Server ist.

Jedweder Lösungsansatz ist willkommen.

lg
aliks
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
Upgrade Windows SBS 2008 auf Windows 2012 R2 (3)

Frage von heisenberg4 zum Thema Windows Server ...

Windows Server
gelöst Windows SBS 2008 Konsole stürzt bei der Berichtserstellung ab (17)

Frage von Yasmin zum Thema Windows Server ...

Windows Server
gelöst NTP Server auf einem Windows Server 2008 R2 DC standardmäßig schon drauf? (11)

Frage von M.Marz zum Thema Windows Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
gelöst Server erkennt Client nicht wenn er ausserhalb des DHCP Pools liegt (28)

Frage von Mar-west zum Thema LAN, WAN, Wireless ...

Outlook & Mail
gelöst Outlook 2010 findet ost datei nicht (19)

Frage von Floh21 zum Thema Outlook & Mail ...

Microsoft
Ordner mit LW-Buchstaben versehen und benennen (19)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...