Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows Server 2003 mit Exchange 2003 hat Daten und OS je auf RAID 1 läuft aber nicht mit nur je einer Platte

Frage Microsoft Windows Server

Mitglied: TomatoDeluXe

TomatoDeluXe (Level 1) - Jetzt verbinden

26.04.2009, aktualisiert 12:45 Uhr, 6011 Aufrufe, 11 Kommentare

Hallo liebe Leserinnen uns Leser.

Bei uns wird ein neuer Windows 2003 von HP mit Exchange 2007 in Kürze eingebaut.
Bis jetzt haben wir einen Windows 2003 Server mit Exchange 2003.
Das Betriebssystem und die Exchange Daten liegen je auf einem RAID 1 mit 2 Platten.

Ich habe ein Acronis Image gemacht für den Notfall das bei der Migration was schief laufen sollte.
Während der Migration werden ja diverse Sachen verschoben, etc.
Mir kam dann die Idee das ich noch bevor am bestehenden Server was gemacht wird je eine Platte aus den beiden RAID nehmen könnte und so die Migration machen könnte.
Dadurch müsste ich doch ein volles backup aller Daten haben. 1 Platte mit dem OS, 1 Platte mit den Daten.

Habe dann Server runter gefahren, je eine Platte raus und gebootet.
Der Server bringt jetzt natürlich eine Meldung das gewisse Devices nicht mehr verfügbar sind, logisch es fehlt ja je eine Platte.
Er bringt dann die Meldung ich müsse eine Taste drücken:

Press F1 for continue or
Press F2 for interimRecovery irgendwas. ( mache einen Screenshot sobald ich kann)
Diese Meldung kommt pro Controller 1 mal , also insgesammt 2 mal. Habe beide Male F1 gedrückt.

1a41c6010d645c99ae31392924030688-f1oderf2 - Klicke auf das Bild, um es zu vergrößern

Habe dann mal F1 gedrückt weil ich nicht genau wusste was passiert. Hatte Angst dass der Server sonst die RAID auflöst und dann die Platten die ich rausgenommen habe nicht mehr erkennt wenn ich sie wieder rein schiebe. Wenn ja mal eine Platte kaputt geht dann meistens dann wenn ein RAID neu aufgebaut werden soll da dann die bestehenden Platten ziemlich gestresst werden.

Der Server hat dann aber gesagt dass kein Betriebssystem gefunden wurde !!!

415775a9b41a2be5f3cef7c1d9e8067f-kein_os - Klicke auf das Bild, um es zu vergrößern

Kennt jemand diese "Interim Recovery" Meldung und kann mir sagen was ich dann machen muss wenn diese Meldung kommt.
Meine Idee müsste dfoch eigentlich klappen oder? Kollege hat das auch schon so gemacht aber die Meldung beim F2 drücken kennt er so nicht.
Mitglied: broecker
26.04.2009 um 12:30 Uhr
Verstehe ich das richtig, zwei RAID 1 eines Produktivservers wurden absichtlich aufgerissen und neu gebootet um zu testen, ob sie in einem anderen Server (mit anderen anderen RAID-Controllern ...) noch laufen würden.
Das inkonsistente RAID soll nun trotz allem im alten System angeschmissen werden und auch einen inkonsistenten Zustand erreichen.
Baut man die alten Platten wieder ein, soll also mindestens ein Resync den Server die nächsten 5-10 Stunden beschäftigen - soweit richtig?
Bitte warten ..
Mitglied: broecker
26.04.2009 um 12:43 Uhr
so, mit den Screenshots ist das einzig sinnvolle weitere vorgehen, die Platten wieder (richtig herum) reinzuschieben, wieder einzuschalten und zu beten, um das Resync herumzukommen, vielleicht ist das SystemRAID ja RAID 0 aus Performance-Gründen. Falls es trotz fehlender Ironie-Tags noch nicht ganz deutlich ist, keine weiteren Versuche mit den Original-Platten!
Bitte warten ..
Mitglied: TomatoDeluXe
26.04.2009 um 12:44 Uhr
Hallo broecker.

Du hast mich vermutlich falsch verstanden, ist ja auch kompliziert formuliert von mir.

Habe bei beiden RAID je eine Platte raus genommen da ich diese als Backup brauchen möchte falls bei der Mitration was in die Hose geht. Der Server "müsste" doch auch so laufen da ja beide Platten komplett gespiegelt sind. Die Platten würde ich natürlich im Notfall wieder in den gleichen Server einbauen um den alten Server wieder betriebsfähig zu bekommen .

Kurzfassung:
Server X ....je eine Platte raus von OS RAID1 und Daten RAID1.
Server X müsste doch auch mit nur je einer Platte laufen da die gespiegelt sind.
Im Notfall würden Platten wieder in Server X eingeschoben wenn Migration in die Hose geht.

Wenn ich jetzt mit nur je einer Platte boote kommt dise Meldung ( Screnshot1 )
Habe dann zwei mal F1 gedrückt.
Server sagt dann ....kein OS gefunden ( Screnshot 2)

Hoffe das macht die Sache klarer. Habe Screenshoot hinzugefügt.
Müsste ich bei beiden Meldungen ( je eine pro Controller ) jetzt F2 drücken, und wen ja, erkennt der Server die alten Platten wieder wenn ich die im Notfall wieder einschiebe ?


Vielen Dank für eure Hilfe!!!
Bitte warten ..
Mitglied: TomatoDeluXe
26.04.2009 um 12:50 Uhr
Kennst du denn dieses "Interim Recovery Mode" Werde mal schauen was Google dazu sagt.

Vielen Dank für deine Hilfe !!

Bitte warten ..
Mitglied: broecker
26.04.2009 um 12:54 Uhr
nochmals deutlich(er): der Notfall liegt JETZT vor, der Server ist down und mit Glück kann er seine RAIDs im Verlauf des Sonntags rechtzeitig wieder aufbauen.
Bitte prüfe das (s.u.) und nächste Tests mit dem neuen Server gehen halt nur wenn man den Inhalt jeder der zwei RAIDs einzeln auf neue Platten überträgt.
Wenn das System-RAID Level 0 war und er sich nicht wiederherstellt, wird es Zeit für Datenrettung aus dem Acronis aber vor allem einen Plan für weiteres vorgehen. (PM)
Bitte warten ..
Mitglied: maretz
26.04.2009 um 14:04 Uhr
Whooohooowwww - das mal ne Hardcore-Idee... Einfach mal aus dem Produktions-Server ne Platte reissen um zu testen ob es geht.. gut - und dann noch am Anfang ohne zu wissen was welcher Modus ist mal lustig auf die Tasten hauen und gucken was passiert... Mein erster Gedanke: DANKE das du kein Arzt geworden bist -> erstmal mit nem Defi ansetzen und nen paar Stromstöße an den Patienten geben - um zu wissen ob der Defi denn im Notfall auch gehen würde... *brrrrrzzzzzllllll*

Bevor du jetzt noch mehr Schaden an der Kiste anrichtest musst du erstmal einige Dinge klären:

a) handelt es sich bei dem Raid-Controller um einen Hardware-Raidcontroller - oder um einen "billigen" Controller der die CPU des Rechners nutzt und erst vom Windows-Treiber zum Raid gemacht wird? Im letzteren Fall: Herzlichen Glückwunsch, du hast 6 Richtige! Denn letztere Treiber spiegeln idR. den Bootblock nicht mit - so traurig es auch ist...

b) Bist du dir sicher das du 2 Raid1 auf dem Raid-Controller hattest? Hattest du da nen Raid5 z.B. mit 4 Platten (aber 2 Partitionen) hast du ebenfalls 6 Richtige -> du hast grad den Raid geschossen...

c) Mit dem Drücken auf "F1" hast du schonmal ganze Arbeit geleistet. Was ist an dem Satz "all logical drives will remain disabled" falsch zu verstehen? Da steht doch schon "Drücke mich und alle Logischen Laufwerke werden deaktiviert bleiben"

Du kannst jetzt nur die Platte wieder einbauen - und hoffen das er den Array wieder erkennt. Dann sollte er das Recovery automatisch machen -> und am Schluß hast du mit etwas Glück wieder einen funktionierenden Array UND etwas mehr Erfahrung fürs nächste Mal...

Dadurch das du vermutlich 2 Raids auf dem Controller hast kann es jetzt nur noch intressant werden -> wenn Windows gestartet wird und der zweite Array noch nicht da ist kann es da auch zu Fehlern kommen... Am besten daher alle Dienste (Exchange!) gleich nach dem Start stoppen bis der Server wieder komplett da ist.

Achso - und für deinen nächsten Versuch folgenden Rat: Wenn ein richtiges Testsystem zu langweilig ist dann würde ich aus dem Produktionsserver nur eine Platte vom System rausnehmen und die datenplatte "remain unchanged" lassen... So hast du dann bei einem Problem nicht gleich 6 Richtige... Vergleichen wir das mal wie folgt:
Arbeiten auf einem Testsystem für solche Versuche: Russisch Roulett mit leerem Revolver
Arbeiten auf Produktionssystem aber nur eine Platte aus einem Raid entfernen: Russisch Roulett mit 1 Patrone im Revolver
Deine Version: Russisch Roulett mit ner Automatik und vollem Magazin...
Bitte warten ..
Mitglied: broecker
26.04.2009 um 16:36 Uhr
na, es war ja nicht ganz so schlimm, die "Vermutung" war ja, daß es RAID1 war und ein Backup vorhanden ist, aber ich hätte hier auch noch viel mehr Aufschreie erwartet
Mindestens die Downtime ist ja bei Exchange fragwürdig.
Bitte warten ..
Mitglied: maretz
26.04.2009 um 16:59 Uhr
Hey - es ist sonntag, die meisten Admins sitzen heute doch wieder im Keller und programmieren ;) - erst morgen is wieder ausgang zum arbeiten freigegeben ;)

gruss aus dem sonnigen bremen
Bitte warten ..
Mitglied: TomatoDeluXe
26.04.2009 um 17:29 Uhr
Mein System läuft problemlos wenn ich beide Platten wieder einsetzte.
Was ich einfach wissen möchte ist wie ich es hinkriege dass mein
Server mit 2 Raid ( beide je 2 Platten gespiegelt) mit nur je einer Platte
läuft.

By the way.....es wird überhaupt kein Recovery gemacht.
Server erkennt Platten wieder ohne Probleme.
Ich bin sicher das ich 2x RAID 1 mit Hardware Controller hab.
Ich möchte ienfach wissen was dieser Interim Recovery Mode genau ist und was der macht.

Danke für alle Tips weiterhin!
Bitte warten ..
Mitglied: broecker
26.04.2009 um 19:47 Uhr
also gut, mit F2 wird hier gesagt, das das Logical-Volume - also das RAID1 ohne zweite Platte alleine anlaufen soll, es ist dann natürlich nicht mehr mit der zweiten Platte syncron, weswegen die, wenn sie später wieder herein käme erst wieder in den RAID-Verbund aufgenommen werden muß, je nach Controller geht das nachdem man sie ganz leert und im Controller-BIOS entsprechend markiert oder auch nur durch anbieten beim reinschieben, dann wird gesynct und das "degradet" RAID danach wieder als funktionsfähig angezeigt, fällt beim "Stresstest" syncen die intakte Platte aus, ist natürlich das WE verdorben..., Hamburg, die Sonne scheint (noch)
Bitte warten ..
Mitglied: jschneider
26.04.2009 um 21:03 Uhr
sry ich habe das Gefühl du hast keine wirkliche Vorstellung davon was bei einer Exchange2003 zu Exchange 2007 Migration eigentlich passiert.

- Der neue Server wird parallel aufgebaut und Exchange2007 in die bestehende Exchange2003 Organisation installiert.
- Wenn das soweit erfolgt ist können "häppchenweise" oder in einem Rutsch Postfächer übertragen und Öffentliche Ordner vom Exchange2003 Server auf den Exchange 2007 Server synchronisiert werden.
- Connectoren für den Exchange 2007 werden parallel eingerichtet.
- und noch viel anderer Kleinscheiss parallel durchgeführt.

Der Exchange2003 Server wird also im Prinzip gar nicht angefasst, ausser dass die Inhalte aus seiner Datenbank in die des Exchange2007 Servers übertragen werden. Und Datenbank-Recovery wäre ein anderes Thema.


Das Hilft die jetzt natürlich nicht mehr, aber wenn HP euch die Migration macht dann sollten die eigentlich wissen was zu tun ist.


Nächste mal erst fragen wenn man sich nicht 100%tig sicher ist oder nen Fachmann ranlassen


Zitat von maretz:
Vergleichen wir das mal wie
folgt:
Arbeiten auf einem Testsystem für solche Versuche: Russisch
Roulett mit leerem Revolver
Arbeiten auf Produktionssystem aber nur eine Platte aus einem Raid
entfernen: Russisch Roulett mit 1 Patrone im Revolver
Deine Version: Russisch Roulett mit ner Automatik und vollem
Magazin...

den muss ich mir merken
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Windows Server
Windows Server und Exchange (7)

Frage von unique24 zum Thema Windows Server ...

Exchange Server
gelöst Microsoft Excange Server 2007 auf Windows Server 2003 Installieren? (9)

Frage von Herbrich19 zum Thema Exchange Server ...

Windows Server
gelöst Suche Windows Server 2003 Enterprise ISO (8)

Frage von Herbrich19 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (33)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...