Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows Server 2003 Netzwerkfreigabe (SMB) Geschwindigkeit

Frage Microsoft Windows Server

Mitglied: Zapper

Zapper (Level 1) - Jetzt verbinden

13.02.2015, aktualisiert 17.02.2015, 996 Aufrufe, 12 Kommentare, 1 Danke

Servus!
Habe hier einen Windows Server 2003 in folgender Konfiguration:
Supermicro X7SPA-H
Atom D510
4GB RAM
Corsair P64 SSD Systemplatte
2TB WD Green
Intel 82574L NIC

Client:
Realtek NIC

Das System läuft soweit ganz gut ...CPU Last ist nahezu immer unter 15%.

Crystaldiskmark und AS SSD ergeben ganz passable Werte mit Schreib/Leseraten Seq von ~100MB/S für die WD Green und ~150mb/s für die Corsair SSD.
Wenn ich nun am Server 2003 das eigene Laufwerk als Netzlaufwerk einbinde erhalte ich bei einem Test mit Intel NASPT Transferraten von ~100mb/s für die WD Green.
Greife ich nun von einem beliebigen Windows 7 oder Windows 8 Rechner auf die Netzwerkfreigaben zu erhalte ich ein Maximum von 61mb/s read | 51mb/s write über Gigabit Lan. CPU Auslastung ist dabei bei etwa 42%. Greife ich vom Server direkt auf die eigen Freigabe zu und starte einen Kopiervorgang beträgt die Auslastung 30%.

Gibt es irgendwelche Einstellungen oder generell Möglichkeiten die Transferrate zu erhöhen?
Mitglied: Zapper
13.02.2015, aktualisiert um 13:52 Uhr
Gerade NETIO laufen lassen:

NETIO - Network Throughput Benchmark, Version 1.32
(C) 1997-2012 Kai Uwe Rommel

TCP connection established.
Packet size 1k bytes: 72.65 MByte/s Tx, 37.32 MByte/s Rx.
Packet size 2k bytes: 69.56 MByte/s Tx, 43.62 MByte/s Rx.
Packet size 4k bytes: 63.38 MByte/s Tx, 57.78 MByte/s Rx.
Packet size 8k bytes: 66.28 MByte/s Tx, 64.05 MByte/s Rx.
Packet size 16k bytes: 64.51 MByte/s Tx, 65.43 MByte/s Rx.
Packet size 32k bytes: 68.44 MByte/s Tx, 68.39 MByte/s Rx.
Done.

Das muss also demnach ein Problem der NICs des Gigabit Switch oder der Kabel sein richtig? Um die 100MB/s sollten drin sein...denk ich.
Bitte warten ..
Mitglied: ukulele-7
13.02.2015, aktualisiert 17.02.2015
Ich würde mal ganz stark vermuten das die Client NIC hier der Flaschenhals ist. Realtek und vermutlich onboard, da ist 60/50 MB/Sek eigentlich kein schlechter Wert.
Bitte warten ..
Mitglied: Zapper
13.02.2015, aktualisiert um 14:54 Uhr
Es ist eine RTL8111D um genau zu sein. Ein Treiberupdate hat den Netio Lesedurchsatz nicht verändert. Die Netzwerkfreigaben sind langsamer geworden...also wieder zurück zum alten Treiber. Ich denke werde hier mal versuchen eine bessere Netzwerkkarte nachzurüsten. Interessanterweise hat sich ein Update der Intel Nic am Server auch Negativ auf die Transferrate ausgewirkt...-5MB/s


Was ist von dieser Intel PRO/1000 GT Desktop Adapter, 1x 1000Base-T, PCI 66MHz zu halten?
Bitte warten ..
Mitglied: ukulele-7
13.02.2015 um 14:52 Uhr
Also ich kenne nur die Faustregel das Intel grundsätzlich gute Netzwerkkarten baut. Ich glaube sogar 2 Intel PRO irgendwas rumliegen zu haben aber zu dem konrekten Modell / Chip kann ich nichts sagen. PCI (und dann auch noch 66MHz, ging das nicht bis 133MHz?) klingt auch irgendwie sehr alt, kannst du kein PCIe in den Client setzen?
Bitte warten ..
Mitglied: Zapper
13.02.2015 um 14:58 Uhr
Hab jetzt mal diese bestellt: Intel EXPI9301CTBLK PRO1000 Netzwerkkarte CT PCIex bulk. Danke für die Hilfe! Ich geb mal die Geschwindigkeit nach Tausch bekannt.
Bitte warten ..
Mitglied: Zapper
17.02.2015 um 12:33 Uhr
So nachdem ich die neue NIC nun verbaut habe liegen die Werte gleich auf mit der Realtek Karte obwohl in den Erfahrungsberichten zum Modell Geschwindigkeiten von 100mb/s beschrieben wurden. Die Treiber sind clientseitig auf dem neuesten Stand. Serverseitig hab ich es nochmal mit den aktuellen (2013) Treibern für Intel 82574L NIC versucht dies brachte aber geringere Übertragungswerte als die 2009er Version des Treibers.
Warum ist es denn so schwer mehr als 560Mbits in nem 1000Mbits Netzwerk zu erreichen?
Bitte warten ..
Mitglied: Zapper
17.02.2015 um 12:51 Uhr
So...auch interessant.
Führe ich Netio am Server als Client und Server aus sprich mache einen Geschwindigkeitstest auf mich selbst erhalte ich nur 68/67 MB/s.
Mache ich dasselbe am Client erhalte ich 150/150 MB/s. Wie kann das denn sein? Ist hier möglicherweise Windows Server 2003 selbst der Flaschenhals?
Bitte warten ..
Mitglied: Zapper
17.02.2015 um 13:46 Uhr
Habe nun den Ras Server deaktiviert und siehe da ich erhalte 93/81 Realtek zu Intel(Server) und 93/77 Intel zu Intel.
Erstaunlich ist, dass die Intel NIC keinen Vorteil zu bringen scheint.
Per SMB erreiche ich jetzt im Schnitt 73 MB/s im Download. Irgend ne Möglichkeit da noch ein bisschen mehr rauszuholen?
Bitte warten ..
Mitglied: Zapper
18.02.2015, aktualisiert um 11:57 Uhr
Nachdem ich nun auf beiden Seiten die Einstellung : Interruptüberprüfung deaktiviert habe bekomme ich Werte von 107/102 MB/s in Netio und bis zu 102/65 MB/s über SMB 1.
Bitte warten ..
Mitglied: ukulele-7
19.02.2015 um 14:37 Uhr
Ich wollte mich mit dem Thema auch immernochmal beschäftigen, daher hatte ich 2 Intel NICs zum testen gekauft. Allerdings habe ich hier derzeit keinen echten Bedarf für solche Transferraten.
Bitte warten ..
Mitglied: Zapper
19.02.2015, aktualisiert um 15:54 Uhr
Nochmal zusammenfassend was ich gemacht habe um die 1 Gigabit zumindest im Download zu bekommen:
TCP Optimizer bei Server und Client auf folgende Werte:
TCP Receive Window: 65535
MTU Discovery: Yes
Black Hole Detect: NO
Selective ACKs: Default
TTL: 64
Window Scaling x

Am Windows 8 Client habe ich noch zusätzlich Superfetch deaktiviert.

Bei den Netzwerkkarteneinstellungen war es in erste Linie wichtig Flusssteuerung und Interruptüberprüfung zu deaktivieren. Mit Jumboframes hats nicht ganz so gut funktioniert daher sind diese deaktiviert. Prüfsummenablagerung und alle anderen Ablagerungseinstellungen sind aktiviert ...Seitenskalierung ebenso. Die Sende/Empfangspuffer stehen auf den jeweiligen Standardwerten. Habe versucht sie bei der Intel Pro auf 2048 zu erhöhen was aber zum Einbruch der Geschwindigkeit geführt hat. Die Prozessorauslastung des Servers liegt bei einem Datendurchsatz von 102+ MB/s bei maximal 40%.

Was ich eigenartig finde ist, dass beim Schreiben zumindest auf die HDDs (bei SSDs hab ich diese Phänomen nicht) die Übertragung immer wieder für einige Sekunden fast komplett zum Stillstand kommt um dann wieder mit voller Geschwindigkeit fortzusetzen....scheint aber Abhängig von der Dateiart zu sein. Weiss jemand näheres?

Hat jemand eventuell eine Idee warum ich im Upload über SMB 1 (Server 2003) nicht über ~60 MB/s komme trotz SSD im Server?
Bitte warten ..
Mitglied: ukulele-7
20.02.2015 um 12:11 Uhr
Zitat von Zapper:
Was ich eigenartig finde ist, dass beim Schreiben zumindest auf die HDDs (bei SSDs hab ich diese Phänomen nicht) die
Übertragung immer wieder für einige Sekunden fast komplett zum Stillstand kommt um dann wieder mit voller
Geschwindigkeit fortzusetzen....scheint aber Abhängig von der Dateiart zu sein. Weiss jemand näheres?
Ich habe das Phänomän ofter zwischen lokalen Datenträgern am Ende einer oder mehrerer Dateien. Beim Transfer einer großen Datei konnte ich das noch nicht beobachten, weder lokal noch im Netzwerk.
Bitte warten ..
Ähnliche Inhalte
Windows Server
Windows Server 2016 Essentials bei Netzwerkfreigaben?
gelöst Frage von havok2Windows Server2 Kommentare

Hallo, ich betreibe einen Computer, welcher im Grunde lediglich eine große Menge Festplattenspeicher im Netzwerk zur Verfügung stellt. Dazu ...

Windows Server
Windows SMB in der Domain
Frage von DiespiterWindows Server5 Kommentare

Hallo, in der Firma wo ich arbeite haben wir Windows Domain mit Windows Server 2008R2 und ca. 400 Windows ...

Windows Netzwerk
SMB Limit bei Windows 7
Frage von Michael-24Windows Netzwerk19 Kommentare

Hallo Leute, mir war nicht bewusst, das man das Limit der SMB Freigaben nicht erhöhen kann. 20 gilt hier ...

Linux Netzwerk
Windows Netzwerkfreigaben unter Ubuntu 14.04
Frage von hildefeuerLinux Netzwerk2 Kommentare

Ich bin Gelegenheit Linux user! Hauptsächlich in fremden WLAN Netzen und bei Hombanking. (Nur) Mit Ubuntu 14.04 kann man ...

Neue Wissensbeiträge
Linux

Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde

Information von Frank vor 7 StundenLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...

Batch & Shell

Open Object Rexx: Eine mittlerweile fast vergessene Skriptsprache aus dem Mainframebereich

Information von Penny.Cilin vor 1 TagBatch & Shell9 Kommentare

Ich kann mich noch sehr gut an diese Skriptsprache erinnern und nutze diese auch heute ab und an noch. ...

Humor (lol)

"gimme gimme gimme": Automatischer Test stolpert über Easter Egg im man-Tool

Information von Penny.Cilin vor 1 TagHumor (lol)6 Kommentare

Interessant, was man so alles als Easter Egg implementiert. Ist schon wieder Ostern? "gimme gimme gimme": Automatischer Test stolpert ...

MikroTik RouterOS

Mikrotik - Lets Encrypt Zertifikate mit MetaROUTER Instanz auf dem Router erzeugen

Anleitung von colinardo vor 2 TagenMikroTik RouterOS8 Kommentare

Einleitung Folgende Anleitung ist aus der Lage heraus entstanden das ein Kunde auf seinem Mikrotik sein Hotspot Captive Portal ...

Heiß diskutierte Inhalte
Router & Routing
Zwei Netzwerke erstellen
Frage von bunteblumeRouter & Routing14 Kommentare

Hallo Zusammen, Ich möchte gerne ein backup von einem bestimmten Folder welcher auf dem Server regelmässig synchronisiert wird auf ...

Windows 10
Alle Programme mit bestimmtem Namen automatisch (per GPO) deinstallieren
gelöst Frage von lordofremixesWindows 1012 Kommentare

Hallo zusammen, gibt es eine Möglichkeit, alle Programme beginnend mit z.B. "Dell" im Namen per Script und somit per ...

Off Topic
Fachkräftemangel in Deutschland? - Talentschmiede schreibt alle 2 Tage die gleichen Stellen aus
Frage von Penny.CilinOff Topic12 Kommentare

Hallo, haben wir in Deutschland Fachkräftemangel? Die Talentschmiede schreibt gefühlt alle zwei Tage dieselben Stellen aus. Und das schon ...

Linux
Limux-Ende in München: Wie ein Linux Projekt unter Ausschluss der Öffentlichkeit zerstört wurde
Information von FrankLinux12 Kommentare

Mein persönlicher Kommentar zum Thema "Limux-Ende". Die SPD-Politikerin Anne Hübner hat die Richtung von München ganz klar definiert: "Wir ...