Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows Server 2003 - Raid 1 Festplatte defekt - Wiederherstellung kompliziert

Frage Microsoft Windows Server

Mitglied: Quebert

Quebert (Level 1) - Jetzt verbinden

26.04.2011, aktualisiert 16:26 Uhr, 8841 Aufrufe, 29 Kommentare

Mein System ist ein Windows Server 2003 Standard Edition mit 2x73 GB SAS Festplatten als Raid 1 konfiguriert.

Jetzt ist eine der beiden Festplatten defekt und ich muss die Platte einschicken. Da ich nicht will, dass das System während der Austauschzeit mit nur einer Platte läuft, wollte ich die "alte" Systemplatte (auch 73 GB SAS) solange einbauen.

Soweit ja kein Problem... nur die "alte" Festplatte ist nicht formatiert und enthält Systemdateien, die etwas älter sind.

Ich muss jetzt diese Festplatte irgendwie formatieren können, ohne dass mir die "alte" Platte die noch funktionierende über das Raid 1 abschießt (da die Daten etwas älter sind und der Server dann ja gleich die Platten synchen will)

Einen "SAS auf USB" Konverter habe ich leider nicht zur Verfügung.


Mein Lösungsansatz:

1) Ich nehme alle Platten raus
2) Ich gebe die "alte" Platte hinein und formatiere diese über das Onboard Raid
3) Ich baue die funktionierende Platte wieder ein und dann sollte er auf die formatierte Platte synchen


Weiß jemand, ob er das Raid löscht, wenn auf einmal nur noch die "alte" Platte drin ist?

Ich weiß nicht, ob er sofort zu synchen beginnt, wenn beide Platten drin hängen und die "alte" nicht formatiert ist...das wäre dann der "worst case"


Bitte um Hilfe oder Vorschläge


Danke!

Lg
Quebert
29 Antworten
Mitglied: 99045
26.04.2011 um 17:30 Uhr
Hi,

warum erstellst du dir nicht erst einmal ein Image der bestehenden Umgebung, bevor du irgend etwas Anderes anfängst? Dann bist du auf der sicheren Seite.

Gruß
Bitte warten ..
Mitglied: Quebert
26.04.2011 um 17:32 Uhr
Hallo,

ein Vollbackup habe ich bereits gezogen. Sollte ja eigentlich immer der letzte Ausweg sein

deswegen wollte ich alles andere zuerst probieren.

lg
Bitte warten ..
Mitglied: 99045
26.04.2011 um 17:37 Uhr
Hi,

dann kannst du ja beruhigt alle Platten ausbauen und die Option 2) wählen. Was dein Raid bzw. der Controller damit anfängt, kann ich dir leider nicht erzählen, vermutlich lässt sich das entsprechend konfigurieren. Meine letzte RAID-Konfiguration war im vorigen Jahrhundert unter Novell-Netware 3.12.

Gruß
Bitte warten ..
Mitglied: Quebert
26.04.2011 um 19:38 Uhr
hmm... tja, die "alte" platte hab ich jetzt erfolgreich formatiert...jedoch wenn ich die systemplatte und die formatierte einhänge bleibt er beim lsi logic sas raid bios hängen.
Bitte warten ..
Mitglied: onlyme
26.04.2011 um 20:36 Uhr
Hallo Quebert,
ist das ein Standard-Server und wenn ja von welchem Hersteller?
Gurß onlyme
Bitte warten ..
Mitglied: Quebert
26.04.2011 um 20:41 Uhr
Hallo

Das ist ein Fujitsu Siemens RX200 S3 Server mit Windows Server 2003 Standard Edition.


Ich hänge jetzt schon seit 2 Stunden ohne dass er die Festplatten erkennt.

Habe die "alte" Festplatte über das Raid-Bios formatiert. Dann wollte ich die funktionierende Systemplatte und die gerade formatierte Platte zusammen einhängen, damit er mir die Daten synchronisieren kann.

Jedoch funktioniert im Moment rein gar nichts. Er hängt beim Raid - Screen bei "initializing" , das geht ca. 5 Minuten und dann geht er mir direkt auf "operating system not found" ich komm nicht ins Raid-Menü.


Jedoch wenn ich die formatierte Platte alleine auf Slot 0 hänge und dann einschalte komm ich ins Raid-Menü rein, jedoch nur so.


Gruß Quebert
Bitte warten ..
Mitglied: onlyme
26.04.2011 um 20:46 Uhr
Hallo Quebert,
so, die RX200S3 gabs mit onboard Raid oder mit extra Karte.
Entsprechend kommt dann die Antwort, bis wann muß die Kiste wieder laufen?
Gruß
onlyme
Bitte warten ..
Mitglied: Quebert
26.04.2011 um 20:50 Uhr
Hier ist das Onboard Raid von LSI Logic im Einsatz.

Die Mühle sollte bis morgen laufen, sollte es länger dauern ist es auch nicht so schlimm.

Gruß Quebert
Bitte warten ..
Mitglied: onlyme
26.04.2011 um 20:56 Uhr
Also gehen wir davon aus das im BIOS das quiet-Boot disabled ist,
Beim Boot kommt man an der Abfragestelle mit ctrl-l in das RAID-BIOS.
Erst mal probieren wenn nur eine Platte (die neue) drin ist, bis man im Menue ist.
Dann diese Platte wieder raus und die Original-Platte alleine rein.
Nochmal prüfen ob Raid-Menue sichtbar ist (muß dann auf degraded stehen).
Dann die zweite Platte rein und jetzt ins Menue.
Dann macht der Controller in aller Regel das Backup alleine.
Was mich stutzig macht ist die Meldung "operating System not found", ist hier ein "Plattendreher" passiert?

Gruß bis später

onlyme
Bitte warten ..
Mitglied: Quebert
26.04.2011 um 21:03 Uhr
mittlerweile hab ich was neues:

Das kommt vom LSI Raid - Bios:

Initializing....
ERROR! Adapter Malfunctioning!

MPT BIOS Fault 13h encountered at adapter PCI(05h,05h,00h)

Press any key to continue...

drück ich hier ist wieder "OS not found"

Ich habe alle Möglichkeiten durch, Systemplatte alleine (obiger Fehler), formatierte Platte alleine ( komm ins Raid Menü aber kein Raid vorhanden ), beide Platten (obiger Fehler)
Bitte warten ..
Mitglied: onlyme
26.04.2011 um 21:09 Uhr
So, dann würde ich folgendes machen.
BIOS-prüfen, auf neuesten Stand bringen.
RAID-BIOS entsprechend erneuern, ggf. die aktuelle Version nochmal drüberschreiben.
Mir würde die Seriennummer des Servers helfen zur weiteren Analyse.
"Adapter Malfunction" würde ein Boardfehler sein, ich denke es ist keine BBU verbaut.

Gruß

onlyme
Bitte warten ..
Mitglied: Quebert
26.04.2011 um 21:21 Uhr
Seriennummer: YKBQ001537

Ja das ist wirklich sehr komisch....Wenn ich jetzt nur die formatierte Platte reinhänge und dann ins RAID - BIOS gehe dann kann ich dort genau ein neues Raid erstellen...mehr nicht.

Gruß
Quebert
Bitte warten ..
Mitglied: onlyme
26.04.2011 um 21:27 Uhr
Also siehst Du eine Platte im Controller, hast Du den Server offen gehabt?
Stecke die Platte mal in den anderen Slot ob Du das gleiche Bild erhälst, aber den anderen Slot aktiv im RAID-BIOS siehst.

Da ich erst morgen wieder auf diesen Servertyp Zugriff habe, ab wann könnte ich Dich erreichen?

Gruß

onlyme
Bitte warten ..
Mitglied: Quebert
26.04.2011 um 21:36 Uhr
Nein, der Server war nicht offen.

Ich sehe nur eine Platte, die ist aber komplett leer. Der Plan ist jetzt einfach die Systemplatte reinzuhängen und den Raidverbund wieder zu aktivieren (degraded) dann die leere Platte dazu und spiegeln lassen.

Ich bin morgen ab 08:00 Uhr online.

Gruß

Quebert
Bitte warten ..
Mitglied: onlyme
26.04.2011 um 21:42 Uhr
Okay, viel Spaß noch und dann bis morgen.
Info erwünscht wies steht.

Gruß und "schönen Abend"

onlyme
Bitte warten ..
Mitglied: Quebert
26.04.2011 um 21:43 Uhr
Vielen Dank!! Bis morgen..ebenfalls einen schönen Abend

Quebert
Bitte warten ..
Mitglied: Quebert
27.04.2011 um 07:25 Uhr
Guten Morgen,

leider keine neuen Infos...Server immer noch im gleichen Zustand. Bin langsam am verzweifeln, da ich den Fehler nicht finde bzw. nicht weiß, was ich falsch mache.

Gruß

Quebert
Bitte warten ..
Mitglied: holli.zimmi
27.04.2011 um 08:05 Uhr
Hi Quebert,

In deinem Fall, so genau hast Du es ja nicht geschrieben, ist die 1. Festplatte am Controller ausgefallen.

Lösung:
Also Du den Server mit der 2. Festplatte hochfahren, gleich nachdem das Betriebssystem gefunden ist. Die 1. Festplatte anschliessen. Ist der Server hochgefahren dein Raid-Software ( also für denRaid-Controller starten ) und dann die Synchr. von der 2. Harddisk auf die 1. Harddisk starten.

Bemerkung: Die alte Festplatte wäre sowieso überbügelt worden.

Gruss

Holgi
Bitte warten ..
Mitglied: Quebert
27.04.2011 um 08:13 Uhr
Hallo,


Nein, es ist vom Raid1 die zweite Festplatte auf Port 1 defekt gewesen. Es ist momentan aber so, dass er die Systemplatte nicht mehr erkennt. Habe ich nur die formatierte Platte drin, dann findet er diese auch. ansonsten kommt der obige Fehler.

Gruß

Quebert
Bitte warten ..
Mitglied: holli.zimmi
27.04.2011 um 08:26 Uhr
Hi Quebert,

kannst du deine formatierte Platte nicht als HOT-SPARE Festplatte einrichten, dann würde der Controller automatisch synchronisieren.

Gruss

Holli
Bitte warten ..
Mitglied: Quebert
27.04.2011 um 08:48 Uhr
Nein, das funktioniert leider nicht, da ich auf der formatieren Platte nur ein neues Array erstellen kann.

Mittlerweile bin ich schon wieder einen Schritt weiter, der obige Fehler scheint jetzt nicht mehr auf.

Starte ich jedoch den Server mit der vorherigen Systemplatte wird diese nicht vom Controller gefunden. SAS Topology: No Device found.

Gebe ich die "defekte" Platte hinein, kommt, dass diese nicht synchronisiert ist.


Jetzt kenne ich mich gar nicht mehr aus.

Gruß
Bitte warten ..
Mitglied: onlyme
27.04.2011 um 19:35 Uhr
Hallo Quebert,
leider kann ich mich jetzt erst melden, bei mir war heute viel los an der Arbeit, da treten diese Dinge in den Hintergrund.
Also, stecke mal die "gute" Platte an einen anderen Port und versuche den Server zu booten.
Was passiert dann?
Wir müssen erst die gute Platte wieder zum laufen kriegen, erst dann machen wir mit der RAID-Config weiter.
Und wie gesagt, es besteht die Möglichkeit das die "gute" Platte nicht mehr funktioniert, dann versuche mal die andere.
Hast Du Zugriff auf eine 2.RX200?

Gruß

onlyme
Bitte warten ..
Mitglied: Quebert
28.04.2011 um 11:00 Uhr
Hallo onlyme,

bin gestern einen großen Schritt weiter gekommen. Hab jetzt mithilfe der Server-CD das Raid-Management starten können und dort habe ich bei der "guten" Platte den Status "unconfigured".

Das Raid ist also zerschossen, aus welchem Grund auch immer.

Ich bekomme heute eine neue Festplatte und probiere dann das Raid neu zu erstellen, da gibt es ja die Möglichkeit, dass er die Daten auf der primären Festplatte beibehält und das Raid neu erstellt.

Ich hoffe mal, das dieser Schritt funktioniert, sonst bleibt nur noch Windows CD rein, Neuinstallation und dann zurücksichern. Die Sicherung habe ich schon in einer VM getestet..jedoch bekomme ich einen Bluescreen nach dem Neustart, ist wie erwartet, da er ja das Raid nicht mehr findet.

Also gehe ich davon aus, dass die Sicherung schon passt.

Ich melde mich dann noch mit weiteren Infos.

Danke für die Hilfe bisher

Gruß

Quebert
Bitte warten ..
Mitglied: miscmike
02.05.2011 um 12:41 Uhr
Ich verstehe immer nicht, wieso hier - statt herumzubasteln - nicht ein kompetenter Fachmann (IT-Dienstleister) hinzugezogen wird !
Sind Eure Serverdaten und die Betriebsbereitschaft so unwichtig ?

Wie sieht es nach der Bastelei z.B. mit der Gewährleistung aus, wenn etwas schiefgeht ? Den Chef schonmal danach gefragt ?


Viele Grüße

Mike Schkölziger
MISC Computers GmbH
Bitte warten ..
Mitglied: thommy75
02.05.2011 um 20:37 Uhr
Hallo miscmike,

Die Lösung "einen Fachmann ranlassen" ist auch nicht immer der beste Weg...

Ich hatte einen sehr ähnlichen Fall wie Quebert, nur ein wenig dramatischer: mir hat es die 1. Festplatte zerstossen.
In meinem Dell-Server werkelt auch ein LSI RAID-Controller, der lt. Dell-Hotline die Eigenschaft hat, zwar auf beide Platten zu schreiben, aber nur von der ersten Platte eines RAID(1)-Verbundes zu lesen.
Nach 5 Tagen allabendlichen Telefonaten mit der Dell-Hotline (und den gleichen Ergebnissen wie bei Quebert, d.h. irgendwann hat der Controller gar keine Platte mehr erkannt) kam dann der "Experte" ins Haus.
Hätte ich nicht daneben gesessen und seine Arbeit ein wenig überwacht, wäre mein RAID komplett hinüber gewesen. Ich konnte ihn gerade noch davon abhalten, ein neues RAID anzulegen und damit meine Daten ins Nirvana zu schicken.

Übrigens haben wir mit der "Hot Spare"-Lösung das Raid letztendlich wieder zum Laufen bekommen.
Leider ist es schon wieder ein paar Tage her, und ich kann mich nicht mehr genau daran erinnern, wie wir dabei genau vorgegangen sind, aber ich bin der Meinung:
Platte 1 rein (sollte ja noch funktionieren), die 2. Platte dazu (die formatierte, aber auf den gleichen Port an dem die defekte Platte hing) und im RAID BIOS die "neue" Platte als Hot Spare deklarieren.
Aber so viel ich noch weiss, müssen beide Platten am Controller hängen, sonst bietet er die HotSpare-Möglichkeit gar nicht an. Und: Formatiert war meine neue Platte auch nicht (fabrikneu, und nicht über den Controller formatiert)!
Wie holli zimmi schon schrieb, synchronisiert sich das RAID dann automatisch.

Gruss, thommy75
Bitte warten ..
Mitglied: miscmike
03.05.2011 um 11:08 Uhr
Hallo thommy75,

naja, ich habe von Fachleuten geredet..... nicht von "Massenabfertigungsfirmen mit Experten, die sich mal eine Umschulungsmaßnahme reingezogen haben" - nichts für ungut DELL, ich habe aber durch Kunden öfter von großen Firmen wie z.B. DELL gehört, denen die Kunden recht egal sind...
Man beruft sich dann auf ".. für Daten ist der Kunde verantwortlich..." , das mag sein, hat aber nichts mit der Berufsehre zu tun.

Wie dem auch sei - wenn eine Fachfirma rangeht, dann gibt es immer eine Gewährleistung für die Arbeit - beim Basteln wohl nicht wirklich..
Bitte warten ..
Mitglied: Quebert
04.05.2011 um 08:42 Uhr
Hallo,

ich habe einige Neuigkeiten!

Ich habe jetzt den RX200 Server durch einen neuen HP DL360 G7 ersetzt. Es war zwar etwas schwierig, da den Server 2003 zu installieren (RAID Treiber) aber mittlerweile läuft die Kiste wieder. Das "ntbackup" habe ich erfolgreich einspielen können.

Jedoch ist mein Sharepoint nicht richtig mitgesichert worden (Dienst war noch aktiv während der Sicherung), dadurch kann ich diesen nur schwer wiederherstellen.

Ist aber nicht weiter schlimm, das ist nur sekundär.


Zum Thema "Basteln": Ich gehe mal davon aus, dass man als angestellter IT-Techniker in einer Firma nicht herumbastelt, das macht man zuhause oder in einer Virtuellen umgebung. Wenn jedoch die Zeit sehr knapp ist, muss man einfach etwas herumprobieren und versuchen, das Ding wieder zum Laufen zu bringen.

Daher verstehe ich die Aussage von miscmike nicht wirklich. Die Daten sind zwar äußerst wichtig (komplette Warenwirtschaft), aber ich kann mit 3 Backups beruhigt an solche Probleme rangehen und auch herumprobieren.


Also...Server läuft wieder -> Topic closed!

Vielen Dank an alle, die mir geholfen haben

Gruß Quebert
Bitte warten ..
Mitglied: miscmike
04.05.2011 um 08:51 Uhr
Hallo Quebert,

schön, dass es wieder läuft. Von Bastelei habe ich deshalb geredet, weil bei solchen Problemen die hier diskutiert werden ein "Mann/Frau vom Fach" eigentlich nur lächelt. Solche Dinge sind in einer IT-Dienstleistungsfirma täglich
anzutreffen und daher in gewisser Form Routine. Dafür muß ich nicht in ein Forum. Ebenfalls steht immer das Thema Gewährleistung im Raum - wer kommt dafür auf, wenn etwas schiefgeht bzw. für die viele verlorene Zeit ?
Das sind Dinge, die Chefs interessieren - einfach mal darüber nachdenken...

So, ich denke es ist angekommen - trotzdem Glückwunsch, dass es wieder läuft.


P.S. Solche Kunden wünsche ich mir manchmal, die dann mal gleich den ganen Server wechseln ))

VG

miscmike
Bitte warten ..
Mitglied: Quebert
04.05.2011 um 09:11 Uhr
Hallo miscmike,

Nur noch so am Rande...falls was schiefgeht kommt immer das Backup dafür auf Sicherlich hat man bei einer Dienstleistungsfirma die gewisse Routine...ist schon klar, dafür bezahlt man auch. Da solche Ausfälle bei meiner Tätigkeit nicht alltäglich sind frage ich einfach bei verschiedensten Quellen nach (auch Forum) nach, um mir gute Tipps zu holen.

Man kann ja nicht alles wissen.

Ja, alte HW ist 5 Jahre alt...Ersatzteile sind da unter 1 Woche gar nicht zu erhalten. Deshalb hat sich der Umstieg auf die neue HW auch nachhaltig gelohnt.

Gruß Quebert
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Exchange Server
gelöst Microsoft Excange Server 2007 auf Windows Server 2003 Installieren? (9)

Frage von Herbrich19 zum Thema Exchange Server ...

Windows Server
gelöst Suche Windows Server 2003 Enterprise ISO (8)

Frage von Herbrich19 zum Thema Windows Server ...

Server
gelöst Client bei Windows Server 2003 ändern (5)

Frage von Therealcookie zum Thema Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...