Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server 2003 RC2, VIER NICS, VMware Host

Frage Netzwerke Router & Routing

Mitglied: Schranzer23

Schranzer23 (Level 1) - Jetzt verbinden

30.04.2006, aktualisiert 10.06.2006, 12940 Aufrufe, 19 Kommentare

Netzwerk von mir, Problemsuche, Hilfe, Vorschläge, bin für alles offen
--
In erster Linie geht es mir um die Konfiguration des Servers,
der die Lastverteilung für sich selbst vornehmen soll. Sprich
ich will entscheiden wo der Traffic über welche NIC laufen soll.

Hallo erstmal an alle !!

ich hoffe ihr könnt euch mit meinem Problem vertraut machen,
versteht meine Netzwerkaufbau und könnt mir dringend weiterhelfen.
Hab ich irgendwo Fehler gemacht ?? kann das Funktionieren oder ist
einfach alles nur Kappes !?!?

Wichtig: ich habe versucht mein Netzwerkplan so gut wie möglich Nachzubauen
bitte dem Anhang entnehmen. (Dies ist mein erster POST)

#Konfiguration Netzwerke
Erstes Subnetz: 192 . 168 . 16 . 0
Zweite Subnetz: 192 . 168 . 32 . 0
Drittes Subnetz: 192 . 168 . 48 . 0
Viertes Subnetz: 192 . 168 . 80 . 0

Subnetzmaske: 255 . 255 . 255 . 128


#Konfiguration Router
Statische IP: 192.168.16.1
Subnetzmaske: 255.255.255.128
DynDNS: vm-appsrv.ath.cx (zum WAN port)
---
DHCP: AN (192.168.16.48 - 192.168.16.64)
NAT: -
FW: nur portmapping (extern Port 21 auf intern zum Server 21 > beispielsweise)

Physikalisch >>

Ausgang 1.EINS > Eingang > Patchfeld > Ausgang > NiC EINS Workstation 16.1
Ausgang 2.ZWEI > Eingang > Patchfeld > Ausgang > NiC ZWEI Server 32.1
Ausgang 3.DREI > Eingang > Patchfeld > Ausgang > NiC DREI Server 48.1
Ausgang 4.Vier > Eingang > Patchfeld > Ausgang > UPLINK 4-Port Switch
> Ausgang NIC VIER Server 80.1
------------------------


#Konfiguration Workstation
Os: Windows XP Professional x64

Netzwerk:
NIC 1: [Zum Patchfeld] > Patchkabel 10/100Mbs
Statische IP: 192.168.16.2
Subnetzmaske: 255.255.255.128
Hostname: Daedalus

NIC 2: [Zum Server] > Crossover 1Gbs
Statische IP: 192.168.112.2
Subnetzmaske: 255.255.255.128
Hostname: Daedalus


#Konfiguration Server
Os: Windows Server 2003 RC2
VM: VMWare Server
> Virtual Machine 1
> Virtual Machine n ...

Netzwerk:
NIC 1: [Zur Workstation] > Crossover 1Gbs
Statische IP: 192.168.112.1
Subnetzmaske: 255.255.255.128
Hostname: NT-NETSRV01

NIC 2: [Zum Patchfeld] > Patchkabel 10/100Mbs
Statische IP: 192.168.32.1
Subnetzmaske: 255.255.255.128
Hostname: NT-NETSRV01

NIC 3: [Zum Patchfeld] > Patchkabel 10/100Mbs
Statische IP: 192.168.48.1
Subnetzmaske: 255.255.255.128
Hostname: NT-NETSRV01

NIC 4: [Zum 4-Port Switch] > Patchkabel 10/100Mbs
Statische IP: 192.168.80.1
Subnetzmaske: 255.255.255.128
Hostname: NT-NETSRV01
Jetzt zu meinem Vorhaben:
Ich möchte gerne auf dem Server festlegen, welche Dienste, bzw.
Welcher Traffic über eine bestimmte NIC laufen soll.
Das Beispielsweise der interne Lan Traffic nur über die
mit dem Crossover Kabel verbundenen Computer laufen soll (file sharing)

Hab gelesen mit einem NLB soll das ganzen funktioniern:
ABER!
muss ich den Server als DC einrichten und Clustering aktivieren ?ß
wie muss das ganze konfiguriert sein?
Hatte mal in einer VM Testweise das Scenario Nachgebaut, hab aber
nicht viel verstanden das Das Thema ja recht breit gefächert ist.
Da gab es soviele einstellungsmöglichkeiten und ich habe ANGST, dass
mein Netz dadurch lahmgelegt wird. F1 F1 F1 F1 !!!

Vielen DANK Schonmal für eurer Mühe euch den ganze Quatsch durchzulesen
und hoffe ihr könnt mir weiterhelfen


BILD:
http://www.future-inc.de/files/Infrastruktur_Detail.jpg
Mitglied: aqui
01.05.2006 um 16:15 Uhr
Was abgesehen von deinen sauberen und fehlerfreien IP Design an deiner nachfolgenden Zeichnung etwas verwirrend ist, ist die Tatsache das dort irgendwie wieder alle sauber getrennten IP Netze über Patchfeld und Switch zusammengeführt sind.
Das geht natürlich so nicht und wäre, wenn das tatsächlich so realisiert sein sollte, ein fehlerhaftes IP Netzdesign !!
Du kannst nicht mit unterschiedlichen IP Segmenten gemeinsam auf einer Layer 2 Switching oder Hub Struktur fahren ! Das funktioniert zwar per se ist aber IP technisch nicht supportet. Das erstmal vorweg....
Insgesamt hast du aus IP Adressierungssicht ja 5 unterschiedliche IP Netzwerke:
- Das Routernetz mit den Links zur WS
- Das Crossovernetz WS - Server
- 3 unterschiedliche Segmente am Server
Alle diese Netze müssen getrennt voneienander betrieben werden und dürfen IP technisch nicht wieder verbunden sein über einen gemeinsamen L2 Switch oder Hub !
Einzige Ausnahme hiervon wäre ein VLAN (Virtual LAN) fähiger Switch, wo ich diesen fünf Segmenten eigenständige und getrennte VLANs zuordne ! Idealerweise könnte dieser Switch noch Layer 3 (OSI Modell) switchen, so das ich eine Kommunikation über diesen Switch zwischen den Segmenten realisieren kann OHNE den Server dazu zu missbrauchen, denn der soll ja Daten "serven" und nicht routen !!!
Das wäre dann erstmal ein sauberes IP Design zu deinem Konzept ganz unabhängig von der Frage auf welchem Segment der Server nun welche Dienste zur Verfügung stellt....

das wäre jetzt nämlich die 2. Baustelle !
Ketzerischerweise könnte man jetzt sagen mit Linux wäre das kein Problem, da ich bestimmte Daemons bzw. Dienste an bestimmte NICs hängen kann aber bei Windows ist das fraglich sofern es sich um Windows interne Dienste handelt.
In den allermeisten Fällen lassen sich externe Serverdienste die über externe SW auf den Server gespielt wird entsprechend konfigurieren, wie z.B. Apache Webserver oder Cerberus FTP Server.
Ob dies allerdings generell gilt für alle 3rd Party SW Hersteller darf bezweifelt werden.
Ein ganz anderes Thema sind die Windows internen Dienste. Ich meine nicht das die sich so ohne weiteres von bestimmten NICs abhängen lassen. Die Microsoft Knowledgebase sagt wenigstens nichts dazu in einem schnellen Durchblick.

Fazit: Der Erfolg deiner Mission hängt erstmal von einem sauberen Netzwerkdesign ab und im 2. Step von den Fähigkeiten deiner SW.
Bitte warten ..
Mitglied: Schranzer23
01.05.2006 um 17:52 Uhr
boar ich bin beeindruckt, danke für die flotte und durchaus konrkete Rückmeldung !!!

Das ich diese netzwerksegmente auch Physikalisch voneinander Trennen muss, das WUSSTE ICH bis gerade eben absolut nicht, hat mir mein Lehrer wohl vorentahlten (das ist übrigens das erste IP netz was ich selbst designe) meine Klausur wo subnetting vorkamh ist gerade mal 4 wochen her. Von daher schonmal gut das das soweit logisch funktioniert. Danke erstmal dafür !

--
Erwähnt wurde ein VLan Switch bzw. Switch der Layer 3 kann (sprich IP_Routing - wegen dritter schicht im OSI Modell) - wie siehts denn mit nem Layer 4 Switch aus, der könnte dann ja sogar mit TCP umgehen. Was würden solche switches kosten ?? VLAN, L2, L3

---
Was ich mit diesem Konzept, verwirklichen wollte. Im Grunde genommen, soll der Server JA / NEIN Daten routen. Ich betreibe Mehrere VMs, ich habe mit dem Windows Server einen DHCP S laufen, der verteilt in jedem Subnetz IP-Adressen | auf diese Subnetze kann ich über die 3rd Party app Vmware gezielt zugreifen, ich kann sagen Virtuelle Maschine 1 du nimmst die Netzwerkkarte 1 als bridge zum Server un damit zum LAN und bekommst ein 32. Subnetz, das funktioniert. Also nochmal ich wollte das Somit jede Virtuelle Maschine Zugriff auf das Internet bekommt und auch ins Lokale Netzwerk, deswegen hab ich alle an dem Router Anschliessen wollen. der Server sorgt für die Verteilung der Bandbreite (Vier NICS) sowie für die Verteilung und Überwachung des IP-Verkehrs NUR ich betone NUR für Die Virtuellen Maschinen.
Nagut dass ich drittanbieter Programme dementsrpechend konfigurieren kann, ist klar. geht nur leider nicht mit jedem Prog. (verfluchte SW Entwickller ).
Sobald einmal meine Infrastruktur steht und wirklich alles tadellos durchorganisiert und geplant ist, werde ich in erwägung ziehen auf einem Unix server umzusteigen (rein ins proprietäre) - Begründung 1 : Ich hasse Laufwerksbuchstaben (bei Sechs Platten errlischt die Übersicht ) Begründung 2 : MS = Kostenaufwändig und ein Freund der Viren und Würmer ; Ich will einfach nichtmehr länger MS unterstützren bin nur Momentan noch dazu gezwungen, da mir noch zuwenig know how fehlt. (Deswegen auch erstmal Soviele VMs, lernen, testen, warten : ) )

vielen Danke nochmal und have a nice day
Bitte warten ..
Mitglied: aqui
02.05.2006 um 22:36 Uhr
Hallo Dominik !

Man strengt sich ja an hier im Forum...danke für die Blumen ! Ich will jetzt auch nichts böses gegen Lehrer schreiben aber IP Design steht meist nicht auf deren Vorlesungsplänen bei der Ausbildung und Schulnetze sind meisten "flach" d.h. ein plattes Layer 2 Netzwerk. Da kann man den Lehrern keinen Vorwurf machen...Deshalb ist es mal löblich zu sehen das du mal andere (vielleicht bessere) Wege gehst...
Fakt ist aber das du deine unterschiedlichen Segmente getrennt voneinander behandeln musst.
Wenn du nicht jedes Segment mit einem separaten Switch oder Hub bedienen willst gibt es sog. VLAN fähige Switches. Das sind Switches bei dem du seine 48 Ports z.B. logisch aufteilen kannst in 4 (oder mehr) unterschiedliche LAN Segmente die zwar physisch auf einer Platform arbeiten aber vollkommen getrennt sind voneiender, also so nicht kommunizieren können. Vorteil ist: statt 4 (oder mehr) einzelnen Switches hat man einen den mal aufteilt (Kosten!) Ein Kommunikation auf einem "Kabel" wäre auch so nicht möglich durch die unterschiedlichen IP Netzwerke die du darauf fährst, denn die "sehen" sich nicht. Eine Konfiguration so eines VLAN Switches sähe z.B. so aus:

vlan 1 name Router by port
untagged ethe 1 to 5

vlan 2 name Subnetz-1 by port
untagged ethe 6 to 10

vlan 3 name Subnetz-2 by port
untagged ethe 11 to 15

vlan 4 name Subnetz3 by port
untagged ethe 16 to 20

Dies können meist auch preiswerte Switches der einschlägigen Anbieter. Damit hättest du deine Netze getrennt. Nun musst du darüber natürlich ein Routing zur Verfügung stellen um zwischen diesen Netzwerken zu kommunizieren.
Am einfachsten realisiert man das mit einem Switch der auch Routen kann. In diese VLANs hängt man jetzt per Konfiguration ein IP Interface, stellt darauf die NICs der jeweiligen Endgeräte in den Segmenten ein und schon kann wieder jeder mit jedem. Leider ist der Nachteil das diese Switches etwas mehr kosten als die nur Layer 2 VLAN fähigen.
Hat man diese Möglichkeit eines VLAN Layer 3 Switches nicht oder die eines standard VLAN Switches und benutzt einzelne Switches, dann kann man z.B. einen ausgedienten Rechner zum FLI4L Router mit Linux machen. 4 preiswerte Netgear Netzwerkkarten für 5 Euronen rein, etwas Speicher und ein Diskettenlaufwerk und fertig ist dein "Poor man" 4 Port Router für den Switch oder die Switches. Für dein Schulnetz sollte der allemal reichen:

http://www.fli4l.de/

Der stellt dann wieder die L3 Verbindungen zwischen den Netzen her. Ist auch ein nettes Bauprojekt für die "Informatik AG"
Dein Vorschlag mit L4 Betrieb ist gar nicht mal so falsch. Meist kann man bei diesen Routern bzw. L3 fähigen Switches noch Access Listen konfigurieren wo du mit einfachen Bordmitteln z.B. für Subnetz 3 nur FTP Zugriff erlaubst, für Subnetz 2 nur HTTP, Fürs Subnetz 1 alles außer Windows NetBios über TCP usw. Damit kommst du schon fast an das ran was du ursprünglich vorhattest und machst dein Schulnetz etwas "wasserdichter"...
Bitte warten ..
Mitglied: Schranzer23
03.05.2006 um 04:30 Uhr
HEY HI !!!

Danke für die ganzen infos, total super lob an alle von euch !
Wollte nur mal etwas dazu sagen, dass ist nicht ein Schulnetz, das ist
meine Infrastruktur zu Hause !!! )))) und ich wll halt genau
das Erreichen, was ihr mir schreibt, - planen, fehler finden, in Betrieb nehmen.

Das soll einer Realweltpraxis ziemlich nahe kommen, da ich beabsichtige nächstes
Jahr wenn die Schule fertig ist, mir eine Ausbildung zu schnappen (zusätzlich zu
meiner schulischen) - Anderer Grund ist Natürlich Netzwerktechnisch mein Wissen
auf nem total aktuellen Stand zu halten um somit im Unterricht ohne Probleme vorran
zu kommen. - Da der Klausurschnitt im BSN _u. meis Fünf is - (zum glück net bei mir = ) )

So jetzt wieder zu dem Quatsch :

Du sagtest ich könnte mir nen poor router mit FLI4l machen, das sys. kenne ich und die IDee
find ich super !! - Was mach ich denn mit dem aktuellen Router dann, wird der dann irgendwann bei ebay landen, odre hab ich das in der Konfiguration vergessen ??


vielen danke, klasse an, echt nen phättes lob an euch : ) *THUMBS UP*
Bitte warten ..
Mitglied: aqui
03.05.2006 um 09:03 Uhr
Du kannst das natürlich auch alles ohne Router aufbauen wenn du dann über den Server routest. Der verbindet dir ja auch alle Segmente. Allerdings ist die Lösung suboptimal, da der Server ja "serven" soll und sich nicht damit beschäftigen soll Packete von A nach B forzuwarden... Deshalb musst du ja routingtechnisch deine unterschiedlichen IP Segmente (Subnetze) verbinden. Dafür brauchst du dann einen Router mit 4 Beinen (in deinem Beispiel) oder aber einen L3 (routingfähigen) VLAN Switch.
Letzterer ist aber in der Tat für einen Heimanwender nicht ganz preiswert und sicher etwas oversized. Einfacher ist es da alle deine Subnetze in kleinen 4 (oder mehr) Port, no name Switches enden zu lassen die es für wenig Geld bei den einschlägigen Händlerketten zu kaufen gibt. In diese 4 Switches, die deine Subnetze sind, steckst du jetzt deinen FLI4L Router um die Segmente routingmässig zu verbinden. Ist natürlich etwas Bastelei aber der Lerneffekt ist unbezahlbar, ausserdem schonst du deinen Geldbeutel. Falls du aber einen L3 fähigen VLAN Switch billig bei eBay "schiessen" kannst ist das natürlich auch eine Alternative... Erfahrungsgemäß sind die aber teuerer.
Bei Fli4l musst du nur sorgfältig mit den Interrupts in der Konfig aufpassen bei 4 Karten aber sollte das noch klappen. Es muss sonst nichts weiter in so einen Rechner rein, ausser Diskettenlaufwerk, Prozessor und etwas RAM (128 Mbit genügen). Ein kleiner "arme Leute" (poor mans) Router aber er macht was er soll und darauf kommt es an.
Bitte warten ..
Mitglied: Schranzer23
03.05.2006 um 21:29 Uhr
Okay, dann werd ich mich mal umschauen
ob ich entweder günstig ne kleine pc kiste bei
ebay ergattern kann oder halt nen VLan Switch.

Letzteres würd mir eher gefallen aufgrund der Stromkosten, so
wären dann fast drei Rechner den ganzen Tag an und zwei Rechner
(Fli4l und Server) - Wenn ich außer haus bin.

However, danke erstma für eurer posts, nu kann ich wieder
mich ohne schwierigkeiten und Gewissensbisse was falsch gemcht zu
haben, an meine Baustelle begeben

super jungX !
Bitte warten ..
Mitglied: Schranzer23
31.05.2006 um 20:35 Uhr
Hallo ich mal wieder, habe mir nun einen
Nortell Baystack 350-T/24 bei ebay ergattern können.

Dieser kann nun mein lang ersehntes VLAN usw.
Ich habe diese Problematik auch in einem anderen Forum gepostet, erstmal
kommt wieder meine Netzwerkkonfig, hat sich nicht viel getan !! (nicht viel ist relativ) =)

so bitte hier der Post und Problembeschreibung, wenn mir jemand helfen kann
wäre das SUPER !!!
Aus anderem Forum (copy paste)

....>>>
(Ist mein erster Switch im profi-bereich)

Um meine Problemaufstellung zu vereinfachen hier
erstmal die Portconfig
/------------------------------------------------------------
Insgesamt VIER VLANS
1,3,5,7,9,11 - 32 Subnet (192.168.32.0) VLAN: SUB-32
2,4,6,8,10,12 - free sub (0.0.0.0) VLAN: SUB-FREE

13,15,17,19,21,23 - 48 Subnet (192.168.48.0) VLAN: SUB-48
14,16,18,20,22,24 - 80 Subnet (192.168.80.0) VLAN: SUB-80
/-------------------------------------------------------------

Die Ports [b]23, 24[/b] haben das Tagged Tag bekommen, weil
dort jeweils ein Patchkabel (kein kreuz) zu einem Router geht.
Der Router hat VIER PORTS (Zwei vom SW belegt).

[1] [3] [5] [7] [9] [11] | [b][13][/b] [15] [17] [19] [21] [23]
|
[2] [4] [6] [8] [10] [12] | [b][14][/b] [16] [18] [20] [22] [24]
Der Switch hat folgende Konfig unter den IP Settings
In-Band Stack IP-Adress: 0.0.0.0
In-Band Switch IP-Adress: 192.168.32.2
In-Band Subnet Mask: 255.255.255.128
Default Gateway: 192.168.16.1

Der Router dagegen
IP: 192.168.16.1
SB: 255.255.255.128

>> Routing table
RIP: both
192.168.16.0 | public | GW: 192.168.16.1 | MT: 2
192.168.32.0 | public | GW: 192.168.16.1 | MT: 2
192.168.48.0 | public | GW: 192.168.16.1 | MT: 2
192.168.80.0 | public | GW: 192.168.16.1 | MT: 2
[b]Zum Server[/b]
VIER NICS
#NIC1 (Patchkabel zum VERTEILER)
192.168. 32. 1
255.255.255.128
>> VOM VERTEILER ZUM ROUTER auf PORT 1 (Internet OK)

#NIC2 (Patchkabel zum SWITCH)
192.168. 48. 1
255.255.255.128

#NIC3 (Patchkabel zum SWITCH)
192.168. 80. 1
255.255.255.128

#NIC4 (Crossover zum CLIENT)
192.168.112. 1
255.255.255.128
[b]Zum Client[/b]
DREI NICS
#NIC1 (Patchkabel zum VERTEILER)
192.168. 16. 3
255.255.255.128
>> VOM VERTEILER ZUM ROUTER auf PORT 2 (Internet OK)

#NIC2 (Patchkabel zum SWITCH)
192.168. 32. 3
255.255.255.128

#NIC3 (Crossover zum SERVER)
192.168.112. 2
255.255.255.128

<<<< SOVIEL ERSTMAL ZU MEINER HEIMNETZWERKINFRASTRUKTUR

Jetzt zum Problem:
Wenn ich über den SERVER per VMware auf #NIC3 eine IP vom Server
bekomme (In jedem Subnetz habe ich jeweils einen Bereich vom DHCP-Server eingespeisst)
funktioniert das, sprich die VM bekommt eine IP, eine Subnetzmaske, die
DNS Informationen und alles nötige was ich eingestellt habe, Die Pings
auf die IP von der VM zum SERVER funktionieren. Jedoch bekomme ich
keine Ping zum Router, geschweigedenn lassen sich internetseiten oder ping www.google.de
aus der VM ausführen.

WARUM NICHT ?? - was habe ich falsch gemacht, das IP-Design sollte soweit
funktionieren, wie gesagt mein erster SW im Profibereich, habe ich die VLANS
falsch eingestellt. Ich habe gelesen, das jeder Port in einem VLAN der zu einem
Router oder anderen SWITCH geht das TAGGING: Tagged Trunk bekommen muss, das habe ich
auch gemacht. Die anderen für das VLAN konfigurierten Ports haben dann das U tag bekommen, also
nur die Ports für die das VLAN aktiv sein soll. Alle anderen haben den - bekommen (was denke ich mal
heißen soll, hier hat das VLAN keinen zugriff).

Bitte helft mir so gut ihr könnt, ich wäre super dankbar. Falls ich was vergessen haben
sollte erstmal das gemekel posten falls ich vom IP-DESIGN was falsch gemacht habe, bitte
dafür einmal schlagen und verprügeln und nun auf die Suche fertig los !

Vielen Dank für diejenigen die sich Zeit nehmen sich damit zu beschäftigen
Bitte warten ..
Mitglied: aqui
01.06.2006 um 00:51 Uhr
Das ist klar warum du keinen Ping vom Router bekommst
Du schreibst oben das du auf den Links zum Router das Tagging am Switch eingeschaltet hast. Damit setzt der Switch einen 802.1q Tag an den Ethernet Frame. Das wiederum versteht dein Router nicht, denn der möchte ganz normale untagged Frames aus dem VLAN Segment sehen ! Für den sind das dann viele ungültige Ethernet Frames da die Tag Erweterung am Frame den für ihn ungültig macht.
Tagging benutzt man NUR auf Switch Trunks um auf einer Switch to Switch Verbindung transparent die VLAN Information mit zu übertragen.
Im Tag steht die VLAN ID damit der Empfängerswitch (...der versteht nämlich wieder Tags wenn er auf dem Interface dafür konfiguriert ist) diesen Frame wieder zum richtigen VLAN zuordnen kann und vice versa....
Dein Router versteht diese Tags nicht und dropped diese Frames.
Schalte das Tagging aus und dann klappts auch mit dem Ping
Bitte warten ..
Mitglied: Schranzer23
01.06.2006 um 06:05 Uhr
boar danke !!!! )))))))))

Super der ping funktioniert aus der VM RAUS

ich kann aus der VM den Host erreichen mit
ping
...32.1
...48.1
...80.1
---

Jetzt klappt nur der Ping auf 192.168.16.3 nicht (Das ist der Client)
Problematik auf Client
die NIC mit 16.3 hängt direkt an dem Router (über ein Patchfeld)

Die VM hängt am SWITCH (und vom Switch ein kabel zum Router [Port 23]

danke für die rasend schnelle Antwort A
Bitte warten ..
Mitglied: aqui
05.06.2006 um 14:37 Uhr
Mmmhhh, ist das eine Punkt zu Punkt Verbindung mit Crosskabel Router - Client ??
Hat der Client die richtige Routeradresse als default Gateway eingetragen ??? Hast du keinen Fehler mit den Subnetzmasken auf allen Systemen gemacht ??? (Du hast krumme" .128er Masken, d.h. bei Hostadressen jenseits der .127 ist immer ein Wechsel in ein anderes Netz bei dir.)
Sind alle Zielnetze die NICHT direkt am Router angeschlossen sind auf diesem statisch konfiguriert mit statischen Routen ??
Ich vermute mal das das jetzt nur noch ein kleiner Routing "Kinken" ist.
Mit "traceroute" oder "tracert" (bei Windows) kannst du eigentlich immer schön sehen wie weit du kommst...
Bitte warten ..
Mitglied: Schranzer23
05.06.2006 um 19:20 Uhr
Hi,
also sind erstmal alles Patchkabel keine gekreutzten, außer das vom Client DIREKT zum Server im 112 er Subnet

Alle IP-Adressen sind mit der Subnetzmaske 255.255.255.128 anzutreffen
Listing:
#Router
192.168.16.1
255.255.255.128

#Client
192.168.16.3
255.255.255.128
192.168.16.1 > GW

#Server
192.168.32.1
255.255.255.128
192.168.16.1 > GW

192.168.48.1
255.255.255.128
Kein > GW (da die Nic als zweitnic im Server ist und ein default GW schon vorhanden ist)

192.168.80.1
255.255.255.128
Kein > GW (da die Nic als zweitnic im Server ist und ein default GW schon vorhanden ist)

Statische Routing tabelle im Konfigurationsmenü des Routers
Routing table
RIP: both

Route1 : 192.168.16.0 | public | GW: 192.168.16.1 | MT: 2
Route2 : 192.168.32.0 | public | GW: 192.168.16.1 | MT: 2
Route3 : 192.168.48.0 | public | GW: 192.168.16.1 | MT: 2
Route4 : 192.168.80.0 | public | GW: 192.168.16.1 | MT: 2

Vom Router gehen die PORTS , 3 und 4 zum SWITCH (Patchkabel)
Vom Router geht der PORT 1 zum SERVER (Patchkabel)
Vom Router geht der PORT 2 zum CLIENT (Patchkabel)

Danke und viele grüße Schranz0r

EDIT:

Also wenn ich einen Ping an 192.168.32.1 machen kommt keine Antwort

Wenn ich aber (route add 192.168.32.0 MASK 255.255.255.128 192.168.16.1 METRIK 2) eingebe und den ping erneut ausführe, geht mein Netzwerk, wat is jetzt kaputt ? :D
Bitte warten ..
Mitglied: aqui
06.06.2006 um 22:17 Uhr
Wenn ich recht verstehe routest du ja nun über deinen Layer 3 switch oder ???

Dann sind deine Routing bzw. Default Gateway Einträge falsch ! Der Server ist im .32er Subnetz hat aber als Gateway die 16.1 eingetragen, das darf eigentlich nie sein, denn ein default Gateway muss sich immer im selben IP Segment befinden wie das System selber das es nutzt. Wie sollte er denn sonst die Adresse des Gateways finden ?? Er kennt ja das 16er Netz nicht ! Das kann also nur über NIC 2 3 oder 4 gehen. Die Gateway Einträge der NICs 2,3 und 4 müssen also immer auf die IP Adresse des VLAN Switches in diesen Segmenten zeigen sofern der auch routet !
Oder hattest du jetzt einen separaten Router mit jeweils einem Bein in den VLANs ??? Dann müssen die def. Gateway Einträge aller maschinen in diesen VLANs auf die IP des Router beins in dem jeweiligen Segment zeigen, nicht nur auf ein einziges Segment !
Ich habe etwas den Überblick über dein aktuelles Netz verloren. Vielleicht postest du nochmal eine aktuelle Zeichnung mit IP Adressen der Netze, das erleichtert das Troubleshooting !
Auf den Endgeräten brauchst du in diesem Senario eigentlich keinerlei Routen statisch zu konfigurieren !!!
Bitte warten ..
Mitglied: Schranzer23
07.06.2006 um 05:33 Uhr
Hier ich hab mich heute dran gesetzt und allet neugemacht, ich hoffe ihr versteht es

http://www.future-inc.de/files/Infrastruktur_Detail_aktuell.jpg
Bitte warten ..
Mitglied: aqui
07.06.2006 um 14:11 Uhr
Ok, dann wolln wir mal sortieren:

1.) Dein 4 Port Router: Hat der 4 unabhängige routebare Ports oder ist das ein integrierter 4 Port Switch im System wie es die meisten Consumer Systeme haben ?
Routest du die VLANs damit oder kann dein Baystack routen also ist der Switch Layer 3 fähig ???

2.) Der Anschluss am Client ist etwas unverständlich mit den 2 Ports die vom Router kommen. Routet der Router darf das so nicht sein ! 2 Routerinterfaces dürfen nicht in ein gemeinsames Layer 2 Netz münden. Wenn du mit dem Baystack routest ist das so ok.
Die 2 Ports rechts am Client, sind das separate NICs oder nur eine Verbindung ?

3.) Dein .112er Subnetz ist so wie ich sehe nur eine Punkt zu Punkt Verbindung. Muss eigentlich nicht sein, da beide maschinen ja über ihre VLANs erreichbar sind aber du wolltest glaube ich etwas mit Routing spielen deshalb hast du sie wohl mit aktiviert. Dies Netz ist aber isoliert und du musst dem Router (entweder dem externen oder den im Baystack wenn du über den Switch routest) eine statische Route dafür bekannt machen. Da du mehrere Interfaces am Server hast musst du dir eines aussuchen für den Zugang.
Im Switch muss dann sowas stehen wie:
ip route 192.168.112.0 255.255.255.128 192.168.48.1
Ich habe mich jetzt mal für NIC2 entschieden Du musst natürlich Routing auf dem Server enablen mit dem Registry Patch unter:
www.microsoft.com/windows2000/de/server/help/default.asp?url=/windows2000/de/server/help/sag_TCPIP_pro_EnableForwarding.htm

Auf der NIC am Client die im 112er Subnetz ist solltest du KEIN Gateway (oder das der .32er Seite) konfigurieren, da am besten alles über das .32er Netz rausgehen sollte um eindeutige Wege zu haben. Nur der Server sollte ins 112er Netz routen.

Wichtig zu wissen ist aber ob du über den Baystack routest oder über den externen Router.
So oder so MÜSSEN alle Gateway Adressen an den Endgeräten sei es Server oder Client immer auf die zu ihrem Segment (VLAN) korrespondierende IP Adresse des Routers zeigen.
Bitte warten ..
Mitglied: Schranzer23
07.06.2006 um 16:36 Uhr
Hallo, jetzt müssen erstma noch n paar dinge geklärt werden

ich arbeitte mich mal schritt für schritt deinem post vorwärts:

1.) Der Router ist ein Kombigerät sprich (DSL-Modem, Switch, Firewall, DynDNS, DHCP)

2.) Hups hatte ich vergessen einzuzeichnen, ja das sind ZWEI NICS, sprich der Client hat DREI INTERNE NETZWERKINTERFACES.
NIC3 ist eine punkt zu punkt Verbindung (eigentlich nicht sinnig, jedoch unterstützt diese 1000MB/s und somit lassen sich Daten vom Client zum Server besser rüberschaufeln. (Der Server hat auch eine interne onboard NIC die 1000MB/s kann (SOMIT is das 112er Subnet abgedeckt), die interfaces haben beidseitig nur Verbindung untereinander, keine DNS oder GW settings wurden eingestellt (Ausser das der Client seine eigene IP als Prim DNS hat und der Server seine eigene IP als prim DNS [112.2 und 112.1]) << hoffe das war jetzt nicht zu umständlich

3.) Wie das Netz bis jetzt aussieht:
Der Server das hast du richtig erkannt soll von aussen als primären Adapter das 32.1 er Subnet benutzen (ohne Umwege über den SWITCH)

NIC 2 und NIC 3 sind ja jeweils einem VLAN zugeordnet, sprich der Switch wurde in vier weitere Switches unterteilt (so hab ich das mit dem VLAN zumindest verstanden) - deswegen hatte ich die Grafik vom SWITCH unten auch noch einmal aufgezeichnet.

Da NIC 2 und NIC 3 fast ausschliesslich nur unter VMWare benutzt werden (um die Netzwerklast unter den VMS aufzuteilen) sollen diese auch getrennt benutzt werden.
Deswegen hat jedes VLAN (3 und 4) jeweils ein kabel welches zu einem Port an dem Router führt (Der Internetconnectivität wegen) Zudem will ich vom CLient später mal
(über den Router hin zum VLAN 3 über das 48.0 er Subnet eine VM erreichen die Beispielsweise Backup dienste liefert).

Sinn des ganzen ich kann zum Beispiel eine VM als Backup Server einrichten, die mir die ganze
Bandbreite auf der NIC 2 Wegfuttert und gleichzeit auf NIC 3 in einem anderen Subnetz (80.0) Andere Dienste benutzen die ebenfalls hohen Traffic verursachen.

Uff ich hoffe ihr habts kapiert :D ??

Das mit dem reg patch stell ich erstmal nach hinten, da der Windows Server bald durch
ein Linux oder Unix System ersetzt wird. (Spart Resourcen, Zeit, liefert Sicherheit und ich bin nun endlich nichtmehr an die drecks Laufwerksbuchstaben gebunden) Bei bald 7 Festplatten, die in mehrere Software RAIDS aufgeteilt sind, wird der Überblick mit den Laufwerksbuchstaben recht knapp und schwer ^^

EDIT:
Was meinten Sie damit

ZITATSo oder so MÜSSEN alle Gateway Adressen an den Endgeräten sei es Server oder Client immer auf die zu ihrem Segment (VLAN) korrespondierende IP Adresse des Routers zeigen.)

- Soll das soviel heissen wie ich muss an der NIC 2 (48.1) im Windows Server den Gateway 192.168.32.2 (SWITCH IP-Adresse) oder (192.168.16.1 (Router IP-Adresse) eintragen ?
konnte das nicht sichten.

Bis jetzt steht bei der NIC 1 (32.1) als GATEWAY die 192.168.16.1, internet usw. klappt auch alles, will ich jetzt einen weiteren Gateway einrichten (bei einer anderen NIC) meckert der win server rum ich soll doch bitte nur ein default gateway benutzen
Bitte warten ..
Mitglied: aqui
08.06.2006 um 18:37 Uhr
Die wichtigste Frage hast du nicht beantwortet: Routet der Switch oder nicht ???
Wenn er es nicht tut, was ich vermute hast du einen Designfehler im Netz !!!
Du führst die eigentlich sauber getrennten VLANs 3 und 4 ( Das VLAN Konzept hast du richtig verstanden !) wieder zusammen über einen Layer 2 Switch am Router. Das ist aus IP Sicht tötlich und designmäßig nicht erlaubt, denn nun fähst du ja mit 2 IP Adressen mit einmal wieder auf einer Infrastruktur. Ein Umstand den du ja eigentlich mit deinem VLAN Switch vermeiden wolltest !! Das ist dein Problem !
Du musst dich entscheiden wo dein Layer 3 Switching also dein Routing stattfinden soll. An diesem Router kommen volkommen getrennt alle IP Segmente (VLANs) an und nur dieses System ist für das Layer 3 forwarding in deinen lokalen Segmenten verantwortlich. Alle haben dann natürlich als default Route den Internet Router aber das ist nur Kosmetik erstmal.
Daraus resultieren deine Probleme.
Wenn der Bay Switch nicht routen kann musst du es über den Server machen oder mit einem externen Router wie z.B. einen FLI4L Diski Router und 3 oder 4 Netzwerkkarten als Recycling für ein altes Mainboard der dann immer ein Bein in den VLANs hat. Als Gateway Adressen MÜSSEN dann immer diese Segmentadressen des Routers genommen werden. Dein Internet Router kann natürlich nicht auf dem gleichen Interface von einem Netz ins andere routen !
Bitte warten ..
Mitglied: Schranzer23
08.06.2006 um 19:53 Uhr
Ei ich glaub ich hab kapiert was du meintest,

also wenn ich richtig liege dann führe ich meine getrennten VLANS (48.0 und 80.0)
wieder am Router zusammen - Was somit falsch ist.

Dann müsste ich die Kabel die vom Router in die getrennten VLANS gehen entfernen
und somit übernimmt dann der Server Das Routing für die beiden Netze. Da ja
Internet Traffic über die Lankarte 32.1 geht.

Ich glaube nicht das der Switch Layer 3 Switching kann, ich bin mir da nicht sicher
in den Dokumentationen konnte ich es bis jetzt nicht auslesen (da der Switch be ebay
ersteigert wurde und mir die Original Handbücher nicht vorliegen).

Dann müsste ich das ganze so konzepieren dass der Server für die VLAN Netze die Internetfunktionalität bereitstellt habe ich das richtig verstanden ??

Jedoch möchte ich nicht das der Client über den Server in das Internet geht, ist das denn
dann soweit in Ordnung vom Design her?

Endresultat wäre dann schliesslich das nur EIN Kabel zur Workstation führt und ein Kabel zum Server, der dann für sich selbst Internetconnectiviät bereit hält und für die beiden VLANS (48.0 und 80.0)

Somit bekommt doch dann der Client als default GW den Router 192.168.16.1
Der Server behält den default Gateway für die Karte 32.1

Und die VMS die über die VLANS 48.0 und 80.0 laufen bekommen dementsprechend dann
je nach Subnetz als default GW 192.168.48.1 und 192.168.80.1 ?

wenn ich damit nun völllig falsch liege bitte ich Sie mir das zu erklären warum das nicht möglich ist, bzw. wo mein Verständnisproblem liegt

Schonmal danke für Ihre bisherigen Beiträge, damit bin ich erstmal ein großes Stück vorrangekommen.

PS: Ich möchte erstmal auf einen poor linux router verzichten, der Stromkosten wegen und vor allem da er wieder wärme produziert. Oder hält sich das ganze in Grenzen ??

bis jetzt läuft in meinem kleine 6m x 5m Zimmer eine Workstation (480Watt NT) ein Server mit (500Watt NT) der Switch (bei bedarf mit 3 internetn Lüftern und 220V anschluss).

EDIT:
Was ich bisher dachte was Router machen, ist das Sie 4 (in meine Beispiel) getrennte Interfaces haben, die sich individuell konfigurieren lassen. Ich hatte nicht gewusst, dass die vier ports an dem Router als ein Interface zu verstehen sind, dann ist klar das das Quatsch ist weil ja der Server mit seinen Drei NICS alle auf die Drei Ports zum Router Laufen oddaaa ???
Bitte warten ..
Mitglied: aqui
10.06.2006 um 13:13 Uhr
Ja, genauso sieht das Szenario aus und du hast es richtig verstanden !!
Wenn du einen zentralen Router hast muss iregndein anderes Gerät zwischen den VLANs/Subnetzen routen. Das bedeutet letztendlich das natürlich auch aller Internet Traffic über den Server greroutet wird in die Subnetze das ist richtig.
Um zu verhindern das Clients das Internet aus Subnetzen nutzen was du nicht willst, trägst du dieses Netz einfach am Internet Router nicht ein ! Diese Netze müssen hier im Routing ja statisch definiert werden sonst weiss der Router nicht wohin damit. Ohne diese Routing Einträge serviced der Router nur das Segment was an ihm selber dran hängt. Ausnahme wäre du "nattest" hier Subnetze mit einer IP Adresse aus dem Segment hier rein, aber das ist in deinem Szenario nur mit Umwegen möglich...würd ich auch nicht machen, da die ganze Sache dann noch unübersichtlicher wird.

Die Doku für den Baystack350 und auch ein paar Tips findest du hier:
www130.nortelnetworks.com/cgi-bin/eserv/cs/main.jsp?cscat=DOCUMENTATION&resetFilter=1&poid=8141
Bitte warten ..
Mitglied: Schranzer23
10.06.2006 um 21:41 Uhr
Hut ab !

Vielen Dank, ich werd mal mein Netzwerk hier ummodeln, ehrlich danke für die tollen Antworten, bin begeistert


Falls ich hier noch Fragen habe (die mit Sicherheit auftreten werden), melde ich mich wieder hier

bis dahin

viele grüße und großen Dank und dickes lob !! - Schranz0r -
Bitte warten ..
Neuester Wissensbeitrag
Microsoft

Lizenzwiederverkauf und seine Tücken

(5)

Erfahrungsbericht von DerWoWusste zum Thema Microsoft ...

Ähnliche Inhalte
Windows Netzwerk
Windows Server 2003 SBS Netzwerk durch neuen Server Ersetzen (9)

Frage von MultiStorm zum Thema Windows Netzwerk ...

Exchange Server
gelöst Microsoft Excange Server 2007 auf Windows Server 2003 Installieren? (9)

Frage von Herbrich19 zum Thema Exchange Server ...

Windows Server
gelöst Suche Windows Server 2003 Enterprise ISO (8)

Frage von Herbrich19 zum Thema Windows Server ...

Server
gelöst Client bei Windows Server 2003 ändern (5)

Frage von Therealcookie zum Thema Server ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (18)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Windows Netzwerk
Windows 10 RDP geht nicht (16)

Frage von Fiasko zum Thema Windows Netzwerk ...

Windows Server
Outlook Verbindungsversuch mit Exchange (15)

Frage von xbast1x zum Thema Windows Server ...