Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows Server 2003 (SP2) nicht mehr ansprechbar

Frage Microsoft Windows Server

Mitglied: franc

franc (Level 2) - Jetzt verbinden

27.09.2008, aktualisiert 08.12.2008, 19453 Aufrufe, 13 Kommentare

Guten Tag,
ich habe ein fieses Phänomen auf meinem Windows Server 2003 (SP2):
gelegentlich, also nicht oft, vielleicht alle 1 bis 2 Monate, fängt plötzlich ein Fehler an, das System-Ereignisprotokoll zuzuballern:

Quelle: Application Popup
Kategorie: Keine
Ereigniskennung: 333

Ein E/A-Vorgang, der durch die Registrierung ausgelöst wurde, ist fehlgeschlagen. Dieser Fehler ist nicht korrigierbar. Die Registrierung konnte eine der Dateien mit dem Systemabbild der Registrierung nicht einlesen oder schreiben.


Zwei Ereignisse gleichzeitig, dann nach jeder Minute wieder.
Das Ereignis unmittelbar (2 Minuten) davor:

Fehler, Srv, 2020
Der Server konnte keinen ausgelagerten Poolspeicher reservieren, da der Pool leer war.


Der Server ist dann aber auch unansprechbar, antwortet zwar noch auf Ping, aber die Dienste sind nicht mehr nutzbar.
Ich muss ihn dann Resetten, danach geht wieder alles ganz normal.
Ich finde keinen Hinweis, was das nun verursacht. Ich kriege das aber dummerweise erst mit, wenn der Server schon (quasi) steht, so dass ich nicht mehr nachschauen kann, was da jetzt los ist (muss dann möglichst schnell wieder laufen, bin auch meistens nicht vor Ort, lasse also per Telefon auf Reset drücken).

Kann mir da jemand einen Tipp geben?

Danke, franc
Mitglied: MaFa
29.09.2008 um 11:47 Uhr
Hallo

schau dir mal http://support.microsoft.com/kb/312362/de an.

Gruß
Bitte warten ..
Mitglied: franc
06.10.2008 um 12:31 Uhr
Danke Manuel für den Tipp, leider hat das nichts geändert.
Ich habe den Poolspeicher geändert, aber der Fehler kam (schnell) wieder.

Die Fehlermeldung (im System-Ereignisprotokoll) heißt immer:

Quelle: Application Popup
Ereigniskennung: 333

Ein E/A-Vorgang, der durch die Registrierung ausgelöst wurde, ist fehlgeschlagen. Dieser Fehler ist nicht korrigierbar. Die Registrierung konnte eine der Dateien mit dem Systemabbild der Registrierung nicht einlesen oder schreiben.


Diesmal ohne den Srv-Fehler 2020 unmittelbar davor.
Dieser kam aber dennoch gelegentlich wieder (-anscheinend ist er wohl nur eine Folge des Application Popup Fehlers).

Die Application Popup-Fehlermeldung fängt (z.B. am 05.10.2008) so an:

09:55:29
09:55:35
09:55:41
09:56:32
09:57:32
09:58:32
09:59:32
10:00:05
10:00:32
10:01:32
usw. mal minütlich mal öfters bis zum Server-Reset.

Und nach dem Reset des Servers (am 06.10.2008 um 09:14:18) kommt eine Meldung:

Das System wurde zuvor am 05.10.2008 um 09:55:27 unerwartet heruntergefahren.

Das ist also unmittelbar vor dem Beginn der Fehlertirade!

Und davor das letzte System-Ereignis ist lediglich eine Information vom Service Control Manager am 04.10.2008 um 21:44:05:
Dienst "WinHTTP-Web Proxy Auto-Discovery-Dienst" befindet sich jetzt im Status "Beendet".

In den anderen Protokollen gibt es auch keinen Hinweis auf Verursacher.
Der Server läuft auch noch weiter, wenn auch sehr eingeschränkt (z.B. mit Meldungen von Security, Systemereignis, 516, wie: Die für die Überwachung reservierten internen Ressourcen sind ausgelastet. Dies wird zu einem Verlust von Überwachungsereignissen führen.). Er lässt sich noch anpingen. Aber (natürlich) kein Zugriff via Remote Desktop (RDP). Auch kein Zugriff auf Freigaben.
Der Server hat ein Raid 1 Plattenverbund mit zwei Platten (ohne Fehler).

Was kann ich tun?
Bitte warten ..
Mitglied: MaFa
06.10.2008 um 13:01 Uhr
Hallo,

um hier nicht alle Fragen, wie z.B. welche Backup Software und andere Anwendungen im Einsatz sind, einzeln stellen zu müssen, gibts bei dem nachfolgenden Link
ein sehr aufwendiges und gut ausgearbeitetes Workaround für den Fehler 333 und
die Folgefehler (2020, 2019 ...etc pp)

http://blogs.technet.com/perfguru/archive/2008/06/24/how-to-troubleshoo ...

Ich hoffe, dass dir der Link hilft.

Gruß

Manu
Bitte warten ..
Mitglied: franc
07.10.2008 um 00:52 Uhr
Danke für den Link.
Ich hab jetzt mal defragmentiert (war nötig) und für srv.sys den Hotfix 927435-v2 installiert (musste ich erst per Mail beantragen).
Ich hab sonst unter den vielen Tipps dort aber nichts gefunden, was so recht gepasst hätte.
Auf dem Server läuft übrigens keine Virensoftware oder Firewall.
Aber Acronis TrueImage 8.01.0000.1213 läuft dort (also ständig die TrueImageMonitor.exe). Aber ohne aktiven Task.
Ob ich das mal deinstallieren sollte?

Zum Verständnis: Ist der 333er Fehler etwa ein Folgefehler von irgendwas?
Bitte warten ..
Mitglied: MaFa
07.10.2008 um 09:34 Uhr
Moin,

bei einigen Systemen soll wohl geholfen haben, die Auslagerungsdatei zu vergrößern.
Wieviel Arbeitsspeicher hat der Server und wie sind die Werte für die Auslagerungsdatei eingestellt?

Das Acronis würde ich erstmal nicht deinstallieren. Da dein Fehler ja erst nach 1-2 Monaten auftritt und du ja anscheinend deine Datensicherung darafu realisierst.

Interessant wäre aber noch, welche Einträge im Anwendungs- und Systemprotokoll eingetragen werden, bevor der Server mit den Fehlern beginnt.

Gruß

Manu
Bitte warten ..
Mitglied: franc
07.10.2008 um 10:17 Uhr
Der Server:

AMD Athlon(tm) 64 Processor
3500+
2.21 GHz, 2,00 GB RAM
Physikalische Adresserweiterung


Die Auslagerungsdatei-Einstellungen:

Größe der Auslagerungsdatei für ein bestimmtes Laufwerk:
Laufwerk: C: [Boot] Verfügbarer Speicherplatz: 39406 MB
x Benutzerdefinierte Größe: Anfangsgröße (MB): 2046 Maximale Größe (MB): 4092


Ich habe die Auslagerungsdatei jetzt auf Laufwerk D gestellt (C: - Keine Auslagerungsdatei) und auf "Größe wird vom System verwaltet" umgestellt.

Im Systemprotokoll ist leider unmittelbar vor Beginn des Fehlers nichts zu finden:

Fehler 05.10.2008 09:55:29 Application Popup Keine 333
Informationen 04.10.2008 21:44:05 Service Control Manager Keine 7036
Informationen 04.10.2008 21:44:05 WinHttpAutoProxySvc Keine 12517
Informationen 04.10.2008 21:44:05 WinHttpAutoProxySvc Keine 12503
Informationen 04.10.2008 21:27:35 Service Control Manager Keine 7036
Informationen 04.10.2008 21:27:35 Service Control Manager Keine 7035


Im Anwendungsprotokoll steht noch weniger:

Fehler 05.10.2008 12:17:29 ESENT Protokollierung/Wiederherstellung 439
Fehler 05.10.2008 12:17:29 ESENT Allgemein 488
Fehler 05.10.2008 11:27:03 Userenv Keine 1081
Informationen 03.10.2008 09:10:45 APCPBEAgent Keine 1004


Die Datensicherung mache ich nur sporadisch (manuell) mit Acronis. In der Hauptsache werden die Daten auf eine externe Festplatte und auf ein Band gesichert. Das geschieht mit dem Taskplaner und mit Iomega Automatic Backup Pro (für das Bandlaufwerk).
Bitte warten ..
Mitglied: MaFa
07.10.2008 um 10:29 Uhr
Ehrlich gesagt viel mehr fällt mir so auch nicht ein.

Eventuell anfangen die optionalen Geschichten temporär zu entfernen / aktualisieren.
- Acronis
- USV Software (APC)
- ...

Vlt auch nicht benötigte Hardware mal temporär rausnehmen/entfernen. (Streamer, USB HDD)

Wenn alle Stricke reissen, würde ich ein Vollbackup mit Acronis erstellen und eine Windows Reparaturinstallation durchführen.

Habe ich schon mehrfach erfolgreich durchgeführt. Aber bitte nur mit vorherigen Vollbackup, wo du Ahnung von hast wie man den Server ohne Probleme wiederherstellen kann !

Gruß
MaFa
Bitte warten ..
Mitglied: franc
07.10.2008 um 10:44 Uhr
Das Dumme ist, dass es evtl. so lange dauert, bis dieser Fehler aufläuft. Dass ich ihn nicht reproduzieren kann.

Die Auslagerungsdatei hab ich wieder auf C: gestellt (aber automatisch zugeordnete Größe), da D: sowieso nur eine Partition ist.
Bitte warten ..
Mitglied: MaFa
07.10.2008 um 11:03 Uhr
Zitat von franc:
Das Dumme ist, dass es evtl. so lange dauert, bis dieser Fehler
aufläuft. Dass ich ihn nicht reproduzieren kann.


Jo das stimmt, sicherlich das größte Manko bei der Fehlersuche.
Bitte warten ..
Mitglied: franc
07.10.2008 um 11:06 Uhr
Falls ich jemals den Fehler lokalisieren kann, werde ich es hier mitteilen.
Bitte warten ..
Mitglied: franc
08.12.2008 um 17:52 Uhr
... bis jetzt noch nicht wieder aufgetreten... (*tock_tock_tock*)
Bitte warten ..
Mitglied: franc
10.10.2009 um 01:55 Uhr
Immer noch nicht wieder aufgetreten. Ich vermute also schwer dass es an der Fragmentierung lag.
Bitte warten ..
Mitglied: franc
01.06.2011 um 11:03 Uhr
Bis heute nie wieder aufgetreten, es war wohl ziemlich sicher die Fragmentierung.

THREAD GESCHLOSSEN
Bitte warten ..
Ähnliche Inhalte
Windows Server
Windows Server 2003 SP2 Neustart bei Passwort zurücksetzen
Frage von razer1993Windows Server7 Kommentare

Ich habe das Problem, sobald ich bei einen Benutzer das Passwort zurücksetzen will gibt mir der Server einen Fehler ...

Firewall
Agfeo Server Ports 5080 nicht ansprechbar
gelöst Frage von lnvictusFirewall9 Kommentare

Hallo Gemeinde, bin hier schon länger im Forum unterwegs, wenn es um neue News oder Lösungen von Problemen geht. ...

Windows Server
Windows Server 2008 R2 Ent. Sp2
Frage von VanWebbyWindows Server1 Kommentar

Liebe Com. Bei den Einstellungen der GPOs ist uns ein Fehler unterlaufen. Wir wollten die Installation und das Öffnen ...

Exchange Server
Exchange 2003 (Windows Server 2003)
gelöst Frage von ET-StudentExchange Server6 Kommentare

Hallo alle zusammen ich hab auf einem alten Server Microsoft Server 2003 und Exchange 2003 installiert und es läuft ...

Neue Wissensbeiträge
Windows 10

Autsch: Microsoft bündelt Windows 10 mit unsicherer Passwort-Manager-App

Tipp von kgborn vor 1 TagWindows 106 Kommentare

Unter Microsofts Windows 10 haben Endbenutzer keine Kontrolle mehr, was Microsoft an Apps auf dem Betriebssystem installiert (die Windows ...

Sicherheits-Tools

Achtung: Sicherheitslücke im FortiClient VPN-Client

Tipp von kgborn vor 1 TagSicherheits-Tools

Ich weiß nicht, wie häufig die NextGeneration Endpoint Protection-Lösung von Fortinet in deutschen Unternehmen eingesetzt wird. An dieser Stelle ...

Internet

USA: Die FCC schaff die Netzneutralität ab

Information von Frank vor 2 TagenInternet5 Kommentare

Jetzt beschädigt US-Präsident Donald Trump auch noch das Internet. Der neu eingesetzte FCC-Chef Ajit Pai ist bekannter Gegner einer ...

DSL, VDSL

ALL-BM200VDSL2V - Neues VDSL-Modem mit Vectoring von Allnet

Information von Lochkartenstanzer vor 2 TagenDSL, VDSL2 Kommentare

Moin, Falls jemand eine Alternative zu dem draytek sucht: Gruß lks

Heiß diskutierte Inhalte
Batch & Shell
Kann man mit einer .txt Datei eine .bat Datei öffnen?
Frage von HelloWorldBatch & Shell16 Kommentare

Wie schon im Titel beschrieben würde ich gerne durch einfaches klicken auf eine Text oder Word Datei eine Batch ...

Router & Routing
OpenWRT bzw. L.E.D.E auf Buffalo WZR-HP-AG300H - update
gelöst Frage von EpigeneseRouter & Routing11 Kommentare

Guten Tag, ich habe auf einem Buffalo WZR-HP-AG300H die alternative Firmware vom L.E.D.E Projekt geflasht. Ich bin es von ...

Windows Server
Ping auf einen bestimmten Server nicht möglich
gelöst Frage von a.thierWindows Server7 Kommentare

Hallo, ich habe folgendes Problem. srv-dc1: Ping srv-nav > geht Ping srv-exchange > geht nicht srv-exchange: Ping srv-dc1 > ...

Hardware
Fujitsu Workstation mit K80 und Quadro P5000, Fehlermeldung: Connect Power Adapter
Frage von MachelloHardware7 Kommentare

Hallo Zusammen, ich benötige euren Rat da ich ratlos bin. Folgende Konfiguration im Büro: Fujitsu Workstation Celcius R940 Power ...