Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows Server 2003 Standart Edition SP1: Batch Datei startet bei einem geplanten Task nicht

Frage Microsoft Windows Server

Mitglied: 25335

25335 (Level 1)

16.02.2006, aktualisiert 16:59 Uhr, 5634 Aufrufe, 7 Kommentare

Hallo zusammen,

ich habe folgendes Problem:

Ich sollte mit Hilfe von Robocopy eine Datensicherung eines Laufwerks vornehmen. Also hab ich auf einem Virtuellen PC, WIN Server 2003 installiert und auf dem Systemlaufwerk 2 Ordner erstellt.

1. Ordner: Quellordner
2. Ordner: Zielordner

Es soll einmal im Monat eine Sicherung der Daten vorgenommen werden und vom Quellordner in den Zielordner verschoben werden (später werden es 2 verschiedene Laufwerke sein)
Nun hab ich ein Script geschrieben (mit Editor und als ".bat" abgespeichert).
Wenn ich diesen Befehl einzeln in der Eingabeaufforderung eingebe führt diese den Befehl auch aus und kopiert die Daten.

Wenn ich diese Batchdatei aber als neuen "geplanten Task" anlege poppt nur kurz das Eingabefenster auf und ich kann lesen, dass der Befehl nicht richtig ist oder nicht gefunden wurde.

Daraufhin habe ich geschaut ob der User die Berechtigung besitzt um "Stapelverarbeitungsaufträge" auszuführen. Das tut der User...

Ebenso hab ich versucht die ".bat" File in eine ".cmd" File umzubenennen, leider ohne das gewünschte Ergebnis.

Das Script sieht folgender Maßen aus:

"Robocopy c:\Quellordner c:\Zielordner\Komplettsicherung /E"

Da ich nicht über genügend backgroundwissen verfüge und ich diese Aufgabe gerne alleine bewältigen würde, wollte ich euch nun um euren Rat bitten.



MfG

Daniel aka Xecutor ;0)
Mitglied: andy0815
16.02.2006 um 14:11 Uhr
Mit den Taskplaner im Windows hatte ich auch schon Probleme, ich würde einfach auf andere Methoden/Sicherungsprogramme zurückgreifen.

Schau dir mal AutoCopy an, damit habe ich früher immer gesichert.
Bitte warten ..
Mitglied: Manji
16.02.2006 um 15:26 Uhr
moin
evtl den kompletten pfad von robocopy mit angeben oder die PATH Variablen überprüfen und gegebenenfalls änder

so long
manji
Bitte warten ..
Mitglied: 25335
16.02.2006 um 16:25 Uhr
Das habe ich alles schon versucht. so lautet dann das script:

"c:\Windows\System32\robocopy.exe
Robocopy c:\Quellordner c:\Zielordner\Komplettsicherung /E"


oder muss ich den 2. Befehl an den ersten anhängen?
Bitte warten ..
Mitglied: Manji
16.02.2006 um 16:31 Uhr
eigtl reicht es so :

c:\windows\system32\robocopy.exe c:\quellordner c:\zielordner\komplettsicherung *.* /e

wobei man den pfad eigtl auch nicht mehr angeben müsste, da sich das programm ja bereits in einem windows-systemordner befindet

ob du das über den scheduler oder manuell aufrufst ist dabei egal ..

falls du noch hilfe bei robocopy brauchst ;) :
http://www.ss64.com/nt/robocopy.html
Bitte warten ..
Mitglied: 25335
16.02.2006 um 16:38 Uhr
Habe nun den Fehler des Problems gefunden.
Ich hatte die batchfile mit einer "UNICODE" Codierung abgespeichert. Nach dem abändern auf den "ANSICODE" funktioniert die batch file.



trotzdem vielen dank für eure einbringungen ;0)
Bitte warten ..
Mitglied: Manji
16.02.2006 um 16:54 Uhr
^^ na dann

hätt mich auch gewundert wenn es einen unterschied zwischen direktem aufruf und aufruf über den scheduler gäbe
Bitte warten ..
Mitglied: 25335
16.02.2006 um 16:59 Uhr
Dieser Satz hat mich auf die (dumme) Idee gebracht die Batchfile als Unicode abzuspeichern...

"ROBOCOPY will accept UNC pathnames.
Robocopy does not run on Windows 95, or NT 3.5. (RoboCopy is a Unicode application)."
Bitte warten ..
Ähnliche Inhalte
Windows Server
gelöst Powershell Skript als geplanter Task (9)

Frage von Ex0r2k16 zum Thema Windows Server ...

Windows Server
Geplante Tasks starten nicht automatisch

Frage von TiTux zum Thema Windows Server ...

Windows Server
gelöst Batch-Datei startet in der Aufgabenplanung nicht (12)

Frage von koehlo zum Thema Windows Server ...

Windows Systemdateien
gelöst Geplante Task einmalig über GPO ausführen (5)

Frage von WinLiCLI zum Thema Windows Systemdateien ...

Neue Wissensbeiträge
Windows Update

Microsoft Update KB4034664 verursacht Probleme mit Multimonitor-Systemen

Tipp von beidermachtvongreyscull zum Thema Windows Update ...

Viren und Trojaner

CNC-Fräsen von MECANUMERIC werden (ggf.) mit Viren, Trojanern, Würmern ausgeliefert

(4)

Erfahrungsbericht von anteNope zum Thema Viren und Trojaner ...

Windows 10

Windows 10: Erste Anmeldung Animation deaktivieren

(3)

Anleitung von alemanne21 zum Thema Windows 10 ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Linksys wrt1200ac v2 mit dd-wrt: keine vlan-einstellungen im GUI (15)

Frage von Pixi123 zum Thema Router & Routing ...

E-Business
Wo tragt ihr eure privaten Termine ein? (13)

Frage von honeybee zum Thema E-Business ...

Batch & Shell
Batch zum suchen und verschieben von Verknüpfungen (12)

Frage von zeroblue2005 zum Thema Batch & Shell ...

Windows Server
Terminalserver starten willkürlich neu (12)

Frage von thaefliger zum Thema Windows Server ...