Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows Server 2008 R2 Standard: Langsamer Zugriff auf dateibasierte Datenbank

Frage Microsoft Windows Server

Mitglied: taschaue

taschaue (Level 1) - Jetzt verbinden

29.12.2014 um 10:22 Uhr, 1457 Aufrufe, 5 Kommentare

Hallo allerseits,

seit einigen Wochen treten bei uns Performanceprobleme beim Zugriff auf eine dateibasierte Datenbank (älteres ERP System) auf. Als Server wird ein Windows Server 2008 R2 Standard DS1 verwendet, die Datenbank ist auf einem DFS-Laufwerk gespeichert (DFS-Replikation zu einem zweiten Windows Server 2008 R2 Standard - DS2). Das DFS-Laufwerk leitet normalerweise auf DS1 weiter (wenn er erreichbar ist) und hier treten dann die Performanceprobleme auf (z.B. langsames Suchen in DB). Greift man jedoch direkt auf DS2 zu, dann treten keine Probleme auf. Beim Kopieren von Größen Dateien von oder auf eine Freigabe auf DS1 über das Netzwerk treten Übertragungsraten in der Größenordnung 80-90MB/s auf, also OK.
Beide Server sind virtualisiert mit VM-Ware ESXi 5.1. mit ähnlicher Hardware (DS2 ist sogar auf älterer Hardware untergebracht). Die Performanceprobleme treten auch von einer anderen VM am selben Host beim Zugriff auf DS1 auf.

Hat von euch jemand schon ein ähnliches Problem gehabt?

Vielen Dank für eure Antworten!

Freundliche Grüße,

taschaue
Mitglied: killtec
29.12.2014 um 10:25 Uhr
Hi,
wo sind denn die Systeme gespeichert? SAN, lokaler Speicher?
Klingt nach einem Lokalem Speicher der die Probleme macht. Wie verhalten sich die Systeme in Sachen Performance wenn du über die vsphere Console drauf gehst?

Gruß
Bitte warten ..
Mitglied: taschaue
29.12.2014 um 10:35 Uhr
Hallo killtec,
Sorry auf die Info hab ich vergessen:
Die Systeme sind auf jeweils auf lokalen Datastores gespeichert. Beim Problemsystem handelt es sich um einen LSI 9260-8i Raid Controller und 8x2TB Festplatten im RAID10 Verbund.
Der funktionierende Server ist ebenfalls auf einem lokalen Datastore mit LSI Controller (genaue Bezeichnung weiß ich jetzt nicht), mit 8x1TB Festplatten und RAID10 Verbund.
Ich habe auch als erstes an ein Datastoreproblem gedacht und habe deshalb schon vorige Woche den Server DS1 von einem anderen Host mit Adaptec 5805 und 8x2TB RAID10 auf den ersten Host (LSI9260) umgesiedelt. Hat aber überhaupt nichts gebracht.

Freundliche Grüße,

taschaue
Bitte warten ..
Mitglied: certifiedit.net
29.12.2014 um 14:09 Uhr
Hallo Taschaue,
um was für eine DB handelt es sich denn? Ggf zu groß?

Grüße
Bitte warten ..
Mitglied: taschaue
29.12.2014 um 14:18 Uhr
Hallo,

die Datenbank besteht aus mehreren Dateien (für jede Tabelle eine Datei) in einen programmspezifischen Datenbankformat. Die Größe aller Tabellendateien gemeinsam beträgt knapp 700MB. Dürfte also kein Problem darstellen.

Freundliche Grüße,

taschaue
Bitte warten ..
Mitglied: taschaue
31.12.2014 um 07:07 Uhr
Danke an alle für die Hilfe!

Ich habe das Problem nun gefunden: Symantec Endpoint Protection (Firewall und Auto Protection) verlangsamte den Zugriff auf die Dateifreigaben. Testweise hatte ich die beiden Funktionen zwar schon deaktiviert aber das half nichts. Nach einer Deinstallation von SEP mit dem CleanWipe Tool (von Symantec Support erhalten, da eine normale Deinstallation immer abgebrochen ist) ist die Performance wieder in Ordnung. Am zweiten Server waren die beiden Funktionen von SEP gar nicht mitinstalliert worden.

Freundliche Grüße

taschaue
Bitte warten ..
Ähnliche Inhalte
Windows Server
Windows Server 2008 R2 Standard Systempartition erweitern
gelöst Frage von BulliTHWindows Server12 Kommentare

Hallo! Ich weiß, dass das Thema schon mal besprochen wurde (2011), aber vielleicht haben sich inzwischen andere Möglichkeiten ergeben? ...

Windows Server
Windows Server 2008 R2 Standard Systempartition clonen
Frage von amandaWindows Server11 Kommentare

Hallo, ich möchte eine Windows Server 2008 R2 Standard Systempartition auf ein neues SSD Raid clonen. Hat jemand bereits ...

Windows Server
Fehler nach Neuinstallation von Windows Server 2008 R2 Standard
gelöst Frage von bellerichWindows Server17 Kommentare

Hallo, ich habe folgendes Problem: Ich habe beim Kunden einen PC-Klasse-Server (von Supermicro, Intel XEON-CPU, Intel-Mainboard, Systemvolume zwei 1TB-Platten ...

Windows Server
Windows Server 2008 R2 - erst langsam, dann keine Reaktion
gelöst Frage von rrobbyyWindows Server10 Kommentare

Hallo zusammen, heute trat zum zweiten Mal innerhalb von 7 Tagen (ganz genau vor einer Woche) das Problem auf, ...

Neue Wissensbeiträge
Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 2 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 3 TagenWebbrowser7 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 3 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Digitiales Fernsehen

Apple TV: Amazon Prime App ist verfügbar

Information von Frank vor 4 TagenDigitiales Fernsehen4 Kommentare

Die Amazon Prime Video App kann ab sofort auf einem Apple TV ab der 3 Generation installiert werden. Einfach ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...