Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit
GELÖST

Windows Server 2008 Terminal Server, Anwendung wird nicht gestartet

Frage Microsoft Windows Server

Mitglied: nordlicht24

nordlicht24 (Level 1) - Jetzt verbinden

22.10.2009, aktualisiert 18.10.2012, 11824 Aufrufe, 8 Kommentare

Mahlzeit,

ich habe folgendes Problem. Ich habe eine Windows Server 2008 Terminal Server Farm welche aus 4 virtuellen Servern besteht. Die Anwendungsbereitstellung erfolgt via RemoteApps, Verteilung der msi-Pakete per GPO in einer Server 2003 Domäne. Der Start der Anwendungen per Doppelklick auf das Icon oder über das Startmenü funktioniert ohne Probleme. Habe ich aber eine Datei-Verknüpfung auf dem Desktop oder wähle die Datei direkt im Dateisystem aus und klicke doppelt erscheint kurz das Fenster für den Verbindungsaufbau, dann bekomme ich folgende Fehlermeldung:

RemoteApp-Fehler

Das Programm %Anwendungsname% wurde nicht gefunden.
Wenden Sie sich an den Systemadministrator, um Unterstützung zu erhalten.

Wie gesagt, alle Anwendungen können gestartet werden, die Dateiverknüpfung zu den Anwendungen ist auch in Ordnung. Meldet sich der Benutzer an der Console des TS an, funktioniert es. Ich habe bereits die msi-Pakete neu erstellt und verteilt, die Anwendungen sind auf allen TS identisch installiert. Der Fehler tritt sowohl beim Aufbau einer neuen Verbindung als auch innerhalb einer bestehenden Session auf. Die Ereignisanzeige ist in allen Bereichen unauffällig.

Weiß jemand Rat?

Gruß aus dem Norden...
Mitglied: manuel-r
22.10.2009 um 13:46 Uhr
MSI-Pakete? Machst du das nicht über den Terminaldienste-RemoteApp-Manager? Damit kann man prima .rdp-Dateien erstellen, die alle notwendigen Infos für den Verbindungsaufbau und die zu startende Anwendung enthalten. Die muss man dann nur noch auf geeignete Weise an den Mann bringen.

Manuel
Bitte warten ..
Mitglied: nordlicht24
22.10.2009 um 14:03 Uhr
Hallo,

ich benutze schon den RemoteApp-Manager. In diesem kann ja aus den RemoteApps entsprechende msi-Pakete erstellen, welche ich per GPO verteilen und bei Bedarf wieder beim jeweiligen User entfernen kann. Die msi's enthalten dann die selben Informationen wie die rdp-Dateien.
Bitte warten ..
Mitglied: manuel-r
22.10.2009 um 15:03 Uhr
Wieder was dazu gelernt
Könnte dein Problem evtl. damit zusammenhängen, dass du die RDPs/MSIs nur auf einem deiner 4 Server in der Farm erstellt hast. Der TS scheint nämlich Anwendungen erst zu veröffentlichen, wenn man auf eben diesem TS mit dem Manager die Dateien erstellt hat. Die anderen TS haben zwar die Anwendung am gleichen Ort, weigern sich aber diese zu veröffentlichen. Das hatte ich hier bei mir auch schon mal als ich von Citrix umgestellt hab - dort ist das nämlich nicht so.
Also hab ich auf den anderen TS einfach auch die RDPs erstellt bzw. die App freigegeben und schon gings. Die RDPs kannst du ja hinterher unauffällig entsorgen
Bitte warten ..
Mitglied: nordlicht24
22.10.2009 um 15:10 Uhr
Nein, die Anwendungen sind auf allen TS veröffentlicht. Es ist auch so, das bei einer laufenden Sitzung, ich habe z.B. MS Word geöffnet und versuche dann per Doppelklick ein anderes Word-Dokument zu öffnen, die gleiche Sitzung genommen wird. Nur das dann oben beschriebener Fehler auftritt. Und der tritt halt nur auf, wenn ich die Anwendungen über die entsprechende Datei öffen will.
Bitte warten ..
Mitglied: nordlicht24
03.11.2009 um 15:34 Uhr
Das Problem ist gelöst. Beim Erstellen des msi Pakets für MS Word ist ein Fehler "eingebaut" worden. Beim Verbindungsaufbau über Word wurden die Netzlaufwerke des Clients nicht in die Sitzung übernommen. Wurde nun ein Dokument von, z.B. Z:\Daten\Word-Dokument, geöffnet, versucht der TS folgendes zu öffenen:

tsclient\Z:\Daten\Word-Dokument

Da aber die lokalen Laufwerke nicht vorhanden sind, konnte er das Dokument nicht finden und gab die oben beschriebene Fehlermeldung aus, welche im übrigen auch noch falsch ist. Die Anwendung würde er ja finden, nur das Dokument nicht.

Stellte man die Verbindung über Programme bei denen das msi in Ordnung ist, funktionierte alles ohne Probleme.
Man kann die durch das msi installierten rdp's mit dem Editor bearbeiten. Ich habe dann die fehlende Zeile für das Laufwerksmapping eingefügt, seit dem funktionierts.

Gruß aus dem Norden...
Bitte warten ..
Mitglied: SimonS
22.08.2011 um 16:53 Uhr
Zitat von nordlicht24:
Man kann die durch das msi installierten rdp's mit dem Editor bearbeiten. Ich habe dann die fehlende Zeile für das
Laufwerksmapping eingefügt, seit dem funktionierts.

Hallo,

ich muss grade mal den alten Thread ausgraben: Ich habe exakt die gleichen Probleme.

Wie und im welchen Format füge ich ich eine Zeile für's Laufwerksmapping ein?

Schönen Gruß,

Simon
Bitte warten ..
Mitglied: 99143
26.08.2011 um 16:12 Uhr
Ich stehe genau vor dem selben Problem und hoffe das ich bald eine Lösung finde.
Bitte warten ..
Mitglied: Excaliburx
16.11.2011, aktualisiert 18.10.2012
Hallo,

ich habe genau das gleiche Problem unter 2008 R2.

Wie sieht den die Lösung dazu aus?

Hier mein Thread dazu:
http://www.administrator.de/forum/fehlermeldung-beim-%c3%96ffnen-von-re ...


Gruß
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Anhand Anwendungsnamen prüfen, ob Anwendung gestartet ist
gelöst Frage von SinzalBatch & Shell6 Kommentare

Hallo Admins, ich habe einen Win Server 2012 R2, auf dem ich ein Java-Programm laufen habe, dass öfters abstürzt. ...

Windows Server
Windows Terminal Server - Lizenzen
gelöst Frage von Goldenone95Windows Server6 Kommentare

Hallo liebe Community, ich habe eine Frage bezüglich der Windows Server Lizenzierung. Wir haben einen WTS und wollen nun ...

Windows Server
Windows Server 2016 - Terminal Server
Frage von artus-ExcaliburWindows Server2 Kommentare

Hallo zusammen, ich habe einen Windows Server 2016 als Terminal-Server im Einsatz und möchte, dass die Benutzer im Startmenü ...

Windows 10
Vbs getobject auf per Task gestartete Anwendung
Frage von schauanWindows 104 Kommentare

Hallo zusammen, ich starte per Task nachts in abgemeldetem Zustand ein Script, welches Excel startet. Das Script startet dann ...

Neue Wissensbeiträge
Internet

Was nützt HTTPS, wenn es auch von Phishing Web-Seiten genutzt wird

Information von Penny.Cilin vor 2 TagenInternet17 Kommentare

HTTPS richtig einschätzen Ob man eine Webseite via HTTPS aufruft, zeigt ein Schloss neben der Adresse im Webbrowser an. ...

Webbrowser

Bugfix für Firefox Quantum released - Installation erfolgt teilweise nicht automatisch!

Erfahrungsbericht von Volchy vor 4 TagenWebbrowser8 Kommentare

Hallo zusammen, gem. dem Artike von heise online wurde mit VersionFirefox 57.0.1 sicherheitsrelevante Bugs behoben. Entgegen der aktuellen Veröffentlichung ...

Sicherheit

Teamviewer Sessions können gekapert werden - Update tw. verfügbar

Information von sabines vor 4 TagenSicherheit6 Kommentare

In bestimmten Konstellationen können Teamviewer Sessions gekapert werden, wahrscheinlich aber ein recht unwahrscheinliches Szenario. Da der Teamviewer gerne für ...

Digitiales Fernsehen

Apple TV: Amazon Prime App ist verfügbar

Information von Frank vor 4 TagenDigitiales Fernsehen4 Kommentare

Die Amazon Prime Video App kann ab sofort auf einem Apple TV ab der 3 Generation installiert werden. Einfach ...

Heiß diskutierte Inhalte
Vmware
Installation Windows 10 VMware
Frage von Ghost108Vmware17 Kommentare

Hallo zusammen, versuche gerade mit Hilfe des vshpere clients eine virtuelle Windows 10 maschine aufzusetzen. 1. virtuelle Maschine erstellt ...

Exchange Server
SBS 2011 E-Mails können gesendet werden, aber nicht von extern empfangen
Frage von andreas1234Exchange Server14 Kommentare

Hallo Community, ich habe das Problem, dass seit knapp zwei Wochen die E-Mails von meinem SBS 2011 einwandfrei gesendet ...

Voice over IP
Telefonstörung - Ortsrufnummern kein Verbindungsaufbau
Frage von Windows10GegnerVoice over IP10 Kommentare

Hallo, sowohl bei uns als auch beim Opa ist es über VoIP nicht möglich Ortsrufnummern anzurufen. Es kommt nach ...

Windows Server
Server 2012 über Eingabeaufforderung devmgmt.msc geht nicht
gelöst Frage von achim222Windows Server9 Kommentare

Hallo, ich habe hier einen Server 2012 der im Reparaturmodus startet. Es liegt an einem falschen VirtIO Treiber für ...