Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server 2008R2 SP1 - englische Sprache nicht vorhanden und lässt sich nicht nachinstallieren

Frage Microsoft Windows Server

Mitglied: MaxMusterfrau

MaxMusterfrau (Level 1) - Jetzt verbinden

17.06.2014, aktualisiert 12:32 Uhr, 2820 Aufrufe, 12 Kommentare

Hallo zusammen,

nachdem ich die letzten Tage mit der Suche nach einer Lösung beschäftigt war und nicht fündig wurde, versuche ich es auf diesem Weg.
Folgendes Problem:

  • OS: Windows Server 2008R2 SP1 Enterprise als MVL
  • 4 TS-Server, die als Farm arbeiten
  • wurden damals von einem externen Dienstleister aufgesetzt, darum kann ich auch nicht sagen ob die englische Sprache bereits seit der Installation fehlt
  • auf 2 von den Servern ist die deutsche (Standard), englische, italienische und russische Sprache installiert
  • auf den anderen beiden sehe ich unter Systemsteuerung -> Sprache und Region -> Tastaturen und Sprachen nur die deutsche, italienische und russische Sprache, die englische fehlt

Ich habe bereits das MUI-Image mit allen Sprachen heruntergeladen und versucht die englische Sprache zu installieren aber nachdem der Fortschrittsbalken voll ist, steht im Fenster in der Nachrichtenspalte nur "Fehler".

Um sicher zu sein, dass das MUI-Image tatsächlich zu der eingesetzten Windows Version (2008R2 SP1) passt, habe ich testweise die französische Sprache installiert, die auch ohne Probleme durchlief.

Ich bin hier halb am verzweifeln, da ich inzwischen so gut wie jede Möglichkeit durchgespielt habe. Windows-Updates sind auf dem neuesten Stand, auch das einzelne Sprachpaket heruntergeladen und versucht zu installieren. Dieses läuft ohne Fehlermeldung durch, aber Englisch steht nicht zur Auswahl. Wenn ich auf "Sprache deinstallieren" gehe, sehe ich die englische ebenfalls nicht. Also einerseits sieht es bei der Installation so aus, als wäre englisch schon vorhanden und die Installation deshalb auf einen Fehler läuft, auf der anderen Seite aber sieht man die Sprache nirgends.

Kennt jemand dieses Phänomen? Kann es sein, dass hier bei der Installation von Windows irgendwas verbockt wurde und falls ja, kann man die englische Sprache irgendwie nachinstallieren, ohne die Kiste direkt neu aufsetzen zu müssen?


Vielen Dank im Voraus
Max
Mitglied: jsysde
17.06.2014 um 12:45 Uhr
Mahlzeit.

Wenn die Server alle vom gleichen Image installiert wurden, ist die Wahrscheinlichkeit von "fehlenden" Bestandteilen doch eher gering...
De-Installiere mal alle installierten Keyboards (also die fremdsprachigen Layouts), starte die Maschine neu und installiere das gewünschte Language Pack direkt von der MUI-DVD (die muss versionstechnisch aber zum Server passen, wenn der Server also SP1 installiert hat, musst du auch die SP1-MUI nehmen).

Cheers,
jsysde
Bitte warten ..
Mitglied: colinardo
17.06.2014, aktualisiert um 12:48 Uhr
Hallo Max,
und wenn es über die GUI nicht funktionieren sollte, das Paket auch mal über die Kommandozeile mit dism hinzufügen und danach unbedingt einen Neustart machen:
http://www.administrator.de/forum/windows-8-1-sprachpaket-seit-dom%C3%A ...

Grüße Uwe
Bitte warten ..
Mitglied: MaxMusterfrau
17.06.2014 um 17:16 Uhr
Danke für die schnelle Antwort. Wenn ich über die Kommandozeile die installierten Pakete aufliesten lasse, bekomme ich u.a. folgendes:


Paketidentit„t : Microsoft-Windows-Server-LanguagePack-Package~31bf3856ad364e35~amd64~de-DE~6.1.7600.16385
Status : Abgel”st
Versionstyp : Language Pack
Installationszeit : 15.07.2011 14:54

Paketidentit„t : Microsoft-Windows-Server-LanguagePack-Package~31bf3856ad364e35~amd64~de-DE~6.1.7601.17514
Status : Installiert
Versionstyp : Language Pack
Installationszeit : 27.11.2011 16:33

Paketidentit„t : Microsoft-Windows-Server-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~6.1.7600.16385
Status : Bereitgestellt
Versionstyp : Language Pack
Installationszeit :

Paketidentit„t : Microsoft-Windows-Server-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514
Status : Bereitgestellt
Versionstyp : Language Pack
Installationszeit :

Paketidentit„t : Microsoft-Windows-Server-LanguagePack-Package~31bf3856ad364e35~amd64~it-IT~6.1.7600.16385
Status : Abgel”st
Versionstyp : Language Pack
Installationszeit : 15.07.2011 14:54

Paketidentit„t : Microsoft-Windows-Server-LanguagePack-Package~31bf3856ad364e35~amd64~it-IT~6.1.7601.17514
Status : Installiert
Versionstyp : Language Pack
Installationszeit : 27.11.2011 16:33


Also "Bereitgestellt" als Status aber was genau soll mir das sagen?
Bitte warten ..
Mitglied: MaxMusterfrau
17.06.2014 um 17:19 Uhr
Hi jsysde,

ob es das gleiche Image ist, kann ich eben nicht sagen, da ich es eben nicht selbst installiert habe. Auf das richtige Paket habe ich ebenfalls geachtet und, wie geschrieben, lässt sich französisch auch ohne weiteres installieren, wahrscheinlich auch alle anderen Sprachen aber ausgerechnet englisch läuft auf einen Fehler bzw. ist nicht sichtbar.
Bitte warten ..
Mitglied: colinardo
17.06.2014, aktualisiert um 17:58 Uhr
wurde die Kiste zwischenzeitlich überhaupt schon mal neu gestartet ? Wenn nicht unbedingt nachholen!
Danach die Pakete mit dism entfernen und erneut diesmal aber mit dism installieren und danach sofort einen Neustart durchführen.

Falls Fehler auftreten sollten können detailliertere Infos im Logfile nachgeschlagen werden: C:\Windows\Logs\DISM\dism.log

Noch ein Hinweis: Language Packs sollten wenn möglich immer vor sämtlichen Windows Updates eingespielt werden!

http://technet.microsoft.com/en-us/library/hh825699.aspx
Do not install a language pack after an update. If you install an update (hotfix, general distribution release [GDR], or service pack [SP]) that contains language-dependent resources before you install a language pack, the language-specific changes that are contained in the update are not applied and you will need to reinstall the update. Always install language packs before installing updates.
Bitte warten ..
Mitglied: MaxMusterfrau
18.06.2014 um 10:53 Uhr
Hi colinardo,

erst einmal vielen Dank für Deine Hilfe. Wie Du Dir sicher vorstellen kannst, sind Neustarts bei einem TS etwas schwierig, zumindest während des Betriebs Habe aber gestern Abend einen machen können, eben wieder versucht das Sprachpaket zu installieren und leder erneut ohne Erfolg. Meldung aus der dism.log:

2014-06-18 10:42:18, Error DISM DISM Package Manager: PID=15808 Failed finalizing changes. - CDISMPackageManager::Internal_Finalize(hr:0x80070643)
2014-06-18 10:42:18, Error DISM DISM Package Manager: PID=15808 Failed processing package changes - CDISMPackageManager::ProcessChanges(hr:0x80070643)
2014-06-18 10:42:18, Info DISM DISM Package Manager: PID=15808 Loaded servicing stack for online use only. - CDISMPackageManager::RefreshInstanceAndLock
2014-06-18 10:42:18, Error DISM DISM Package Manager: PID=15808 Failed while processing command add-package. - CPackageManagerCLIHandler::ExecuteCmdLine(hr:0x80070643)
2014-06-18 10:42:18, Info DISM DISM Package Manager: PID=15808 Further logs for online package and feature related operations can be found at %WINDIR%\logs\CBS\cbs.log - CPackageManagerCLIHandler::ExecuteCmdLine
2014-06-18 10:42:18, Error DISM DISM.EXE: DISM Package Manager processed the command line but failed. HRESULT=80070643
Bitte warten ..
Mitglied: colinardo
18.06.2014, aktualisiert um 11:17 Uhr
Wie Du Dir sicher vorstellen kannst, sind Neustarts bei einem TS etwas schwierig
Sicher, aber essentiell bei solchen Aktionen und der Problembehebung !

eben wieder versucht das Sprachpaket zu installieren und leder erneut ohne Erfolg. Meldung aus der dism.log:
und vorher die en-us Lang-Pakete auch entfernt ? Nach der Installation sollte erneut ein Neustart erfolgen!

und was steht im cbs.log dazu ?:
%WINDIR%\logs\CBS\cbs.log
Bitte warten ..
Mitglied: MaxMusterfrau
18.06.2014 um 12:22 Uhr
Habe eben das Paket wieder entfernt und die Maschine durchgestartet. Vorher nochmal mit dism /online /get-packages sichergestellt, dass das Paket wirklich entfernt wurde. Nun wieder versucht zu installieren und wieder die gleiche Fehlermeldung. In der cbs.log steht folgendes:

2014-06-18 12:14:53, Info CBS Exec: Cancelled pending transactions after rollback. [HRESULT = 0x00000000 - S_OK]
2014-06-18 12:14:53, Error CBS Exec: An error occurred while committing the transaction, the transaction has been rolled back. [HRESULT = 0x80070643 - ERROR_INSTALL_FAILURE]
2014-06-18 12:14:53, Info CSI 00001842@2014/6/18:10:14:53.391 CSI Transaction @0x25ab8d0 destroyed
2014-06-18 12:14:53, Info CBS Perf: InstallUninstallChain complete.
2014-06-18 12:14:53, Info CBS Failed to execute execution chain. [HRESULT = 0x80070643 - ERROR_INSTALL_FAILURE]
2014-06-18 12:14:53, Error CBS Failed to process single phase execution. [HRESULT = 0x80070643 - ERROR_INSTALL_FAILURE]
2014-06-18 12:14:53, Info CBS WER: Generating failure report for package: Microsoft-Windows-Server-Refresh-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514, status: 0x80070643, failure source: Execute, start state: Staged, target state: Installed, client id: DISM Package Manager Provider
2014-06-18 12:14:53, Info CBS Failed to query DisableWerReporting flag. Assuming not set... [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
2014-06-18 12:14:53, Info CBS Failed to add %windir%\winsxs\pending.xml to WER report because it is missing. Continuing without it...
2014-06-18 12:14:53, Info CBS Failed to add %windir%\winsxs\pending.xml.bad to WER report because it is missing. Continuing without it...
2014-06-18 12:14:53, Info CBS Reboot mark refs: 0
2014-06-18 12:14:53, Info CBS SQM: Reporting package change for package: Microsoft-Windows-Server-Refresh-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514, current: Absent, pending: Default, start: Absent, applicable: Installed, target: Installed, limit: Installed, hotpatch status: DisabledBecauseNoHotpatchPackagesInitiated, status: 0x0, failure source: Execute, reboot required: False, client id: DISM Package Manager Provider, initiated offline: False, execution sequence: 532, first merged sequence: 532
2014-06-18 12:14:53, Info CBS SQM: Upload requested for report: PackageChangeBegin_Microsoft-Windows-Server-Refresh-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514, session id: 142859, sample type: Standard
2014-06-18 12:14:53, Info CBS SQM: Ignoring upload request because the sample type is not enabled: Standard
2014-06-18 12:14:53, Info CBS SQM: Reporting package change completion for package: Microsoft-Windows-Server-Refresh-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514, current: Staged, original: Absent, target: Installed, status: 0x80070643, failure source: Execute, failure details: "(null)", client id: DISM Package Manager Provider, initiated offline: False, execution sequence: 532, first merged sequence: 532
2014-06-18 12:14:53, Info CBS SQM: execute time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
2014-06-18 12:14:53, Info CBS SQM: Failed to initialize Win SAT assessment. [HRESULT = 0x80040154 - Unknown Error]
2014-06-18 12:14:53, Info CBS SQM: average disk throughput datapoint is invalid [HRESULT = 0x80040154 - Unknown Error]
2014-06-18 12:14:53, Info CBS SQM: Upload requested for report: PackageChangeEnd_Microsoft-Windows-Server-Refresh-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514, session id: 142862, sample type: Standard
2014-06-18 12:14:53, Info CBS SQM: Ignoring upload request because the sample type is not enabled: Standard
2014-06-18 12:14:57, Info CBS Enabling LKG boot option
2014-06-18 12:14:57, Info CBS Restored system sleep block state: 0x80000000
2014-06-18 12:14:57, Info CBS Exec: Processing complete. Session: 30378716_1019161936, Package: Microsoft-Windows-Server-Refresh-LanguagePack-Package~31bf3856ad364e35~amd64~en-US~6.1.7601.17514 [HRESULT = 0x80070643 - ERROR_INSTALL_FAILURE]
2014-06-18 12:14:57, Error CBS Failed to perform operation. [HRESULT = 0x80070643 - ERROR_INSTALL_FAILURE]
2014-06-18 12:14:57, Info CBS Session: 30378716_1019161936 finalized. Reboot required: no [HRESULT = 0x80070643 - ERROR_INSTALL_FAILURE]
2014-06-18 12:14:57, Info CBS Session: 30378718_672102825 initialized by client DISM Package Manager Provider.



Zum Verrückwerden
Bitte warten ..
Mitglied: colinardo
18.06.2014, aktualisiert um 12:42 Uhr
Welche Originalsprache hatte die ursprüngliche Installationsquelle ? Ziehe das LanguagePack mal erneut, eventuell ist es beim Download beschädigt worden, hatte ich auch schon mal den Fall. Auf der anderen Seite kann ein Windows Update die Installation verhindern, deshalb schreibt MS das ja (s.o.). Bei Voll-Lokalisierten Sprachpaketen wie das "en-US" Paket eines ist, kann es dabei zu Komplikationen kommen. Das nächste mal also beim einrichten des OS vorher schon alle eventuell benötigten Sprachpakete aufspielen.
Bitte warten ..
Mitglied: MaxMusterfrau
18.06.2014 um 13:28 Uhr
Deutsch ist die Standardsprache und da wir international arbeiten, wurden auch zusätzliche Sprachen installiert. Sehr ärgerlich natürlich, dass ausgerechnet die englische sich bei den beiden Maschinen nicht nachinstallieren lässt.

Das mit den Updates könnte evtl. noch ein Grund dafür sein, wie Du geschrieben hast, nur wie kann ich das zum jetzigen Zeitpunkt noch lösen, ohne das Windows neu installieren zu müssen? Gibt es eine Möglichkeit alle Updates auf einen Schlag zu deinstallieren, sodass ich wieder eine Basis hab, mit der ich einen Versuch starten kann?

Danke
Max
Bitte warten ..
Mitglied: colinardo
18.06.2014, aktualisiert um 16:27 Uhr
Besorge dir einen Account bei experts-exchange da gab es wohl jemanden der über das selbe Problem klagt:
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/W ...
Dort kann man leider nur mit einem Account die Lösung einsehen ...

Grüße Uwe
Bitte warten ..
Mitglied: MaxMusterfrau
18.06.2014 um 16:59 Uhr
Alles klar, Danke auf jeden Fall für die Unterstützung. Sollte ich es irgendwie gelöst bekommen, melde ich micht wieder.
Bitte warten ..
Neuester Wissensbeitrag
Ähnliche Inhalte
Windows Server
BPA bei Windows Server 2008R2 Standard (15)

Frage von MiSt zum Thema Windows Server ...

Windows Server
Windows Server 2008r2 (Winlogon Dienst beendet sich) (3)

Frage von Mauric zum Thema Windows Server ...

Netzwerkmanagement
NSClient++ liefert keine Infos vom Windows Server 2008R2 (7)

Frage von M.Marz zum Thema Netzwerkmanagement ...

Heiß diskutierte Inhalte
Windows Userverwaltung
Ausgeschiedene Mitarbeiter im Unternehmen - was tun mit den AD Konten? (29)

Frage von patz223 zum Thema Windows Userverwaltung ...

LAN, WAN, Wireless
FritzBox, zwei Server, verschiedene Netze (21)

Frage von DavidGl zum Thema LAN, WAN, Wireless ...

Viren und Trojaner
Aufgepasst: Neue Ransomware Goldeneye verbreitet sich rasant (20)

Link von Penny.Cilin zum Thema Viren und Trojaner ...

Windows Netzwerk
Windows 10 RDP geht nicht (18)

Frage von Fiasko zum Thema Windows Netzwerk ...