Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server 2012, AD, DNS -- Falsche IP im DNS A-record bei Win7 Client mit 2 Netzwerkkarten

Frage Microsoft Windows Server

Mitglied: SilentWarrior

SilentWarrior (Level 1) - Jetzt verbinden

07.12.2012 um 18:07 Uhr, 4603 Aufrufe, 9 Kommentare

Hi,

ich habe einen Windows Server auf dem der Domaincontroller läuft und der auch gleichzeitig den DNS-Server stellt. Nun habe ich einen Win7 Client, indem zwei Netzwerkkarten vorhanden sind. Eine Netzwerkkarte ist mit dem Domainnetzwerk verbunden, die andere Netzwerkkarte ist statisch direkt mit einem NAS verbunden.

Nun habe ich festgestellt, das die DNS dieses Rechners falsch aufgelöst wird, hier wird die IP der zweiten Netzwerkkarte verwendet. Diese ist auf dem Server auch im A record so eingetragen und wird ja dynamisch vom AD an den DNS übermittelt. Also eine Änderung im DNS A record ist nur bis zur nächsten Aktualisierung gültig und wird dann wieder überschrieben.

Nun die Frage, warum ist der DC der Ansicht, er müsse die Adresse der "falschen" Netzwerkkarte nehmen. Eigentlich sollte doch der DC feststellen können über welche IP er mit dem Client kommuniziert und die IP der Adresse richtig zuordnen.

Habe nun schon eine Weile gegoogelt und selbst einiges ausprobiert, aber ich bekomme es leider nicht hin, dass die richtige IP verwendet wird.

Hoffe es weiss jemand Rat.


Danke
Mitglied: jens2001
07.12.2012 um 18:59 Uhr
Und jetzt sollen wir raten?
Bitte warten ..
Mitglied: Pjordorf
08.12.2012 um 02:01 Uhr
Hallo,

Zitat von SilentWarrior:
ich einen Win7 Client, indem zwei Netzwerkkarten vorhanden sind. Eine Netzwerkkarte ist mit dem Domainnetzwerk verbunden, die andere Netzwerkkarte ist statisch direkt mit einem NAS verbunden.
Stell mal bitte die ertgebniss von IPConfig /all des Clients hier rein und sage uns auch wie die bindungen sind. Weiterhin brauchen wir auch die IPConfig /all deines Servers. Auch die IP/SN/DNS/GW deines NAS ist hier von Belang. Danach können wir dann schon etwas gezielter raten

Gruß,
Peter
Bitte warten ..
Mitglied: aqui
08.12.2012 um 17:16 Uhr
An der 2ten statischen Netzwerkkarte darf ausschliesslich nur IP Adresse und Maske konfiguriert sein und sonst nix.
Zusätzlich kannst du die Bindungsreihenfolge der NICs noch so verändern das nur die Doamin karte die primäre Karte ist.
Das fixt in der Regel das Problem...
Bitte warten ..
Mitglied: redocomp
09.12.2012 um 12:38 Uhr
hi silentwarrior,

ein weiterer Ansatz könnte sein, das man der 2. Netzwerkkarte verbietet sich im DNS zu registrieren.
Entweder und / oder in der Netzwerkkartenkonfig oder der Registry.

Mit freundlichen Grüßen redocomp
Bitte warten ..
Mitglied: SilentWarrior
10.12.2012 um 08:30 Uhr
Hi,

sorry, es sollte kein Ratespiel werden. Ich bin davon ausgegangen, dass es hierzu ein paar triviale Ansätze wie aus den letzten beiden Posts gibt.

@aqui:
Genauso sind die beiden Karten konfiguriert und ich hatte auch schon geschaut, dass die Domain-Karte in der Reihenfolge der Netzerkadapter an erster Stelle steht. Hatte aber leider nichts geholfen.

@redocomp:
Dies hatte ich noch nicht probiert und eben nachgeholt. Wenn ich den Hacken zur Registrierung am DNS und den DNS-Server aus der IPv4 Konfiguration herausnehme passt die Sache und es wird nur der erste Netzwerkadapter mit der richtigen IP am DNS Server registriert. Leider ist aber nach einer Neuanmeldung die Einstellung wieder weg. Ich habe nun schon die Policies durchsucht aber dazu nichts passendes gefunden, was dafür sorgt, dass der Netzwerkadapter immer automatisch umgestellt wird. Wo kann denn dies konfiguriert werden ?


Hier noch ein Konfiginfos:

Win7:
Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : PC15477
Primäres DNS-Suffix . . . . . . . : domain.local
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : domain.local

Ethernet-Adapter Domainnetzwerk:

Verbindungsspezifisches DNS-Suffix: domain.local
Beschreibung. . . . . . . . . . . : Intel(R) 82579V Gigabit Network Connection
Physikalische Adresse . . . . . . : 8C-89-A5-9F-8A-81
DHCP aktiviert. . . . . . . . . . : Ja
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::8ccc:d716:8a82:c561%14(Bevorzugt)
IPv4-Adresse . . . . . . . . . . : 192.168.2.3(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.0.0
Lease erhalten. . . . . . . . . . : Montag, 10. Dezember 2012 05:38:29
Lease läuft ab. . . . . . . . . . : Dienstag, 11. Dezember 2012 05:38:27
Standardgateway . . . . . . . . . : 192.168.1.1
DHCP-Server . . . . . . . . . . . : 192.168.1.2
DHCPv6-IAID . . . . . . . . . . . : 327977381
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-16-F4-08-B7-8C-89-A5-9F-8A-80

DNS-Server . . . . . . . . . . . : 192.168.1.5
192.168.1.1
192.168.1.2
Primärer WINS-Server. . . . . . . : 192.168.1.5
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Ethernet-Adapter NAS:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connection
Physikalische Adresse . . . . . . : 8C-89-A5-9F-8A-80
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::bd9e:7310:3a1:bbb8%11(Bevorzugt)
IPv4-Adresse . . . . . . . . . . : 10.10.10.2(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.255.0
Standardgateway . . . . . . . . . :
DHCPv6-IAID . . . . . . . . . . . : 244091301
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-16-F4-08-B7-8C-89-A5-9F-8A-80

DNS-Server . . . . . . . . . . . : 192.168.1.5 <== Wird nach Neuanmeldung/Neustart wieder automatisch hinzugefügt
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Server:
Windows-IP-Konfiguration

Hostname . . . . . . . . . . . . : WinServer-1
Primäres DNS-Suffix . . . . . . . : domain.local
Knotentyp . . . . . . . . . . . . : Hybrid
IP-Routing aktiviert . . . . . . : Nein
WINS-Proxy aktiviert . . . . . . : Nein
DNS-Suffixsuchliste . . . . . . . : domain.local

Ethernet-Adapter Domainnetzwerk:

Verbindungsspezifisches DNS-Suffix:
Beschreibung. . . . . . . . . . . : Citrix PV Ethernet Adapter #0
Physische Adresse . . . . . . . . : 4A-CF-DB-9E-36-BC
DHCP aktiviert. . . . . . . . . . : Nein
Autokonfiguration aktiviert . . . : Ja
Verbindungslokale IPv6-Adresse . : fe80::c8c1:b98c:eb59:55d4%15(Bevorzugt)
IPv4-Adresse . . . . . . . . . . : 192.168.1.5(Bevorzugt)
Subnetzmaske . . . . . . . . . . : 255.255.0.0
Standardgateway . . . . . . . . . : 192.168.1.1
DHCPv6-IAID . . . . . . . . . . . : 256561115
DHCPv6-Client-DUID. . . . . . . . : 00-01-00-01-18-4A-98-BE-4A-CF-DB-9E-36-BC
DNS-Server . . . . . . . . . . . : ::1
127.0.0.1
NetBIOS über TCP/IP . . . . . . . : Aktiviert

Die NAS hat auf dem zweiten Adapter folgende Einstellung:
Gateway: 192.168.1.1
DNS-Server: 192.168.1.5, 192.168.1.1, 192.168.1.2

Auf dem ersten Adapter ist nur die statische IP 10.10.10.1 konfiguriert.
Die NAS macht auch kein NAT oder ähnliches.

Hoffe dies hilft beim Raten nun weiter...
Bitte warten ..
Mitglied: redocomp
10.12.2012 um 08:49 Uhr
hi,

wenn ich mich recht erinnere musst du das eben doch noch zusätzlich in der Registry hinzufügen (neuer DWORD), frsge dazu bitte nochmal google.

Mit freundlichen Grüßen redocomp
Bitte warten ..
Mitglied: SilentWarrior
10.12.2012 um 10:46 Uhr
Hi,

so langsam verzweifle ich noch mit diesem Problem, ich habe mir nun die Finger wund gegoogelt und stoße immer wieder "nur" auf folgenden Key, der mit Win2000 genannt wird.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameter\<Adaptername>

Ich habe dort den Key DisableDynamicUpdate = 1 angelegt, macht aber keinen Unterschied, der A record für den zweiten Netzwerkadapter wird trotzdem im DNS angelegt.

Grüsse
SW
Bitte warten ..
Mitglied: redocomp
10.12.2012 um 11:27 Uhr
hi,

das war aber bisher immer meine Lösung.
gebootet hast du aber nach der Registry Änderung schon ?

Mit freundlichen Grüßen redocomp
Bitte warten ..
Mitglied: SilentWarrior
10.12.2012 um 12:15 Uhr
Hi,

ja, hatte gleich zweimal gebootet.
Habe aber das Problem nun wohl gefunden und zwar ist der Dienst "Windows Server-LAN-Konfiguration" verantwortlich, dass bei jedem Neustart die DNS-Konfiguration prüft und ggf. überschreibt, deshalb waren die Einstellungen nach Änderung und Neustart wieder zurück gesetzt.
Habe den Dienst deaktiviert und werde jetzt mal sehen, ob es auf Dauer nun funktioniert.

Grüsse
SW
Bitte warten ..
Neuester Wissensbeitrag
Humor (lol)

Linkliste für Adventskalender

(3)

Information von nikoatit zum Thema Humor (lol) ...

Ähnliche Inhalte
Windows Netzwerk
gelöst Windows Server 2012 R2 als Memberserver einem 2008 R2 AD hinzufügen (5)

Frage von diemilz zum Thema Windows Netzwerk ...

Windows Server
gelöst Keine DNS-Einträge vom DHCP-Server im Windows Server 2012 R2 (8)

Frage von jeschero zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 mit Fritzbox per VPN verbinden (13)

Frage von StefanT81 zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 Standard Upgrade auf R2 (8)

Frage von Hendrik2586 zum Thema Windows Server ...

Heiß diskutierte Inhalte
Router & Routing
gelöst Ipv4 mieten (22)

Frage von homermg zum Thema Router & Routing ...

Windows Server
DHCP Server switchen (20)

Frage von M.Marz zum Thema Windows Server ...

Exchange Server
gelöst Exchange 2010 Berechtigungen wiederherstellen (20)

Frage von semperf1delis zum Thema Exchange Server ...

Hardware
gelöst Negative Erfahrungen LAN-Karten (19)

Frage von MegaGiga zum Thema Hardware ...