Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server Cluster 2008 R2 - Quorum Failed - Network Configuration

Frage Microsoft Windows Server

Mitglied: sersch87

sersch87 (Level 1) - Jetzt verbinden

13.07.2012, aktualisiert 16.07.2012, 3596 Aufrufe, 3 Kommentare

Hallo Zusammen,

folgende Konfiguration besteht in unserem Cluster:

2x Windows Server 2008 R2 Enterprise Edition SP1
Konfiguriert im Windows Failover Cluster - Node and Disk Majority (Quorum)
4x Gigabit-Ethernet Interfaces pro Server
- 2x im Team durch HP Network Configuration Utility im Switch-assisted Load Balancing with Fault Tolerance (SLB) (1 IP-Adresse)
-- Verbunden mit unserem sogenannten "Produktions-Netz" (physikalisch separates Netz Subnet 0.0 /23)
- 2x separate Interfaces (2 IP-Adressen)
-- Verbunden mit unserem sogenannten "MGMT-Netz" (physikalisch separates Netz Subnet 10.0 /24)

Cluster-Konfiguration
- Node-1 - Network: "MGMT - Heartbeat" - MGMT_2 IP-Adresse 10.95
- Node-1 - Network: "Prod" - Team_1 IP-Adresse: 0.91
- Node-2 - Network: "MGMT - Heartbeat" - MGMT_2 IP-Adresse 10.96
- Node-2 - Network: "Prod" - Team_1 IP-Adresse: 0.92

Wir haben heute Nacht bereits den 2ten Ausfall unseres SQL-Server-Clusters gehabt.
Nach Durchforstung aller uns bekannten Logs sieht es irgendwie nach einem Netzwerkfehler aus.

Wenn ich den eigenen „Validate This Cluster“-Check ausführe, dann bekomme ich folgende Meldung:

Adapters MGMT_2 and MGMT_1 on node SQL-1 have IP addresses on the same subnet.
Multiple adapters on node SQL-1 have addresses on the same subnet.
Adapters MGMT_2 and MGMT_1 on node SQL-2 have IP addresses on the same subnet.
Multiple adapters on node SQL-2 have addresses on the same subnet.

Kann dies zu einem Fehler führen?

Aus den Logs können wir sehen, dass Node-1 das Quorum gehalten hat.
Die erste Meldung war, dass Node-2 und Node-1 sich anscheinend nicht mehr erreichen konnten und sich gegenseitige aus dem Cluster geworfen haben.
Daraufhin wollte Node-2 eine Cluster-Gruppe von Node-1 hochfahren, obwohl diese noch aktiv im Node-1 war und das Quorum auch von Node-1 gehalten wurde.
Das versuchte er 3x und danach hat Node-1 alle Cluster-Gruppen ausgeschaltet und auch das Quorum war weg.

Wir können uns nicht erklären was da genau passiert ist und die Tatsache, dass auf beiden Servern jeweils 2 Interfaces im selben Subnet konfiguriert sind, ist nicht von der Hand zu weisen – könnte dies zu solchen Fehlern führen? Kann man nicht 2 Interfaces einem Cluster-Network hinzufügen?
Einem Netzwerkfehler auf den Switchen oder Kabeln, können wir erst nächste Woche nachgehen.

Der Fehler ist heute Nacht um 02:25 zum 2ten mal aufgetreten. Das letzte Mal beim Umzug auf die neuen Server am 29.06.2012 um 11:18.
Eine Parallele kann ich irgendwie nicht erkennen.

Vielleicht hat wer einen Wink in die richtige Richtung...

Vielen Dank!

mfg Sersch
Mitglied: Philipp711
13.07.2012, aktualisiert um 21:16 Uhr
Hallo!

Kurze fragen:
Über welche Netzwerkschnittstelle baust du die Verbindung zum zentralen Speicher (z.B. iSCSI-SAN) auf?
Sind die Interfaces an getrennte Switche bzw. eigene VLANs angeschlossen, oder einfach alles an 1 Switch ohne trennung?

Bei der Fehlermeldung "Adapters MGMT_2 and MGMT_1 on node CPMS-SQL-1.intra.delkeskamp.de have IP addresses on the same subnet" sieht es so aus als ob 2 Adapter auf z.B. SQL1 ins gleiche Subnetz zeigen. <- das selbe natürlich auch beim SQL2

Als Beispiel:
Wir haben einen Hyper-V-Failovercluster laufen. Dort gibts pro Host 1xMGMT + 1xLivemigration + 1xCSV + 2xISCSI.

MGMT -> 10.0.0.0/24
Livemigration ->172.16.0.0/24
CSV->172.16.1.0/24
ISCSI1->192.168.1.0/24
ISCSI2->192.168.2.0/24

Grund für die Trennung ist, das der Server immer ganau weiß welches Netz er über welches Interface erreicht. Evtl kann es ja sein das 2 Interfaces das gleiche Subnetz bedienen aber gar nicht am selben Switch hängen...dann gehen zwangsläufig Pakete verlornen bzw. der Serve routet falsch durch

Schau doch noch einmal in den IP-Einstellungen nach und überprüfe ob wirklich jedes interface pro Host in einem separaten Subnetz ist. Evtl. kriegt der Server das Routing nicht richtig hin, da prinzipiell jedes Interface im richtigen Netz "hängt" aber (da du vielleicht das Switch durch VLANs aufgeteilt hast) phyisikalisch eben nicht...
Bitte warten ..
Mitglied: sersch87
16.07.2012 um 08:24 Uhr
Hallo Philipp,

danke für deine Antwort!

Für das SAN haben wir ein separates Netz mit eigenen Controllern.

Die beiden Interfaces von Team_1 sind auf Switch #1 in unserem Produktionsnetz und die beiden Interfaces von MGMT_1 und MGMT_2 sind auf Switch #2 in unserem MGMT-Netz. Diese beiden Netze sind nur durch eine Firewall/Router verbunden.
Derzeit ist es tatsächlich so, dass MGMT_1 und MGMT_2 beide in ein Netz gehen ... ob es tatsächlich ein Switch ist, weiß ich nicht, aus der Verkabelungsaktion halte ich mich immer bewusst raus

Mir ist aber irgendwie nicht ganz klar, warum die beiden Interfaces nicht in das selbe Subnetz zeigen dürfen...
Bitte warten ..
Mitglied: Philipp711
16.07.2012 um 10:26 Uhr
Wärst du so nett und könntest das mal skizzieren? Ich blick da irgendwie grad nicht durch
Bitte warten ..
Neuester Wissensbeitrag
Windows 10

Powershell 5 BSOD

(8)

Tipp von agowa338 zum Thema Windows 10 ...

Ähnliche Inhalte
Windows Server
gelöst Windows Server 2012 zu R2 inkl. Hyper-V (12)

Frage von agnostiker zum Thema Windows Server ...

Windows Server
Startmenü über GPO Windows 10 - DC 2008 R2 (1)

Frage von dekztar zum Thema Windows Server ...

Windows Server
gelöst Windows Server 2012 Std R2 zu einer 2003er Domäne hinzufügen (13)

Frage von bluepython zum Thema Windows Server ...

Windows Server
gelöst Server mit 2008 R2 mails (5)

Frage von serguni zum Thema Windows Server ...

Heiß diskutierte Inhalte
Microsoft
Ordner mit LW-Buchstaben versehen und benennen (21)

Frage von Xaero1982 zum Thema Microsoft ...

Netzwerkmanagement
gelöst Anregungen, kleiner Betrieb, IT-Umgebung (18)

Frage von Unwichtig zum Thema Netzwerkmanagement ...

Windows Update
Treiberinstallation durch Windows Update läßt sich nicht verhindern (17)

Frage von liquidbase zum Thema Windows Update ...