Top-Themen

AppleEntwicklungHardwareInternetLinuxMicrosoftMultimediaNetzwerkeOff TopicSicherheitSonstige SystemeVirtualisierungWeiterbildungZusammenarbeit

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server DHCP empfängt DHCP Discovery neuer Clients nicht

Frage Microsoft Windows Server

Mitglied: 114875

114875 (Level 1)

27.01.2014 um 16:04 Uhr, 3834 Aufrufe, 16 Kommentare, 1 Danke

Hallo zusammen,

wir haben in unserem Netzwerk kürzlich 91 neue PCs (Optiplex 920, Intel I217-LM) erhalten, die ich derzeit einpflegen will. Da wir unsere Clients mittels Citrix Provisioning Services mit einem Betriebssystem versorgen, booten die Clients via PXE. Dazu holen sie sich ihre IP und weitere Daten von einem Windows Server DHCP (unter 2008 R2).

Nun ist aber folgendes Problem: Die neuen Clients erhalten einfach keine IP, stattdessen gibt es irgendwann "PXE-E51: No DHCP or proxyDHCP offers were received". Ich möchte betonen: Die restlichen, älteren Clients - 120 Stück - machen keine Probleme. Nachdem wir selbst keinen Zugriff auf Netzwerkswitches haben (ich arbeite an der Uni; die Switches werden vom Rechenzentrum gestellt, die Serverhardware von uns), habe ich das Problem in einem kleinen Labortest untersuchen wollen. Zwei Clients untereinander verkabelt und den Traffic mit Wireshark untersucht zeigte, dass sehr wohl ein DHCP Discovery geschickt wird. Ein kleiner DHCP Server auf den zweiten Client konnte die Anfrage auch beantworten.

Das ganze habe ich dann nochmal in unserem Netzwerk getestet und dabei herausgefunden: Deaktiviere ich DHCP auf unserem Windows Server, und verwende stattdessen z.B. Open DHCP Server, können alle Anfragen anstandslos beantwortet werden. Auf einem zweiten Server, der eigentlich nur Backup macht, habe ich testweise DHCP installiert (Windows Server 2003), aber auch da war das Ergebnis dasselbe: keine Reaktion. Auch hier funktionierte Open DHCP Server problemlos.

Die DHCP Logs auf beiden Servern deuten nichtmal an, dass überhaupt ein DHCP Discovery stattfindet (ich habe Full Audit eingerichtet). WireShark hingegen empfängt einen entsprechenden Broadcast.

Hat jemand eine Erklärung dafür? Ich will nun eigentlich ungerne einen anderen DHCP Server laufen lassen.

Viele Grüße,
Patrick
Mitglied: Ausserwoeger
27.01.2014 um 16:17 Uhr
Hi

Ich würde mit einem Firmwareupdate der Netzwerkkarten beginnen. Bzw. schauen welche Karten verbaut sind und ob es auf der Herstellerseite Infos zu diesem Fehler gibt.

Ich würde mir ebenfalls anhören was der Verkäufer dazu sagt.

LG
Bitte warten ..
Mitglied: certifiedit.net
27.01.2014 um 16:18 Uhr
Hallo Patrick,

sehe ich das richtig, dass der OpenDHCP auch auf den Servern lief?

Firewall oder ähnliches aus? DMZ?

Bist du dir sicher, dass der Windows Interne DHCP Server korrekt funktioniert?

Mal als Ansätze.

LG
Bitte warten ..
Mitglied: 114875
27.01.2014 um 16:26 Uhr
@Ausserwoeger: Zu dem Problem habe ich bisher gar nichts gefunden, nur zu anderen Problemen im Zusammenhang mit dieser Karte, verursacht durch die Verwendung von IPv6 (bei uns aber komplett deaktiviert). Firmware-Updates von DELL, die diese Probleme beschreiben könnten, gibt es bisher leider nicht - daran hatte ich zuerst gedacht.

@certifiedit: Ja, der lief zu Testzwecken kurzzeitig auf dem Server (nicht als Dienst). Die Probleme existierten aber schon vorher. Firewall ist aus, DMZ haben wir nicht. Ich bin mir eigentlich relativ sicher, dass der DHCP funktioniert. Das Binding ist korrekt. Die Clients bekommen ihre Zuweisung über Reservierungen, aber auch dynamisch werden sie nicht wahrgenommen. Wie gesagt, die anderen Clients laufen ja weiterhin, und da haben wir auch komplett verschiedene Systeme. Gibt es denn noch etwas, was ich hinsichtlich des DHCP-Servers überprüfen könnte?
Bitte warten ..
Mitglied: certifiedit.net
27.01.2014 um 16:29 Uhr
Schau mal im BIOS der Dinger, ob die gewünschte PXE Funktion überhaupt an ist.
Bitte warten ..
Mitglied: colinardo
27.01.2014, aktualisiert um 16:33 Uhr
Hallo Patrick,
Gibt es denn noch etwas, was ich hinsichtlich des DHCP-Servers überprüfen könnte?
Sind denn noch genügend Adress-Leases frei ? Bzw. auf welchen Zeitraum ist die Lease-Time eingestellt?

Grüße Uwe
Bitte warten ..
Mitglied: Ausserwoeger
27.01.2014 um 16:32 Uhr
Hi

Zugriff auf die Switches gibt es nicht. Es gibt auch keine möglichkeit zugriff zu bekommen ?
Hast du versucht die Netzwerkkarten auf eine Fixe Geschwindgkeit einzustellen testweise ? Zb. 100 Mbit Full Duplex. Welche Switches laufen den da ? Welche netzwerkkarten sind den in den Kisten verbaut ?

LG
Bitte warten ..
Mitglied: 114875
27.01.2014, aktualisiert um 16:50 Uhr
@certifiedit: Ist es, sonst würden die ja nicht über "Open DHCP Server" booten ;)
@colinardo: Die Leases werden reserviert, d.h. es sind noch genügend frei. Die Leasetime ist auf 8 Tage gesetzt.
@Ausserwoeger: In den Clients ist eine Onboard Intel I217-LM verbaut, die auf 1Gbit Full Duplex eingestellt ist. Aber das kann ich ja nur unter Windows einstellen. Beim Bootvorgang hat diese Einstellung ja keine Gültigkeit, oder? Zugriff auf die Switches kann ich nicht bekommen, da diese nicht von uns verwaltet werden. Ich habe aber schon beim Rechenzentrum angefragt und die haben ihre Switches überprüft. Spanning Tree ist aktiviert (das habe ich vermutet,weswegen ich da von Problemen ausging), aber auch PortFast (sodass PXE letztlich wieder kein Problem machen sollte).
Bitte warten ..
Mitglied: Ausserwoeger
27.01.2014 um 17:00 Uhr
Hi

Hast du zufällig einen Switsch rumliegen mit dem du einen test anwerfen könntest ? Ein kleiner 8 Port DLink switch würde reichen. Das würde ich zumindest versuchen um es auszuschliesen

LG
Bitte warten ..
Mitglied: 114875
27.01.2014 um 17:07 Uhr
@Ausserwoeger: Das habe ich leider schon probiert. Sowohl direkt angeschlossen (Client direkt an die Netzwerkkarte des Servers), über ein kleines Desktop-Switch als auch über ein verwaltetes Switch (vom Rechenzentrum) verhält sich der DHCP-Server identisch: er reagiert nicht.
Bitte warten ..
Mitglied: Ausserwoeger
27.01.2014, aktualisiert um 17:23 Uhr
Hi

Hartes Problem. Die Ports UDP-Ports 67 und 68 können auch nicht irgendwo blockiert sein nehme ich an.

Wie weit kommt den dein Client ? Bis zum DHCPDISCOVER oder bekommt der Client noch eine
DHCPOFFER oder macht der Client gar noch einen DHCPREQUEST.


Info:
DHCPDISCOVER: Ein Client ohne IP-Adresse sendet eine Broadcast-Anfrage nach Adress-Angeboten an den/die DHCP-Server im lokalen Netz.
DHCPOFFER: Der/die DHCP-Server antworten mit entsprechenden Werten auf eine DHCPDISCOVER-Anfrage.
DHCPREQUEST: Der Client fordert (eine der angebotenen) IP-Adresse(n), weitere Daten sowie Verlängerung der Lease-Zeit von einem der antwortenden DHCP-Server.

LG
Bitte warten ..
Mitglied: 114875
27.01.2014 um 17:42 Uhr
Ich habe eben mal die BIOS Historie beim Optiplex 9020 durchgeschaut und festgestellt, dass A03 (damit wurden alle PCs bei uns ausgeliefert) auch folgenden Fix enthält:

Update Intel PXE ROM to 1.5.38.

Könnte ein (fehlerhaftes) PXE ROM daran Schuld sein? Ich werde testweise morgen mal auf A02 downgraden und gucken, wie sich ein PC danach verhält. Zumindest bis zur aktuellen Version A05 gibt es sonst keine Änderungen mehr am PXE ROM.
Bitte warten ..
Mitglied: 114875
27.01.2014 um 17:43 Uhr
@Ausserwoeger:

Wireshark meldet mir, dass der Client ein DHCPDISCOVER meldet, aber keine Antwort erhält (unter Windows Server DHCP).

Verwende ich Open DHCP Server, wird der DHCPDISCOVER gesehen, woraufhin die Kette von Antworten fällt: Offer, Request, Ack etc.

Ich weiß, wirklich schwierige Nuss...
Bitte warten ..
Mitglied: certifiedit.net
27.01.2014 um 18:32 Uhr
Zitat von 114875:

@certifiedit: Ist es, sonst würden die ja nicht über "Open DHCP Server" booten ;)

Missverständnis, ich habe es so gelesen, dass sich Clients per DHCP die Adressen ziehen.

Evtl eine Fehlkonfiguration des Windows DHCP Servers?
Bitte warten ..
Mitglied: Ausserwoeger
28.01.2014, aktualisiert um 09:12 Uhr
Zitat von certifiedit.net:

Evtl eine Fehlkonfiguration des Windows DHCP Servers?

Hi

Da du schon 2 verschiedene DHCP Server getestet hast und diese denke ich gleich konfiguriert hast.Könnte das stimmen.

Intressant wäre auch zu wissen ob das DHCPDISCOVER Packet am Server auch ankommt und der Server versucht zu antworten oder ob er einfach gar nichts macht.

Das kann nix mit deinem Problem zu tun haben oder ? http://support.microsoft.com/kb/259670/de

Möglicherweise ein Timeout problem.

PS: Du könntest auch die MTU Size mal Prüfen und sie gegebenenfalls ändern und testen ob dann geantwortet wird.Oder die Netzwerkkarte mal auf 100 Fix stellen oder auf 10.


LG
Bitte warten ..
Mitglied: 114875
28.01.2014 um 09:28 Uhr
So, danke erstmal alle für eure Hilfe. Ich habe das Problem heute morgen tatsächlich lösen können, indem ich ein älteres BIOS (A02) installiert habe. Dieses enthält ein älteres PXE Rom für die Onboard NIC. Und siehe da: es funktionierte sofort. Also ist der Fehler in der Firmware zu suchen - ich werde das ganze an DELL weitergeben.
Bitte warten ..
Mitglied: alekra
18.03.2014, aktualisiert 19.03.2014
Hallo Patrick,

wir haben aktuell ebenfalls die selben Probleme wie du, unsere Umgebung ähnelt eurer. Wäre super wenn du mal berichten könntest welche Erfahrungen Ihr mit dem DHCP/PXE-Problem in den letzten Wochen gemacht habt.

Hier noch ein kurzes Update meinerseits, nach weiteren Analysen und einer längeren Internet Recherche habe ich die genaue Ursache ermittelt und einen Workaround erstellt.
Auf http://ftp.dell.com/FOLDER01899604M/1/Firmware_Release_Notes.txt steht in den Release Notes folgendes:

1G PXE Boot - Reverting to a previous PXE Boot Version to solve an issue with DHCP IP reservations

Ich habe dann für zwei betroffene Clients (Dell und Lenovo) zwei DHCP-Pool Adressen aktiviert (sonst läuft bei uns alles auf DHCP-Reservierungen) und dadurch lief PXE wie gewohnt und ohne Fehler durch


MfG
Alexander
Bitte warten ..
Ähnliche Inhalte
Windows Server
SCCMCB - delete inactive client discovery data

Frage von Hoerti zum Thema Windows Server ...

Windows Netzwerk
gelöst FTP-Server per DHCP an Client übergeben (7)

Frage von BarracoBarner zum Thema Windows Netzwerk ...

LAN, WAN, Wireless
gelöst Clients finden DHCP nicht (12)

Frage von Ghost108 zum Thema LAN, WAN, Wireless ...

Windows Server
gelöst Windows Server 2016 ohne DNS und DHCP (6)

Frage von unique24 zum Thema Windows Server ...

Neue Wissensbeiträge
Windows 10

Heise Newsticker: Microsoft veröffentlicht das "Fall Creators Update

(7)

Information von Penny.Cilin zum Thema Windows 10 ...

LAN, WAN, Wireless

Schwachstelle im WPA2 Protokoll veröffentlicht

(3)

Information von colinardo zum Thema LAN, WAN, Wireless ...

Heiß diskutierte Inhalte
Windows Server
gelöst Gruppenrichtlinie greift nicht zu! (23)

Frage von Syosse zum Thema Windows Server ...

Windows 7
gelöst Windows 7 Anmeldedomäne festlegen (13)

Frage von flotaut zum Thema Windows 7 ...

Hosting & Housing
Mailserver Software Empfehlungen (12)

Frage von sunics zum Thema Hosting & Housing ...